SUNWacroread.spec revision 20857
10139N/A#
10139N/A# spec file for package SUNWacroread
10139N/A#
10139N/A# includes module(s): acroread
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner dermot
10139N/A#
10139N/A# DO NOT REMOVE NEXT LINE
10139N/A# PACKAGE NOT ARC REVIEWED BY SUN JDS TEAM
10603N/A#
10139N/A%include Solaris.inc
10139N/A%define _prefix %{_basedir}
10139N/A%define _bindir %{_prefix}/bin
10139N/A%define _libdir %{_prefix}/lib
10603N/A
10411N/A
10142N/A%ifarch sparc
10411N/A%use acroread = acroread.spec
10139N/A%else
10548N/A%use acroread = acroread-x86.spec
10616N/A%endif
10616N/A
10139N/A
10139N/AName: SUNWacroread
10139N/AIPS_package_name: desktop/pdf-viewer/acroread
10139N/AMeta(info.classification): %{classification_prefix}:Applications/Office
10139N/ASummary: Acrobat Reader for PDF files
10139N/AVersion: %{acroread.version}
10139N/ASUNW_BaseDir: %{_basedir}
10139N/ASUNW_Category: MOZ17,application,%{jds_version}
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ASUNW_Copyright: %{name}.copyright
10139N/ALicense: %{acroread.license}
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10139N/ARequires: SUNWmfrun
10139N/ABuildRequires: SUNWxwplt
10139N/ABuildRequires: SUNWlibms
10139N/ARequires: SUNWdesktop-cache
10139N/ARequires: SUNWglib2
10139N/ARequires: SUNWgtk2
10139N/ARequires: SUNWpango
10139N/ARequires: SUNWcurl
10139N/ARequires: SUNWlibatk
10139N/ABuildRequires: SUNWgnome-component
10139N/ABuildRequires: SUNWgnome-vfs
10139N/A
10139N/A
10139N/A%package plugin
10139N/AIPS_package_name: desktop/pdf-viewer/acroread/plugin
10142N/ASummary: Acrobat Reader Plugin for Firefox
10139N/ASUNW_BaseDir: %{_basedir}
10139N/A%include default-depend.inc
10139N/A%include gnome-incorporation.inc
10616N/ABuildRequires: SUNWfirefox
10139N/ARequires: SUNWfirefox
10139N/ARequires: SUNWacroread
10139N/A
10139N/A
10139N/A%prep
10139N/Arm -rf %name-%version
10139N/Amkdir %name-%version
10139N/A%acroread.prep -d %name-%version
10139N/A
10139N/A
10139N/A%install
10139N/A%acroread.install -d %name-%version
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A
10139N/A%ifarch sparc
10139N/A# ifarch for post/preun/files
10139N/A
10139N/A%post
10139N/A%restart_fmri icon-cache
10139N/A# This is Yuk! But it's needed as SVr4 pkgs cannot handle
10139N/A# spaces in paths
10139N/APKGCOND=/usr/bin/pkgcond
10139N/Ais_srngz=99
10139N/Ais_ngz=99
10139N/A
10139N/Aif [ -x $PKGCOND ]; then
10139N/A $PKGCOND -v is_sparse_root_nonglobal_zone > /dev/null 2>&1
10139N/A is_srngz=$?
10139N/A $PKGCOND -v is_nonglobal_zone > /dev/null 2>&1
10139N/A is_ngz=$?
10139N/Afi
10139N/A
10139N/A## 'pkgcond' does not exist when you do live upgrade from S8/S9
10139N/A## so in that case, use 'touch' instead for the testing
10139N/A##
10139N/Atest_writable() {
10139N/A if [ $is_srngz -ne 99 ]; then
10139N/A $PKGCOND is_path_writable $1 && return $?
10139N/A else
10139N/A /usr/bin/touch $1/.test.$$ > /dev/null 2>&1
10139N/A if [ $? != 0 ]; then
10139N/A return 1
10139N/A else
10139N/A rm -f $1/.test.$$ > /dev/null 2>&1
10139N/A return 0
10139N/A fi
10139N/A fi
10139N/A}
10139N/A
10139N/Aif test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/; then
10139N/A if [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader" ]; then
10139N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
10139N/A fi
10139N/A ln -s Adobe_Reader "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
10139N/Afi
10139N/A
10139N/Aif test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP; then
10139N/A if [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader" ]; then
10139N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
10139N/A fi
10139N/A ln -s Adobe_Reader "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
10139N/Afi
10139N/A
10139N/A
10139N/A%preun
10603N/APKGCOND=/usr/bin/pkgcond
10616N/Ais_srngz=99
10616N/Ais_ngz=99
10548N/A
10548N/Aif [ -x $PKGCOND ]; then
10474N/A $PKGCOND -v is_sparse_root_nonglobal_zone > /dev/null 2>&1
10474N/A is_srngz=$?
10413N/A $PKGCOND -v is_nonglobal_zone > /dev/null 2>&1
10413N/A is_ngz=$?
10285N/Afi
10285N/A
10261N/A## 'pkgcond' does not exist when you do live upgrade from S8/S9
10261N/A## so in that case, use 'touch' instead for the testing
10199N/A##
10199N/Atest_writable() {
10139N/A if [ $is_srngz -ne 99 ]; then
10139N/A $PKGCOND is_path_writable $1 && return $?
10139N/A else
10139N/A /usr/bin/touch $1/.test.$$ > /dev/null 2>&1
10139N/A if [ $? != 0 ]; then
10139N/A return 1
10139N/A else
10139N/A rm -f $1/.test.$$ > /dev/null 2>&1
10139N/A return 0
10139N/A fi
10139N/A fi
10139N/A}
10139N/A
10139N/Aif [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader" ]; then
10139N/A if test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/; then
10139N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
10139N/A fi
10139N/Afi
10139N/A
10139N/Aif [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader" ]; then
10139N/A if test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP; then
10139N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
10139N/A fi
10139N/Afi
10139N/A
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, bin) %{_libdir}/AdobeReader
10139N/A%{_libdir}/AdobeReader/*
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, bin) %{_prefix}/sfw
10139N/A%dir %attr (0755, root, bin) %{_prefix}/sfw/bin
10139N/A%{_prefix}/sfw/bin/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/apps
10139N/A%attr (0644, root, bin) %{_datadir}/applications/acroread.desktop
10139N/A%attr (-, root, other) %{_datadir}/icons/hicolor/*/apps/*
10139N/A
10139N/A
10139N/A%else #ifarch else for post/preun/files
10139N/A
10139N/A%post
10139N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
10139N/A
10139N/A
10139N/A%preun
10139N/A%restart_fmri desktop-mime-cache
10139N/A
10139N/A
10139N/A%files
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, bin) %{_libdir}/AdobeReader
10139N/A%{_libdir}/AdobeReader/*
10139N/A%dir %attr (0755, root, bin) %{_bindir}
10139N/A%{_bindir}/*
10139N/A%dir %attr (0755, root, sys) %{_datadir}
10139N/A%dir %attr (0755, root, other) %{_datadir}/applications
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/apps
10139N/A%{_datadir}/applications/acroread.desktop
10139N/A%{_datadir}/icons/hicolor/*/apps/*
10139N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/mimetypes
10139N/A%attr (-, root, other) %{_datadir}/icons/hicolor/*/mimetypes/*
10139N/A%dir %attr (0755, root, root) %{_datadir}/mime
10139N/A%dir %attr (0755, root, root) %{_datadir}/mime/packages
10139N/A%{_datadir}/mime/packages/acroread.xml
10139N/A%dir %attr (0755, root, bin) %{_mandir}
10139N/A%dir %attr (0755, root, bin) %{_mandir}/*
10139N/A%{_mandir}/*/*
10139N/A
10139N/A#ifarch endif for post/preun/files
10139N/A%endif
10139N/A
10139N/A
10139N/A%files plugin
10139N/A%defattr (-, root, bin)
10139N/A%dir %attr (0755, root, bin) %{_libdir}
10139N/A%dir %attr (0755, root, bin) %{_libdir}/firefox
10139N/A%dir %attr (0755, root, bin) %{_libdir}/firefox/plugins
10139N/A%{_libdir}/firefox/plugins/nppdf.so
10139N/A
10139N/A
10139N/A%changelog
10139N/A* Tue Jun 30 2009 - elaine.xiong@sun.com
10139N/A- Add dependencies for SPARC version.
10139N/A* Tue May 19 2009 - elaine.xiong@sun.com
10139N/A- Add dependencies.
10139N/A* Wed Apr 08 2009 - elaine.xiong@sun.com
10139N/A- combine x86 pkg build into this spec-file.
10139N/A use desktop-cache instead of postrun.
10139N/A* Wed May 26 2008 - dermot.mccluskey@sun.com
10139N/A- fix typo in postinstall
10139N/A* Mon May 26 2008 - dermot.mccluskey@sun.com
10139N/A- add check for existing file in postinstall
10139N/A* Fri Apr 25 2008 - dermot.mccluskey@sun.com
10139N/A- re-do pre and post scripts for sparse zones
10139N/A* Wed Apr 02 2008 - dermot.mccluskey@sun.com
10139N/A- Updates for 8.1.2
10139N/A* Wed Mar 12 2008 - dermot.mccluskey@sun.com
10139N/A- modify %post and %preun to use BASEDIR
10139N/A* Tue Jan 22 2008 - laca@sun.com
10139N/A- use an include instead of an inline script
10139N/A* Fri Jan 18 2008 - dermot.mccluskey@sun.com
10139N/A- Updates for version 8.1.1
10139N/A* Sun Nov 24 2006 - darren.kenny@sun.com
10139N/A- Add .desktop and icons in appropriate places.
10139N/A* Sun Jun 11 2006 - laca@sun.com
10139N/A- change group from other to bin/sys
10139N/A* Mon May 22 2006 - laca@sun.com
10139N/A- use product version number instead of "1.0"
10139N/A* Wed May 10 2006 - dave.lin@sun.com
10139N/A- move plugin file to /usr/lib/firefox/plugins since firefox changed the
10139N/A install location
10139N/A* Thu Apr 6 2006 - damien.carbery@sun.com
10139N/A- Add SUNWgnome-base-libs/-devel to Build/Requires after check-deps.pl run.
10139N/A* Wed Nov 02 2005 - damien.carbery@sun.com
10139N/A- Copy in v7 changes from JDS3.1 branch. Change mozilla references to firefox.
10139N/A* Mon Oct 10 2005 - damien.carbery@sun.com
10139N/A- Add %{_prefix}/sfw/bin to for backward compatability symlink. Fixes 6300634.
10139N/A* Thu Aug 25 2005 - dermot.mccluskey@sun.com
10139N/A- re-write for version 7 (new install dir, etc)
10139N/A* Fri Nov 26 2004 - laca@sun.com
10139N/A- Removed SUNWjds-integration dependency
10139N/A* Fri Nov 19 2004 - damien.carbery@sun.com
10139N/A- Partial fix for 6178971. Remove %pkgbuild_process because it was modifying
10139N/A the Adobe-tested binaries.
10139N/A* Fri Nov 12 2004 - laca@sun.com
10139N/A- Added SUNWjds-integration dependency
10139N/A* Tue Oct 05 2004 - shirley.woo@sun.com
10139N/A- CR 6174047 : Change SUNWacroread to install to /usr/sfw
10139N/A* Sat Oct 02 2004 - laca@sun.com
10139N/A- added %pkgbuild_postprocess
10139N/A* Thu Sep 30 2004 - damien.carbery@sun.com
10139N/A- Add '%ifarch sparc' around SUNWbcp dependency as this is only on sparc.
10139N/A* Wed Sep 29 2004 - shirley.woo@sun.com
10139N/A- added additional dependencies to acroread &
10139N/A added acroread dependency to plugin subpkg
10139N/A* Mon Sep 20 2004 - laca@sun.com
10139N/A- added default dependencies to plugin subpkg
10139N/A* Fri Aug 20 2004 - laca@sun.com
10139N/A- moved to mozilla category.
10139N/A* Mon Aug 16 2004 - dermot.mccluskey@sun.com
10139N/A- added -plugin pkg
10139N/A* Mon Aug 16 2004 - dermot.mccluskey@sun.com
10139N/A- use acroread-copyright.txt instead of default
10139N/A* Fri Aug 06 2004 - dermot.mccluskey@sun.com
10139N/A- initial version
10139N/A
10139N/A
10139N/A