10145N/A#
10145N/A# spec file for package SUNWacroread
10145N/A#
10145N/A# includes module(s): acroread
10145N/A#
12242N/A# Copyright 2008 Sun Microsystems, Inc.
10145N/A# This file and all modifications and additions to the pristine
10145N/A# package are under the same license as the package itself.
10145N/A#
17834N/A%define owner dermot
10145N/A#
10145N/A# DO NOT REMOVE NEXT LINE
10145N/A# PACKAGE NOT ARC REVIEWED BY SUN JDS TEAM
10145N/A#
10145N/A%include Solaris.inc
10145N/A%define _prefix %{_basedir}
10145N/A%define _bindir %{_prefix}/bin
10145N/A%define _libdir %{_prefix}/lib
10145N/A
10145N/A
16334N/A%ifarch sparc
10145N/A%use acroread = acroread.spec
16334N/A%else
16334N/A%use acroread = acroread-x86.spec
16334N/A%endif
10145N/A
10145N/A
10145N/AName: SUNWacroread
20055N/AIPS_package_name: desktop/pdf-viewer/acroread
20055N/AMeta(info.classification): %{classification_prefix}:Applications/Office
10145N/ASummary: Acrobat Reader for PDF files
10145N/AVersion: %{acroread.version}
10145N/ASUNW_BaseDir: %{_basedir}
10145N/ASUNW_Category: MOZ17,application,%{jds_version}
10145N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12689N/ASUNW_Copyright: %{name}.copyright
19140N/ALicense: %{acroread.license}
10145N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10145N/ARequires: SUNWmfrun
20239N/ABuildRequires: SUNWxwplt
20239N/ABuildRequires: SUNWlibms
16334N/ARequires: SUNWdesktop-cache
16728N/ARequires: SUNWglib2
16728N/ARequires: SUNWgtk2
16728N/ARequires: SUNWpango
16728N/ARequires: SUNWcurl
16728N/ARequires: SUNWlibatk
20352N/ABuildRequires: SUNWgnome-component
20352N/ABuildRequires: SUNWgnome-vfs
10145N/A
10145N/A
10145N/A%package plugin
20055N/AIPS_package_name: desktop/pdf-viewer/acroread/plugin
10145N/ASummary: Acrobat Reader Plugin for Firefox
10145N/ASUNW_BaseDir: %{_basedir}
10145N/A%include default-depend.inc
20857N/A%include gnome-incorporation.inc
10145N/ABuildRequires: SUNWfirefox
10145N/ARequires: SUNWfirefox
10145N/ARequires: SUNWacroread
10145N/A
10145N/A
10145N/A%prep
10145N/Arm -rf %name-%version
10145N/Amkdir %name-%version
10145N/A%acroread.prep -d %name-%version
10145N/A
10145N/A
10145N/A%install
10145N/A%acroread.install -d %name-%version
10145N/A
10145N/A
10145N/A%clean
10145N/Arm -rf $RPM_BUILD_ROOT
10145N/A
12230N/A
16334N/A%ifarch sparc
16334N/A# ifarch for post/preun/files
16334N/A
10145N/A%post
16334N/A%restart_fmri icon-cache
12594N/A# This is Yuk! But it's needed as SVr4 pkgs cannot handle
12230N/A# spaces in paths
12952N/APKGCOND=/usr/bin/pkgcond
12952N/Ais_srngz=99
12952N/Ais_ngz=99
12952N/A
12952N/Aif [ -x $PKGCOND ]; then
12952N/A $PKGCOND -v is_sparse_root_nonglobal_zone > /dev/null 2>&1
12952N/A is_srngz=$?
12952N/A $PKGCOND -v is_nonglobal_zone > /dev/null 2>&1
12952N/A is_ngz=$?
12952N/Afi
12952N/A
12952N/A## 'pkgcond' does not exist when you do live upgrade from S8/S9
12952N/A## so in that case, use 'touch' instead for the testing
12952N/A##
12952N/Atest_writable() {
12952N/A if [ $is_srngz -ne 99 ]; then
12952N/A $PKGCOND is_path_writable $1 && return $?
12952N/A else
12952N/A /usr/bin/touch $1/.test.$$ > /dev/null 2>&1
12952N/A if [ $? != 0 ]; then
12952N/A return 1
12952N/A else
12952N/A rm -f $1/.test.$$ > /dev/null 2>&1
12952N/A return 0
12952N/A fi
12952N/A fi
12952N/A}
12952N/A
12952N/Aif test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/; then
13257N/A if [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader" ]; then
13100N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
13100N/A fi
12952N/A ln -s Adobe_Reader "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
12952N/Afi
12952N/A
12952N/Aif test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP; then
13257N/A if [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader" ]; then
13100N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
13100N/A fi
12952N/A ln -s Adobe_Reader "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
12952N/Afi
12230N/A
12230N/A
12230N/A%preun
12952N/APKGCOND=/usr/bin/pkgcond
12952N/Ais_srngz=99
12952N/Ais_ngz=99
12952N/A
12952N/Aif [ -x $PKGCOND ]; then
12952N/A $PKGCOND -v is_sparse_root_nonglobal_zone > /dev/null 2>&1
12952N/A is_srngz=$?
12952N/A $PKGCOND -v is_nonglobal_zone > /dev/null 2>&1
12952N/A is_ngz=$?
12952N/Afi
12952N/A
12952N/A## 'pkgcond' does not exist when you do live upgrade from S8/S9
12952N/A## so in that case, use 'touch' instead for the testing
12952N/A##
12952N/Atest_writable() {
12952N/A if [ $is_srngz -ne 99 ]; then
12952N/A $PKGCOND is_path_writable $1 && return $?
12952N/A else
12952N/A /usr/bin/touch $1/.test.$$ > /dev/null 2>&1
12952N/A if [ $? != 0 ]; then
12952N/A return 1
12952N/A else
12952N/A rm -f $1/.test.$$ > /dev/null 2>&1
12952N/A return 0
12952N/A fi
12952N/A fi
12952N/A}
12952N/A
12594N/Aif [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader" ]; then
12952N/A if test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/; then
12952N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/en_US/Adobe Reader"
12952N/A fi
12594N/Afi
12594N/A
12594N/Aif [ -h "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader" ]; then
12952N/A if test_writable ${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP; then
12952N/A rm "${BASEDIR}/lib/AdobeReader/Adobe/Help/ja_JP/Adobe Reader"
12952N/A fi
12594N/Afi
12594N/A
10145N/A
10145N/A%files
10145N/A%defattr (-, root, bin)
10145N/A%dir %attr (0755, root, bin) %{_libdir}
10145N/A%dir %attr (0755, root, bin) %{_libdir}/AdobeReader
10145N/A%{_libdir}/AdobeReader/*
10145N/A%dir %attr (0755, root, bin) %{_bindir}
10145N/A%{_bindir}/*
10145N/A%dir %attr (0755, root, bin) %{_prefix}/sfw
10145N/A%dir %attr (0755, root, bin) %{_prefix}/sfw/bin
10145N/A%{_prefix}/sfw/bin/*
10145N/A%dir %attr (0755, root, sys) %{_datadir}
10145N/A%dir %attr (0755, root, other) %{_datadir}/applications
10145N/A%dir %attr (0755, root, other) %{_datadir}/icons
10145N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor
10145N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*
10145N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/apps
10145N/A%attr (0644, root, bin) %{_datadir}/applications/acroread.desktop
10145N/A%attr (-, root, other) %{_datadir}/icons/hicolor/*/apps/*
10145N/A
16334N/A
16334N/A%else #ifarch else for post/preun/files
16334N/A
16334N/A%post
16334N/A%restart_fmri desktop-mime-cache icon-cache gconf-cache
16334N/A
16334N/A
16334N/A%preun
16334N/A%restart_fmri desktop-mime-cache
16334N/A
16334N/A
16334N/A%files
16334N/A%defattr (-, root, bin)
16334N/A%dir %attr (0755, root, bin) %{_libdir}
16334N/A%dir %attr (0755, root, bin) %{_libdir}/AdobeReader
16334N/A%{_libdir}/AdobeReader/*
16334N/A%dir %attr (0755, root, bin) %{_bindir}
16334N/A%{_bindir}/*
16334N/A%dir %attr (0755, root, sys) %{_datadir}
16334N/A%dir %attr (0755, root, other) %{_datadir}/applications
16334N/A%dir %attr (0755, root, other) %{_datadir}/icons
16334N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor
16334N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*
16334N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/apps
16334N/A%{_datadir}/applications/acroread.desktop
16334N/A%{_datadir}/icons/hicolor/*/apps/*
16334N/A%dir %attr (0755, root, other) %{_datadir}/icons/hicolor/*/mimetypes
16334N/A%attr (-, root, other) %{_datadir}/icons/hicolor/*/mimetypes/*
16334N/A%dir %attr (0755, root, root) %{_datadir}/mime
16334N/A%dir %attr (0755, root, root) %{_datadir}/mime/packages
16334N/A%{_datadir}/mime/packages/acroread.xml
16334N/A%dir %attr (0755, root, bin) %{_mandir}
16334N/A%dir %attr (0755, root, bin) %{_mandir}/*
16334N/A%{_mandir}/*/*
16334N/A
16334N/A#ifarch endif for post/preun/files
16334N/A%endif
16334N/A
16334N/A
10145N/A%files plugin
10145N/A%defattr (-, root, bin)
10145N/A%dir %attr (0755, root, bin) %{_libdir}
10145N/A%dir %attr (0755, root, bin) %{_libdir}/firefox
10145N/A%dir %attr (0755, root, bin) %{_libdir}/firefox/plugins
10145N/A%{_libdir}/firefox/plugins/nppdf.so
10145N/A
10145N/A
10145N/A%changelog
16728N/A* Tue Jun 30 2009 - elaine.xiong@sun.com
16728N/A- Add dependencies for SPARC version.
16531N/A* Tue May 19 2009 - elaine.xiong@sun.com
16531N/A- Add dependencies.
16334N/A* Wed Apr 08 2009 - elaine.xiong@sun.com
16334N/A- combine x86 pkg build into this spec-file.
16334N/A use desktop-cache instead of postrun.
13257N/A* Wed May 26 2008 - dermot.mccluskey@sun.com
13257N/A- fix typo in postinstall
13100N/A* Mon May 26 2008 - dermot.mccluskey@sun.com
13100N/A- add check for existing file in postinstall
13100N/A* Fri Apr 25 2008 - dermot.mccluskey@sun.com
12952N/A- re-do pre and post scripts for sparse zones
12748N/A* Wed Apr 02 2008 - dermot.mccluskey@sun.com
12748N/A- Updates for 8.1.2
12594N/A* Wed Mar 12 2008 - dermot.mccluskey@sun.com
12594N/A- modify %post and %preun to use BASEDIR
12242N/A* Tue Jan 22 2008 - laca@sun.com
12242N/A- use an include instead of an inline script
12230N/A* Fri Jan 18 2008 - dermot.mccluskey@sun.com
12230N/A- Updates for version 8.1.1
10145N/A* Sun Nov 24 2006 - darren.kenny@sun.com
10145N/A- Add .desktop and icons in appropriate places.
10145N/A* Sun Jun 11 2006 - laca@sun.com
10145N/A- change group from other to bin/sys
10145N/A* Mon May 22 2006 - laca@sun.com
10145N/A- use product version number instead of "1.0"
10145N/A* Wed May 10 2006 - dave.lin@sun.com
10145N/A- move plugin file to /usr/lib/firefox/plugins since firefox changed the
10145N/A install location
10145N/A* Thu Apr 6 2006 - damien.carbery@sun.com
10145N/A- Add SUNWgnome-base-libs/-devel to Build/Requires after check-deps.pl run.
10145N/A* Wed Nov 02 2005 - damien.carbery@sun.com
10145N/A- Copy in v7 changes from JDS3.1 branch. Change mozilla references to firefox.
10145N/A* Mon Oct 10 2005 - damien.carbery@sun.com
10145N/A- Add %{_prefix}/sfw/bin to for backward compatability symlink. Fixes 6300634.
10145N/A* Thu Aug 25 2005 - dermot.mccluskey@sun.com
10145N/A- re-write for version 7 (new install dir, etc)
10145N/A* Fri Nov 26 2004 - laca@sun.com
10145N/A- Removed SUNWjds-integration dependency
10145N/A* Fri Nov 19 2004 - damien.carbery@sun.com
10145N/A- Partial fix for 6178971. Remove %pkgbuild_process because it was modifying
10145N/A the Adobe-tested binaries.
10145N/A* Fri Nov 12 2004 - laca@sun.com
10145N/A- Added SUNWjds-integration dependency
10145N/A* Tue Oct 05 2004 - shirley.woo@sun.com
10145N/A- CR 6174047 : Change SUNWacroread to install to /usr/sfw
10145N/A* Sat Oct 02 2004 - laca@sun.com
10145N/A- added %pkgbuild_postprocess
10145N/A* Thu Sep 30 2004 - damien.carbery@sun.com
10145N/A- Add '%ifarch sparc' around SUNWbcp dependency as this is only on sparc.
10145N/A* Wed Sep 29 2004 - shirley.woo@sun.com
10145N/A- added additional dependencies to acroread &
10145N/A added acroread dependency to plugin subpkg
10145N/A* Mon Sep 20 2004 - laca@sun.com
10145N/A- added default dependencies to plugin subpkg
10145N/A* Fri Aug 20 2004 - laca@sun.com
10145N/A- moved to mozilla category.
10145N/A* Mon Aug 16 2004 - dermot.mccluskey@sun.com
10145N/A- added -plugin pkg
10145N/A* Mon Aug 16 2004 - dermot.mccluskey@sun.com
10145N/A- use acroread-copyright.txt instead of default
10145N/A* Fri Aug 06 2004 - dermot.mccluskey@sun.com
10145N/A- initial version
19150N/A
19467N/A