12258N/A#
12258N/A# spec file for package w3m
12258N/A#
12412N/A# Copyright 2008 Sun Microsystems, Inc.
12258N/A# This file and all modifications and additions to the pristine
12258N/A# package are under the same license as the package itself.
12258N/A#
20307N/A%define owner liyuan
12258N/A#
12258N/A
17183N/A%define OSR 6973:0.5
17183N/A
12258N/AName: w3m
17354N/ALicense: MIT
12258N/AGroup: Applications/Internet
20021N/AVersion: 0.5.2
12258N/ARelease: 4
12258N/ADistribution: Java Desktop System
18616N/AVendor: Sourceforge
12258N/ASummary: A text-based web browser
12258N/ASource: http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13331N/A%if %build_l10n
13331N/ASource1: l10n-configure.sh
13331N/A%endif
13331N/A# date:2008-06-04 owner:fujiwara type:bug bugster:6710470
13331N/APatch1: w3m-01-build.diff
20307N/A# date:2009-02-16 owner:liyuan type:branding
16048N/APatch2: w3m-02-checkgc.diff
20034N/A# date:2011-02-16 owner:liyuan type bug bugster:7008664
20034N/APatch3: w3m-03-istream.diff
12258N/AURL: http://w3m.sourceforge.net/
12258N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12258N/ADocdir: %{_defaultdocdir}/doc
12258N/AAutoreqprov: on
12258N/APrereq: /sbin/ldconfig
12258N/A
12258N/ABuildPreReq: openssl-devel >= 0.9.8a, ncurses-devel
12258N/ABuildPreReq: gdk-pixbuf-devel >= 0.16.0
12258N/ABuildPreReq: libpng-devel >= 1.2.2, gc-devel
12258N/A
13256N/A%define openssl_version 0.9.8a
13256N/ABuildRequires: openssl-devel >= %{openssl_version}
13256N/A
12258N/A%description
12258N/AW3m is a pager adapted to World Wide Web. W3m is a text-based WWW
12258N/Abrowser as well as a pager.
12258N/A
12258N/A%prep
12258N/A%setup -q
13331N/A%patch1 -p1
16048N/A%patch2 -p1
20034N/A%patch3 -p1
12258N/A
12258N/A%build
12258N/A%ifos linux
12258N/Aif [ -x /usr/bin/getconf ]; then
12258N/A CPUS=`getconf _NPROCESSORS_ONLN`
12258N/Afi
12258N/A%else
12258N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12258N/A%endif
12258N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12258N/A CPUS=1
12258N/Afi
12258N/A
13331N/Aintltoolize -c -f --automake
13331N/A
13331N/A%if %build_l10n
13331N/Abash -x %SOURCE1 --enable-copyright
13331N/A%endif
13331N/A
13331N/A# the orignal aclocal.m4 defines AC_W3M_SSL_DIGEST_AUTH
13331N/Amv aclocal.m4 ssl.m4
13331N/Aaclocal -I .
13331N/Aautoconf
12258N/ACFLAGS="$RPM_OPT_FLAGS" \
12258N/A./configure --prefix=%{_prefix} \
12258N/A --mandir=%{_mandir} \
12258N/A --libdir=%{_libdir} \
12258N/A --libexecdir=%{_libexecdir} \
12258N/A --sysconfdir=%{_sysconfdir} \
12258N/A --with-browser=/usr/bin/firefox \
12258N/A
13331N/Atouch po/stamp-it
14160N/A#FIXME: If the simultaneously running job > 2, it builds failed
14160N/A#make -j $CPUS
14160N/Amake -j 2
12258N/A
12258N/A%install
12258N/Amake install DESTDIR=$RPM_BUILD_ROOT
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
12258N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
12258N/A
12258N/A%clean
12258N/Arm -rf $RPM_BUILD_ROOT
12258N/A
12258N/A%post -p /sbin/ldconfig
12258N/A%postun -p /sbin/ldconfig
12258N/A
12258N/A%files
12258N/A%files
12258N/A%defattr(-, root, root)
12258N/A%doc Bonus ChangeLog NEWS README TODO doc doc-jp
12258N/A%{_sysconfdir}/w3m
12258N/A%{_bindir}/w3m
12258N/A%dir %{_libexecdir}/w3m
12258N/A%{_libexecdir}/w3m/inflate
12258N/A%dir %{_libexecdir}/w3m/cgi-bin
12258N/A%{_libexecdir}/w3m/cgi-bin/w3mbookmark
12258N/A%{_libexecdir}/w3m/cgi-bin/w3mhelperpanel
12258N/A%{_mandir}/man1/w3m.1*
12258N/A%{_mandir}/ja/man1/w3m.1*
12258N/A%{_datadir}/locale/*/*/*
12258N/A%{_datadir}/w3m/w3mhelp-funcdesc.en.pl
12258N/A%{_datadir}/w3m/w3mhelp-funcdesc.ja.pl
12258N/A%{_datadir}/w3m/w3mhelp-funcname.pl
12258N/A%{_datadir}/w3m/w3mhelp.html
12258N/A
12258N/A%changelog
20034N/A* Wed Feb 16 2011 - lee.yuan@oracle.com
20034N/A- Add w3m-03-istream.diff to fix CR7008664.
14160N/A* Fri Sep 05 2008 - dave.lin@sun.com
14160N/A- commented out the line "make -j $CPU" and specified the simultaneously running job as 2,
14160N/A it built failed when the job is 16
13331N/A* Wed Jun 04 2008 - takao.fujiwara@sun.com
13331N/A- Add w3m-01-build.diff to enable nls.
13256N/A* Mon May 26 2008 - rick.ju@sun.com
13256N/A- Add openssl dependency
12851N/A* Mon Apr 14 2008 - halton.huo@sun.com
12851N/A- Remove %gtk_doc_option when configure because there is no this option.
12425N/A* Thu Feb 21 2008 - laca@sun.com
12426N/A- delete all autotoolization, particularly intltoolize,
12426N/A since intltool is not used at all in this module
12412N/A* Wed Feb 20 2008 - halton.huo@sun.com
12412N/A- Remove commented lines.
12258N/A* Wed Jan 02 2008 - halton.huo@sun.com
12258N/A- spilit from SFEw3m.spec