vte.spec revision 12020
10139N/A#
10139N/A# spec file for package vte
10139N/A#
16171N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: yippi
10139N/A#
17180N/AName: vte
17180N/ALicense: LGPL
17180N/AGroup: System/Libraries
10139N/AVersion: 0.16.9
15322N/ARelease: 1
10139N/ADistribution: Java Desktop System
17853N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Terminal Emulation Widget Library
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.16/%{name}-%{version}.tar.bz2
10139N/A#owner:yippi date:2004-06-22 type:bug bugzilla:142640
10139N/APatch1: vte-01-fcconfig.diff
17361N/AURL: http://www.gnome.org
17726N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17726N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoReqProv: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.10.0
10139N/A%define python_version 2.4
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: python >= %{python_version}
10139N/A
17459N/A%description
10139N/AVTE is a terminal emulation widget for GTK+, used in GNOME Terminal.
10139N/A
10139N/A%package devel
10139N/ASummary: Terminal Emulation Widget Development Library
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}-%{release}
10139N/ARequires: gtk2-devel >= %{gtk2_version}
10139N/A
10139N/A%description devel
10139N/AVTE is a terminal emulation widget for GTK+, used in GNOME Terminal.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
17726N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
17459N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
10139N/Aautomake -a -c -f
16172N/Aautoconf
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --datadir=%{_datadir} \
17649N/A --libexecdir=%{_libexecdir} \
17649N/A %{gtk_doc_option}
17649N/Amake -j $CPUS \
17649N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
17649N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
17649N/A
17684N/A%install
17684N/Amake DESTDIR=$RPM_BUILD_ROOT install \
17750N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
17684N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
17750N/A#Copy zh_HK from zh_TW
17684N/A#Fixes bug 4930405
17649N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
17649N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
17649N/A# Clean up unpackaged files
17643N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
17643N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.la
10139N/A
10139N/A
10139N/A%clean
17684N/Arm -rf $RPM_BUILD_ROOT
17684N/A
17750N/A%post
17684N/A/sbin/ldconfig
17750N/A
17684N/A%postun
15576N/A/sbin/ldconfig
10139N/A
17459N/A%files
17459N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
17643N/A%{_libdir}/*.so*
17643N/A%attr(2711,root,utmp) %{_libexecdir}/gnome-pty-helper
17643N/A%{_datadir}/%{name}
17643N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
17643N/A%{_mandir}/man1/*
10139N/A%{_mandir}/man3/*
10139N/A
17459N/A%files devel
17459N/A%defattr(-,root,root)
17643N/A%{_datadir}/gtk-doc/html/%{name}
17643N/A%{_includedir}/*
17643N/A%{_libdir}/*.so
17643N/A%dir %{_libdir}/%{name}
10139N/A%{_libdir}/%{name}/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/python2.4/vendor-packages/gtk-2.0/vtemodule.so
10139N/A
16039N/A%changelog
10139N/A* Mon Dec 03 2007 - takao.fujiwara@sun.com
16039N/A- Remove vte-02-inputmethod-spotlocation.diff to replace the gtk patch.
16039N/A* Tue Nov 06 2007 - brian.cameron@sun.com
10139N/A- Remove stale vte-03-selection-perf-improve.diff patch. It does not
10139N/A improve performance and it was rejected by the maintainer.
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.8. Remove upstream patch, 03-cut-copy-paste-handle. Renumber
10139N/A rest.
10139N/A* Tue Jul 31 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.8.
10139N/A* Mon Jul 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.7.
10139N/A* Tue Jun 19 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.6.
10139N/A* Tue May 29 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.4. Remove upstream patches, 05-g11n-segv-preedit and
10139N/A 06-terminal-access-visibility-notify.
10139N/A* Fri May 25 2007 - yi.jin@sun.com
10139N/A- Add vte-06-terminal-access-visibility-notify.diff. Fixes 6556709.
10139N/A The signal callback function should return FALSE to let the rest of
10139N/A callback functions get called.
10139N/A* Mon Apr 30 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.3.
10139N/A* Fri Apr 27 2007 - takao.fujiwara@sun.com
10139N/A- Add vte-05-g11n-segv-preedit.diff. Fixes 6548846
10139N/A* Tue Apr 24 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.2. Remove upstream patch 04-utf8-ambiguous. Renumber rest.
10139N/A* Thu Apr 12 2007 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 06-nullptr-check.
10139N/A* Wed Apr 11 2007 - damien.carbery@sun.com
10139N/A- Bump to 0.16.1.
17459N/A* Wed Apr 4 2007 - dougs@truemail.co.th
10139N/A- Added patch vte-06-nullptr-check.diff to fix bugzilla 425767.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
17853N/A- Bump to 0.16.0.
17853N/A* Mon Mar 05 2007 - damien.carbery@sun.com
17749N/A- Bump to 0.15.6.
17749N/A* Wed Feb 28 2007 - damien.carbery@sun.com
17726N/A- Bump to 0.15.5. Remove upstream patch 06-environ.
17726N/A* Wed Feb 14 2007 - damien.carbery@sun.com
17726N/A- Remove upstream patch, 06-vte-pty-open. Add patch, 06-environ to fix #407839.
17726N/A* Tue Feb 13 2007 - damien.carbery@sun.com
17657N/A- Bump to 0.15.3.
17657N/A* Thu Feb 08 2007 - brian.cameron@sun.com
17496N/A- Remove unneeded patch vte-01-vtefc.diff. Now FC_WIDTH is defined on
17657N/A Solaris, so it's no longer needed to wrap it with #ifdef FC_WIDTH.
17440N/A* Tue Jan 23 2007 - damien.carbery@sun.com
17440N/A- Add patch, 07-vte-pty-open, to sync func declaration with definition; #400184.
17420N/A* Tue Jan 23 2007 - damien.carbery@sun.com
17657N/A- Bump to 0.15.2. Remove upstream patch, 06-get-text. Renumber remainder.
17420N/A* Tue Jan 09 2007 - damien.carbery@sun.com
17361N/A- Bump to 0.15.1.
17361N/A* Thu Dec 07 2006 - damien.carbery@sun.com
17361N/A- Bump to 0.15.0.
17251N/A* Fri Nov 3 2006 - laca@sun.com
17251N/A- use %gtk_doc_option in configure so that it can be disabled using
17150N/A --without-gtk-doc
17150N/A* Tue Oct 03 2006 - damien.carbery@sun.com
17106N/A- Bump to 0.14.1.
17106N/A* Thu Sep 14 2006 - matt.keenan@sun.com
16649N/A- Remove patch vte-08-pre-edit-crash-on-close.diff, as causing
16649N/A two bugs, 6453098, and 6465619, and removing does not re-introduce 6193929.
16490N/A* Tue Sep 05 2006 - damien.carbery@sun.com
16490N/A- Bump to 0.14.0.
16368N/A* Fri Aug 25 2006 - damien.carbery@sun.com
16368N/A- Bump to 0.13.7.
16171N/A* Mon Aug 21 2006 - damien.carbery@sun.com
16368N/A- Bump to 0.13.6.
16171N/A* Tue Aug 01 2006 - damien.carbery@sun.com
16368N/A- Bump to 0.13.5.
16368N/A* Tue Jul 25 2006 - damien.carbery@sun.com
16039N/A- Remove upstream patch, 05-update-logout-record. Rename remaining.
16039N/A* Tue Jul 25 2006 - damien.carbery@sun.com
15754N/A- Bump to 0.13.4.
15754N/A* Fri Jul 21 2006 - padraig.obriain@sun.com
15576N/A- Bump to 0.13.3 for gnome 2.15.
16368N/A- Remove patch vte-07-g11n-word-char.diff as this issue is addressed,
16368N/A slightly differently, in vte code.
16368N/A* Fri Jun 23 2006 - brian.cameron@sun.com
16368N/A- Bump to 0.12.2.
15470N/A* Thu Apr 27 2006 - damien.carbery@sun.com
15470N/A- Remove upstream patch, vte-12-msgfmt-no-c-param.diff.
15470N/A* Thu Apr 27 2006 - damien.carbery@sun.com
15448N/A- Bump to 1.12.1.
16368N/A* Tue Mar 14 2006 - damien.carbery@sun.com
15428N/A- Add patch, 12-msgfmt-no-c-param, to remove '-c' param from msgfmt call. That
15428N/A switch breaks Solaris build.
14484N/A* Mon Mar 13 2006 - damien.carbery@sun.com
14484N/A- Bump to 1.12.0.
14213N/A* Thu Mar 9 2006 - damien.carbery@sun.com
14213N/A- Bump to 0.11.21.
13780N/A* Sun Feb 26 2006 - damien.carbery@sun.com
13780N/A- Bump to 0.11.20.
13343N/A- Remove upstream patch, 08-logname. Renumber 12-g11n-word-char to 08.
13343N/A* Tue Feb 14 2006 - damien.carbery@sun.com
12875N/A- Enable freetype test in configure. Somehow this makes it build.
12875N/A* Mon Feb 13 2006 - damien.carbery@sun.com
12875N/A- Bump to 0.11.18.
12875N/A* Sun Jan 29 2006 - damien.carbery@sun.com
12875N/A- Bump to 0.11.17
12584N/A* Mon Jan 16 2006 - damien.carbery@sun.com
12584N/A- Remove upstream patch 08-fix-crash; rename 13-logname to 08-logname.
12153N/A* Sun Jan 15 2006 - damien.carbery@sun.com
12153N/A- Bump to 0.11.16
12072N/A* Thu Oct 27 2005 - laca@sun.com
12072N/A- move the python stuff from site-packages to vendor-packages
12022N/A* Tue Sep 06 2005 - damien.carbery@sun.com
12022N/A- Remove upstream patch, vte-04-a11y-selection.diff. Reorder remaining.
12020N/A* Mon Sep 05 2005 - damien.carbery@sun.com
12020N/A- Bump to 2.11.15.
11874N/A* Thu Aug 25 2005 - damien.carbery@sun.com
11874N/A- Add python build dependency and add python modules back into %files.
11874N/A* Wed Aug 24 2005 - damien.carbery@sun.com
11260N/A- Remove python references as the module doesn't generate any.
12022N/A* Tue Aug 16 2005 - damien.carbery@sun.com
11260N/A- Bump to 0.11.14.
10979N/A* Fri May 13 2005 - balamurali.viswanathan@wipro.com
10979N/A- Bump to 0.11.13
10972N/A* Wed Mar 16 2005 - takao.fujiwara@sun.com
10972N/A- Added vte-14-g11n-word-char.diff fo select localized strings exactly.
10818N/A Fix 6241338.
10818N/A* Wed Nov 24 2004 - narayana.pattipati@wipro.com
10698N/A- Updated the patch vte-11-scrolling-perf-improve.diff to chnage
10698N/A vte input buffer size to 2K. Fixes bugtraq bug#6198452.
10698N/A Patch reviewed by ghee.teo@sun.com
10689N/A* Fri Nov 12 2004 - suresh.chandrasekharan@sun.com
10689N/A- Added patch vte-13-preddit-crash-on-close.diff
10689N/A Bugster #6193929
10689N/A* Fri Nov 05 2004 - balamurali.viswanathan@wipro.com
10552N/A- Added patch vte-12-selection-perf-improve.diff to improve selection
10552N/A performance
10540N/A* Fri Oct 29 2004 - narayana.pattipati@wipro.com
10540N/A- Added patch vte-11-scrolling-perf-improve.diff to improve scrolling
10516N/A performance of gnome-terminal based on VTE. The patch improves the
10516N/A performance of the issues mentioned in bugtraq bug#5014824. Most of
10471N/A the patch is taken from the patch given to bugzilla bug#143914.
10471N/A* Thu Oct 28 2004 - matt.keenan@sun.com
10462N/A- Add vte.1, libvte.3 man pages
10462N/A* Wed Oct 27 2004 - padraig.obriain@sun.com
10410N/A- Add patch vte-10-get-text.diff to fix bugzilla 156161.
10410N/A* Mon Oct 18 2004 - padraig.obriain@sun.com
10285N/A- Add patch vte-09-fix-crash.diff to fix bug 5107420.
10285N/A* Sat Oct 09 2004 - federic.zhang@sun.com
10179N/A- Add patch vte-08-utf8-ambiguous.diff to fix bug 5028816
10179N/A gnome-terminal display full-width characters as half-width on UTF-8
10139N/A* Fri Oct 08 2004 - archana.shah@wipro.com
10139N/A- Added patch vte-07-update-logout-record.diff
10139N/A Fixes bug#5084840
10139N/A* Mon Oct 04 2004 - narayana.pattipati@wipro.com
10139N/A- Added patch vte-06-cut-copy-paste-handle.diff to make Sun Cut,
10139N/A Copy, Paste keys work in gnome-terminal. Fixes bug#5098217
10139N/A* Thu Aug 26 2004 - hidetoshi.tajima@sun.com
10139N/A- Add patch vte-05-inputmethod-spotlocation.diff for bugzilla #150052,
10139N/A bugtraq #5080038
10139N/A* Wed Aug 18 2004 - brian.cameron@sun.com
10139N/A- added --enable-gtk-doc
10139N/A* Thu Jul 22 2004 - padraig.obriain@sun.com
10139N/A- Add patch vte-04-a11y-selection.diff for bugzilla #113590
10139N/A* Sun Jul 11 2004 - niall.power@sun.com
10139N/A- build fixup
10139N/A* Thu Jul 08 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A- removed auto*-jds stuff, not needed with SuSE 9.1
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
16368N/A- Updated l10n content to vte-l10n-po-1.2.tar.bz2
10139N/A* Thu Jul 08 2004 - ghee.teo@sun.com
10139N/A- updated vte.spec to remove the ifos from around gnome-pty-helper
10139N/A essentially yo revert back to what it was.
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Tue Jun 22 2004 <federic.zhang@sun.com>
10139N/A- Based on the 0.11.11 version, recreate the vte-03-fcconfig.diff patch
10139N/A* Mon Jun 14 2004 ghee.teo@sun.com
10139N/A- Fixes stopper bug 5062671, not to use gnome-pty-helper on Solaris.
10139N/A Essentially just don't include the binary in Solaris.
10139N/A* Fri Jun 11 2004 damien.carbery@sun.com
10139N/A- Added patch to add '-lglib-2.0' to src/Makefile.am to build on Solaris sparc.
10139N/A* Thu Jun 10 2004 johan.steyn@sun.com
10139N/A- Changed to use correct autotools, hence no longer need autotools patch
10139N/A* Wed Jun 09 2004 damien.carbery@sun.com
10139N/A- Add '--disable-freetypetest' configure switch because S9x86 build fails when
10139N/A configure tries to run the test app, because /opt/jds/lib not in
10139N/A LD_LIBRARY_PATH or -R link parameter.
10139N/A* Tue Jun 08 2004 johan.steyn@sun.com
10139N/A- Update to 0.11.11 tarball
10139N/A* Mon May 17 2004 - <federic.zhang@sun.com>
10139N/A- Fixed bug 5042257 by adding patch vte-02-fcconfig.diff
10139N/A [Cinnabar Linux] The CJK font rendering in gnome-terminal is not acceptable
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to vte-l10n-po-1.1.tar.bz2
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to vte-l10n-po-1.0.tar.bz2
10139N/A* Tue Feb 24 2004 - <matt.keenan@sun.com>
10139N/A- Update Distro, l10n tarball
10139N/A* Thu Feb 12 2004 - <niall.power@sun.com>
10139N/A- Added patch #01 to create an *-uninstalled-pc.file
10139N/A- Autotoolize the build stage
10139N/A* Fri Oct 17 2003 - <michael.twomey@sun.com> - 0.11.10-1
10139N/A- Uprevved to GNOME 2.4.0 version.
10139N/A- Changed source url.
10139N/A* Thu Aug 14 2003 - <laca@sun.com>
10139N/A- remove *.a
10139N/A* Tue May 13 2003 - ghee.teo@sun.com
10139N/A- initial Sun release
10139N/A