vte.spec revision 10552
19997N/A#
19997N/A# spec file for package vte
19997N/A#
19997N/A# Copyright (c) 2005 Sun Microsystems, Inc.
19997N/A# This file and all modifications and additions to the pristine
19997N/A# package are under the same license as the package itself.
19997N/A#
19997N/A# Owner: yippi
19997N/A#
19997N/AName: vte
19997N/ALicense: LGPL
19997N/AGroup: System/Libraries
19997N/AVersion: 0.16.3
19997N/ARelease: 1
19997N/ADistribution: Java Desktop System
19997N/AVendor: Sun Microsystems, Inc.
19997N/ASummary: Terminal Emulation Widget Library
19997N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.16/%{name}-%{version}.tar.bz2
19997N/A#owner:yippi date:2004-06-22 type:bug bugzilla:142640
19997N/APatch1: vte-01-fcconfig.diff
19997N/A#owner:yippi date:2005-09-06 type:bug bugzilla:150052 bugster:5080038
19997N/APatch2: vte-02-inputmethod-spotlocation.diff
19997N/A#owner:yippi date:2005-09-06 type:bug bugzilla:153265 bugster:5098217
19997N/APatch3: vte-03-cut-copy-paste-handle.diff
19997N/A#owner:yippi date:2005-09-06 type:bug bugster:6198452,5014824 bugzilla:143914
19997N/APatch4: vte-04-selection-perf-improve.diff
19997N/A#owner:fujiwara date:2007-04-27 type:bug bugster:6548846 bugzilla:433776
19997N/APatch5: vte-05-g11n-segv-preedit.diff
19997N/AURL: http://www.gnome.org
19997N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19997N/ADocdir: %{_defaultdocdir}/doc
19997N/AAutoReqProv: on
19997N/APrereq: /sbin/ldconfig
19997N/A
19997N/A%define gtk2_version 2.10.0
19997N/A%define python_version 2.4
19997N/A
19997N/ARequires: gtk2 >= %{gtk2_version}
19997N/ABuildRequires: gtk2-devel >= %{gtk2_version}
19997N/ABuildRequires: python >= %{python_version}
19997N/A
19997N/A%description
19997N/AVTE is a terminal emulation widget for GTK+, used in GNOME Terminal.
19997N/A
19997N/A%package devel
19997N/ASummary: Terminal Emulation Widget Development Library
19997N/AGroup: Development/Libraries
19997N/ARequires: %{name} = %{version}-%{release}
19997N/ARequires: gtk2-devel >= %{gtk2_version}
19997N/A
19997N/A%description devel
19997N/AVTE is a terminal emulation widget for GTK+, used in GNOME Terminal.
19997N/A
19997N/A%prep
19997N/A%setup -q
19997N/A%patch1 -p1
19997N/A%patch2 -p1
19997N/A%patch3 -p1
19997N/A%patch4 -p1
19997N/A%patch5 -p1
19997N/A
19997N/A%build
19997N/A%ifos linux
19997N/Aif [ -x /usr/bin/getconf ]; then
19997N/A CPUS=`getconf _NPROCESSORS_ONLN`
19997N/Afi
19997N/A%else
19997N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19997N/A%endif
19997N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
19997N/A CPUS=1
19997N/Afi
19997N/A
19997N/Alibtoolize --force
19997N/Aaclocal $ACLOCAL_FLAGS -I .
19997N/Aautoheader
19997N/Aautomake -a -c -f
19997N/Aautoconf
19997N/A
19997N/ACFLAGS="$RPM_OPT_FLAGS" \
19997N/A./configure --prefix=%{_prefix} \
19997N/A --sysconfdir=%{_sysconfdir} \
19997N/A --datadir=%{_datadir} \
19997N/A --libexecdir=%{_libexecdir} \
19997N/A %{gtk_doc_option}
19997N/Amake -j $CPUS \
19997N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
19997N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
19997N/A
19997N/A%install
19997N/Amake DESTDIR=$RPM_BUILD_ROOT install \
19997N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
19997N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
19997N/A#Copy zh_HK from zh_TW
19997N/A#Fixes bug 4930405
19997N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
19997N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
19997N/A# Clean up unpackaged files
19997N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
19997N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
19997N/Arm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.a
19997N/Arm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.la
19997N/A
19997N/A
19997N/A%clean
19997N/Arm -rf $RPM_BUILD_ROOT
19997N/A
19997N/A%post
19997N/A/sbin/ldconfig
19997N/A
19997N/A%postun
19997N/A/sbin/ldconfig
19997N/A
19997N/A%files
19997N/A%defattr(-,root,root)
19997N/A%{_bindir}/*
19997N/A%{_libdir}/*.so*
19997N/A%attr(2711,root,utmp) %{_libexecdir}/gnome-pty-helper
19997N/A%{_datadir}/%{name}
19997N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
19997N/A%{_mandir}/man1/*
19997N/A%{_mandir}/man3/*
19997N/A
19997N/A%files devel
19997N/A%defattr(-,root,root)
19997N/A%{_datadir}/gtk-doc/html/%{name}
19997N/A%{_includedir}/*
19997N/A%{_libdir}/*.so
19997N/A%dir %{_libdir}/%{name}
19997N/A%{_libdir}/%{name}/*
19997N/A%{_libdir}/pkgconfig/*
19997N/A%{_libdir}/python2.4/vendor-packages/gtk-2.0/vtemodule.so
19997N/A
19997N/A%changelog
19997N/A* Mon Apr 30 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.16.3.
19997N/A* Fri Apr 27 2007 - takao.fujiwara@sun.com
19997N/A- Add vte-05-g11n-segv-preedit.diff. Fixes 6548846
19997N/A* Tue Apr 24 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.16.2. Remove upstream patch 04-utf8-ambiguous. Renumber rest.
19997N/A* Thu Apr 12 2007 - damien.carbery@sun.com
19997N/A- Remove upstream patch, 06-nullptr-check.
19997N/A* Wed Apr 11 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.16.1.
19997N/A* Wed Apr 4 2007 - dougs@truemail.co.th
19997N/A- Added patch vte-06-nullptr-check.diff to fix bugzilla 425767.
19997N/A* Tue Mar 13 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.16.0.
19997N/A* Mon Mar 05 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.15.6.
19997N/A* Wed Feb 28 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.15.5. Remove upstream patch 06-environ.
19997N/A* Wed Feb 14 2007 - damien.carbery@sun.com
19997N/A- Remove upstream patch, 06-vte-pty-open. Add patch, 06-environ to fix #407839.
19997N/A* Tue Feb 13 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.15.3.
19997N/A* Thu Feb 08 2007 - brian.cameron@sun.com
19997N/A- Remove unneeded patch vte-01-vtefc.diff. Now FC_WIDTH is defined on
19997N/A Solaris, so it's no longer needed to wrap it with #ifdef FC_WIDTH.
19997N/A* Tue Jan 23 2007 - damien.carbery@sun.com
19997N/A- Add patch, 07-vte-pty-open, to sync func declaration with definition; #400184.
19997N/A* Tue Jan 23 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.15.2. Remove upstream patch, 06-get-text. Renumber remainder.
19997N/A* Tue Jan 09 2007 - damien.carbery@sun.com
19997N/A- Bump to 0.15.1.
19997N/A* Thu Dec 07 2006 - damien.carbery@sun.com
19997N/A- Bump to 0.15.0.
19997N/A* Fri Nov 3 2006 - laca@sun.com
19997N/A- use %gtk_doc_option in configure so that it can be disabled using
19997N/A --without-gtk-doc
19997N/A* Tue Oct 03 2006 - damien.carbery@sun.com
19997N/A- Bump to 0.14.1.
19997N/A* Thu Sep 14 2006 - matt.keenan@sun.com
19997N/A- Remove patch vte-08-pre-edit-crash-on-close.diff, as causing
two bugs, 6453098, and 6465619, and removing does not re-introduce 6193929.
* Tue Sep 05 2006 - damien.carbery@sun.com
- Bump to 0.14.0.
* Fri Aug 25 2006 - damien.carbery@sun.com
- Bump to 0.13.7.
* Mon Aug 21 2006 - damien.carbery@sun.com
- Bump to 0.13.6.
* Tue Aug 01 2006 - damien.carbery@sun.com
- Bump to 0.13.5.
* Tue Jul 25 2006 - damien.carbery@sun.com
- Remove upstream patch, 05-update-logout-record. Rename remaining.
* Tue Jul 25 2006 - damien.carbery@sun.com
- Bump to 0.13.4.
* Fri Jul 21 2006 - padraig.obriain@sun.com
- Bump to 0.13.3 for gnome 2.15.
- Remove patch vte-07-g11n-word-char.diff as this issue is addressed,
slightly differently, in vte code.
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 0.12.2.
* Thu Apr 27 2006 - damien.carbery@sun.com
- Remove upstream patch, vte-12-msgfmt-no-c-param.diff.
* Thu Apr 27 2006 - damien.carbery@sun.com
- Bump to 1.12.1.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Add patch, 12-msgfmt-no-c-param, to remove '-c' param from msgfmt call. That
switch breaks Solaris build.
* Mon Mar 13 2006 - damien.carbery@sun.com
- Bump to 1.12.0.
* Thu Mar 9 2006 - damien.carbery@sun.com
- Bump to 0.11.21.
* Sun Feb 26 2006 - damien.carbery@sun.com
- Bump to 0.11.20.
- Remove upstream patch, 08-logname. Renumber 12-g11n-word-char to 08.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Enable freetype test in configure. Somehow this makes it build.
* Mon Feb 13 2006 - damien.carbery@sun.com
- Bump to 0.11.18.
* Sun Jan 29 2006 - damien.carbery@sun.com
- Bump to 0.11.17
* Mon Jan 16 2006 - damien.carbery@sun.com
- Remove upstream patch 08-fix-crash; rename 13-logname to 08-logname.
* Sun Jan 15 2006 - damien.carbery@sun.com
- Bump to 0.11.16
* Thu Oct 27 2005 - laca@sun.com
- move the python stuff from site-packages to vendor-packages
* Tue Sep 06 2005 - damien.carbery@sun.com
- Remove upstream patch, vte-04-a11y-selection.diff. Reorder remaining.
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.15.
* Thu Aug 25 2005 - damien.carbery@sun.com
- Add python build dependency and add python modules back into %files.
* Wed Aug 24 2005 - damien.carbery@sun.com
- Remove python references as the module doesn't generate any.
* Tue Aug 16 2005 - damien.carbery@sun.com
- Bump to 0.11.14.
* Fri May 13 2005 - balamurali.viswanathan@wipro.com
- Bump to 0.11.13
* Wed Mar 16 2005 - takao.fujiwara@sun.com
- Added vte-14-g11n-word-char.diff fo select localized strings exactly.
Fix 6241338.
* Wed Nov 24 2004 - narayana.pattipati@wipro.com
- Updated the patch vte-11-scrolling-perf-improve.diff to chnage
vte input buffer size to 2K. Fixes bugtraq bug#6198452.
Patch reviewed by ghee.teo@sun.com
* Fri Nov 12 2004 - suresh.chandrasekharan@sun.com
- Added patch vte-13-preddit-crash-on-close.diff
Bugster #6193929
* Fri Nov 05 2004 - balamurali.viswanathan@wipro.com
- Added patch vte-12-selection-perf-improve.diff to improve selection
performance
* Fri Oct 29 2004 - narayana.pattipati@wipro.com
- Added patch vte-11-scrolling-perf-improve.diff to improve scrolling
performance of gnome-terminal based on VTE. The patch improves the
performance of the issues mentioned in bugtraq bug#5014824. Most of
the patch is taken from the patch given to bugzilla bug#143914.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add vte.1, libvte.3 man pages
* Wed Oct 27 2004 - padraig.obriain@sun.com
- Add patch vte-10-get-text.diff to fix bugzilla 156161.
* Mon Oct 18 2004 - padraig.obriain@sun.com
- Add patch vte-09-fix-crash.diff to fix bug 5107420.
* Sat Oct 09 2004 - federic.zhang@sun.com
- Add patch vte-08-utf8-ambiguous.diff to fix bug 5028816
gnome-terminal display full-width characters as half-width on UTF-8
* Fri Oct 08 2004 - archana.shah@wipro.com
- Added patch vte-07-update-logout-record.diff
Fixes bug#5084840
* Mon Oct 04 2004 - narayana.pattipati@wipro.com
- Added patch vte-06-cut-copy-paste-handle.diff to make Sun Cut,
Copy, Paste keys work in gnome-terminal. Fixes bug#5098217
* Thu Aug 26 2004 - hidetoshi.tajima@sun.com
- Add patch vte-05-inputmethod-spotlocation.diff for bugzilla #150052,
bugtraq #5080038
* Wed Aug 18 2004 - brian.cameron@sun.com
- added --enable-gtk-doc
* Thu Jul 22 2004 - padraig.obriain@sun.com
- Add patch vte-04-a11y-selection.diff for bugzilla #113590
* Sun Jul 11 2004 - niall.power@sun.com
- build fixup
* Thu Jul 08 2004 - niall.power@sun.com
- ported to rpm4
- removed auto*-jds stuff, not needed with SuSE 9.1
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to vte-l10n-po-1.2.tar.bz2
* Thu Jul 08 2004 - ghee.teo@sun.com
- updated vte.spec to remove the ifos from around gnome-pty-helper
essentially yo revert back to what it was.
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Tue Jun 22 2004 <federic.zhang@sun.com>
- Based on the 0.11.11 version, recreate the vte-03-fcconfig.diff patch
* Mon Jun 14 2004 ghee.teo@sun.com
- Fixes stopper bug 5062671, not to use gnome-pty-helper on Solaris.
Essentially just don't include the binary in Solaris.
* Fri Jun 11 2004 damien.carbery@sun.com
- Added patch to add '-lglib-2.0' to src/Makefile.am to build on Solaris sparc.
* Thu Jun 10 2004 johan.steyn@sun.com
- Changed to use correct autotools, hence no longer need autotools patch
* Wed Jun 09 2004 damien.carbery@sun.com
- Add '--disable-freetypetest' configure switch because S9x86 build fails when
configure tries to run the test app, because /opt/jds/lib not in
LD_LIBRARY_PATH or -R link parameter.
* Tue Jun 08 2004 johan.steyn@sun.com
- Update to 0.11.11 tarball
* Mon May 17 2004 - <federic.zhang@sun.com>
- Fixed bug 5042257 by adding patch vte-02-fcconfig.diff
[Cinnabar Linux] The CJK font rendering in gnome-terminal is not acceptable
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to vte-l10n-po-1.1.tar.bz2
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to vte-l10n-po-1.0.tar.bz2
* Tue Feb 24 2004 - <matt.keenan@sun.com>
- Update Distro, l10n tarball
* Thu Feb 12 2004 - <niall.power@sun.com>
- Added patch #01 to create an *-uninstalled-pc.file
- Autotoolize the build stage
* Fri Oct 17 2003 - <michael.twomey@sun.com> - 0.11.10-1
- Uprevved to GNOME 2.4.0 version.
- Changed source url.
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.a
* Tue May 13 2003 - ghee.teo@sun.com
- initial Sun release