tracker.spec revision 17700
18861N/A#
18861N/A# spec file for package tracker
18861N/A#
18861N/A# Copyright 2008 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A%define owner jerrytan
18861N/A#
18861N/A
18861N/A%define OSR gnome.org:0
18861N/A
18861N/A%include l10n.inc
18861N/AName: tracker
18861N/ALicense: GPL v2
18861N/AGroup: Applications/System
18861N/AVersion: 0.6.95
18861N/A#### DO NOT BUMP MODULE TO 0.7.0 AS IT'S DEPENDENCY ARE NOT READY
18861N/ARelease: 1
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/AURL: http://www.tracker-project.org
18861N/ASummary: Desktop search tool
18861N/ASource: ftp://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/tracker-%{version}.tar.gz
18861N/ASource1: l10n-configure.sh
18861N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
18861N/A# date:2008-01-23 owner:halton type:branding
18861N/APatch1: %{name}-01-disable-autostart.diff
18861N/A# date:2008-01-23 owner:jerrytan type:branding
18861N/APatch2: %{name}-02-man.diff
18861N/A# date:2008-08-22 owner:jerrytan type:branding bugster:6723896
18861N/APatch3: tracker-03-removetag.diff
18861N/A# date:2008-09-12 owner:jedy type:branding
18861N/APatch4: tracker-04-menu-entries.diff
18861N/A# date:2008-10-27 owner:jerrytan type:branding
18861N/APatch5: tracker-05-disable-home-index.diff
18861N/A# date:2009-02-24 owner:jerrytan type:branding
18861N/APatch6: %{name}-06-upgrade.diff
18861N/A# date:2009-03-04 owner:jerrytan type:branding
18861N/APatch7: %{name}-07-replace-odt2txt-with-o3read.diff
18861N/A# date:2009-03-30 owner:jerrytan type:branding
18861N/APatch8: %{name}-08-strcasestr.diff
18861N/A# date:2009-09-24 owner:jerrytan type:branding
18861N/APatch9: tracker-09-ugrade_to_gmime2.4.diff
18861N/A# date:2009-11-13 owner:jerrytan type:branding
18861N/APatch10: tracker-10-web-history-module.diff
18861N/A
18861N/A
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
18861N/A
18861N/ABuildRequires: gmime-devel, poppler-devel, gettext
18861N/ABuildRequires: gnome-desktop-devel, gamin-devel
18861N/ABuildRequires: libexif-devel, libgsf-devel, gstreamer-devel
18861N/ABuildRequires: desktop-file-utils, intltool
18861N/ABuildRequires: sqlite-devel
18861N/ABuildRequires: dbus-devel, dbus-glib
18861N/A
18861N/A
18861N/A%description
18861N/ATracker is a powerful desktop-neutral first class object database,
18861N/Atag/metadata database, search tool and indexer.
18861N/A
18861N/AIt consists of a common object database that allows entities to have an
18861N/Aalmost infinte number of properties, metadata (both embedded/harvested as
18861N/Awell as user definable), a comprehensive database of keywords/tags and
18861N/Alinks to other entities.
18861N/A
18861N/AIt provides additional features for file based objects including context
18861N/Alinking and audit trails for a file object.
18861N/A
18861N/AIt has the ability to index, store, harvest metadata. retrieve and search
18861N/Aall types of files and other first class objects
18861N/A
18861N/A%package devel
18861N/ASummary: Headers for developing programs that will use %{name}
18861N/AGroup: Development/Libraries
18861N/ARequires: %{name} = %{version}-%{release}
18861N/ARequires: pkgconfig
18861N/A
18861N/A%description devel
18861N/AThis package contains the static libraries and header files needed for
18861N/Adeveloping with tracker
18861N/A
18861N/A%prep
18861N/A%setup -q
18861N/Abash %SOURCE1 --enable-sun-linguas
18861N/Abzcat %SOURCE2 | tar xf -
18861N/Acd po-sun; make; cd ..
18861N/A
18861N/A%patch1 -p1
18861N/A%patch2 -p1
18861N/A%patch3 -p1
18861N/A%patch4 -p1
18861N/A%patch5 -p1
18861N/A%patch6 -p1
18861N/A%patch7 -p1
18861N/A%patch8 -p1
18861N/A%patch9 -p1
18861N/A
18861N/A%build
18861N/A%ifos linux
18861N/Aif [ -x /usr/bin/getconf ]; then
18861N/A CPUS=`getconf _NPROCESSORS_ONLN`
18861N/Afi
18861N/A%else
18861N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/A%endif
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Aintltoolize --force --automake
18861N/A
18861N/Abash -x %SOURCE1 --enable-copyright
18861N/A
18861N/Alibtoolize --force
18861N/Aaclocal $ACLOCAL_FLAGS -I .
18861N/Aautoheader
18861N/Aautomake -a -c -f
18861N/Aautoconf
18861N/A
18861N/A./configure --prefix=%{_prefix} \
18861N/A --bindir=%{_bindir} \
18861N/A --mandir=%{_mandir} \
18861N/A --libdir=%{_libdir} \
18861N/A --libexecdir=%{_bindir} \
18861N/A --datadir=%{_datadir} \
18861N/A --includedir=%{_includedir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --disable-warnings \
18861N/A --enable-external-sqlite \
18861N/A --disable-evolution-push-module
18861N/A
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
%postun
/sbin/ldconfig
%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_bindir}/htmless
%{_bindir}/tracker*
%{_datadir}/tracker/
%{_datadir}/pixmaps/tracker/
%{_datadir}/dbus-1/services/org.freedesktop.Tracker.*
%{_datadir}/gtk-doc/
%{_libexecdir}/tracker*
%{_libdir}/*.so.*
%{_mandir}/man1/tracker*.1.gz
%{_sysconfdir}/xdg/autostart/trackerd.desktop
%files devel
%defattr(-, root, root)
%{_includedir}/tracker*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%changelog
* Wed Apr 15 2009 - dave.lin@sun.com
- Bump to 0.6.93
* Wed Mar 04 2009 - jerry.tan@sun.com
- Add tracker-18-replace-odt2txt-with-o3read.diff to use o3read until odt2txt introduced
* Tue Feb 24 2009 - jerry.tan@sun.com
- Add tracker-17-upgrade.diff to upgrade to tracker0.6.90
* Mon Feb 16 2009 - jerry.tan@sun.com
- Add tracker-16-extract-jpeg-core-dump.diff to fix bug 6802570
* Fri Feb 06 2009 - jerry.tan@sun.com
- Add tracker-15-libumem-check.diff to fix bug 6763771
* Mon Dec 15 2008 - takao.fujiwara@sun.com
- Apply po.diff before l10n tarball is extracted.
* Wed Oct 01 2008 - takao.fujiwara@sun.com
- Add l10n tarball.
* Fri Sep 12 2008 - jedy.wang@sun.com
- Add tracker-12-menu-entries.diff.
* Wed Aug 13 2008 - takao.fujiwara@sun.com
- Add tracker-10-po.diff from community trunk.
* Mon Mar 03 2008 - halton.huo@sun.com
- Bump to 0.6.6
- Remove upstreamed patch r1071-latest.diff and firefox-history.diff, reorder
* Wed Feb 27 2008 - halton.huo@sun.com
- Update comment for thunderbird.diff and firefox-history.diff to type:feature
* Tue Feb 26 2008 - halton.huo@sun.com
- Update comment for r1071-latest.diff to type:feature state:upstream
* Wed Jan 23 2008 - nonsea@users.sourceforge.net
- Remove upstreamed patch preferences-explicit-apply.diff
- Add temporary patch tp-reindex.diff
* Tue Jan 22 2008 - nonsea@users.sourceforge.net
- Add patch preferences-explicit-apply.diff
- Add patch evo-reload.diff
- Add patch man.diff
- Rename r1071-r1092.diff to r1071-latest.diff
- Reorder patches.
* Thu Jan 03 2008 - nonsea@users.sourceforge.net
- Add patch disable-autostart.diff
- Add patch check-remote.diff
- Add patch r1071-r1092.diff
* Sat Nov 17 2007 - daymobrew@users.sourceforge.net
- Unbump to 0.6.3 and remove obsolete patch, 02-thunderbird.
* Fri Nov 02 2007 - nonsea@users.sourceforge.net
- Initial version, spilit from SFEtracker.spec