tracker.spec revision 16572
10139N/A#
10139N/A# spec file for package tracker
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: jerrytan
10139N/A#
10139N/A
10139N/A%include l10n.inc
11819N/AName: tracker
10139N/ALicense: GPL v2
10139N/AGroup: Applications/System
10139N/AVersion: 0.6.95
10139N/ARelease: 1
11819N/ADistribution: Java Desktop System
10794N/AVendor: Sun Microsystems, Inc.
10794N/AURL: http://www.tracker-project.org
10794N/ASummary: Desktop search tool
10139N/ASource: ftp://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/tracker-%{version}.tar.gz
10815N/ASource1: l10n-configure.sh
11418N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
11418N/A# date:2008-01-23 owner:halton type:branding
10139N/APatch1: %{name}-01-disable-autostart.diff
10139N/A# date:2008-01-23 owner:jerrytan type:branding
10139N/APatch2: %{name}-02-man.diff
10139N/A# date:2008-08-22 owner:jerrytan type:branding bugster:6723896
10139N/APatch3: tracker-03-removetag.diff
10139N/A# date:2008-09-12 owner:jedy type:branding
10139N/APatch4: tracker-04-menu-entries.diff
10139N/A# date:2008-10-27 owner:jerrytan type:branding
10139N/APatch5: tracker-05-disable-home-index.diff
10139N/A# date:2009-02-24 owner:jerrytan type:branding
10139N/APatch6: %{name}-06-upgrade.diff
10139N/A# date:2009-03-04 owner:jerrytan type:branding
10139N/APatch7: %{name}-07-replace-odt2txt-with-o3read.diff
10139N/A# date:2009-03-30 owner:jerrytan type:branding
10139N/APatch8: %{name}-08-strcasestr.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/A
10139N/ABuildRequires: gmime-devel, poppler-devel, gettext
10139N/ABuildRequires: gnome-desktop-devel, gamin-devel
10139N/ABuildRequires: libexif-devel, libgsf-devel, gstreamer-devel
10139N/ABuildRequires: desktop-file-utils, intltool
10139N/ABuildRequires: sqlite-devel
10139N/ABuildRequires: dbus-devel, dbus-glib
10139N/A
10139N/A
10139N/A%description
10139N/ATracker is a powerful desktop-neutral first class object database,
10139N/Atag/metadata database, search tool and indexer.
10139N/A
10139N/AIt consists of a common object database that allows entities to have an
10139N/Aalmost infinte number of properties, metadata (both embedded/harvested as
10139N/Awell as user definable), a comprehensive database of keywords/tags and
10139N/Alinks to other entities.
10139N/A
10139N/AIt provides additional features for file based objects including context
10139N/Alinking and audit trails for a file object.
10139N/A
10139N/AIt has the ability to index, store, harvest metadata. retrieve and search
10139N/Aall types of files and other first class objects
10139N/A
10139N/A%package devel
10139N/ASummary: Headers for developing programs that will use %{name}
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}-%{release}
10139N/ARequires: pkgconfig
10139N/A
10139N/A%description devel
10139N/AThis package contains the static libraries and header files needed for
10139N/Adeveloping with tracker
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/Abash %SOURCE1 --enable-sun-linguas
10139N/Abzcat %SOURCE2 | tar xf -
10139N/Acd po-sun; make; cd ..
10794N/A
10794N/A%if %option_with_sun_branding
10794N/A%patch1 -p1
10794N/A%endif
11087N/A%patch2 -p1
11418N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A%patch8 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aintltoolize --force --automake
10139N/A
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A
11338N/Alibtoolize --force
11338N/Aaclocal $ACLOCAL_FLAGS -I .
11338N/Aautoheader
11338N/Aautomake -a -c -f
11338N/Aautoconf
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_bindir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --disable-warnings \
10139N/A --enable-external-sqlite \
10139N/A --disable-evolution-push-module
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
11338N/A%post
11338N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS ChangeLog COPYING NEWS README
10139N/A%{_bindir}/htmless
10139N/A%{_bindir}/tracker*
10139N/A%{_datadir}/tracker/
10139N/A%{_datadir}/pixmaps/tracker/
10139N/A%{_datadir}/dbus-1/services/org.freedesktop.Tracker.*
10139N/A%{_datadir}/gtk-doc/
10139N/A%{_libexecdir}/tracker*
10139N/A%{_libdir}/*.so.*
10139N/A%{_mandir}/man1/tracker*.1.gz
10139N/A%{_sysconfdir}/xdg/autostart/trackerd.desktop
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/tracker*
10139N/A%{_libdir}/*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A
10139N/A%changelog
10139N/A* Wed Apr 15 2009 - dave.lin@sun.com
10139N/A- Bump to 0.6.93
10139N/A* Wed Mar 04 2009 - jerry.tan@sun.com
10139N/A- Add tracker-18-replace-odt2txt-with-o3read.diff to use o3read until odt2txt introduced
10139N/A* Tue Feb 24 2009 - jerry.tan@sun.com
10139N/A- Add tracker-17-upgrade.diff to upgrade to tracker0.6.90
10139N/A* Mon Feb 16 2009 - jerry.tan@sun.com
10139N/A- Add tracker-16-extract-jpeg-core-dump.diff to fix bug 6802570
10139N/A* Fri Feb 06 2009 - jerry.tan@sun.com
10139N/A- Add tracker-15-libumem-check.diff to fix bug 6763771
10139N/A* Mon Dec 15 2008 - takao.fujiwara@sun.com
10139N/A- Apply po.diff before l10n tarball is extracted.
10139N/A* Wed Oct 01 2008 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Fri Sep 12 2008 - jedy.wang@sun.com
10139N/A- Add tracker-12-menu-entries.diff.
11819N/A* Wed Aug 13 2008 - takao.fujiwara@sun.com
11819N/A- Add tracker-10-po.diff from community trunk.
11416N/A* Mon Mar 03 2008 - halton.huo@sun.com
11418N/A- Bump to 0.6.6
11338N/A- Remove upstreamed patch r1071-latest.diff and firefox-history.diff, reorder
11338N/A* Wed Feb 27 2008 - halton.huo@sun.com
11253N/A- Update comment for thunderbird.diff and firefox-history.diff to type:feature
11253N/A* Tue Feb 26 2008 - halton.huo@sun.com
11172N/A- Update comment for r1071-latest.diff to type:feature state:upstream
11172N/A* Wed Jan 23 2008 - nonsea@users.sourceforge.net
11118N/A- Remove upstreamed patch preferences-explicit-apply.diff
11118N/A- Add temporary patch tp-reindex.diff
11087N/A* Tue Jan 22 2008 - nonsea@users.sourceforge.net
11087N/A- Add patch preferences-explicit-apply.diff
11087N/A- Add patch evo-reload.diff
11073N/A- Add patch man.diff
11067N/A- Rename r1071-r1092.diff to r1071-latest.diff
11067N/A- Reorder patches.
11060N/A* Thu Jan 03 2008 - nonsea@users.sourceforge.net
11060N/A- Add patch disable-autostart.diff
11025N/A- Add patch check-remote.diff
11025N/A- Add patch r1071-r1092.diff
11025N/A* Sat Nov 17 2007 - daymobrew@users.sourceforge.net
10986N/A- Unbump to 0.6.3 and remove obsolete patch, 02-thunderbird.
10988N/A* Fri Nov 02 2007 - nonsea@users.sourceforge.net
10980N/A- Initial version, spilit from SFEtracker.spec
10980N/A