tracker.spec revision 16130
10139N/A#
10139N/A# spec file for package tracker
10139N/A#
17957N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: jerrytan
10139N/A#
16128N/A
16128N/A%include l10n.inc
16128N/AName: tracker
18603N/ALicense: GPL v2
17181N/AGroup: Applications/System
10139N/AVersion: 0.6.90
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
18524N/AURL: http://www.tracker-project.org
17957N/ASummary: Desktop search tool
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.6/tracker-%{version}.tar.gz
18615N/ASource1: l10n-configure.sh
10139N/ASource2: %{name}-po-sun-%{po_sun_version}.tar.bz2
18524N/A# date:2008-01-23 owner:halton type:branding
10139N/APatch1: %{name}-01-disable-autostart.diff
10139N/A# date:2008-01-23 owner:jerrytan type:branding
10139N/APatch2: %{name}-02-man.diff
10139N/A# date:2008-08-22 owner:jerrytan type:branding bugster:6723896
10139N/APatch3: tracker-03-removetag.diff
10139N/A# date:2008-09-12 owner:jedy type:branding
10139N/APatch4: tracker-04-menu-entries.diff
10139N/A# date:2008-10-27 owner:jerrytan type:branding
10139N/APatch5: tracker-05-disable-home-index.diff
10139N/A# date:2009-02-24 owner:jerrytan type:branding
10139N/APatch6: %{name}-06-upgrade.diff
10139N/A# date:2009-03-04 owner:jerrytan type:branding
10139N/APatch7: %{name}-07-replace-odt2txt-with-o3read.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/A
10139N/ABuildRequires: gmime-devel, poppler-devel, gettext
10139N/ABuildRequires: gnome-desktop-devel, gamin-devel
10139N/ABuildRequires: libexif-devel, libgsf-devel, gstreamer-devel
10139N/ABuildRequires: desktop-file-utils, intltool
10139N/ABuildRequires: sqlite-devel
10139N/ABuildRequires: dbus-devel, dbus-glib
10139N/A
10139N/A
10139N/A%description
10139N/ATracker is a powerful desktop-neutral first class object database,
10139N/Atag/metadata database, search tool and indexer.
10139N/A
10139N/AIt consists of a common object database that allows entities to have an
10139N/Aalmost infinte number of properties, metadata (both embedded/harvested as
10139N/Awell as user definable), a comprehensive database of keywords/tags and
10139N/Alinks to other entities.
10139N/A
10139N/AIt provides additional features for file based objects including context
10139N/Alinking and audit trails for a file object.
10139N/A
10139N/AIt has the ability to index, store, harvest metadata. retrieve and search
10139N/Aall types of files and other first class objects
16128N/A
10139N/A%package devel
15469N/ASummary: Headers for developing programs that will use %{name}
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}-%{release}
10139N/ARequires: pkgconfig
10139N/A
10139N/A%description devel
10139N/AThis package contains the static libraries and header files needed for
10139N/Adeveloping with tracker
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/Abash %SOURCE1 --enable-sun-linguas
10139N/Abzcat %SOURCE2 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A
10139N/A%if %option_with_sun_branding
10139N/A%patch1 -p1
10139N/A%endif
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A
18524N/A%build
18524N/A%ifos linux
17957N/Aif [ -x /usr/bin/getconf ]; then
17957N/A CPUS=`getconf _NPROCESSORS_ONLN`
16176N/Afi
17957N/A%else
17957N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
16128N/A%endif
16128N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15469N/A CPUS=1
17957N/Afi
15461N/A
17957N/Aintltoolize --force --automake
12722N/A
12722N/Abash -x %SOURCE1 --enable-copyright
12634N/A
12634N/Alibtoolize --force
11333N/Aaclocal $ACLOCAL_FLAGS -I .
11333N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
17957N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
17957N/A --mandir=%{_mandir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_bindir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --disable-warnings \
10139N/A --enable-external-sqlite \
10139N/A# --enable-evolution-plugin\
10139N/A
17957N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
17957N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
17957N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
17957N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
17957N/A/sbin/ldconfig
%postun
/sbin/ldconfig
%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_bindir}/htmless
%{_bindir}/tracker*
%{_datadir}/tracker/
%{_datadir}/pixmaps/tracker/
%{_datadir}/dbus-1/services/org.freedesktop.Tracker.*
%{_datadir}/gtk-doc/
%{_libexecdir}/tracker*
%{_libdir}/*.so.*
%{_mandir}/man1/tracker*.1.gz
%{_sysconfdir}/xdg/autostart/trackerd.desktop
%files devel
%defattr(-, root, root)
%{_includedir}/tracker*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%changelog
* Wed Mar 04 2009 - jerry.tan@sun.com
- Add tracker-18-replace-odt2txt-with-o3read.diff to use o3read until odt2txt introduced
* Tue Feb 24 2009 - jerry.tan@sun.com
- Add tracker-17-upgrade.diff to upgrade to tracker0.6.90
* Mon Feb 16 2009 - jerry.tan@sun.com
- Add tracker-16-extract-jpeg-core-dump.diff to fix bug 6802570
* Fri Feb 06 2009 - jerry.tan@sun.com
- Add tracker-15-libumem-check.diff to fix bug 6763771
* Mon Dec 15 2008 - takao.fujiwara@sun.com
- Apply po.diff before l10n tarball is extracted.
* Wed Oct 01 2008 - takao.fujiwara@sun.com
- Add l10n tarball.
* Fri Sep 12 2008 - jedy.wang@sun.com
- Add tracker-12-menu-entries.diff.
* Wed Aug 13 2008 - takao.fujiwara@sun.com
- Add tracker-10-po.diff from community trunk.
* Mon Mar 03 2008 - halton.huo@sun.com
- Bump to 0.6.6
- Remove upstreamed patch r1071-latest.diff and firefox-history.diff, reorder
* Wed Feb 27 2008 - halton.huo@sun.com
- Update comment for thunderbird.diff and firefox-history.diff to type:feature
* Tue Feb 26 2008 - halton.huo@sun.com
- Update comment for r1071-latest.diff to type:feature state:upstream
* Wed Jan 23 2008 - nonsea@users.sourceforge.net
- Remove upstreamed patch preferences-explicit-apply.diff
- Add temporary patch tp-reindex.diff
* Tue Jan 22 2008 - nonsea@users.sourceforge.net
- Add patch preferences-explicit-apply.diff
- Add patch evo-reload.diff
- Add patch man.diff
- Rename r1071-r1092.diff to r1071-latest.diff
- Reorder patches.
* Thu Jan 03 2008 - nonsea@users.sourceforge.net
- Add patch disable-autostart.diff
- Add patch check-remote.diff
- Add patch r1071-r1092.diff
* Sat Nov 17 2007 - daymobrew@users.sourceforge.net
- Unbump to 0.6.3 and remove obsolete patch, 02-thunderbird.
* Fri Nov 02 2007 - nonsea@users.sourceforge.net
- Initial version, spilit from SFEtracker.spec