tracker.spec revision 13032
4623N/A#
4070N/A# spec file for package tracker
6033N/A#
4070N/A# Copyright 2008 Sun Microsystems, Inc.
4070N/A# This file and all modifications and additions to the pristine
4070N/A# package are under the same license as the package itself.
4070N/A#
4070N/A# Owner:halton
4070N/A#
4070N/A
4070N/AName: tracker
4070N/ALicense: GPL
4070N/AGroup: Applications/System
4070N/AVersion: 0.6.6
4070N/ARelease: 1
4070N/ADistribution: Java Desktop System
4070N/AVendor: Sun Microsystems, Inc.
4070N/AURL: http://www.tracker-project.org
4070N/ASummary: Desktop search tool
4070N/ASource: http://www.gnome.org/~jamiemcc/tracker/tracker-%{version}.tar.bz2
4070N/A%if %build_l10n
4070N/ASource1: l10n-configure.sh
4070N/A%endif
4070N/A# date:2008-01-23 owner:jerrytan type:branding
4070N/APatch1: %{name}-01-w3m-crash.diff
4070N/A# date:2008-01-23 owner:halton type:branding
4312N/APatch2: %{name}-02-disable-autostart.diff
4312N/A# date:2008-01-23 owner:jerrytan type:branding
4312N/APatch3: %{name}-03-man.diff
4070N/A# date:2008-01-23 owner:halton type:bug bugzilla:503725,503727,503960,503966,504000
4070N/APatch4: %{name}-04-tp-reindex.diff
4070N/A# date:2008-01-23 owner:halton type:bug bugzilla:503376
6033N/APatch5: %{name}-05-evo-reload.diff
6033N/A# date:2008-01-23 owner:migi type:feature
6033N/APatch6: %{name}-06-thunderbird.diff
6033N/A# date:2008-01-23 owner:rickju type:bug bugzilla:511474
4070N/APatch7: %{name}-07-check-remote.diff
6033N/A# date:2008-04-10 owner:jerrytan type:branding
6033N/APatch8: %{name}-08-enable-webhistory.diff
6033N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
6033N/A
6033N/ABuildRequires: gmime-devel, poppler-devel, gettext
6033N/ABuildRequires: gnome-desktop-devel, gamin-devel
6033N/ABuildRequires: libexif-devel, libgsf-devel, gstreamer-devel
6033N/ABuildRequires: desktop-file-utils, intltool
6033N/ABuildRequires: sqlite-devel
6033N/ABuildRequires: dbus-devel, dbus-glib
6033N/A
6033N/A
6033N/A%description
6033N/ATracker is a powerful desktop-neutral first class object database,
6033N/Atag/metadata database, search tool and indexer.
6033N/A
6033N/AIt consists of a common object database that allows entities to have an
6033N/Aalmost infinte number of properties, metadata (both embedded/harvested as
6033N/Awell as user definable), a comprehensive database of keywords/tags and
6033N/Alinks to other entities.
6033N/A
6033N/AIt provides additional features for file based objects including context
6033N/Alinking and audit trails for a file object.
6033N/A
6033N/AIt has the ability to index, store, harvest metadata. retrieve and search
6033N/Aall types of files and other first class objects
6033N/A
6033N/A%package devel
6033N/ASummary: Headers for developing programs that will use %{name}
6033N/AGroup: Development/Libraries
6033N/ARequires: %{name} = %{version}-%{release}
6033N/ARequires: pkgconfig
6033N/A
6033N/A%description devel
6033N/AThis package contains the static libraries and header files needed for
6033N/Adeveloping with tracker
6033N/A
6033N/A%prep
6033N/A%setup -q
6033N/A%patch1 -p1
6033N/A%patch2 -p1
6033N/A%patch3 -p0
6033N/A%patch4 -p1
6033N/A%patch5 -p1
6033N/A%patch6 -p1
6033N/A%patch7 -p1
6033N/A%patch8 -p1
6033N/A
6033N/A%build
6033N/A%ifos linux
6033N/Aif [ -x /usr/bin/getconf ]; then
6033N/A CPUS=`getconf _NPROCESSORS_ONLN`
6033N/Afi
6033N/A%else
6033N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
6033N/A%endif
6033N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
6033N/A CPUS=1
6033N/Afi
6033N/A
6033N/Aintltoolize --force --automake
6033N/A
6033N/A%if %build_l10n
6033N/Abash -x %SOURCE1 --enable-copyright
6033N/A%endif
6033N/A
6033N/Alibtoolize --force
6033N/Aaclocal $ACLOCAL_FLAGS -I .
6033N/Aautoheader
6033N/Aautomake -a -c -f
6033N/Aautoconf
4070N/A
4070N/A./configure --prefix=%{_prefix} \
4312N/A --bindir=%{_bindir} \
4312N/A --mandir=%{_mandir} \
4312N/A --libdir=%{_libdir} \
4312N/A --datadir=%{_datadir} \
4312N/A --includedir=%{_includedir} \
4312N/A --sysconfdir=%{_sysconfdir} \
4312N/A --disable-warnings \
4312N/A --enable-external-sqlite \
4312N/A
4312N/Amake -j $CPUS
4312N/A
4312N/A%install
4312N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
4070N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
4070N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
4070N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
4070N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
4070N/A
4070N/A%clean
4070N/Arm -rf $RPM_BUILD_ROOT
4070N/A
4070N/A%post
4070N/A/sbin/ldconfig
4070N/A
4070N/A%postun
4070N/A/sbin/ldconfig
4070N/A
4070N/A%files
4070N/A%defattr(-, root, root)
4070N/A%doc AUTHORS ChangeLog COPYING NEWS README
4070N/A%{_bindir}/htmless
4070N/A%{_bindir}/o3totxt
4070N/A%{_bindir}/tracker*
4070N/A%{_datadir}/tracker/
4070N/A%{_datadir}/pixmaps/tracker/
4070N/A%{_datadir}/dbus-1/services/tracker.service
4070N/A%{_libdir}/*.so.*
4312N/A%{_mandir}/man1/tracker*.1.gz
4312N/A%{_sysconfdir}/xdg/autostart/trackerd.desktop
4312N/A
4312N/A%files devel
4070N/A%defattr(-, root, root)
4312N/A%{_includedir}/tracker*
4312N/A%{_libdir}/*.so
4312N/A%{_libdir}/pkgconfig/*.pc
4070N/A
4070N/A%changelog
4070N/A* Mon Mar 03 2008 - halton.huo@sun.com
4070N/A- Bump to 0.6.6
4070N/A- Remove upstreamed patch r1071-latest.diff and firefox-history.diff, reorder
4070N/A* Wed Feb 27 2008 - halton.huo@sun.com
4070N/A- Update comment for thunderbird.diff and firefox-history.diff to type:feature
4070N/A* Tue Feb 26 2008 - halton.huo@sun.com
4070N/A- Update comment for r1071-latest.diff to type:feature state:upstream
4070N/A* Wed Jan 23 2008 - nonsea@users.sourceforge.net
4070N/A- Remove upstreamed patch preferences-explicit-apply.diff
4070N/A- Add temporary patch tp-reindex.diff
4070N/A* Tue Jan 22 2008 - nonsea@users.sourceforge.net
4070N/A- Add patch preferences-explicit-apply.diff
4070N/A- Add patch evo-reload.diff
4070N/A- Add patch man.diff
4070N/A- Rename r1071-r1092.diff to r1071-latest.diff
4070N/A- Reorder patches.
4070N/A* Thu Jan 03 2008 - nonsea@users.sourceforge.net
4070N/A- Add patch disable-autostart.diff
4070N/A- Add patch check-remote.diff
4070N/A- Add patch r1071-r1092.diff
4070N/A* Sat Nov 17 2007 - daymobrew@users.sourceforge.net
4070N/A- Unbump to 0.6.3 and remove obsolete patch, 02-thunderbird.
4070N/A* Fri Nov 02 2007 - nonsea@users.sourceforge.net
4070N/A- Initial version, spilit from SFEtracker.spec
4312N/A