tracker.spec revision 12258
10139N/A#
10139N/A# spec file for package tracker
12219N/A#
10139N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:halton
10139N/A#
10139N/A
10139N/AName: tracker
12571N/ALicense: GPL
10139N/AGroup: Applications/System
10139N/AVersion: 0.6.4
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
12571N/AVendor: Sun Microsystems, Inc.
10794N/AURL: http://www.tracker-project.org
10794N/ASummary: Desktop search tool
12773N/ASource: http://www.gnome.org/~jamiemcc/tracker/tracker-%{version}.tar.bz2
12773N/A# date:2008-01-23 owner:jerrytan type:branding
12773N/APatch1: %{name}-01-w3m-crash.diff
10794N/A# date:2008-01-23 owner:halton type:branding
10139N/APatch2: %{name}-02-disable-autostart.diff
10815N/A# date:2008-01-23 owner:halton type:branding
12526N/APatch3: %{name}-03-r1071-latest.diff
12526N/A# date:2008-01-23 owner:halton type:bug bugzilla:503725,503727,503960,503966,504000
10139N/APatch4: %{name}-04-tp-reindex.diff
10139N/A# date:2008-01-23 owner:halton type:bug bugzilla:503376
10139N/APatch5: %{name}-05-evo-reload.diff
10139N/A# date:2008-01-23 owner:migi type:branding
10139N/APatch6: %{name}-06-thunderbird.diff
10139N/A# date:2008-01-23 owner:jerrytan type:branding
10139N/APatch7: %{name}-07-firefox-history.diff
10139N/A# date:2008-01-23 owner:rickju type:bug bugzilla:511474
10139N/APatch8: %{name}-08-check-remote.diff
10139N/A# date:2008-01-23 owner:halton type:branding
10139N/APatch9: %{name}-09-man.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/A
10139N/ABuildRequires: gmime-devel, poppler-devel, gettext
10139N/ABuildRequires: gnome-desktop-devel, gamin-devel
10139N/ABuildRequires: libexif-devel, libgsf-devel, gstreamer-devel
10139N/ABuildRequires: desktop-file-utils, intltool
10139N/ABuildRequires: sqlite-devel
10139N/ABuildRequires: dbus-devel, dbus-glib
10139N/A
10139N/A
10139N/A%description
10139N/ATracker is a powerful desktop-neutral first class object database,
10139N/Atag/metadata database, search tool and indexer.
10139N/A
10139N/AIt consists of a common object database that allows entities to have an
10139N/Aalmost infinte number of properties, metadata (both embedded/harvested as
10139N/Awell as user definable), a comprehensive database of keywords/tags and
10139N/Alinks to other entities.
10139N/A
10139N/AIt provides additional features for file based objects including context
10139N/Alinking and audit trails for a file object.
10139N/A
10139N/AIt has the ability to index, store, harvest metadata. retrieve and search
10139N/Aall types of files and other first class objects
10139N/A
10139N/A%package devel
10139N/ASummary: Headers for developing programs that will use %{name}
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}-%{release}
10139N/ARequires: pkgconfig
10139N/A
10139N/A%description devel
10139N/AThis package contains the static libraries and header files needed for
10139N/Adeveloping with tracker
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p0
10794N/A%patch8 -p1
10794N/A%patch9 -p0
12754N/A
10794N/A%build
11087N/A%ifos linux
12526N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aintltoolize --force --automake
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/A./configure --prefix=%{_prefix} \
10139N/A --bindir=%{_bindir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libdir=%{_libdir} \
10139N/A --datadir=%{_datadir} \
10139N/A --includedir=%{_includedir} \
11338N/A --sysconfdir=%{_sysconfdir} \
11338N/A --disable-warnings \
11338N/A --enable-external-sqlite \
11338N/A
11338N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
12773N/A%clean
12773N/Arm -rf $RPM_BUILD_ROOT
12773N/A
12773N/A%post
12773N/A/sbin/ldconfig
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc AUTHORS ChangeLog COPYING NEWS README
10139N/A%{_bindir}/htmless
10139N/A%{_bindir}/o3totxt
10139N/A%{_bindir}/tracker*
10139N/A%{_datadir}/tracker/
10139N/A%{_datadir}/pixmaps/tracker/
10139N/A%{_datadir}/dbus-1/services/tracker.service
10139N/A%{_libdir}/*.so.*
10139N/A%{_mandir}/man1/tracker*.1.gz
10139N/A%{_sysconfdir}/xdg/autostart/trackerd.desktop
10139N/A
11338N/A%files devel
11338N/A%defattr(-, root, root)
10139N/A%{_includedir}/tracker*
10139N/A%{_libdir}/*.so
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A
10139N/A%changelog
10139N/A* Wed Jan 23 2008 - nonsea@users.sourceforge.net
10139N/A- Remove upstreamed patch preferences-explicit-apply.diff
10139N/A- Add temporary patch tp-reindex.diff
10139N/A* Tue Jan 22 2008 - nonsea@users.sourceforge.net
10139N/A- Add patch preferences-explicit-apply.diff
10139N/A- Add patch evo-reload.diff
10139N/A- Add patch man.diff
10139N/A- Rename r1071-r1092.diff to r1071-latest.diff
10139N/A- Reorder patches.
10139N/A* Thu Jan 03 2008 - nonsea@users.sourceforge.net
10139N/A- Add patch disable-autostart.diff
10139N/A- Add patch check-remote.diff
10139N/A- Add patch r1071-r1092.diff
10139N/A* Sat Nov 17 2007 - daymobrew@users.sourceforge.net
10139N/A- Unbump to 0.6.3 and remove obsolete patch, 02-thunderbird.
10139N/A* Fri Nov 02 2007 - nonsea@users.sourceforge.net
10139N/A- Initial version, spilit from SFEtracker.spec
10139N/A