10139N/A#
10139N/A# spec file for package totem
10139N/A#
19024N/A# Copyright (c) 2003, 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A#
17178N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17178N/A
10139N/A%include l10n.inc
10139N/AName: totem
20840N/ALicense: GPL v2, LGPL v2, MIT, BSD
10139N/AGroup: System/GUI/GNOME
18761N/AVersion: 2.30.2
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
10139N/ASummary: Totem Multimedia Player
18580N/ASource: http://ftp.gnome.org/pub/GNOME/sources/totem/2.30/%{name}-%{version}.tar.bz2
10139N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
12773N/A%if %build_l10n
12773N/ASource2: l10n-configure.sh
12773N/A%endif
18739N/A#owner:yippi date:2006-01-08 type:branding
10139N/APatch1: totem-01-remove-unsupported-format.diff
10139N/A#owner:yippi date:2006-04-27 type:branding
10139N/APatch2: totem-02-menu-entry.diff
18739N/A#owner:yippi date:2007-06-20 type:branding
11875N/APatch3: totem-03-browserplugin.diff
17733N/A#owner:yippi date:2008-07-29 type:branding doo:10274
16924N/A# This patch is needed until docbook 4.5 is available.
17657N/APatch4: totem-04-docbook.diff
19024N/A# date:2010-07-22 owner:yippi type:branding
19024N/APatch5: totem-05-python.diff
19024N/A# date:2010-07-22 owner:yippi type:bug doo:16623 bugzilla:631053
19024N/APatch6: totem-06-volume.diff
20325N/A# date:2011-06-01 owner:gheet type:branding
20325N/APatch7: totem-07-link-ice.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define gstreamer_version 0.8.1
10139N/A%define gstreamer_plugins_version 0.8.1
10139N/A%define gnome_desktop_version 2.6.1
10139N/A
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: gstreamer >= %{gstreamer_version}
10139N/ARequires: gstreamer-plugins >= %{gstreamer_plugins_version}
10139N/ARequires: gnome-desktop >= %{gnome_desktop_version}
10139N/ARequires: iso-codes
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: gstreamer-devel >= %{gstreamer_version}
10139N/ABuildRequires: gstreamer-plugins-devel >= %{gstreamer_plugins_version}
10139N/ABuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
10139N/A
10139N/A%description
10139N/ATotem is multimeida player for the GNOME desktop, allowing you to play CDs, DVDS and a
10139N/Awide range of multimedia formats
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10139N/A%patch1 -p1
10139N/A%patch2 -p1
11891N/A%patch3 -p1
12950N/A%patch4 -p1
19024N/A%patch5 -p1
19024N/A%patch6 -p1
20325N/A%patch7 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
17460N/Aexport PYTHON=/usr/bin/python%{default_python_version}
16129N/A
10139N/Aif test "x$x_includes" = "x"; then
10139N/A x_includes="/usr/X11/include"
10139N/Afi
10139N/A
10139N/Aif test "x$x_libraries" = "x"; then
10139N/A x_libraries="/usr/X11/lib"
10139N/Afi
10139N/A
10139N/Alibtoolize --force
11149N/Aintltoolize --force --copy --automake
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE2 --enable-copyright
12773N/A%endif
12773N/A
19864N/Agnome-doc-prepare --copy --force
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
11103N/Aexport MOZILLA_PLUGINDIR="%{_libdir}/firefox/plugins"
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
12959N/A
15903N/A# We enable the above totem plugins including gmp, narrowspace,
12959N/A# mully, cone since they are used for media types that are
15903N/A# not supported on Solaris, but can get codecs through codeina
12959N/A#
12959N/A# - GMP = Windows Media
12959N/A# - narrowspace = QuickTime
12959N/A# - MullY = DivX
12959N/A# - Cone = VLC
12959N/A#
12959N/A
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --localstatedir=/var/lib \
10139N/A --enable-gstreamer \
10139N/A --disable-lirc \
10139N/A --x-includes="$x_includes" \
10139N/A --x-libraries="$x_libraries"
12959N/A
16830N/Amake
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="totem.schemas totem-video-thumbnail.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_sysconfdir}/gconf/schemas
10139N/A%{_libdir}/*
10139N/A%{_libexecdir}/*
10139N/A%{_datadir}/applications
10139N/A%{_datadir}/gnome/help/totem/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/omf/totem/*
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_datadir}/totem/*
10139N/A%{_mandir}/man1/totem*
10139N/A%{_includedir}/totem/*
10139N/A
10139N/A%changelog
19024N/A* Thu Sep 30 2010 - brian.cameron@oracle.com
19024N/A- Add a patch to setup the volume slider properly on startup.
19024N/A* Wed Jul 21 2010 - brian.cameron@oracle.com
19024N/A- Add patch totem-05-python.diff to ensure scripts use Python 2.6.
18761N/A* Fri May 21 2010 - brian.cameron@oracle.com
18761N/A- Bump to 2.30.2.
18710N/A* Mon May 03 2010 - brian.cameron@oracle.com
18710N/A- Bump to 2.30.1.
18580N/A* Mon Apr 12 2010 - christian.kelly@oracle.com
18580N/A- Bump to 2.30.0.
18482N/A* Fri Mar 19 2010 - christian.kelly@sun.com
18482N/A- Bump to 2.29.92.
18463N/A* Sun Mar 14 2010 - christian.kelly@sun.com
18463N/A- Bump to 2.29.91.
18236N/A* Mon Feb 1 2010 - christian.kelly@sun.com
18236N/A- Bump to 2.29.4.
18132N/A* Mon Jan 18 2010 - christian.kelly@sun.com
18132N/A- Bump to 2.28.5.
17749N/A* Thu Nov 19 2009 - brian.cameron@sun.com
17749N/A- Bump to 2.28.4.
17657N/A* Wed Nov 04 2009 - brian.cameron@sun.com
17657N/A- Bump to 2.28.2.
17519N/A* Wed Oct 14 2009 - dave.lin@sun.com
17519N/A- Bump to 2.28.1
17361N/A* Tue Sep 22 2009 - brian.cameron@sun.com
17361N/A- Bump to 2.28.0, remove upstream patch totem-06-function.diff.
17251N/A* Tue Sep 08 2009 - brian.cameron@sun.com
17251N/A- Bump to 2.27.92. Add patch totem-06-function.diff to fix build issue.
17010N/A* Wed Aug 12 2009 - christian.kelly@sun.com
17010N/A- Bump to 2.27.2.
16865N/A* Sun Jul 26 2009 - christian.kelly@sun.com
16865N/A- Unbump to 2.26.2, build problems.
16830N/A* Tue Jul 21 2009 - brian.cameron@sun.com
16830N/A- Bump to 2.27.1
16592N/A* Wed Jun 03 2009 - dave.lin@sun.com
16592N/A- removed unnecessary patch 05-libsocket.diff
16490N/A* Thu May 07 2009 - brian.cameron@sun.com
16490N/A- Bump to 2.26.2.
16368N/A* Tue Apr 14 2009 - brian.cameron@sun.com
16368N/A- Bump to 2.26.1.
16159N/A* Tue Mar 17 2009 - dave.lin@sun.com
16368N/A- Bump to 2.26.0.
16129N/A* Thu Mar 12 2009 - brian.cameron@sun.com
16129N/A- Bump to 2.25.92. Add PYTHON environment variable to %build section.
15876N/A* Tue Feb 17 2009 - brian.cameron@sun.com
15876N/A- Bump to 2.25.91.
15775N/A* Thu Feb 05 2009 - christian.kelly@sun.com
15775N/A- Bump to 2.25.90.
15775N/A- Remove patches/totem-06-function.diff.
15775N/A- Rework patches/totem-01-remove-unsupported-format.diff.
15696N/A* Tue Jan 20 2009 - brian.cameron@sun.com
15696N/A- Bump to 2.25.3. Remove upstream patch totem-05-avoid-plugin-coredump.diff.
15696N/A Add patch totem-06-function.diff.
15302N/A* Tue Nov 04 2008 - brian.cameron@sun.com
15302N/A- Backout fix for bug #6227253. This changed totem's help file to point to
15302N/A sample_apps_info.xml since totem previously did not have its own docs.
15302N/A Now that totem has docs, this hack needs to be removed or users can't see
15302N/A the actual totem help when selecting help from totem's menus. Fixes bug
15302N/A #6756164.
14487N/A* Wed Sep 24 2008 - christian.kelly@sun.com
14487N/A- Bump to 2.24.0.
14086N/A* Mon Sep 01 2008 - christian.kelly@sun.com
14086N/A- Bump to 2.23.91.
14086N/A- patches/totem-01-remove-unsupported-format.diff: rework.
14086N/A- patches/totem-03-browserplugin.diff: rework.
14086N/A- patches/totem-04-web-plugin.diff: rework.
13454N/A* Fri Jun 20 2008 - jerry.tan@sun.com
13454N/A- Bump to 2.23.4
13324N/A* Wed Jun 04 2008 - damien.carbery@sun.com
13324N/A- Bump to 2.23.3.
13111N/A* Tue May 27 2008 - jijun.yu@sun.com
13112N/A- Remove --with-ff3 option since it also works agaist ff 2.
13112N/A* Tue May 27 2008 - jijun.yu@sun.com
13111N/A- Add a firfox 3 specific patch.
13008N/A* Thu May 08 2008 - jijun.yu@sun.com
13008N/A- Remove patch 5.
13002N/A* Wed May 07 2008 - jijun.yu@sun.com
13002N/A- Add a patch to fix bugster bug #6695629.
12959N/A* Mon Apr 28 2008 - jijun.yu@sun.com
12959N/A- Disable 4 plugins:libtotem-gmp, libtotem-narrowspace, libtotem-mully,
12959N/A libtotem-cone.
12950N/A* Fri Apr 25 2008 - jijun.yu@sun.com
12950N/A- Add a patch to remove some MIME types unsupported including flv, mp3.
12945N/A* Thu Apr 24 2008 - damien.carbery@sun.com
12945N/A- Bump to 2.22.2.
12829N/A* Thu Apr 10 2008 - damien.carbery@sun.com
12829N/A- Bump to 2.22.1.
12571N/A* Mon Mar 10 2008 - damien.carbery@sun.com
12571N/A- Bump to 2.22.0.
12529N/A* Tue Mar 4 2008 - damien.carbery@sun.com
12529N/A- Bump to 2.21.96.
12480N/A* Wed Feb 27 2008 - damien.carbery@sun.com
12480N/A- Bump to 2.21.95.
12451N/A* Mon Feb 25 2008 - damien.carbery@sun.com
12451N/A- Bump to 2.21.94.
12360N/A* Tue Feb 12 2008 - damien.carbery@sun.com
12360N/A- Bump to 2.21.93.
12334N/A* Tue Feb 05 2007 - brian.cameron@sun.com
12334N/A- Bump to 2.21.92.
12147N/A* Mon Jan 07 2007 - brian.cameron@sun.com
12147N/A- Bump to 2.21.90.
12017N/A* Mon Dec 03 2007 - brian.cameron@sun.com
12017N/A- Bump to 2.21.4.
11912N/A* Mon Nov 12 2007 - damien.carbery@sun.com
11912N/A- Bump to 2.21.2. Remove upstream patches, 04-shell-change, 05-asprintf and
11912N/A 06-tick.
11875N/A* Tue Nov 06 2007 - brian.cameron@sun.com
11875N/A- Remove totem-03-novisual.diff patch. This patch was added because using
11875N/A the GStreamer GOOM plugin with totem caused severe flashing and audio
11875N/A stuttering performance issues. These issues have gone away with the
11875N/A latest GStreamer releases.
11827N/A* Wed Oct 31 2007 - damien.carbery@sun.com
11838N/A- Bump to 2.21.1.
11838N/A* Wed Oct 31 2007 - damien.carbery@sun.com
11833N/A- Add patch 07-tick to change TICK to TTICK to fix bugzilla 492087.
11832N/A* Wed Oct 31 2007 - damien.carbery@sun.com
11827N/A- Add patches 05-shell-change and 06-asprintf.
11819N/A* Tue Oct 30 2007 - damien.carbery@sun.com
11838N/A- Bump to 2.21.0.
11426N/A* Mon Oct 22 2007 - damien.carbery@sun.com
11426N/A- Bump to 2.20.1.
11266N/A* Wed Sep 19 2007 - damien.carbery@sun.com
11266N/A- Bump to 2.20.0.
11149N/A* Thu Aug 30 2007 - damien.carbery@sun.com
11149N/A- Add intltoolize call to update intltool scripts.
11103N/A* Wed Aug 22 2007 - damien.carbery@sun.com
11103N/A- Set MOZILLA_PLUGINDIR before configure call as configure.in has been changed
11103N/A to fix #414457.
11094N/A* Mon Aug 20 2007 - damien.carbery@sun.com
11094N/A- Bump to 2.19.90.
10847N/A* Fri Jun 22 2007 - jerry.tan@sun.com
10847N/A- put totem plugins into /usr/lib/firefox/plugins
10838N/A* Wed Jun 21 2007 - irene.huang@sun.com
10838N/A- Removing patch 05-xthreadinit.diff, since it is the root cause
10838N/A of the bug is exists in libXi.
10746N/A* Wed Jun 06 2007 - damien.carbery@sun.com
10746N/A- Bump to 2.19.4.
10681N/A* Wed May 23 2007 - damien.carbery@sun.com
10681N/A- Remove dos2unix call because the be.po file is correct (closes bugzilla
10681N/A #398052). Set PKG_CONFIG_PATH so that gnome-icon-theme.pc in
10681N/A %{_datadir}/pkgconfig can be found.
10675N/A* Mon May 21 2007 - damien.carbery@sun.com
10675N/A- Bump to 2.19.3.
10653N/A* Wed May 16 2007 - damien.carbery@sun.com
10653N/A- Change patch -05-xthreadinit.diff to be branding
10636N/A* Tue May 15 2007 - damien.carbery@sun.com
10639N/A- Bump to 2.19.2. Remove code that deletes 'vanity' files and the pixmaps dir
10639N/A because they are not installed.
10504N/A* Thu Apr 19 2007 - laca@sun.com
10504N/A- add -ascii option to dos2unix so that utf8 strings are not messed up
10414N/A* Wed Apr 04 2007 - damien.carbery@sun.com
10636N/A- Bump to 2.18.1.
10349N/A* Wed Mar 22 2007 - irene.huang@sun.com
10349N/A- add patch 05-xthreadinit.diff
10341N/A* Wed Mar 21 2007 - irene.huang@sun.com
10341N/A- add patch -04-cdmenuitem.diff.
10258N/A* Sun Mar 11 2007 - damien.carbery@sun.com
10258N/A- Bump to 2.18.0. Remove upstream patches, 04-grep-no-q and
10258N/A 05-gst-0.10.12-support.
10251N/A* Fri Mar 09 2007 - damien.carbery@sun.com
10251N/A- Add patch, 05-gst-0.10.12-support, to build against new gst tarballs. These
10251N/A changes are from totem CVS.
10177N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10177N/A- Add patch, 04-grep-no-q, to remove -q from grep call. Fixes 414961.
10139N/A* Thu Feb 22 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.92. Remove upstream patches, 04-shell-func, 05-func-macro and
10139N/A 06-debug-macros.
10139N/A* Tue Feb 13 2007 - takao.fujiwara@sun.com
10139N/A- Add l10n tarball.
10139N/A* Thu Feb 08 2007 - damien.carbery@sun.com
10139N/A- Add patch, 04-shell-func, to make shell script work. Fixes 405758.
10139N/A- Add patch 05-func-macro to use G_GNUC_FUNCTION (bugzilla 405850) and
10139N/A 06-debug-macros to use G_GNUC_PRETTY_FUNCTION and proper va_args (#405880).
10139N/A* Thu Feb 08 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.91. Remove upstream patches, 03-function-macro and
10139N/A 04-moz-plugin. Renumber rest.
10139N/A* Mon Jan 29 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.90. Remove upstream patches, 07-va_args, 06-2175-fix and
10139N/A 03-uninstalled-pc. Add 03-function-macro to fix #402163.
10139N/A* Thu Jan 18 2007 - damien.carbery@sun.com
10139N/A- Add patch, 06-2175-fix, to include a missing file. Fixes 398071. Add patch,
10139N/A 07-va_args, to make variable args macro work with forte. Fixes 398090.
10139N/A* Wed Jan 17 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5. Remove upstream patch, 04-fixcd. Renumber remainder.
10139N/A* Wed Dec 06 2006 - brian.cameron@sun.com
10139N/A- Add totem-06-novisual.diff so that the visualizer is turned off
10139N/A by default since goom has basd performance issues on Solaris
10139N/A that often cause audio stuttering. Better to leave it off until
10139N/A the visualizer performance improves.
10139N/A* Thu Nov 23 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Remove 'rm' lines from %install as the files listed are not installed.
10139N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.2.
10139N/A- Remove '-f' from 'rm' calls to force failure when source changes need
10139N/A attention.
10139N/A* Fri Sep 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.1.
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Tue Aug 22 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.5.92.
10139N/A- Remove upstream patch, 05-automake-conditional, renumber rest.
10139N/A* Thu Aug 17 2006 - damien.carbery@sun.com
10139N/A- Add patch, 06-moz-plugin, to get mozilla plugin to build.
10139N/A* Wed Aug 16 2006 - damien.carbery@sun.com
10139N/A- Add patch, 05-automake-conditional, to fix an automake issue. #351617.
10139N/A* Mon Aug 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.5.91.
10139N/A* Fri Jul 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.5.90.
10139N/A* Thu Jul 13 2006 - brian.cameron@sun.com
10139N/A- Patch to fix totem so it passes the CD device name to GStreamer on Solaris.
10139N/A* Wed Jun 21 2006 - brian.cameron@sun.com
10139N/A- Bump to 1.5.2.
10139N/A* Mon May 01 2006 - brian.cameron@sun.com
10139N/A- Added uninstalled.pc file to totem so that rhythmbox can be built in same
10139N/A package, since rhythmbox depends on totem.
10139N/A* Fri Apr 28 2006 - glynn.foster@sun.com
10139N/A- Add patch to call it 'Totem Movie Player' from
10139N/A now on.
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.4.0.
10139N/A* Wed Mar 1 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.92.
10139N/A* Mon Feb 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.91.
10139N/A* Sun Jan 29 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.90
10139N/A* Mon Jan 23 2006 - damien.carbery@sun.com
10139N/A- Remove obsolete patch, 03-fixfunc.
10139N/A* Fri Jan 20 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.3.1.
10139N/A* Tue Jan 03 2006 - damien.carbery@sun.com
10139N/A- Remove obsolete patch, 01-desktop.sh; renumber remainder.
10139N/A- Remove obsolete patch, 02-menu-entry.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 1.3.0
10139N/A* Tue Nov 29 2005 - laca.com
10139N/A- remove javahelp stuff
10139N/A* Tue Sep 27 2005 - brian.cameron@sun.com
10139N/A- Bump to 1.2.0.
10139N/A- Fix patch4 so it compiles against latest code.
10139N/A* Tue Sep 27 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.1.5.
10139N/A* Mon Sep 12 2005 - laca@sun.com
10139N/A- add patch desktop.sh.diff: changes echo -n to printf as echo -n doesn't
10139N/A work on Solaris
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
10139N/A- Bump to 1.1.4.
10139N/A* Tue Jul 12 2005 - damien.carbery@sun.com
10139N/A- Add patch 5 to build CD-ROM code (src/totem-disc.c) on Solaris.
10139N/A http://bugzilla.gnome.org/show_bug.cgi?id=310149
10139N/A* Thu Jun 16 2005 - matt.keenan@sun.com
10139N/A- Bump to 1.0.3
10139N/A* Thu Jun 09 2005 - matt.keenan@sun.com
10139N/A- Bump to 1.0.1
10139N/A- Remove patchs 02, 03, 04
10139N/A- Rename patch 05 to 03
10139N/A* Thu May 05 2005 - damien.carbery@sun.com
10139N/A- 6227253: Change xml file in totem-C.omf from totem.xml to
10139N/A sample_apps_info.xml (part of gnome-user-docs). Bit of a hack but a very easy
10139N/A one to maintain.
10139N/A* Fri Feb 25 2005 - kazuhiko.maekawa@sun.com
10139N/A- Added dummy l10n help files to follow base update
10139N/A* Mon Feb 14 2005 - damien.carbery@sun.com
10139N/A- Integrate docs tarball (totem-docs-0.1) from irene.ryan@sun.com.
10139N/A* Thu Feb 10 2005 - matt.keenan@sun.com
10139N/A- 6227304 : install german help correctly
10139N/A* Wed Jan 19 2005 - matt.keenan@sun.com
10139N/A- Add Javahelp convert #6197736
10139N/A* Sun Nov 14 2004 - laca@sun.com
10139N/A- add --bindir=%{_bindir} and --libdir=%{_libdir} to configure opts
10139N/A* Fri Oct 29 2004 - laca@sun.com
10139N/A- Add missing deps
10139N/A* Fri Oct 01 2004 - takao.fujiwara@sun.com
10139N/A- Added '--x-libraries' option in configure to fix bug 5081938
10139N/A* Sat Sep 11 2004 - laca@sun.com
10139N/A- Move Solaris specific LDFLAGS to the Solaris spec file
10139N/A* Fri Sep 10 2004 - damien.carbery@sun.com
10139N/A- Set LDFLAGS so Xrandr and Xrender can be found.
10139N/A* Fri Sep 03 2004 - kaushal.kumar@wipro.com
10139N/A- Added patch 05 to let jmplay handle wav and mp3 files.
10139N/A Fixes bugtraq #5093284.
10139N/A* Mon Jul 19 2004 - brian.cameron@sun.com
10139N/A- Added patch 04 so that icons get displayed on Solaris.
10139N/A Patch approved by totem maintainer.
10139N/A* Fri Jul 16 2004 - brian.cameron@sun.com
10139N/A- Added patch 03 to support building on Solaris.
10139N/A* Wed Jul 14 2004 - niall.power@sun.com
10139N/A- packaging fixes for rpm4
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to totem-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to totem-l10n-po-1.1.tar.bz2
10139N/A* Mon Apr 26 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.99.11
10139N/A* Thu Apr 15 2004 - glynn.foster@sun.com
10139N/A- Bump to 0.99.10, and remove Ghee's temporary workaround
10139N/A patch.
10139N/A* Tue Apr 06 2004 - ghee.teo@sun.com
10139N/A- Created a totem-03-temporary-workaround-build.diff to resolve the
10139N/A hardcoded GST_MAJORMINOR=0.7 problem. This patch should be removed
10139N/A once a new release totem is available.
10139N/A* Wed Mar 31 2004 - brian.cameron@sun.com
10139N/A- replace tar jxf with the more solaris friendly
10139N/A bzcat piped through tar
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Adding totem-l10n-po-1.0.tar.bz2 l10n content
10139N/A* Fri Feb 13 2004 - matt.keenan@sun.com
10139N/A- Bump tarball to 0.99.9, redo patch 01
10139N/A* Mon Jan 12 2004 - matt.keenan@sun.com
10139N/A- Bump tarball to 0.99.8, patch for compile errors
10139N/A* Fri Nov 14 2003 - glynn.foster@sun.com
10139N/A- Re add the desktop patch to change the menu entry.
10139N/A* Fri Oct 31 2003 - glynn.foster@sun.com
10139N/A- Remove the Sun Supported keyword from the
10139N/A desktop file, since we're no longer going with the Extras
10139N/A menu.
10139N/A* Wed Oct 22 2003 - glynn.foster@sun.com
10139N/A- Update to 0.99.7
10139N/A* Fri Oct 13 2003 - laca@sun.com
10139N/A- Update to 0.99.6
10139N/A* Thu Aug 14 2003 - ghee.teo@sun.com
10139N/A- Removed totem totem.applications and totem.keys so that jmplay can
10139N/A become the default media player.
10139N/A* Sat Aug 02 2003 - glynn.foster@sun.com
10139N/A- Update menu entry.
10139N/A* Fri Jul 25 2003 - glynn.foster@sun.com
10139N/A- Initial Sun release