thunderbird.spec revision 18243
#
# Copyright (c) Sun Microsystems, Inc.
#
%define owner davelam
# bugdb: bugzilla.mozilla.org
#
#####################################
## Package Information Section ##
#####################################
Name: thunderbird
Summary: Mozilla Thunderbird Standalone E-mail and Newsgroup Client
Version: 3.0.1
%if %option_with_lightning
%define lightning_version 1.0
%endif
%define tarball_version 3.0.1
Release: 1
Copyright: MPL/LGPL
Group: Applications/Internet
Distribution:Java Desktop System
Vendor: Sun Microsystems, Inc.
Source: http://ftp.mozilla.org/pub/mozilla.org/%{name}/releases/%{tarball_version}/source/%{name}-%{tarball_version}.source.tar.bz2
Source1: thunderbird-icon.png
Source2: thunderbird.desktop
%if %option_with_lightning
Source3: http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/releases/1.0b1/source/lightning-sunbird-1.0b1.source.tar.bz2
Source4: lightning-chrome.manifest
%endif
%if %option_without_moz_nss_nspr
Source8: nspr-nss-config
%endif
# owner:hawklu date:2007-11-28 type:branding
# change preference to support multi-language
Patch1: thunderbird3-01-locale.diff
# owner:alfred date:2008-10-10 type:bug bugster:6750518
# status:upstream
Patch5: thunderbird3-05-ksh.diff
# owner:ginnchen date:2008-10-15 type:feature
# bugzilla:457196
Patch11: thunderbird3-11-jemalloc-shared-library.diff
# owner:ginnchen date:2009-03-04 type:feature bugzilla:478390 bugster:6805829
# status:upstream
Patch14: thunderbird3-14-compiler-workaround.diff
# owner:fujiwara date:2008-04-10 type:bug
# bugster:6686579 bugzilla:285267
Patch15: thunderbird3-15-g11n-nav-lang.diff
# owner:ginnchen date:2008-08-19 type:bug
# bugster:6724471 bugzilla:451007
Patch16: thunderbird3-16-delay-stopping-realplayer.diff
# owner:ginnchen date:2009-09-18 type:feature bugster:6839690
# status:upstream
Patch17: thunderbird3-17-compiler-workaround-2.diff
# owner:ginnchen date:2008-11-27 type:bug bugzilla:464443
Patch18: thunderbird3-18-fix-mimetype-for-helper-app.diff
%if %option_without_moz_nss_nspr
# owner:ginnchen date:2009-05-21 type:branding
Patch20: thunderbird3-20-system-nss-nspr.diff
%endif
# owner:hawklu date:2009-05-19 type:bug doo:8471
Patch21: thunderbird3-21-sunaudio-sparc.diff
# owner:hawklu date:2009-05-22 type:branding
Patch22: thunderbird3-22-use-system-theora-and-sqlite.diff
# owner:chrisk date:2009-07-19 type:bug
# status:upstream
Patch24: thunderbird3-24-gtk-includes.diff
# owner:hawklu date:2009-09-03 type:bug doo:1114
Patch26: thunderbird3-26-no-offline-download.diff
# owner:ginnchen date:2009-12-15 type:bug bugzilla:416053 bugzilla:534845
# status:upstream
Patch27: thunderbird3-27-startup-notification.diff
# owner:hawklu date:2010-01-25 type:bug bugzilla:537210
Patch30: thunderbird3-30-using-sqlite-3-6-17.diff
# owner:hawklu date:2009-12-31 type:bug bugzilla:537210
Patch28: thunderbird3-28-sync-toolbar.diff
# owner:hawklu date:2009-12-31 type:bug bugzilla:534588
Patch29: thunderbird3-29-account-setup.diff
URL: http://www.sun.com/software/javadesktopsystem/
BuildRoot: %{_tmppath}/%{name}-%{tarball_version}-build
Prefix: /usr
Provides: webclient
Autoreqprov: on
#####################################
## Package Defines Section ##
#####################################
%define _unpackaged_files_terminate_build 0
%define _tbdir %{_libdir}/%{name}
#####################################
## Package Description Section ##
#####################################
%description
Mozilla Thunderbird is a standalone e-mail and newsgroup client
that can be used as a companion to Mozilla Firefox or by itself.
#####################################
## Package Preparation Section ##
#####################################
%prep
%setup -q -c -n %{name}
cd ..
mkdir -p sunbird
cd sunbird
bzcat %SOURCE3 | tar xf -
cd ..
rm -rf %{name}/comm-1.9.1/calendar
cp -r sunbird/comm-1.9.1/calendar %{name}/comm-1.9.1/calendar
cd %{name}/comm-1.9.1/mozilla
%patch1 -p1
%patch5 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1
%patch18 -p1
%patch21 -p1
%patch24 -p1
%patch27 -p1
%patch30 -p1
%if %option_without_moz_nss_nspr
%patch20 -p1
%endif
# go back to the thunderbird directory
cd ..
%patch11 -p1
%patch22 -p1
%patch26 -p1
%patch28 -p1
%patch29 -p1
#####################################
## Package Build Section ##
#####################################
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
cat << "EOF" > .mozconfig
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
ac_add_options --prefix=%{_prefix}
ac_add_options --libdir=%{_libdir}
ac_add_options --mandir=%{_mandir}
ac_add_options --enable-static
ac_add_options --enable-official-branding
ac_add_options --enable-application=mail
ac_add_options --enable-dtrace
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --enable-system-cairo
ac_add_options --disable-updater
ac_add_options --disable-tests
%if %option_with_debug
ac_add_options --enable-debug
ac_add_options --disable-optimize
%else
ac_add_options --disable-debug
ac_add_options --enable-optimize
%endif
ac_add_options --disable-shared
ac_add_options --disable-crashreporter
%if %option_without_moz_nss_nspr
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
%endif
%if %option_with_lightning
ac_add_options --enable-calendar
%endif
ac_add_options --enable-system-sqlite
ac_add_options --enable-startup-notification
EOF
BUILD_OFFICIAL=1
MOZILLA_OFFICIAL=1
MOZ_PKG_FORMAT=BZ2
PKG_SKIP_STRIP=1
export BUILD_OFFICIAL MOZILLA_OFFICIAL MOZ_PKG_FORMAT PKG_SKIP_STRIP CFLAGS CXXFLAGS
SRCDIR=$PWD
export MOZCONFIG=$PWD/.mozconfig
mkdir -p ../objdir-tb
%if %option_without_moz_nss_nspr
cp %{SOURCE8} ${SRCDIR}/../objdir-tb
chmod +x ${SRCDIR}/../objdir-tb/nspr-nss-config
export NSPR_CONFIG=${SRCDIR}/../objdir-tb/nspr-nss-config\ nspr
export NSS_CONFIG=${SRCDIR}/../objdir-tb/nspr-nss-config\ nss
%endif
cd ${SRCDIR}/../objdir-tb
${SRCDIR}/comm-1.9.1/configure
make
make package
%install
/bin/rm -rf $RPM_BUILD_ROOT
BUILDDIR=$PWD/../objdir-tb
/bin/mkdir -p $RPM_BUILD_ROOT%{_libdir}
cd $RPM_BUILD_ROOT%{_libdir}
/usr/bin/bzip2 -dc $BUILDDIR/mozilla/dist/thunderbird-*.tar.bz2 | gtar -xf -
/bin/mkdir -p $RPM_BUILD_ROOT%{_bindir}
/bin/ln -s ../lib/thunderbird/thunderbird $RPM_BUILD_ROOT%{_bindir}/thunderbird
%if %option_with_lightning
LIGHTNING_ID="{e2fda1a4-762b-4020-b5ad-a41df1933103}"
cp %{SOURCE4} $RPM_BUILD_ROOT%{_libdir}/thunderbird/extensions/$LIGHTNING_ID/chrome.manifest
%endif
/bin/mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
/bin/mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
install -c -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/thunderbird-icon.png
install -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/applications/thunderbird.desktop
# remove local dictionary and share the one that delivered
# by myspell-dictionary
rm -f $RPM_BUILD_ROOT%{_tbdir}/dictionaries/en-US.dic
rm -f $RPM_BUILD_ROOT%{_tbdir}/dictionaries/en-US.aff
rmdir $RPM_BUILD_ROOT%{_tbdir}/dictionaries
%clean
/bin/rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Feb 02 2010 - brian.lu@sun.com
- Using chrome.manifest that supports mutli languages
* Mon Jan 25 2010 - brian.lu@sun.com
- Bump to 3.0.1
* Wed Jan 13 2010 - brian.lu@sun.com
- bug d.o.o 13561 is fixed in 1.0b1
Remove the patch thunderbird3-30-timezone.diff
* Thu Dec 31 2009 - brian.lu@sun.com
- Add two patches:
thunderbird3-28-sync-toolbar.diff
thunderbird3-29-account-setup.diff
* Fri Dec 18 2009 - ginn.chen@sun.com
- Bump lighting to 1.0b1rc1.
* Wed Dec 16 2009 - ginn.chen@sun.com
- Add thunderbird3-27-startup-notification.diff
* Mon Dec 14 2009 - brian.lu@sun.com
- Define lightning_version
* Thu Dec 08 2009 - brian.lu@sun.com
- Bump to 3.0
* Wed Dec 02 2009 - ginn.chen@sun.com
- Bump to Thunderbird 3.0rc2.
* Wed Nov 25 2009 - ginn.chen@sun.com
- Bump to Thunderbird 3.0rc1.
* Fri Nov 13 2009 - ginn.chen@sun.com
- Remove thunderbird.cfg, thunderbird3-02-disable-online-update.diff
disable-updater should be enough.
- Update thunderbird3-11-jemalloc-shared-library.diff
* Web Sep 23 2009 - ginn.chen@sun.com
- Remove configure files.
* Wed Sep 23 2009 - brian.lu@sun.com
- Remove the upstreamed patch thunderbird3-23-bug504043.diff
and thunderbird3-25-downloadable-font.diff
- Update patch thunderbird3-26-no-offline-download.diff
- Bump to beta4
* Tue Sep 22 2009 - brian.lu@sun.com
- Update patch thunderbird3-26-no-offline-download.diff
* Fri Sep 18 2009 - ginn.chen@sun.com
- Add patch thunderbird3-17-compiler-workaround-2.diff
* Thu Sep 03 2009 - brian.lu@sun.com
- Add patch thunderbird3-26-no-offline-download.diff
* Wed Jul 29 2009 - ginn.chen@sun.com
- Add patch thunderbird3-25-downloadable-font.diff
* Thu Jul 23 2009 - ginn.chen@sun.com
- Update thunderbird3-22-use-system-theora-and-sqlite.diff
Fix build issue with system sqlite library.
* Thu Jul 23 2009 - brian.lu@sun.com
- Bump to 3.0b3
Remove following upstreamed patches:
thunderbird3-03-js.diff
thunderbird3-06-font-config.diff
thunderbird3-07-pango-1-23.diff
thunderbird3-08-im-context-not-match.diff
thunderbird3-09-rename-nsSelectionBatcher.diff
thunderbird3-10-bigendian.diff
thunderbird3-13-js-dtrace.diff
thunderbird3-14-xinerama.diff
thunderbird3-17-runmozilla.diff
thunderbird3-19-small-migration-wizard-window.diff
Update following patches:
thunderbird3-16-delay-stopping-realplayer.diff
thunderbird3-20-system-nss-nspr.diff
* Wed Jun 17 2009 - brian.lu@sun.com
- Enable debug mode when "--with-debug" is specified
* Wed Jun 02 2009 - brian.lu@sun.com
- Change bugzilla:9112 to doo:9112 and bugzilla:8471 to doo:8471
* Mon May 25 2009 - ginn.chen@sun.com
- Add thunderbird3-20-system-nss-nspr.diff
thunderbird3-21-sunaudio-sparc.diff
thunderbird3-22-use-system-theora.diff
* Tue Mar 31 2009 - brian.lu@sun.com
- Fix bug 7723
* Mon Mar 30 2009 - ginn.chen@sun.com
- Remove thunderbird3-12-ldap-crash.diff, this bug is gone.
* Fri Mar 06 2009 - ginn.chen@sun.com
- Copy firefox3-25-pango-1-23.diff to thunderbird3-07-pango-1-23.diff
* Fri Mar 06 2009 - brian.lu@sun.com
- Replace the patch thunderbird3-07-pango-1-23.diff with
the patch firefox3-25-pango-1-23.diff
* Thu Mar 05 2009 - ginn.chen@sun.com
- add option to use system cairo and jpeg
* Wed Mar 04 2009 - ginn.chen@sun.com
- copy firefox3-*.diff to thunderbird3-*.diff
- use configure in ext-sources
* Mon Mar 02 2009 - alfred.peng@sun.com
- Patch updates for Thunderbird 3.0b2.
* Fri Feb 27 2009 - brian.lu@sun.com
- bump to Thunderbird 3.0b2
* Thu Feb 19 2009 - brian.lu@sun.com
- Fix the issue caused by pango upgrade
* Fri Jan 23 2009 - brian.lu@sun.com
- Fix the bug 6187
* Fri Jan 16 2009 - brian.lu@sun.com
- Change the bugzilla ID of thunderbird-13-ldap-crash.diff to 374731
* Wed Dec 31 2008 - brian.lu@sun.com
- Replace the patch thunderbird-24-rename-selectionBacher.diff
with thunderbird-25-allow-muldefs.diff
* Mon Dec 22 2008 - brian.lu@sun.com
- Upgrade to 3.0b1
* Tue Dec 02 2008 - brian.lu@sun.com
- Fix the bug CR677345
* Mon Oct 13 2008 - ginn.chen@sun.com
- Change /bin/tar to tar.
* Oct 10 2008 - alfred.peng@sun.com
- Add thunderbird-21-ksh.diff for indiana only to fix bugster CR6750518.
* Man 06 2008 - brian.lu@sun.com
- Bump lightning to 0.9
* Sat Sep 27 2008 - ginn.chen@sun.com
- Bump to 2.0.0.17
* Fri Sep 26 2008 - brian.lu@sun.com
- Fix the bug CR6752288
* Tue Jul 29 2008 - brian.lu@sun.com
- bump to 2.0.0.16
* Mon Jul 21 2008 - ginn.chen@sun.com
- Add bugdb info.
* Mon Jun 02 2008 - ginn.chen@sun.com
- Add indiana branding patch: thunderbird-18-remove-hardcoded-fontname.diff
* Mon May 05 2008 - dave.lin@sun.com
- bump to 2.0.0.14
* Thu April 24 2008 - brian.lu@sun.com
- bump lightning to 0.8
* Wed Mar 26 2008 - brian.lu@sun.com
- Fix bug CR6640830
* Thu Feb 28 2008 - dave.lin@sun.com
- bump to TB 2.0.0.12
* Fir Nov 28 2007 - evan.yan@sun.com
- replace thunderbird-08-locale.diff with mozilla-09-locale.diff, to correct our
way of supporting multi-language
* Mon Nov 19 2007 - dave.lin@sun.com
- bump to TB 2.0.0.9
- remove patch thunderbird-16-crash-with-some-themes.diff since it has been upstreamed
* Tue Nov 13 2007 - brian.lu@sun.com
- Add patch, thunderbird-16-crash-with-some-themes.diff
to fix 'thunderbird crashing under some themes' bug CR6586103
* Fri Nov 02 2007 - dave.lin@sun.com
- bump lightning to 0.7
* Fri Aug 03 2007 - dave.lin@sun.com
- bump to 2.0.0.6
* Mon Jun 23 2007 - dave.lin@sun.com
- bump to 2.0.0.5
* Thu Jun 21 2007 - damien.carbery@sun.com
- Add patch, mozilla-08-cairo-update.diff, to update the private copy of
cairo.h used in the build.
* Tue June 05 2007 - brian.lu@sun.com
- Fix the bug CR6284006: GConf Error: Bad key or directory name: "desktop/gnome/url-handlers/GMT+00/command": `+' messages
* Mon Apr 30 2007 - dave.lin@sun.com
- remove local dictionary and use the one delivered by myspell-dictionary(CR6218511)
* Thu Apr 27 2007 - brian.lu@sun.com
- add patch to grey out "Check for Updates" in Thunderbird menu since it's not supported
* Sat Apr 21 2007 - dave.lin@sun.com
- Bump to 2.0.0.0
* Thu Apr 12 2007 - dave.lin@sun.com
- bump to 2.0.0.0rc1, removed the patches thunderbird-11-drag-and-drop.diff,
thunderbird-12-defaultAccount.diff which are upstreamed in this release
* Thu Apr 12 2007 - dave.lin@sun.com
- disable update feature in Thunderbird menu since it's not supported
on Solaris so far(CR#6542910)
* Wed Mar 23 2007 - brian.lu@sun.com
- Fix the bug CR6535724:Thunderbird crashes with LDAP in snv 60
* Mon Mar 12 2007 - brian.lu@sun.com
- Fix the bug CR6530327
* Sat Mar 10 2007 - dougs@truemail.co.th
- Fixed URL for lightning
* Sat Mar 03 2007 - dave.lin@sun.com
- bump lightning version to 0.3.1
* Thu Feb 01 2007 - brian.lu@sun.com
- fix drag and drop crashing bug CR6519257
- bugzilla id 367203. The patch has been put into upstream
* Sun Jan 28 2007 - laca@sun.com
- add full download url for lightning
* Fri Jan 26 2007 - dave.lin@sun.com
- enable lightning extension(0.3) in Thunderbird
* Wed Jan 24 2007 - dave.lin@sun.com
- bump version to 2.0b2
* Thu Dec 28 2006 - dave.lin@sun.com
- change the patch type to branding for some patches in patch comments
- bump version to 2.0b1 and remove mozilla-03-s11s-smkfl.diff,
mozilla-04-s11x-smkfl.diff since they're upstreamed in that branch
* Fri Nov 17 2006 - dave.lin@sun.com
- add patch comments
* Mon Nov 13 2006 - dave.lin@sun.com
- change the version to 1.5.0.8 since 2.0a1 could not be able to integrated
into SNV, and add patches mozilla-03-s11s-smkfl.diff, mozilla-04-s11x-smkfl.diff
back because they're not upstreamed in the branch that for Thunderbird 1.5.x
* Thu Sep 07 2006 - dave.lin@sun.com
- add patch thunderbird-10-no-pkg-files.diff to remove patch checker scripts
since it's unnecessary to deliver them with the bundled version
- change the version 2.0a1 to 2.0 to comply WOS integration rules
- re-organize the patch list
* Mon Aug 28 2006 - dave.lin@sun.com
- create symbol link libnssckbi.so -> /usr/lib/mps/libnssckbi.so
to fix bug CR#6459752
* Tue Aug 08 2006 - dave.lin@sun.com
- bump version to 2.0a1
- remove the patch mozilla-03-s11s-smkfl.diff, mozilla-04-s11x-smkfl.diff
which have been fixed in 2.0a1
- change to xpinstall/packager to run the make to generate the binary tarball
* Mon Jul 31 2006 - dave.lin@sun.com
- bump to 1.5.0.5
* Fri Jul 07 2006 - dave.lin@sun.com
- add patch mozilla-07-no-ldlibpath.diff to remove the LD_LIBRARY_PATH in
- change to "disable-static, enable-shared" per Brian Lu
* Wed Jun 21 2006 - dave.lin@sun.com
- remove patch thunderbird-07-ldap-prefs.diff to fix bug CR#6344861
* Fri Jun 02 2006 - dave.lin@sun.com
- bump src version to 1.5.0.4
* Sat Apr 29 2006 - halton.huo@sun.com
- Add patch thunderbird-09-no-nss-nspr.diff to not deliver the nss,nspr
* Fri Apr 27 2006 - damien.carbery@sun.com
- Remove patch 9 as it is not in svn and breaks build.
* Fri Apr 27 2006 - dave.lin@sun.com
- change to not deliver the devel pkg
- add patch thunderbird-09-no-nss-nspr.diff to not deliver the nss,nspr
libraries, and use firefox's instead
- remove patch mozilla-06-skip-strip.diff, use another simple way to skip
strip instead, setting PKG_SKIP_STRIP=1
* Fri Apr 21 2006 - dave.lin@sun.com
- bump to 1.5.0.2, remove patch 06 thunderbird-06-save-all-attach.diff,
which is already upstreamed
* Fri Apr 14 2006 - dave.lin@sun.com
- add patch mozilla-06-skip-strip.diff to make no stripped libraries
- add patch firefox-13-locale.diff to make firefox automatically
pick up locale setting from user environment and start up in
that locale
* Thu Apr 13 2006 - dave.lin@sun.com
- Changed the installation location from "/usr/sfw/lib" to "/usr/lib"
on Solaris
* Fri Mar 10 2006 -halton.huo@sun.com
- Add patch thunderbird-06-save-all-attach.diff to fix 6373061.
- Add patch thunderbird-07-ldap-prefs.diff to fix CR6344861.
* Tue Jan 17 2006 - dave.lin@sun.com
- Bump tarball version to 1.5
- add two configure options --enable-static, --disable-shared
- to get rid of intermedia shared libraries
- disable parallel build option
* Tue Nov 08 2005 - dave.lin@sun.com
- Bump tarball version to 1.5rc1
- Remove the patch mozilla-07-bz307041.diff since it's upstreamed in 1.5rc1 already
* Thu Nov 1 2005 - laca@sun.com
- change version to numeric and introduce %tarball_version
* Fri Oct 21 2005 - <halton.huo@sun.com>
- Bump to 1.5b2.
- Add patch 307041 from bugzilla.
* Mon Sep 26 2005 - <halton.huo@sun.com>
- Bump to 1.5b1.
- Move dir mozilla to thunderbird after tarball unpacking.
* Thu Sep 08 2005 - damien.carbery@sun.com
- Change BuildPrereq to BuildRequires, a format that build-gnome2 understands.
* Mon Sep 05 2005 - Dave Lin <dave.lin@sun.com>
- Add patches to remove the specific gtar options
- Set MOZ_PKG_FORMAT=BZ2 to keep consistent of tarball
format between linux and solaris
* Fri Sep 02 2005 - damien.carbery@sun.com
- Change gtar to tar and rework tar command.
* Mon Aug 22 2005 - Dave Lin <dave.lin@sun.com>
- initial version of the spec file created