system-config-printer.spec revision 20777
10363N/A#
10363N/A# spec file for package system-config-printer
10363N/A#
10363N/A# includes module(s): system-onfig-printer
10363N/A#
10363N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10363N/A# This file and all modifications and additions to the pristine
10363N/A# package are under the same license as the package itself.
10363N/A#
10363N/A%define owner gheet
10363N/A#
15665N/A
10363N/A%define OSR 10483&10484:1.0.x
10363N/A
10363N/A%include l10n.inc
10363N/A
10363N/AName: system-config-printer
10363N/ALicense: GPL V2
10363N/AGroup: Development/Languages/Python
10363N/AVersion: 1.0.16
10363N/ARelease: 1
10363N/ADistribution: Java Desktop System
10363N/AVendor: Other
10363N/ASummary: Print Manager for CUPS
10363N/ASource: http://cyberelk.net/tim/data/%{name}/1.0.x/%{name}-%{version}.tar.bz2
10363N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
10363N/A# Source2: safaridoc from tech writer. Renamed PMOLH.xml to %{name}.xml
10363N/A# Modified DOCTYPE to point at 4.1.2/docbookx.dtd
10363N/ASource2: %{name}-online-help.tar
10363N/APatch1: system-config-printer-01-temp-for-2.4.diff
10363N/APatch2: system-config-printer-02-no-manpage.diff
10363N/A#owner:gheet date:2006-11-03 type:branding
10363N/APatch3: system-config-printer-03-app-path.diff
10363N/A#owner:gheet date:2006-11-03 type:branding bugster:6780731
10363N/APatch4: system-config-printer-04-remove-fedora-specific.diff
10363N/A#owner:gheet date:2009-12-10 type:bug doo:13117
10363N/APatch5: system-config-printer-05-init-monitor-timer.diff
10363N/A#owner:gheet date:2009-12-18 type:branding
10363N/APatch6: system-config-printer-06-python-version.diff
10363N/A#owner:gheet date:2011-06-16 type:branding bugster:7049775
10363N/APatch7: system-config-printer-07-online-help.diff
10363N/AURL: http://cyberelk.net/tim/software/%{name}
10363N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10363N/ADocdir: %{_defaultdocdir}/doc
10363N/AAutoreqprov: off
10363N/APrereq: /sbin/ldconfig
10363N/ARequires: SUNWpycups
10363N/A# uncomment this once we sorted samba 3.2.x
10363N/A#Requires: SUNWpysmbc
10363N/ABuildRequires: SUNWpycups
10363N/A#BuildRequires: SUNWpysmbc
10363N/A
10363N/A%description
10363N/ASystem Config Printer is a tool is to configure a CUPS server (often the local machine)
10363N/Ausing the CUPS API. The tool is written in Python, using pygtk for the graphical parts
10363N/Aand with some Python bindings (pycups) for the CUPS API.
10363N/A
10363N/AIt is largely the same as using the CUPS web interface for configuring printers, but
10363N/Ahas the advantage of being a native application rather than a web page.
10363N/A
10363N/A%prep
10363N/A%setup -q -n %{name}-%{version}
10363N/Amkdir -p help/C
10363N/Acd help/C
10363N/Atar xf %{SOURCE2}
10363N/Acd ../..
10363N/Abzcat %SOURCE1 | tar xf -
10363N/Acd po-sun; make; cd ..
10363N/A
10363N/A%patch01 -p1
10363N/A%patch02 -p0
10363N/A%patch03 -p0
10363N/A%patch04 -p1
10363N/A%patch05 -p1
10363N/A%patch06 -p1
10363N/A%patch07 -p1
10363N/A
10363N/A%build
15665N/Aexport PYTHON=/usr/bin/python%{default_python_version}
15665N/A
10363N/Acp /usr/share/gnome-common/data/*.make .
10363N/Acp /usr/share/gnome-doc-utils/gnome-doc-utils.make .
intltoolize --force --copy
aclocal
automake -a -c -f
autoconf
./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc
make
make install DESTDIR=$RPM_BUILD_ROOT
%install
python%{default_python_version} setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT
# move private directory from /usr/share to /usr/lib
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{name}
mv $RPM_BUILD_ROOT%{_datadir}/%{name}/*.py \
$RPM_BUILD_ROOT%{_libdir}/%{name}
# move troubleshoot to /ur/lib
mv $RPM_BUILD_ROOT%{_datadir}/%{name}/troubleshoot \
$RPM_BUILD_ROOT%{_libdir}/%{name}
# Move system-config-printer-applet to /usr/lib/%{name}
mv $RPM_BUILD_ROOT%{_bindir}/system-config-printer-applet \
$RPM_BUILD_ROOT%{_libdir}/%{name}
# do not deliver my-default-printer
rm $RPM_BUILD_ROOT%{_bindir}/my-default-printer
rm $RPM_BUILD_ROOT%{_libdir}/%{name}/my-default-printer.py
# Don't need desktop files as they are shared and managed by sym links
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
rm -rf $RPM_BUILD_ROOT/etc/xdg
# move to vendor-packages, but don't provide .pyc files
# deliver cupshelper into 2.6/vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/vendor-packages
rm $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/cupshelpers/*.pyc
rm $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/*egg-info
mv $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/* \
$RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages
%clean
rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Jun 16 2011 - ghee.teo@oracle.com
- Added online-help from Tech writer.
* Tue Dec 07 2010 - brian.cameron@oracle.com
- No longer provide the Python 2.4 bindings.
* Tue Dec 15 2009 - ghee.teo@sun.com
- Fix doo#13356. Move troubleshoot to %{_libdir}
- also make a copy of cupshelpers in 2.4 vendor-packages for hal-cups-utils
* Sun Dec 06 2009 - dave.lin@sun.com
- Remove the duplicated directory %{_datadir}/%{name}/troubleshoot
- Remove the python2.4 lines
* Wed Aug 12 2009 - christian.kelly@sun.com
- Bump to 1.0.16.
* Mon Jan 19 2009 - ghee.teo@sun.com
- Bump tarball to 1.0.13. Removed upteram l10n patch.
* Mon Dec 15 2008 - takao.fujiwara@sun.com
- Add l10n tarball.
* Fri Dec 12 2008 - takao.fujiwara@sun.com
- Add patch 05-g11n-textdomain.diff to set textdomain.
* Thu Dec 11 2008 - ghee.teo@sun.com
uprev to 1.0.12 tarball and added patch 04-remove-fedora-specific.diff
* Wed Nov 05 2008 - ghee.teo@sun.com
- initial version