15409N/A#
15409N/A# spec file for package system-config-printer
15409N/A#
15409N/A# includes module(s): system-onfig-printer
15409N/A#
15409N/A# Copyright (c) 2008 Sun Microsystems, Inc.
15409N/A# This file and all modifications and additions to the pristine
15409N/A# package are under the same license as the package itself.
15409N/A#
17185N/A%define owner gheet
15409N/A#
17176N/A
17176N/A%define OSR 10483&10484:1.0.x
17176N/A
15522N/A%include l10n.inc
15409N/A
15409N/AName: system-config-printer
15409N/ALicense: GPL V2
15409N/AGroup: Development/Languages/Python
17009N/AVersion: 1.0.16
15409N/ARelease: 1
15409N/ADistribution: Java Desktop System
18616N/AVendor: Other
15409N/ASummary: Print Manager for CUPS
15409N/ASource: http://cyberelk.net/tim/data/%{name}/1.0.x/%{name}-%{version}.tar.bz2
15522N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
20373N/A# Source2: safaridoc from tech writer. Renamed PMOLH.xml to %{name}.xml
20373N/A# Modified DOCTYPE to point at 4.1.2/docbookx.dtd
20777N/ASource2: %{name}-online-help.tar
15409N/APatch1: system-config-printer-01-temp-for-2.4.diff
15409N/APatch2: system-config-printer-02-no-manpage.diff
15507N/A#owner:gheet date:2006-11-03 type:branding
15409N/APatch3: system-config-printer-03-app-path.diff
15507N/A#owner:gheet date:2006-11-03 type:branding bugster:6780731
15507N/APatch4: system-config-printer-04-remove-fedora-specific.diff
17910N/A#owner:gheet date:2009-12-10 type:bug doo:13117
17910N/APatch5: system-config-printer-05-init-monitor-timer.diff
17956N/A#owner:gheet date:2009-12-18 type:branding
17956N/APatch6: system-config-printer-06-python-version.diff
20373N/A#owner:gheet date:2011-06-16 type:branding bugster:7049775
20373N/APatch7: system-config-printer-07-online-help.diff
20826N/A#owner:gheet date:2011-08-18 type:branding bugster:7076227
20826N/APatch8: system-config-printer-08-desktop-files.diff
15409N/AURL: http://cyberelk.net/tim/software/%{name}
15409N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15409N/ADocdir: %{_defaultdocdir}/doc
15409N/AAutoreqprov: off
15409N/APrereq: /sbin/ldconfig
15409N/ARequires: SUNWpycups
15409N/A# uncomment this once we sorted samba 3.2.x
15409N/A#Requires: SUNWpysmbc
15409N/ABuildRequires: SUNWpycups
15409N/A#BuildRequires: SUNWpysmbc
15409N/A
15409N/A%description
15409N/ASystem Config Printer is a tool is to configure a CUPS server (often the local machine)
15409N/Ausing the CUPS API. The tool is written in Python, using pygtk for the graphical parts
15409N/Aand with some Python bindings (pycups) for the CUPS API.
15409N/A
15409N/AIt is largely the same as using the CUPS web interface for configuring printers, but
15409N/Ahas the advantage of being a native application rather than a web page.
15409N/A
15409N/A%prep
15409N/A%setup -q -n %{name}-%{version}
20373N/Amkdir -p help/C
20373N/Acd help/C
20373N/Atar xf %{SOURCE2}
20373N/Acd ../..
15522N/Abzcat %SOURCE1 | tar xf -
15522N/Acd po-sun; make; cd ..
15522N/A
15517N/A%patch01 -p1
15409N/A%patch02 -p0
15409N/A%patch03 -p0
15507N/A%patch04 -p1
17910N/A%patch05 -p1
17956N/A%patch06 -p1
20373N/A%patch07 -p1
20826N/A%patch08 -p1
15409N/A
15409N/A%build
17939N/Aexport PYTHON=/usr/bin/python%{default_python_version}
17939N/A
20373N/Acp /usr/share/gnome-common/data/*.make .
20373N/Acp /usr/share/gnome-doc-utils/gnome-doc-utils.make .
15409N/Aintltoolize --force --copy
15409N/Aaclocal
15409N/Aautomake -a -c -f
15409N/Aautoconf
15409N/A./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc
20777N/Amake
15409N/Amake install DESTDIR=$RPM_BUILD_ROOT
15409N/A
15409N/A%install
17463N/Apython%{default_python_version} setup.py install --prefix=%{_prefix} --root=$RPM_BUILD_ROOT
15409N/A
17939N/A# move private directory from /usr/share to /usr/lib
15409N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/%{name}
17939N/Amv $RPM_BUILD_ROOT%{_datadir}/%{name}/*.py \
17939N/A $RPM_BUILD_ROOT%{_libdir}/%{name}
17939N/A# move troubleshoot to /ur/lib
17939N/Amv $RPM_BUILD_ROOT%{_datadir}/%{name}/troubleshoot \
17939N/A $RPM_BUILD_ROOT%{_libdir}/%{name}
17939N/A
17939N/A# Move system-config-printer-applet to /usr/lib/%{name}
17939N/Amv $RPM_BUILD_ROOT%{_bindir}/system-config-printer-applet \
17939N/A $RPM_BUILD_ROOT%{_libdir}/%{name}
17939N/A
17939N/A# do not deliver my-default-printer
17939N/Arm $RPM_BUILD_ROOT%{_bindir}/my-default-printer
17939N/Arm $RPM_BUILD_ROOT%{_libdir}/%{name}/my-default-printer.py
15409N/A
20826N/A# Remove desktop files which are not delivered in Solaris
20826N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/applications/redhat-my-default-printer.desktop
20826N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/applications/redhat-manage-print-jobs.desktop
15409N/A
15517N/A# move to vendor-packages, but don't provide .pyc files
17939N/A# deliver cupshelper into 2.6/vendor-packages
17463N/Amkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/vendor-packages
17939N/Arm $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/cupshelpers/*.pyc
17939N/Arm $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/*egg-info
17939N/A
17463N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages/* \
17463N/A $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/vendor-packages/
17463N/A
17463N/Armdir $RPM_BUILD_ROOT%{_libdir}/python%{default_python_version}/site-packages
15409N/A
15409N/A%clean
15409N/Arm -rf $RPM_BUILD_ROOT
15409N/A
15409N/A%changelog
20373N/A* Thu Jun 16 2011 - ghee.teo@oracle.com
20373N/A- Added online-help from Tech writer.
19819N/A* Tue Dec 07 2010 - brian.cameron@oracle.com
19819N/A- No longer provide the Python 2.4 bindings.
17939N/A* Tue Dec 15 2009 - ghee.teo@sun.com
17939N/A- Fix doo#13356. Move troubleshoot to %{_libdir}
17939N/A- also make a copy of cupshelpers in 2.4 vendor-packages for hal-cups-utils
17939N/A* Sun Dec 06 2009 - dave.lin@sun.com
17939N/A- Remove the duplicated directory %{_datadir}/%{name}/troubleshoot
17939N/A- Remove the python2.4 lines
17009N/A* Wed Aug 12 2009 - christian.kelly@sun.com
17009N/A- Bump to 1.0.16.
15686N/A* Mon Jan 19 2009 - ghee.teo@sun.com
15686N/A- Bump tarball to 1.0.13. Removed upteram l10n patch.
15522N/A* Mon Dec 15 2008 - takao.fujiwara@sun.com
15522N/A- Add l10n tarball.
15510N/A* Fri Dec 12 2008 - takao.fujiwara@sun.com
15510N/A- Add patch 05-g11n-textdomain.diff to set textdomain.
15507N/A* Thu Dec 11 2008 - ghee.teo@sun.com
15507N/A uprev to 1.0.12 tarball and added patch 04-remove-fedora-specific.diff
15409N/A* Wed Nov 05 2008 - ghee.teo@sun.com
15409N/A- initial version