sqlitetcl.spec revision 20322
10139N/A#
10139N/A# Copyright (c) 2010 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
12894N/A%define owner hawklu
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
10139N/A
17185N/A%define OSR 12578:1.0.2
10139N/A%define tarball_version 3070603
10139N/A
13561N/AName: sqlite-tea
10139N/ALicense: public domain
10139N/AGroup: System/Libraries
10139N/AVersion: 3.7.6.3
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18688N/AVendor: www.sqlite.org
18688N/ASummary: SQL database engine Tcl extension
10139N/A
10139N/A# This is specified here since unzip is used in this spec file.
13561N/ABuildRequires: compress/unzip
10139N/A
12894N/A# owner:hawklu date:2011-01-30 type:bug bugster:7015869
19140N/APatch1: sqlite3tcl-01-using-LD.diff
10139N/A
10139N/AURL: http://www.sqlite.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19142N/ADocdir: %{_defaultdocdir}
10139N/AAutoreqprov: on
10139N/A
10139N/A%description
10139N/ASQLite is a software library that implements a self-contained,
10139N/Aserverless, zero-configuration, transactional SQL database engine.
19142N/ASQLite is the most widely deployed SQL database engine in the world.
10139N/A
13437N/A%prep
10139N/Acp -r sqlite-autoconf-%{tarball_version} %{name}-%{tarball_version}
10139N/Acd %{name}-%{tarball_version}/tea
13561N/A
13561N/A%patch1 -p1
13561N/A
13561N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
13561N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
13561N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
13561N/A CPUS=1
13561N/Afi
13561N/A
10139N/Aexport PATH=`pwd`:$PATH
10139N/A
10139N/A%if %option_with_debug
10139N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_ENABLE_STAT2 -I. "
10139N/A%else
10139N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_ENABLE_STAT2 -I. "
10139N/A%endif
10139N/A
10139N/Aexport LDFLAGS="%_ldflags -Bdirect"
10139N/Acd %{name}-%{tarball_version}/tea
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --exec_prefix=%{_prefix} \
10139N/A --libdir=%{_libdir}/tcl8.4/ \
10139N/A --bindir=%{_bindir} \
10139N/A --enable-shared \
10139N/A --with-tcl="/usr/lib"
13561N/A
10139N/Amake -j $CPUS
13561N/A
10139N/A%install
10139N/Acd %{name}-%{tarball_version}/tea
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Arm -rf $RPM_BUILD_ROOT%{_mandir}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A
10139N/A%changelog
10139N/A* Tue May 31 2011 - ginn.chen@oracle.com
10139N/A- Bump to 3.7.6.3.
10139N/A* Mon Apr 18 2011 - ginn.chen@oracle.com
10139N/A- Enable SQLITE_ENABLE_STAT2.
10147N/A* Fri Apr 15 2011 - ginn.chen@oracle.com
10139N/A- Bump to 3.7.6.1
18921N/A* Mon Jan 31 2011 - brian.lu@oracle.com
18921N/A- initial version of the spec file.
18952N/A