20038N/A#
20038N/A# Copyright (c) 2010 Sun Microsystems, Inc.
20038N/A# This file and all modifications and additions to the pristine
20038N/A# package are under the same license as the package itself.
20038N/A#
20038N/A%define owner hawklu
20038N/A# bugdb: bugzilla.freedesktop.org
20038N/A#
20038N/A
20038N/A%define OSR 12578:1.0.2
20322N/A%define tarball_version 3070603
20038N/A
20038N/AName: sqlite-tea
20038N/ALicense: public domain
20038N/AGroup: System/Libraries
20322N/AVersion: 3.7.6.3
20038N/ARelease: 1
20038N/ADistribution: Java Desktop System
20038N/AVendor: www.sqlite.org
20038N/ASummary: SQL database engine Tcl extension
20038N/A
20038N/A# This is specified here since unzip is used in this spec file.
20038N/ABuildRequires: compress/unzip
20038N/A
20038N/A# owner:hawklu date:2011-01-30 type:bug bugster:7015869
20038N/APatch1: sqlite3tcl-01-using-LD.diff
20038N/A
20038N/AURL: http://www.sqlite.org
20038N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20038N/ADocdir: %{_defaultdocdir}
20038N/AAutoreqprov: on
20038N/A
20038N/A%description
20038N/ASQLite is a software library that implements a self-contained,
20038N/Aserverless, zero-configuration, transactional SQL database engine.
20038N/ASQLite is the most widely deployed SQL database engine in the world.
20038N/A
20038N/A%prep
20212N/Acp -r sqlite-autoconf-%{tarball_version} %{name}-%{tarball_version}
20212N/Acd %{name}-%{tarball_version}/tea
20038N/A
20038N/A%patch1 -p1
20038N/A
20038N/A%build
20038N/A%ifos linux
20038N/Aif [ -x /usr/bin/getconf ]; then
20038N/A CPUS=`getconf _NPROCESSORS_ONLN`
20038N/Afi
20038N/A%else
20038N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20038N/A%endif
20038N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20038N/A CPUS=1
20038N/Afi
20038N/A
20038N/Aexport PATH=`pwd`:$PATH
20038N/A
20038N/A%if %option_with_debug
20215N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_ENABLE_STAT2 -I. "
20038N/A%else
20215N/A export CFLAGS="%optflags -D_POSIX_PTHREAD_SEMANTICS -DNDEBUG -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_FTS3 -DUSE_PREAD -DHAVE_USLEEP -DHAVE_FDATASYNC -DHAVE_STATVFS -DSQLITE_ENABLE_UNLOCK_NOTIFY -DSQLITE_ENABLE_STAT2 -I. "
20038N/A%endif
20038N/A
20038N/Aexport LDFLAGS="%_ldflags -Bdirect"
20212N/Acd %{name}-%{tarball_version}/tea
20038N/A./configure \
20038N/A --prefix=%{_prefix} \
20038N/A --exec_prefix=%{_prefix} \
20038N/A --libdir=%{_libdir}/tcl8.4/ \
20038N/A --bindir=%{_bindir} \
20038N/A --enable-shared \
20038N/A --with-tcl="/usr/lib"
20038N/A
20038N/Amake -j $CPUS
20038N/A
20038N/A%install
20212N/Acd %{name}-%{tarball_version}/tea
20038N/Amake install DESTDIR=$RPM_BUILD_ROOT
20814N/Arm -rf $RPM_BUILD_ROOT%{_mandir}/mann
20038N/A
20038N/A%clean
20038N/Arm -rf $RPM_BUILD_ROOT
20038N/A
20038N/A%files
20038N/A
20038N/A%changelog
20322N/A* Tue May 31 2011 - ginn.chen@oracle.com
20322N/A- Bump to 3.7.6.3.
20215N/A* Mon Apr 18 2011 - ginn.chen@oracle.com
20215N/A- Enable SQLITE_ENABLE_STAT2.
20212N/A* Fri Apr 15 2011 - ginn.chen@oracle.com
20212N/A- Bump to 3.7.6.1
20038N/A* Mon Jan 31 2011 - brian.lu@oracle.com
20038N/A- initial version of the spec file.