seahorse.spec revision 17182
10139N/A#
10139N/A# spec file for package seahorse
10139N/A#
12158N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
15894N/A# Owner: jefftsai
10139N/A#
10139N/A
17178N/A%define OSR gnome.org:0
17178N/A
10139N/AName: seahorse
10139N/ALicense: GPL v2, LGPL v2, FDL v1.1
10139N/AGroup: System/GUI/GNOME
17110N/AVersion: 2.27.90
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Seahorse
10139N/ASource: http://download.gnome.org/sources/%{name}/2.27/%{name}-%{version}.tar.bz2
16920N/A%if %build_l10n
10142N/ASource1: l10n-configure.sh
12132N/A%endif
12132N/A
10142N/A# date:2008-10-22 owner:jefftsai type:branding
12773N/APatch2: seahorse-02-disable-remote.diff
14434N/A# date:2008-11-04 bugzilla:556670 owner:jefftsai type:bug
12773N/APatch3: seahorse-03-import-ssh.diff
14434N/A# date:2008-12-29 owner:jefftsai type:branding
15440N/APatch6: seahorse-06-return-void.diff
15440N/A
15740N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12107N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
12796N/A%define pkgconfig_version 0.15.0
10139N/A%define gtk_doc_version 1.1
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
12107N/A%description
13969N/ASeahorse is a GNOME application for managing encryption keys. It also
12107N/Aintegrates with nautilus, gedit and other places for encryption, decrption
14181N/Aand other operations.
14181N/A
14181N/A%prep
14181N/A%setup -q
14181N/A%patch2 -p1
14181N/A%patch3 -p1
15440N/A%patch6 -p1
14181N/A
10139N/A%build
14181N/A%ifos linux
16852N/Aif [ -x /usr/bin/getconf ]; then
16852N/A CPUS=`getconf _NPROCESSORS_ONLN`
17108N/Afi
17108N/A%else
17165N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17165N/A%endif
15864N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize -f -c --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Agnome-doc-prepare --force
10139N/Aaclocal -I /usr/share/aclocal -I m4
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --disable-ldap \
10139N/A --disable-hkp
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%check
10139N/Amake check
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%changelog
10139N/A* Tue Aug 11 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.90
10139N/A* Wed Jul 29 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.5
10139N/A* Sun May 31 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.27.1
10139N/A* Tue Apr 14 2009 - halton.huo@sun.com
10139N/A- Bump to 2.26.1
10139N/A* Mon Mar 16 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.26.0
10139N/A- Remove patch -04-disable-im, upstreamed.
10139N/A* Tue Mar 03 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.92
10139N/A* Mon Feb 16 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.91
10139N/A* Wed Feb 04 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.90
10139N/A- Remove patch -05-libtasn1, not needed since the dependency
10139N/A is removed
10139N/A* Mon Feb 02 2009 - jeff.cai@sun.com
10139N/A- Add patch -05-libtasn1.diff, Fix #570171.
10139N/A- Remove patch -01-input-passwd.diff, this bug is not
10139N/A reproducible on 2.25.4
10139N/A* Fri Jan 09 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.4
10139N/A- Remove -05-ssh-upload.diff, upstreamed
10139N/A- Remove -07-gp11object-slot.diff, not needed.
10139N/A* Mon Dec 29 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.25.3
10139N/A- Remove -03-a11y-hang, upstreamed.
10139N/A- Remove -04-show-error, upstreamed.
10139N/A- Remove -05-dialog-markup, upstreamed.
10139N/A- Remove -08-progress-pos, upstreamed.
10139N/A- Remove -09-key-name, upstreamed.
10139N/A- Reorder the rest patches.
10142N/A- Add patch -06-return-void, upstreamed.
10139N/A- Add patch -07-gpobject-slot, fix bug #566031.
10139N/A This is only a temporary solution for the build issue.
12176N/A* Thu Nov 27 2008 - jeff.cai@sun.com
10139N/A- Add -10-ssh-upload.diff to defer the destroy of swidget
12796N/A Fix #562413
12125N/A* Tue Nov 20 2008 - jeff.cai@sun.com
10139N/A- Add -09-key-name.diff to refresh key names if it changes.
10139N/A Fix #561641
12886N/A* Tue Nov 19 2008 - jeff.cai@sun.com
12886N/A- Add seahorse-08-progress-pos.diff to make the progress dialog
12886N/A not cover the password dialog.
13367N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
12127N/A- Add seahorse-07-disable-im.diff to disable input method in password.
15740N/A* Wed Nov 04 2008 - jeff.cai@sun.com
14181N/A- Add patch -06-import-ssh, need a better patch.
16852N/A* Fri Oct 31 2008 - jeff.cai@sun.com
17108N/A- Change the license tag.
17165N/A* Thu Oct 30 2008 - jeff.cai@sun.com
10139N/A- Add comment " not upgrade it before it goes to nevada"
14434N/A* Thu Oct 30 2008 - jeff.cai@sun.com
15440N/A- Add patch -04-show-error to fix #558491
15440N/A- Add patch -05-dialog-markup to fix #558494
15740N/A* Thu Oct 23 2008 - jeff.cai@sun.com
14434N/A- Add patch -03-a11y-hang to fix #557537
10139N/A* Wed Oct 22 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.24.1.
10139N/A- Remove upstream patch -01-build-thread
10139N/A- Add patch -01-input-password
10142N/A- Add patch -02-disable-remote since solaris doesn't
10139N/A have PGP support
10139N/A* Mon Sep 22 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.24.0.
10139N/A- Add patch -01-build-thread
10139N/A* Thu Sep 08 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.23.92.
10139N/A* Thu Sep 02 2008 - christian.kelly@sun.com
10139N/A- Bump to 2.23.91.
10139N/A* Tue Aug 19 2008 - dave.lin@sun.com
10139N/A- Bump to 2.23.90
10139N/A* Tue Aug 05 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.6. Remove all patches as they are upstream.
10139N/A
10139N/A* Wed Jul 23 2008 - jeff.cai@sun.com
10139N/A- Add bug no.
10139N/A
10139N/A* Mon Jul 21 2008 - jeff.cai@sun.com
10139N/A- Initial Sun release
10139N/A