seahorse.spec revision 15746
10139N/A#
10139N/A# spec file for package seahorse
10139N/A#
12198N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: jefftsai
10139N/A#
10139N/AName: seahorse
10139N/ALicense: GPL v2, LGPL v2, FDL v1.1
10139N/AGroup: System/GUI/GNOME
10139N/A# Please don't upgrade it before it goes into nevada.
15739N/AVersion: 2.25.4
12578N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Seahorse
15689N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.25/%{name}-%{version}.tar.bz2
11419N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
11419N/A%endif
10139N/A
10142N/A# date:2008-10-22 owner:jefftsai type:branding
10142N/APatch2: seahorse-02-disable-remote.diff
10244N/A# date:2008-11-04 bugzilla:556670 owner:jefftsai type:bug
14429N/APatch3: seahorse-03-import-ssh.diff
14429N/A# date:2008-11-18 bugzilla:561331 bugster:6772733 owner:fujiwara type:feature
12773N/APatch4: seahorse-04-disable-im.diff
14444N/A# date:2009-02-02 bugzilla:570171 owner:jefftsai type:bug
12773N/APatch5: seahorse-05-libtasn1.diff
11419N/A# date:2008-12-29 owner:jefftsai type:branding
10139N/APatch6: seahorse-06-return-void.diff
10139N/A
11419N/AURL: http://www.gnome.org
11437N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11962N/AAutoreqprov: on
11437N/APrereq: /sbin/ldconfig
11437N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
10139N/A%define gtk_doc_version 1.1
10139N/A
10803N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
10139N/A%description
13462N/ASeahorse is a GNOME application for managing encryption keys. It also
13462N/Aintegrates with nautilus, gedit and other places for encryption, decrption
13462N/Aand other operations.
11419N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch2 -p1
10139N/A%patch3 -p1
11419N/A%patch4 -p1
10139N/A%patch5 -p1
13901N/A%patch6 -p1
10139N/A
13901N/A%build
13571N/A%ifos linux
13901N/Aif [ -x /usr/bin/getconf ]; then
14048N/A CPUS=`getconf _NPROCESSORS_ONLN`
15733N/Afi
14151N/A%else
15733N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
14151N/A%endif
15733N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize -f -c --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Agnome-doc-prepare --force
10139N/Aaclocal -I /usr/share/aclocal -I m4
10139N/Aautoconf
10139N/Aautoheader
10139N/Aautomake
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --disable-ldap \
10139N/A --disable-hkp
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%check
10139N/Amake check
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%changelog
10139N/A* Mon Feb 02 2009 - jeff.cai@sun.com
10139N/A- Add patch -05-libtasn1.diff, Fix #570171.
10139N/A- Remove patch -01-input-passwd.diff, this bug is not
10139N/A reproducible on 2.25.4
10139N/A* Fri Jan 09 2009 - jeff.cai@sun.com
10139N/A- Bump to 2.25.4
10139N/A- Remove -05-ssh-upload.diff, upstreamed
10139N/A- Remove -07-gp11object-slot.diff, not needed.
10139N/A* Mon Dec 29 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.25.3
10139N/A- Remove -03-a11y-hang, upstreamed.
10139N/A- Remove -04-show-error, upstreamed.
10139N/A- Remove -05-dialog-markup, upstreamed.
10139N/A- Remove -08-progress-pos, upstreamed.
10244N/A- Remove -09-key-name, upstreamed.
12754N/A- Reorder the rest patches.
10139N/A- Add patch -06-return-void, upstreamed.
11855N/A- Add patch -07-gpobject-slot, fix bug #566031.
10139N/A This is only a temporary solution for the build issue.
11855N/A* Thu Nov 27 2008 - jeff.cai@sun.com
11855N/A- Add -10-ssh-upload.diff to defer the destroy of swidget
11855N/A Fix #562413
11855N/A* Tue Nov 20 2008 - jeff.cai@sun.com
10139N/A- Add -09-key-name.diff to refresh key names if it changes.
10139N/A Fix #561641
10139N/A* Tue Nov 19 2008 - jeff.cai@sun.com
10139N/A- Add seahorse-08-progress-pos.diff to make the progress dialog
10139N/A not cover the password dialog.
13462N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
13462N/A- Add seahorse-07-disable-im.diff to disable input method in password.
13462N/A* Wed Nov 04 2008 - jeff.cai@sun.com
11419N/A- Add patch -06-import-ssh, need a better patch.
12524N/A* Fri Oct 31 2008 - jeff.cai@sun.com
10139N/A- Change the license tag.
11419N/A* Thu Oct 30 2008 - jeff.cai@sun.com
13901N/A- Add comment " not upgrade it before it goes to nevada"
13901N/A* Thu Oct 30 2008 - jeff.cai@sun.com
13901N/A- Add patch -04-show-error to fix #558491
13901N/A- Add patch -05-dialog-markup to fix #558494
14048N/A* Thu Oct 23 2008 - jeff.cai@sun.com
14151N/A- Add patch -03-a11y-hang to fix #557537
12316N/A* Wed Oct 22 2008 - jeff.cai@sun.com
10142N/A- Bump to 2.24.1.
14429N/A- Remove upstream patch -01-build-thread
14429N/A- Add patch -01-input-password
11419N/A- Add patch -02-disable-remote since solaris doesn't
10139N/A have PGP support
11419N/A* Mon Sep 22 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.24.0.
10139N/A- Add patch -01-build-thread
10142N/A* Thu Sep 08 2008 - jeff.cai@sun.com
10139N/A- Bump to 2.23.92.
10139N/A* Thu Sep 02 2008 - christian.kelly@sun.com
10139N/A- Bump to 2.23.91.
10139N/A* Tue Aug 19 2008 - dave.lin@sun.com
10139N/A- Bump to 2.23.90
10139N/A* Tue Aug 05 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.23.6. Remove all patches as they are upstream.
10139N/A
10139N/A* Wed Jul 23 2008 - jeff.cai@sun.com
10139N/A- Add bug no.
10139N/A
10139N/A* Mon Jul 21 2008 - jeff.cai@sun.com
10139N/A- Initial Sun release
10139N/A