seahorse.spec revision 15384
13629N/A#
13629N/A# spec file for package seahorse
13629N/A#
13629N/A# Copyright (c) 2008 Sun Microsystems, Inc.
13629N/A# This file and all modifications and additions to the pristine
13629N/A# package are under the same license as the package itself.
13629N/A#
13629N/A# Owner: jefftsai
13629N/A#
13629N/AName: seahorse
15291N/ALicense: GPL v2, LGPL v2, FDL v1.1
13629N/AGroup: System/GUI/GNOME
15287N/A# Please don't upgrade it before it goes into nevada.
15240N/AVersion: 2.24.1
13629N/ARelease: 1
13629N/ADistribution: Java Desktop System
13629N/AVendor: Sun Microsystems, Inc.
13629N/ASummary: Seahorse
14461N/ASource: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.24/%{name}-%{version}.tar.bz2
13629N/A%if %build_l10n
13629N/ASource1: l10n-configure.sh
13629N/A%endif
14461N/A
15240N/A# date:2008-10-22 bugzilla:551318 owner:jefftsai type:bug
15240N/APatch1: seahorse-01-input-password.diff
15240N/A# date:2008-10-22 owner:jefftsai type:branding
15240N/APatch2: seahorse-02-disable-remote.diff
15242N/A# date:2008-10-23 bugzilla:557537 owner:jefftsai type:bug
15242N/APatch3: seahorse-03-a11y-hang.diff
15279N/A# date:2008-10-30 bugzilla:558491 owner:jefftsai type:bug
15279N/APatch4: seahorse-04-show-error.diff
15279N/A# date:2008-10-30 bugzilla:558494 owner:jefftsai type:bug
15279N/APatch5: seahorse-05-dialog-markup.diff
15299N/A# date:2008-11-04 bugzilla:556670 owner:jefftsai type:bug
15299N/APatch6: seahorse-06-import-ssh.diff
15370N/A# date:2008-11-18 bugzilla:561331 bugster:6772733 owner:fujiwara type:feature
15370N/APatch7: seahorse-07-disable-im.diff
15375N/A# date:2008-11-18 bugzilla:561476 owner:jefftsai type:bug
15375N/APatch8: seahorse-08-progress-pos.diff
15384N/A# date:2008-11-20 bugzilla:561641 owner:jefftsai type:bug
15384N/APatch9: seahorse-09-key-name.diff
14461N/A
13629N/AURL: http://www.gnome.org
13629N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
13629N/AAutoreqprov: on
13629N/APrereq: /sbin/ldconfig
13629N/A
13629N/A%define gtk2_version 2.4.0
13629N/A%define pkgconfig_version 0.15.0
13629N/A%define gtk_doc_version 1.1
13629N/A
13629N/ARequires: gtk2 >= %{gtk2_version}
13629N/ABuildRequires: gtk2-devel >= %{gtk2_version}
13629N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
13629N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
13629N/A
13629N/A%description
13629N/ASeahorse is a GNOME application for managing encryption keys. It also
13629N/Aintegrates with nautilus, gedit and other places for encryption, decrption
13629N/Aand other operations.
13629N/A
13629N/A%prep
13629N/A%setup -q
15242N/A%patch1 -p1
15240N/A%patch2 -p1
15242N/A%patch3 -p1
15279N/A%patch4 -p1
15279N/A%patch5 -p1
15299N/A%patch6 -p1
15370N/A%patch7 -p1
15375N/A%patch8 -p1
15384N/A%patch9 -p1
13629N/A
13629N/A%build
13629N/A%ifos linux
13629N/Aif [ -x /usr/bin/getconf ]; then
13629N/A CPUS=`getconf _NPROCESSORS_ONLN`
13629N/Afi
13629N/A%else
13629N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
13629N/A%endif
13629N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
13629N/A CPUS=1
13629N/Afi
13629N/A
13629N/Alibtoolize --force
13629N/Aintltoolize -f -c --automake
13629N/A
13629N/A%if %build_l10n
13629N/Abash -x %SOURCE1 --enable-copyright
13629N/A%endif
13629N/A
13629N/Agnome-doc-prepare --force
14461N/Aaclocal -I /usr/share/aclocal -I m4
13629N/Aautoconf
13629N/Aautoheader
13629N/Aautomake
13629N/A
13629N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
13629N/A./configure --prefix=%{_prefix} \
13629N/A --sysconfdir=%{_sysconfdir} \
13629N/A --mandir=%{_mandir} \
15240N/A --libexecdir=%{_libexecdir} \
15240N/A --disable-ldap \
15240N/A --disable-hkp
13629N/Amake -j $CPUS
13629N/A
13629N/A%install
13629N/Amake DESTDIR=$RPM_BUILD_ROOT install
13629N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
13629N/A
13629N/A%check
13629N/Amake check
13629N/A
13629N/A%clean
13629N/Arm -rf $RPM_BUILD_ROOT
13629N/A
13629N/A%changelog
15384N/A* Tue Nov 20 2008 - jeff.cai@sun.com
15384N/A- Add -09-key-name.diff to refresh key names if it changes.
15384N/A Fix #561641
15375N/A* Tue Nov 19 2008 - jeff.cai@sun.com
15375N/A- Add seahorse-08-progress-pos.diff to make the progress dialog
15375N/A not cover the password dialog.
15370N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
15370N/A- Add seahorse-07-disable-im.diff to disable input method in password.
15299N/A* Wed Nov 04 2008 - jeff.cai@sun.com
15299N/A- Add patch -06-import-ssh, need a better patch.
15291N/A* Fri Oct 31 2008 - jeff.cai@sun.com
15291N/A- Change the license tag.
15279N/A* Thu Oct 30 2008 - jeff.cai@sun.com
15287N/A- Add comment " not upgrade it before it goes to nevada"
15287N/A* Thu Oct 30 2008 - jeff.cai@sun.com
15279N/A- Add patch -04-show-error to fix #558491
15279N/A- Add patch -05-dialog-markup to fix #558494
15242N/A* Thu Oct 23 2008 - jeff.cai@sun.com
15242N/A- Add patch -03-a11y-hang to fix #557537
15242N/A* Wed Oct 22 2008 - jeff.cai@sun.com
15240N/A- Bump to 2.24.1.
15240N/A- Remove upstream patch -01-build-thread
15240N/A- Add patch -01-input-password
15240N/A- Add patch -02-disable-remote since solaris doesn't
15240N/A have PGP support
14461N/A* Mon Sep 22 2008 - jeff.cai@sun.com
14461N/A- Bump to 2.24.0.
14461N/A- Add patch -01-build-thread
14185N/A* Thu Sep 08 2008 - jeff.cai@sun.com
14185N/A- Bump to 2.23.92.
14157N/A* Thu Sep 02 2008 - christian.kelly@sun.com
14157N/A- Bump to 2.23.91.
13920N/A* Tue Aug 19 2008 - dave.lin@sun.com
13920N/A- Bump to 2.23.90
13764N/A* Tue Aug 05 2008 - damien.carbery@sun.com
13764N/A- Bump to 2.23.6. Remove all patches as they are upstream.
13629N/A
13630N/A* Wed Jul 23 2008 - jeff.cai@sun.com
13630N/A- Add bug no.
13630N/A
13629N/A* Mon Jul 21 2008 - jeff.cai@sun.com
13629N/A- Initial Sun release