13629N/A#
13629N/A# spec file for package seahorse
13629N/A#
16362N/A# Copyright 2009 Sun Microsystems, Inc.
13629N/A# This file and all modifications and additions to the pristine
13629N/A# package are under the same license as the package itself.
13629N/A#
17185N/A%define owner jefftsai
13629N/A#
17182N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17182N/A
13629N/AName: seahorse
15291N/ALicense: GPL v2, LGPL v2, FDL v1.1
13629N/AGroup: System/GUI/GNOME
18783N/AVersion: 2.30.1
13629N/ARelease: 1
13629N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
13629N/ASummary: Seahorse
18536N/ASource: http://download.gnome.org/sources/%{name}/2.30/%{name}-%{version}.tar.bz2
13629N/A%if %build_l10n
13629N/ASource1: l10n-configure.sh
13629N/A%endif
14461N/A
17674N/A# date:2009-10-16 owner:jefftsai type:branding
17674N/APatch1: seahorse-01-sun-ldap.diff
20329N/APatch2: seahorse-02-libcryptui-l10n.diff
20369N/A# date:2011-06-15 owner:jefftsai type:bug bugster:6772733 bugzilla:561331
20369N/APatch3: seahorse-03-disable-im.diff
14461N/A
13629N/AURL: http://www.gnome.org
13629N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
13629N/AAutoreqprov: on
13629N/APrereq: /sbin/ldconfig
13629N/A
13629N/A%define gtk2_version 2.4.0
13629N/A%define pkgconfig_version 0.15.0
13629N/A%define gtk_doc_version 1.1
13629N/A
13629N/ARequires: gtk2 >= %{gtk2_version}
13629N/ABuildRequires: gtk2-devel >= %{gtk2_version}
13629N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
13629N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
13629N/A
13629N/A%description
13629N/ASeahorse is a GNOME application for managing encryption keys. It also
13629N/Aintegrates with nautilus, gedit and other places for encryption, decrption
13629N/Aand other operations.
13629N/A
13629N/A%prep
13629N/A%setup -q
17674N/A%patch1 -p1
20329N/A%patch2 -p1
20369N/A%patch3 -p1
13629N/A
13629N/A%build
13629N/A%ifos linux
13629N/Aif [ -x /usr/bin/getconf ]; then
13629N/A CPUS=`getconf _NPROCESSORS_ONLN`
13629N/Afi
13629N/A%else
13629N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
13629N/A%endif
13629N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
13629N/A CPUS=1
13629N/Afi
13629N/A
13629N/Alibtoolize --force
13629N/Aintltoolize -f -c --automake
13629N/A
13629N/A%if %build_l10n
13629N/Abash -x %SOURCE1 --enable-copyright
13629N/A%endif
13629N/A
13629N/Agnome-doc-prepare --force
14461N/Aaclocal -I /usr/share/aclocal -I m4
13629N/Aautoconf
13629N/Aautoheader
13629N/Aautomake
13629N/A
13629N/ACFLAGS="$RPM_OPT_FLAGS -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include" \
13629N/A./configure --prefix=%{_prefix} \
13629N/A --sysconfdir=%{_sysconfdir} \
13629N/A --mandir=%{_mandir} \
18478N/A --libexecdir=%{_libexecdir} \
18478N/A --enable-introspection=no
13629N/Amake -j $CPUS
13629N/A
13629N/A%install
13629N/Amake DESTDIR=$RPM_BUILD_ROOT install
13629N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
13629N/A
13629N/A%check
13629N/Amake check
13629N/A
13629N/A%clean
13629N/Arm -rf $RPM_BUILD_ROOT
13629N/A
13629N/A%changelog
20369N/A* Jun 15 2011 - jeff.cai@oracle.com
20369N/A- Add patch -03-disable-im to fix #6772733, #561331
18783N/A* May 26 2010 - jeff.cai@sun.com
18783N/A- Bump to 2.30.1
18536N/A* Mar 31 2010 - jeff.cai@sun.com
18536N/A- Bump to 2.30.0
18478N/A* Mar 18 2010 - jeff.cai@sun.com
18478N/A- Disable introspection to fix #15247
18325N/A* Feb 23 2010 - jeff.cai@sun.com
18325N/A- Bump to 2.29.91
18268N/A* Feb 09 2010 - jeff.cai@sun.com
18268N/A- Bump to 2.29.90
18268N/A- Removed the patch -02-autostart-desktop, the trunk also not autostart
18268N/A seahorse, the patch not needed.
18133N/A* Mon 18 2010 - christian.kelly@sun.com
18133N/A- Bump 2.29.4.
17882N/A* Dec 07 2009 - jeff.cai@sun.com
17882N/A- Bump 2.29.3
17882N/A- Removed patch -03-import-ssh since upstreamed
17882N/A- Removed patch -02-disable-remote since gpg is enabled,
17882N/A this patch is not needed
17882N/A- Removed patch -05-check-gpg2 since upstreamed
17857N/A* Dec 3 2009 - christian.kelly@sun.com
17857N/A- Bumo to 2.29.1.
17674N/A* Nov 06 2009 - jeff.cia@sun.com
17674N/A- Add patch -01-sun-ldap, a patch for sun ldap.
17674N/A- Add patch -04-autostart-desktop, move the .desktop file
17674N/A- Add patch -05-check-gpg2, check gpg2
17554N/A* Oct 20 2009 - jeff.cai@sun.com
17554N/A- Bump to 2.28.1
17358N/A* Tue Sep 22 2009 - jeff.cai@sun.com
17358N/A- Bump to 2.28.0
17358N/A- Upstream patch -06-return-void
17297N/A* Mon Sep 14 2009 - jeff.cai@sun.com
17297N/A- Bump to 2.27.92
16980N/A* Tue Aug 11 2009 - jeff.cai@sun.com
16980N/A- Bump to 2.27.90
16918N/A* Wed Jul 29 2009 - jeff.cai@sun.com
16918N/A- Bump to 2.27.5
16571N/A* Sun May 31 2009 - jeff.cai@sun.com
16571N/A- Bump to 2.27.1
16362N/A* Tue Apr 14 2009 - halton.huo@sun.com
16362N/A- Bump to 2.26.1
16146N/A* Mon Mar 16 2009 - jeff.cai@sun.com
16146N/A- Bump to 2.26.0
16146N/A- Remove patch -04-disable-im, upstreamed.
16026N/A* Tue Mar 03 2009 - jeff.cai@sun.com
16026N/A- Bump to 2.25.92
15837N/A* Mon Feb 16 2009 - jeff.cai@sun.com
15837N/A- Bump to 2.25.91
15759N/A* Wed Feb 04 2009 - jeff.cai@sun.com
15759N/A- Bump to 2.25.90
15759N/A- Remove patch -05-libtasn1, not needed since the dependency
15759N/A is removed
15746N/A* Mon Feb 02 2009 - jeff.cai@sun.com
15746N/A- Add patch -05-libtasn1.diff, Fix #570171.
15746N/A- Remove patch -01-input-passwd.diff, this bug is not
15746N/A reproducible on 2.25.4
15637N/A* Fri Jan 09 2009 - jeff.cai@sun.com
15637N/A- Bump to 2.25.4
15637N/A- Remove -05-ssh-upload.diff, upstreamed
15637N/A- Remove -07-gp11object-slot.diff, not needed.
15584N/A* Mon Dec 29 2008 - jeff.cai@sun.com
15584N/A- Bump to 2.25.3
15584N/A- Remove -03-a11y-hang, upstreamed.
15584N/A- Remove -04-show-error, upstreamed.
15584N/A- Remove -05-dialog-markup, upstreamed.
15584N/A- Remove -08-progress-pos, upstreamed.
15584N/A- Remove -09-key-name, upstreamed.
15584N/A- Reorder the rest patches.
15584N/A- Add patch -06-return-void, upstreamed.
15584N/A- Add patch -07-gpobject-slot, fix bug #566031.
15584N/A This is only a temporary solution for the build issue.
15411N/A* Thu Nov 27 2008 - jeff.cai@sun.com
15411N/A- Add -10-ssh-upload.diff to defer the destroy of swidget
15411N/A Fix #562413
15384N/A* Tue Nov 20 2008 - jeff.cai@sun.com
15384N/A- Add -09-key-name.diff to refresh key names if it changes.
15384N/A Fix #561641
15375N/A* Tue Nov 19 2008 - jeff.cai@sun.com
15375N/A- Add seahorse-08-progress-pos.diff to make the progress dialog
15375N/A not cover the password dialog.
15370N/A* Tue Nov 18 2008 - takao.fujiwara@sun.com
15370N/A- Add seahorse-07-disable-im.diff to disable input method in password.
15299N/A* Wed Nov 04 2008 - jeff.cai@sun.com
15299N/A- Add patch -06-import-ssh, need a better patch.
15291N/A* Fri Oct 31 2008 - jeff.cai@sun.com
15291N/A- Change the license tag.
15279N/A* Thu Oct 30 2008 - jeff.cai@sun.com
15287N/A- Add comment " not upgrade it before it goes to nevada"
15287N/A* Thu Oct 30 2008 - jeff.cai@sun.com
15279N/A- Add patch -04-show-error to fix #558491
15279N/A- Add patch -05-dialog-markup to fix #558494
15242N/A* Thu Oct 23 2008 - jeff.cai@sun.com
15242N/A- Add patch -03-a11y-hang to fix #557537
15242N/A* Wed Oct 22 2008 - jeff.cai@sun.com
15240N/A- Bump to 2.24.1.
15240N/A- Remove upstream patch -01-build-thread
15240N/A- Add patch -01-input-password
15240N/A- Add patch -02-disable-remote since solaris doesn't
15240N/A have PGP support
14461N/A* Mon Sep 22 2008 - jeff.cai@sun.com
14461N/A- Bump to 2.24.0.
14461N/A- Add patch -01-build-thread
14185N/A* Thu Sep 08 2008 - jeff.cai@sun.com
14185N/A- Bump to 2.23.92.
14157N/A* Thu Sep 02 2008 - christian.kelly@sun.com
14157N/A- Bump to 2.23.91.
13920N/A* Tue Aug 19 2008 - dave.lin@sun.com
13920N/A- Bump to 2.23.90
13764N/A* Tue Aug 05 2008 - damien.carbery@sun.com
13764N/A- Bump to 2.23.6. Remove all patches as they are upstream.
13629N/A
13630N/A* Wed Jul 23 2008 - jeff.cai@sun.com
13630N/A- Add bug no.
13630N/A
13629N/A* Mon Jul 21 2008 - jeff.cai@sun.com
13629N/A- Initial Sun release