rhythmbox.spec revision 12658
18068N/A#
18068N/A# spec file for package rhythmbox
18068N/A#
18068N/A# Copyright (c) 2008 Sun Microsystems, Inc.
18068N/A# This file and all modifications and additions to the pristine
18589N/A# package are under the same license as the package itself.
18068N/A#
18068N/A# Owner: yippi
18068N/A#
18068N/AName: rhythmbox
18068N/ALicense: GPL
18068N/AGroup: System/GUI/GNOME
18068N/AVersion: 0.11.5
18068N/ARelease: 1
18068N/ADistribution: Java Desktop System
18068N/AVendor: Sun Microsystems, Inc.
18068N/ASummary: Rhythmbox Multimedia Player
18068N/ASource: http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.11/%{name}-%{version}.tar.bz2
18068N/A#owner:yippi date:2006-06-22 type:branding bugzilla:507368
18589N/APatch1: rhythmbox-01-nocheck.diff
18756N/A#owner:sh162551 date:2007-03-14 bugster:6532865 type:branding bugzilla:466752
18688N/APatch2: rhythmbox-02-null-title.diff
18068N/A#owner:jerrytan date:2008-01-16 type:bug bugzilla:509846
18068N/APatch3: rhythmbox-03-playcd.diff
19140N/AURL: http://www.gnome.org
18068N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18068N/ADocdir: %{_defaultdocdir}/%{name}
18068N/AAutoreqprov: on
19142N/A
18069N/A%define libgnomeui_version 2.6.0
18069N/A%define gstreamer_version 0.8.1
18249N/A%define gstreamer_plugins_version 0.8.1
18069N/A%define gnome_desktop_version 2.6.1
18249N/A
18249N/ARequires: libgnomeui >= %{libgnomeui_version}
18069N/ARequires: gstreamer >= %{gstreamer_version}
18249N/ARequires: gstreamer-plugins >= %{gstreamer_plugins_version}
18249N/ARequires: gnome-desktop >= %{gnome_desktop_version}
18069N/ARequires: iso-codes
18068N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
18068N/ABuildRequires: gstreamer-devel >= %{gstreamer_version}
18068N/ABuildRequires: gstreamer-plugins-devel >= %{gstreamer_plugins_version}
19126N/ABuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
18069N/A
19126N/A%description
18068N/ARhythmbox is an integrated music management application
19142N/A
18069N/A%prep
18068N/A%setup -q
18068N/A%patch1 -p1
18068N/A%patch2 -p1
18068N/A%patch3 -p1
18068N/A
18068N/A%build
19142N/A%ifos linux
18068N/Aif [ -x /usr/bin/getconf ]; then
18068N/A CPUS=`getconf _NPROCESSORS_ONLN`
18068N/Afi
18068N/A%else
18068N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
19142N/A%endif
18069N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18068N/A CPUS=1
18068N/Afi
18068N/A
18068N/Aif test "x$x_includes" = "x"; then
18068N/A x_includes="/usr/X11/include"
18068N/Afi
18068N/A
18068N/Aif test "x$x_libraries" = "x"; then
18068N/A x_libraries="/usr/X11/lib"
18068N/Afi
18068N/A
18068N/Aintltoolize --copy --force --automake
18068N/Alibtoolize --force
18068N/A## FIXME: Swap aclocal dir order to pick up gnome-doc-utils.m4 in 'macros'.
18068N/A##aclocal $ACLOCAL_FLAGS -I ./macros
18249N/Aaclocal -I ./macros $ACLOCAL_FLAGS
18249N/Aautoheader
18249N/Aautomake -a -c -f
18249N/Aautoconf
18249N/A
18068N/Aexport MOZILLA_PLUGINDIR="%{_libdir}/firefox/plugins"
18068N/A# --with-ipod requires that gtkpod be installed or configure will fail.
18068N/ACFLAGS="$RPM_OPT_FLAGS" \
18068N/A./configure \
18068N/A --prefix=%{_prefix} \
18068N/A --sysconfdir=%{_sysconfdir} \
18068N/A --libdir=%{_libdir} \
18068N/A --bindir=%{_bindir} \
18068N/A --libexecdir=%{_libexecdir} \
18068N/A --mandir=%{_mandir} \
18068N/A --localstatedir=/var/lib \
18068N/A --disable-daap \
18068N/A --enable-gstreamer
18068N/A#FIXME -j is breaking the build removing for now.
18068N/A#make -j $CPUS
18068N/Amake
18068N/A
18068N/A%install
18068N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
18068N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
18068N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
18068N/Arm $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/lib*a
18068N/A
18068N/A%clean
18068N/Arm -rf $RPM_BUILD_ROOT
18068N/A
18068N/A%post
18068N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
18068N/ASCHEMAS="totem.schemas totem-video-thumbnail.schemas"
18068N/Afor S in $SCHEMAS; do
18068N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
18068N/Adone
18068N/A
18068N/A%files
18068N/A%defattr (-, root, root)
18068N/A%{_bindir}/*
18068N/A%{_sysconfdir}/gconf/schemas
18068N/A%{_libdir}/*
18068N/A%{_libexecdir}/*
18068N/A%{_datadir}/applications
18068N/A%{_datadir}/gnome/help/totem/*
18068N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
18068N/A%{_datadir}/pixmaps/*
18068N/A
18068N/A%changelog
18068N/A* Wed Mar 26 2008 - brian.cameron@sun.com
18068N/A- Bum to 0.11.5.
18068N/A* Wed Mar 05 2008 - brian.cameron@sun.com
18068N/A- Patch to fix linking with soup to avoid crash on startup. Fixes #6671873.
18317N/A* Thu Jan 31 2008 - damien.carbery@sun.com
18317N/A- Add patch 05-libsoup to allow building with libsoup 2.3.x. Fixes #509701.
18249N/A* Wed Jan 16 2008 - jerry.tan@sun.com
18249N/A- Add patch for fix the bug that rhythmbox can not play CD. Fixes bugzilla
18068N/A 509846.
18068N/A* Thu Jan 10 2008 - damien.carbery@sun.com
18068N/A- Add patch 03-mozilla-plugindir to allow specifying of mozilla plugin dir via
18068N/A MOZILLA_PLUGINDIR env var. Code copied from totem. Bug 508499.
19376N/A* Sun Dec 23 2007 - damien.carbery@sun.com
19693N/A- Bump to 0.11.4. Remove upstream patch, 03-empty-dialog.
* Tue Dec 11 2007 - Irene.huang@sun.com
- Added patch rhythmbox-03-empty-dialog.diff
* Fri Nov 09 2007 - damien.carbery@sun.com
- Bump to 0.11.3.
* Wed Sep 26 2007 - brian.cameron@sun.com
- Call intltoolize so that the desktop file gets built.
* Thu Aug 16 2007 - damien.carbery@sun.com
- Bump to 0.11.2.
* Mon Jul 02 2007 - damien.carbery@sun.com
- Bump to 0.11.1.
* Mon May 28 2007 - damien.carbery@sun.com
- Bump to 0.11.0.
* Mon May 28 2007 - irene.huang@sun.com
- change patch -02-null-title to be branding
* Fri May 25 2007 - damien.carbery@sun.com
- Bump to 0.10.90.
* Tue Apr 24 2007 - irene.huang@sun.com
- Modify bug number for patch null-title.diff
* Mon Apr 02 2007 - damien.carbery@sun.com
- Bump to 0.10.0. Remove upstream patch, 03-wronglocking.
* Wed Mar 22 2007 - irene.huang@sun.com
- add patch rhythmbox-03-wronglocking.diff
* Wed Mar 14 2007 - irene.huang@sun.com
- add patch rhythmbox-02-null-title.diff.
* Mon Mar 12 2007 - laca@sun.com
- delete .la files
* Wed Feb 28 2007 - halton.huo@sun.com
- Remove patch 02-gnome-doc-utils since g-d-u is upgrade to 0.9.x.
* Thu Feb 22 2007 - damien.carbery@sun.com
- Add patch, 02-gnome-doc-utils, to create gnome-doc-utils.m4 in macros subdir.
This is needed because g-d-u is too old (it's blocked waiting for docbook
update). The dir order in the aclocal call is also reversed to pick up the
new gnome-doc-utils.m4 before the (older) system one. When g-d-u is updated
the patch can be removed and aclocal call restored.
* Tue Dec 19 2006 - damien.carbery@sun.com
- Bump to 0.9.7. Remove upstream patch, rhythmbox-02-audiocd.diff.
- Remove code that deletes the .la/.a files as none are generated.
* Wed Oct 18 2006 - brian.cameron@sun.com
- Add rhythmbox-02-audiocd.diff to fix linking of audiocd plugin
to include nautilus-burn library. Without this, rhythmbox fails
to start.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Remove 'rm' line from %install as the files listed are not installed.
* Mon Oct 02 2006 - damien.carbery@sun.com
- Bump to 0.9.6.
- Remove '-f' from 'rm' calls to force failure when source changes need
attention.
* Fri Sep 15 2006 - brian.cameron@sun.com
- Remove patch 2, no longer needed.
* Wed Jun 21 2006 - brian.cameron@sun.com
- Bump to 0.9.5.
* Mon May 01 2006 - brian.cameron@sun.com
- Add patch to fix compile issue that appears when building with HAL.
* Wed Apr 26 2006 - damien.carbery@sun.com
- Removed upstream patch rhythmbox-01-fixcompile.diff.
* Tue Apr 25 2006 - damien.carbery@sun.com
- Bump to 0.9.4.1.
* Tue Apr 18 2006 - damien.carbery@sun.com
- Bump to 0.9.4.
* Wed Apr 5 2006 - damien.carbery@sun.com
- Remove --with-ipod option as gtkpod is not in build.
* Mon Mar 20 2006 - Brian.Cameron@sun.com
- Created