10139N/A#
10139N/A# spec file for package rhythmbox
10139N/A#
17365N/A# Copyright (c) 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner yippi
10139N/A#
17178N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17178N/A
10139N/AName: rhythmbox
20840N/ALicense: GPL v2, LGPLv2, MIT, BSD
10139N/AGroup: System/GUI/GNOME
20227N/AVersion: 0.13.3
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
10139N/ASummary: Rhythmbox Multimedia Player
19996N/ASource: http://ftp.gnome.org/pub/GNOME/sources/rhythmbox/0.13/%{name}-%{version}.tar.bz2
12773N/A%if %build_l10n
12773N/ASource1: l10n-configure.sh
12773N/A%endif
18739N/A#owner:yippi date:2008-01-16 type:bug bugzilla:509846
12725N/APatch1: rhythmbox-01-playcd.diff
18666N/A#owner:yippi date:2010-04-22 type:branding
20227N/APatch2: rhythmbox-02-gvfs.diff
20227N/A#owner:yippi date:2010-04-22 type:branding
20227N/APatch3: rhythmbox-03-vala.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A%define libgnomeui_version 2.6.0
10139N/A%define gstreamer_version 0.8.1
10139N/A%define gstreamer_plugins_version 0.8.1
10139N/A%define gnome_desktop_version 2.6.1
10139N/A
10139N/ARequires: libgnomeui >= %{libgnomeui_version}
10139N/ARequires: gstreamer >= %{gstreamer_version}
10139N/ARequires: gstreamer-plugins >= %{gstreamer_plugins_version}
10139N/ARequires: gnome-desktop >= %{gnome_desktop_version}
10139N/ARequires: iso-codes
10139N/ABuildRequires: libgnomeui-devel >= %{libgnomeui_version}
10139N/ABuildRequires: gstreamer-devel >= %{gstreamer_version}
10139N/ABuildRequires: gstreamer-plugins-devel >= %{gstreamer_plugins_version}
10139N/ABuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
10139N/A
10139N/A%description
10139N/ARhythmbox is an integrated music management application
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
17473N/A%patch2 -p1
18063N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
17460N/Aexport PYTHON=/usr/bin/python%{default_python_version}
16129N/A
10139N/Aif test "x$x_includes" = "x"; then
10139N/A x_includes="/usr/X11/include"
10139N/Afi
10139N/A
10139N/Aif test "x$x_libraries" = "x"; then
10139N/A x_libraries="/usr/X11/lib"
10139N/Afi
10139N/A
11303N/Aintltoolize --copy --force --automake
12773N/A
12773N/A%if %build_l10n
12773N/Abash -x %SOURCE1 --enable-copyright
12773N/A%endif
12773N/A
10139N/A## FIXME: Swap aclocal dir order to pick up gnome-doc-utils.m4 in 'macros'.
10139N/A##aclocal $ACLOCAL_FLAGS -I ./macros
10139N/Aaclocal -I ./macros $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
12173N/Aexport MOZILLA_PLUGINDIR="%{_libdir}/firefox/plugins"
12173N/A# --with-ipod requires that gtkpod be installed or configure will fail.
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --bindir=%{_bindir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --localstatedir=/var/lib \
13963N/A --disable-browser-plugin \
10139N/A --enable-gstreamer
10139N/A#FIXME -j is breaking the build removing for now.
10139N/A#make -j $CPUS
10139N/Amake
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake -i install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10273N/Arm $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/lib*a
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="totem.schemas totem-video-thumbnail.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_sysconfdir}/gconf/schemas
10139N/A%{_libdir}/*
10139N/A%{_libexecdir}/*
10139N/A%{_datadir}/applications
10139N/A%{_datadir}/gnome/help/totem/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_datadir}/pixmaps/*
10139N/A
10139N/A%changelog
20227N/A* Tue Apr 12 2011 - brian.cameron@oracle.com
20227N/A- Bump to 0.13.3.
19029N/A* Wed Oct 20 2010 - brian.cameron@oracle.com
19029N/A- Bump to 0.13.1.
18666N/A* Thu Apr 22 2010 - brian.cameron@sun.com
18666N/A- Add patch rhythmbox-04-gvfs.diff so that rhythmbox makes use of gvfs when
18666N/A accessing CDDA metadata.
18524N/A* Mon Mar 29 2010 - brian.cameron@sun.com
18524N/A- No longer disable daap plugin since GNOME bugzilla bug #447951 has been
18524N/A fixed.
18430N/A* Thu Mar 11 2010 - christian.kelly@sun.com
18430N/A- Bump to 0.12.7.
18063N/A* Tue Jan 12 2010 - ke.wang@sun.com
18063N/A- Add patch to fix bugzilla #13643 - Rhythmbox: can't enable "context panel"
18063N/A plugin.
17766N/A* Mon Nov 23 2009 - brian.cameron@sun.com
17766N/A- Bump to 0.12.6.
17361N/A* Tue Sep 22 2009 - brian.cameron@sun.com
17361N/A- Bump to 0.12.5.
17106N/A* Tue Aug 25 2009 - brian.cameron@sun.com
17106N/A- Bump to 0.12.4.
16784N/A* Wed Jul 15 2009 - brian.cameron@sun.com
17106N/A- Bump to 0.12.3.
16746N/A* Mon Jul 06 2009 - christian.kelly@sun.com
16746N/A- Bump to 0.12.2.
16440N/A* Tue Apr 28 2009 - brian.cameron@sun.com
16440N/A- Bump to 0.12.1.
16129N/A* Thu Mar 12 2009 - brian.cameron@sun.com
16129N/A- Set PYTHON environment variable in %build section.
15608N/A* Wed Jan 07 2009 - takao.fujiwara@sun.com
15608N/A- Add patch po.diff for zh_CN. SVN revision 6121.
13963N/A* Thu Aug 21 2008 - jijun.yu@sun.com
13963N/A- add --disable-browser-plugin option at configuring.
13524N/A* Wed Jul 09 2008 - damien.carbery@sun.com
13524N/A- Bump to 0.11.6.
12658N/A* Wed Mar 26 2008 - brian.cameron@sun.com
13524N/A- Bump to 0.11.5.
12545N/A* Wed Mar 05 2008 - brian.cameron@sun.com
12545N/A- Patch to fix linking with soup to avoid crash on startup. Fixes #6671873.
12310N/A* Thu Jan 31 2008 - damien.carbery@sun.com
12315N/A- Add patch 05-libsoup to allow building with libsoup 2.3.x. Fixes #509701.
12205N/A* Wed Jan 16 2008 - jerry.tan@sun.com
12205N/A- Add patch for fix the bug that rhythmbox can not play CD. Fixes bugzilla
12205N/A 509846.
12173N/A* Thu Jan 10 2008 - damien.carbery@sun.com
12173N/A- Add patch 03-mozilla-plugindir to allow specifying of mozilla plugin dir via
12173N/A MOZILLA_PLUGINDIR env var. Code copied from totem. Bug 508499.
12091N/A* Sun Dec 23 2007 - damien.carbery@sun.com
12091N/A- Bump to 0.11.4. Remove upstream patch, 03-empty-dialog.
12052N/A* Tue Dec 11 2007 - Irene.huang@sun.com
12052N/A- Added patch rhythmbox-03-empty-dialog.diff
11903N/A* Fri Nov 09 2007 - damien.carbery@sun.com
11903N/A- Bump to 0.11.3.
11303N/A* Wed Sep 26 2007 - brian.cameron@sun.com
11303N/A- Call intltoolize so that the desktop file gets built.
11074N/A* Thu Aug 16 2007 - damien.carbery@sun.com
11074N/A- Bump to 0.11.2.
10889N/A* Mon Jul 02 2007 - damien.carbery@sun.com
10889N/A- Bump to 0.11.1.
10695N/A* Mon May 28 2007 - damien.carbery@sun.com
10695N/A- Bump to 0.11.0.
10690N/A* Mon May 28 2007 - irene.huang@sun.com
10690N/A- change patch -02-null-title to be branding
10686N/A* Fri May 25 2007 - damien.carbery@sun.com
10686N/A- Bump to 0.10.90.
10514N/A* Tue Apr 24 2007 - irene.huang@sun.com
10514N/A- Modify bug number for patch null-title.diff
10391N/A* Mon Apr 02 2007 - damien.carbery@sun.com
10391N/A- Bump to 0.10.0. Remove upstream patch, 03-wronglocking.
10349N/A* Wed Mar 22 2007 - irene.huang@sun.com
10349N/A- add patch rhythmbox-03-wronglocking.diff
10322N/A* Wed Mar 14 2007 - irene.huang@sun.com
10322N/A- add patch rhythmbox-02-null-title.diff.
10273N/A* Mon Mar 12 2007 - laca@sun.com
10273N/A- delete .la files
10139N/A* Wed Feb 28 2007 - halton.huo@sun.com
10139N/A- Remove patch 02-gnome-doc-utils since g-d-u is upgrade to 0.9.x.
10139N/A* Thu Feb 22 2007 - damien.carbery@sun.com
10139N/A- Add patch, 02-gnome-doc-utils, to create gnome-doc-utils.m4 in macros subdir.
10139N/A This is needed because g-d-u is too old (it's blocked waiting for docbook
10139N/A update). The dir order in the aclocal call is also reversed to pick up the
10139N/A new gnome-doc-utils.m4 before the (older) system one. When g-d-u is updated
10139N/A the patch can be removed and aclocal call restored.
10139N/A* Tue Dec 19 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.9.7. Remove upstream patch, rhythmbox-02-audiocd.diff.
10139N/A- Remove code that deletes the .la/.a files as none are generated.
10139N/A* Wed Oct 18 2006 - brian.cameron@sun.com
10139N/A- Add rhythmbox-02-audiocd.diff to fix linking of audiocd plugin
10139N/A to include nautilus-burn library. Without this, rhythmbox fails
10139N/A to start.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Remove 'rm' line from %install as the files listed are not installed.
10139N/A* Mon Oct 02 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.9.6.
10139N/A- Remove '-f' from 'rm' calls to force failure when source changes need
10139N/A attention.
10139N/A* Fri Sep 15 2006 - brian.cameron@sun.com
10139N/A- Remove patch 2, no longer needed.
10139N/A* Wed Jun 21 2006 - brian.cameron@sun.com
10139N/A- Bump to 0.9.5.
10139N/A* Mon May 01 2006 - brian.cameron@sun.com
10139N/A- Add patch to fix compile issue that appears when building with HAL.
10139N/A* Wed Apr 26 2006 - damien.carbery@sun.com
10139N/A- Removed upstream patch rhythmbox-01-fixcompile.diff.
10139N/A* Tue Apr 25 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.9.4.1.
10139N/A* Tue Apr 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 0.9.4.
10139N/A* Wed Apr 5 2006 - damien.carbery@sun.com
10139N/A- Remove --with-ipod option as gtkpod is not in build.
10139N/A* Mon Mar 20 2006 - Brian.Cameron@sun.com
10139N/A- Created