pyorbit.spec revision 17180
1N/A
1N/A# spec file for package pyorbit
1N/A#
1N/A# Copyright 2008 Sun Microsystems, Inc.
1N/A# This file and all modifications and additions to the pristine
1N/A# package are under the same license as the package itself.
1N/A#
1N/A# Owner: laca
1N/A#
1N/A
1N/A%define OSR gnome.org:0
1N/A
1N/AName: pyorbit
1N/ALicense: LGPL
1N/AGroup: System/Library
1N/AVersion: 2.24.0
1N/ARelease: 1
1N/ADistribution: Java Desktop System
1N/AVendor: Sun Microsystems, Inc.
1N/ASummary: Python bindings for ORBit2
1N/ASource: http://ftp.gnome.org/pub/GNOME/sources/pyorbit/2.24/pyorbit-%{version}.tar.bz2
1N/AURL: http://www.gnome.org
1N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
1N/ADocdir: %{_defaultdocdir}/doc
1N/AAutoreqprov: on
1N/A
1N/A%define ORBit2_version 2.10.1
1N/A%{?!python_version:%define python_version 2.4}
1N/A
1N/ARequires: ORBit2 >= %{ORBit2_version}
1N/ARequires: python >= %{python_version}
1N/ABuildRequires: ORBit2-devel >= %{ORBit2_version}
1N/A
1N/A%description
1N/APyORBit is a Python language binding for the ORBit2 CORBA implementation.
1N/AIt aims to take advantage of new features found in ORBit2 to make language
1N/Abindings more efficient.
1N/A
1N/A%package devel
1N/ASummary: Files needed to build applications using the Python bindings for ORBit2
1N/AGroup: Development/Languages
1N/ARequires: %{name} = %{version}
1N/A
1N/A%description devel
1N/AThis package contains files required to build Python applications that need
1N/Ato interoperate with pyorbit.
1N/A
1N/A%prep
1N/A%setup -q -n pyorbit-%{version}
1N/A
1N/A%build
1N/ACFLAGS="$RPM_OPT_FLAGS"
1N/A./configure --prefix=%{_prefix} \
1N/A --sysconfdir=%{_sysconfdir}
1N/Amake \
1N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
1N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
1N/A
1N/A%install
1N/Amake install DESTDIR=$RPM_BUILD_ROOT \
1N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
1N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
1N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
1N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
1N/A
1N/A%clean
1N/Arm -rf $RPM_BUILD_ROOT
1N/A
1N/A%post
1N/A
1N/A%postun
1N/A
1N/A%files
1N/A%defattr(-,root,root)
1N/A%{_libdir}/python?.?/vendor-packages/CORBA.py*
1N/A%{_libdir}/python?.?/vendor-packages/PortableServer.py*
1N/A%{_libdir}/python?.?/vendor-packages/ORBit.so
1N/A
1N/A%doc AUTHORS NEWS README ChangeLog
1N/A
1N/A%files devel
1N/A%defattr(-, root, root)
1N/A%dir %{_includedir}/pyorbit-2
1N/A%{_includedir}/pyorbit-2/pyorbit.h
1N/A%{_libdir}/pkgconfig/*
1N/A
1N/A%changelog
1N/A* Mon Nov 24 2008 - laca@sun.com
1N/A- use %{pythonver} macro to select which version of Python to build with
1N/A* Mon Sep 29 2008 - christian.kelly@sun.com
1N/A- Bump to 2.24.0.
1N/A* Mon May 28 2007 - damien.carbery@sun.com
1N/A- Bump to 2.14.3.
1N/A* Mon Mar 05 2007 - damien.carbery@sun.com
1N/A- Bump to 2.14.2.
1N/A* Fri Jul 21 2006 - damien.carbery@sun.com
1N/A- Bump to 2.14.1.
1N/A* Mon Mar 13 2006 - damien.carbery@sun.com
1N/A- Bump to 2.14.0.
1N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
1N/A- Bump to 2.13.1
1N/A* Thu Oct 27 2005 - laca@sun.com
1N/A- move from site-packages to vendor-packages
1N/A* Fri Aug 12 2005 - rich.burridge@sun.com
1N/A- Initial Sun release
1N/A