15395N/A
10139N/A# spec file for package pyorbit
10139N/A#
15395N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner laca
10139N/A#
17180N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17180N/A
10139N/AName: pyorbit
10139N/ALicense: LGPL
10139N/AGroup: System/Library
14565N/AVersion: 2.24.0
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
10139N/ASummary: Python bindings for ORBit2
14572N/ASource: http://ftp.gnome.org/pub/GNOME/sources/pyorbit/2.24/pyorbit-%{version}.tar.bz2
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/A
10139N/A%define ORBit2_version 2.10.1
19805N/A%{?!python_version:%define python_version 2.6}
10139N/A
10139N/ARequires: ORBit2 >= %{ORBit2_version}
10139N/ARequires: python >= %{python_version}
10139N/ABuildRequires: ORBit2-devel >= %{ORBit2_version}
10139N/A
10139N/A%description
10139N/APyORBit is a Python language binding for the ORBit2 CORBA implementation.
10139N/AIt aims to take advantage of new features found in ORBit2 to make language
10139N/Abindings more efficient.
10139N/A
10139N/A%package devel
10139N/ASummary: Files needed to build applications using the Python bindings for ORBit2
10139N/AGroup: Development/Languages
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AThis package contains files required to build Python applications that need
10139N/Ato interoperate with pyorbit.
10139N/A
10139N/A%prep
10139N/A%setup -q -n pyorbit-%{version}
10139N/A
10139N/A%build
10139N/ACFLAGS="$RPM_OPT_FLAGS"
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
10139N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
10139N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A
10139N/A%postun
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_libdir}/python?.?/vendor-packages/CORBA.py*
10139N/A%{_libdir}/python?.?/vendor-packages/PortableServer.py*
10139N/A%{_libdir}/python?.?/vendor-packages/ORBit.so
10139N/A
10139N/A%doc AUTHORS NEWS README ChangeLog
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%dir %{_includedir}/pyorbit-2
10139N/A%{_includedir}/pyorbit-2/pyorbit.h
10139N/A%{_libdir}/pkgconfig/*
10139N/A
10139N/A%changelog
15395N/A* Mon Nov 24 2008 - laca@sun.com
15395N/A- use %{pythonver} macro to select which version of Python to build with
14565N/A* Mon Sep 29 2008 - christian.kelly@sun.com
14565N/A- Bump to 2.24.0.
10691N/A* Mon May 28 2007 - damien.carbery@sun.com
10691N/A- Bump to 2.14.3.
10181N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10181N/A- Bump to 2.14.2.
10139N/A* Fri Jul 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.1.
10139N/A* Mon Mar 13 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.0.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.13.1
10139N/A* Thu Oct 27 2005 - laca@sun.com
10139N/A- move from site-packages to vendor-packages
10139N/A* Fri Aug 12 2005 - rich.burridge@sun.com
10139N/A- Initial Sun release