pygtk2.spec revision 18616
10139N/A#
10139N/A# spec file for package pygtk2
10139N/A#
18223N/A# Copyright 2010 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A%define owner laca
10139N/A#
17180N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17180N/A
10139N/AName: pygtk2
10139N/ALicense: LGPL
10139N/AGroup: System/Library
18134N/AVersion: 2.17.0
17365N/ARelease: 1
10139N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
10139N/ASummary: Python bindings for GTK+
18222N/ASource: http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.17/pygtk-%{version}.tar.bz2
10139N/A# date:2005-10-27 owner:dcarbery type:feature bugzilla:385131
17378N/APatch1: pygtk2-01-uninstalled-pc.diff
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/A
10139N/A%define libglade_version 2.4.0
10139N/A%define glib2_version 2.6.0
10139N/A%define gtk2_version 2.6.0
10139N/A%define atk_version 1.8.0
10139N/A%define pango_version 1.8.0
15395N/A%{?!python_version:%define python_version 2.4}
10139N/A
10139N/ARequires: libglade >= %{libglade_version}
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: atk >= %{atk_version}
10139N/ARequires: pango >= %{pango_version}
10139N/ARequires: python >= %{python_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libglade-devel >= %{libglade_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: atk-devel >= %{atk_version}
10139N/ABuildRequires: pango-devel >= %{pango_version}
10139N/A
10139N/A%description
10139N/APyGTK is an extension module for python that gives you access to the GTK+
10139N/Awidget set. Just about anything you can write in C with GTK+ you can write
10139N/Ain python with PyGTK (within reason), but with all the benefits of python.
10139N/A
10139N/A%package devel
10139N/ASummary: files needed to build wrappers for GTK+ addon libraries
10139N/AGroup: Development/Languages
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AThis package contains files required to build wrappers for GTK+ addon
10139N/Alibraries so that they interoperate with pygtk.
10139N/A
10139N/A%prep
10139N/A%setup -q -n pygtk-%{version}
10139N/A%patch1 -p1
10139N/A
10139N/A%build
15395N/Anumpy_INCLUDES=`$PYTHON -c "import numpy; print numpy.get_include()"`
15395N/Aexport CFLAGS="$CFLAGS -I$numpy_INCLUDES"
15826N/Aaclocal $ACLOCAL_FLAGS -I ./m4
15826N/Alibtoolize --force
15826N/Aautoheader
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT \
10139N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
10139N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
15395N/Aperl -pi -e s,/site-packages,/vendor-packages, \
15395N/A $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pygtk-2.0.pc
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A
10139N/A%postun
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%doc examples
10139N/A%doc AUTHORS NEWS README MAPPING ChangeLog
10139N/A%{_bindir}/*
10139N/A%{_includedir}/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/pygtk/*
10139N/A%{_datadir}/pygtk/*
10139N/A
10139N/A%changelog -n pygtk2
18134N/A* Mon Jan 18 2010 - christian.kelly@sun.com
18134N/A- Bump to 2.17.0.
17365N/A* Tue Sep 22 2009 - brian.cameron@sun.com
17365N/A- Bump to 2.16.0 and remove pygtk2-02-numpy-r2808.diff patch since it is
17365N/A upstream.
16144N/A* Fri Mar 13 2009 - dave.lin@sun.com
16144N/A- Bump to 2.14.1
15826N/A* Thu Feb 12 2009 - brian.cameron@sun.com
15826N/A- Bump to 2.14.0. Add autotools commands before calling configure, now needed
15826N/A to build.
15395N/A* Mon Nov 24 2008 - laca@sun.com
15395N/A- use %{python_version} macro to select with version of Python to build which
14019N/A* Tue Aug 26 2008 - dave.lin@sun.com
14019N/A- Bump to 2.13.0, update the following patches to fix the hunk failures,
14019N/A pygtk2-01-uninstalled.pc.diff
14019N/A pygtk2-02-numpy-r2808.diff
12133N/A* Fri Jan 04 2008 - damien.carbery@sun.com
12133N/A- Bump to 2.12.1.
11844N/A* Mon Oct 22 2007 - brian.cameron@sun.com
11844N/A- Add patch so pygtk builds against numpy to add numeric processing extension
11844N/A support.
11266N/A* Wed Sep 19 2007 - damien.carbery@sun.com
11266N/A- Bump to 2.12.0.
11121N/A* Mon Aug 27 2007 - damien.carbery@sun.com
11121N/A- Bump to 2.11.0.
10920N/A* Wed Jul 11 2007 - damien.carbery@sun.com
10920N/A- Bump to 2.10.5. Remove obsolete patch, 02-gtk-tooltips.
10851N/A* Fri Jun 22 2007 - damien.carbery@sun.com
10853N/A- Add patch 02-gtk-tooltips to fix bugzilla 449318 (pygtk not in sync with gtk+)
10139N/A* Tue Feb 6 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.10.4.
10139N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10139N/A- Remove patch 02-pygobject-xsl-dir as nothing is built in the docs dir.
10139N/A* Wed Oct 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.3.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.2.
10139N/A* Sat Sep 9 2006 - laca@sun.com
10139N/A- re-enable optimisation as the compiler bug that prevented it has been fixed
10139N/A* Tue Sep 05 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.1.
10139N/A* Mon Aug 28 2006 - harry.lu@sun.com
10139N/A- Bump to 2.9.6 really
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.6.
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.5.
10139N/A* Mon Aug 07 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.4.
10139N/A* Fri Jul 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.3.
10139N/A* Tue Apr 4 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.9.0.
10139N/A* Fri Mar 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.8.5.
10139N/A* Wed Feb 15 2006 - damien.carbery@sun.com
10139N/A- Disable optimizations on x86 to workaround compiler bug 6382078.
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.8.4
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.8.2
10139N/A* Thu Oct 27 2005 - laca@sun.com
10139N/A- add patch uninstalled.pc.diff so the pygtk can be included in the same
10139N/A Solaris pkg as gnome-python
10139N/A- move from site-packages to vendor-packages
10139N/A* Tue Sep 27 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.7.4.
10139N/A* Thu Aug 25 2005 rich.burridge@sun.com
10139N/A- Adjusted the defattr lines to have three parameters, not four.
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.7.3.
10139N/A* Mon Aug 04 2003 - glynn.foster@sun.com
10139N/A- Initial Sun release