pygtk2.spec revision 10851
10139N/A#
10139N/A# spec file for package pygtk2
10139N/A#
15395N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: laca
10139N/A#
17180N/AName: pygtk2
17180N/ALicense: LGPL
17180N/AGroup: System/Library
10139N/AVersion: 2.10.4
10139N/ARelease: 2
10139N/ADistribution: Java Desktop System
16144N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: Python bindings for GTK+
10139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/pygtk/2.10/pygtk-%{version}.tar.bz2
10139N/A# date:2005-10-27 owner:dcarbery type:feature bugzilla:385131
10139N/APatch1: pygtk2-01-uninstalled.pc.diff
15826N/A# date:2007-06-22 owner:dcarbery type:bug bugzilla:450044
10139N/APatch2: pygtk2-02-gtk-tooltips.diff
10139N/AURL: http://www.gnome.org
11844N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
11844N/ADocdir: %{_defaultdocdir}/doc
11845N/AAutoreqprov: on
11844N/A
10139N/A%define libglade_version 2.4.0
10139N/A%define glib2_version 2.6.0
10139N/A%define gtk2_version 2.6.0
10139N/A%define atk_version 1.8.0
10139N/A%define pango_version 1.8.0
10139N/A%define python_version 2.4
10139N/A
10139N/ARequires: libglade >= %{libglade_version}
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ARequires: glib2 >= %{glib2_version}
15395N/ARequires: atk >= %{atk_version}
10139N/ARequires: pango >= %{pango_version}
10139N/ARequires: python >= %{python_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: libglade-devel >= %{libglade_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: atk-devel >= %{atk_version}
10139N/ABuildRequires: pango-devel >= %{pango_version}
10139N/A
10139N/A%description
10139N/APyGTK is an extension module for python that gives you access to the GTK+
10139N/Awidget set. Just about anything you can write in C with GTK+ you can write
10139N/Ain python with PyGTK (within reason), but with all the benefits of python.
10139N/A
10139N/A%package devel
10139N/ASummary: files needed to build wrappers for GTK+ addon libraries
10139N/AGroup: Development/Languages
10139N/ARequires: %{name} = %{version}
10139N/A
10139N/A%description devel
10139N/AThis package contains files required to build wrappers for GTK+ addon
10139N/Alibraries so that they interoperate with pygtk.
10139N/A
10139N/A%prep
10139N/A%setup -q -n pygtk-%{version}
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A
10139N/A%build
10139N/Aautoconf
10139N/A./configure --prefix=%{_prefix} \
16322N/A --sysconfdir=%{_sysconfdir}
10139N/Amake
10139N/A
15395N/A%install
15395N/Amake install DESTDIR=$RPM_BUILD_ROOT \
15826N/A pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
15826N/A pythondir=%{_libdir}/python%{python_version}/vendor-packages
15826N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post
10139N/A
10139N/A%postun
10139N/A
15395N/A%files
15395N/A%defattr(-, root, root)
10139N/A%{_libdir}/python?.?/vendor-packages/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%doc examples
10139N/A%doc AUTHORS NEWS README MAPPING ChangeLog
10139N/A%{_bindir}/*
10139N/A%{_includedir}/*
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_libdir}/pygtk/*
10139N/A%{_datadir}/pygtk/*
10139N/A
10139N/A%changelog -n pygtk2
10139N/A* Fri Jun 22 2007 - damien.carbery@sun.com
10139N/A- Add patch 02-gtk-tooltips to fix bugzilla 450044 (pygtk not in sync with gtk+)
10139N/A* Tue Feb 6 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.10.4.
10139N/A* Thu Dec 14 2006 - damien.carbery@sun.com
10139N/A- Remove patch 02-pygobject-xsl-dir as nothing is built in the docs dir.
10139N/A* Wed Oct 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.3.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.10.2.
10139N/A* Sat Sep 9 2006 - laca@sun.com
10139N/A- re-enable optimisation as the compiler bug that prevented it has been fixed
16144N/A* Tue Sep 05 2006 - damien.carbery@sun.com
16144N/A- Bump to 2.10.1.
15826N/A* Mon Aug 28 2006 - harry.lu@sun.com
15826N/A- Bump to 2.9.6 really
15826N/A* Tue Aug 08 2006 - damien.carbery@sun.com
15395N/A- Bump to 2.9.6.
15395N/A* Tue Aug 08 2006 - damien.carbery@sun.com
14019N/A- Bump to 2.9.5.
14019N/A* Mon Aug 07 2006 - damien.carbery@sun.com
14019N/A- Bump to 2.9.4.
14019N/A* Fri Jul 21 2006 - damien.carbery@sun.com
12133N/A- Bump to 2.9.3.
12133N/A* Tue Apr 4 2006 - damien.carbery@sun.com
11844N/A- Bump to 2.9.0.
11844N/A* Fri Mar 31 2006 - damien.carbery@sun.com
11844N/A- Bump to 2.8.5.
11266N/A* Wed Feb 15 2006 - damien.carbery@sun.com
11266N/A- Disable optimizations on x86 to workaround compiler bug 6382078.
11121N/A* Sun Jan 15 2006 - damien.carbery@sun.com
11121N/A- Bump to 2.8.4
10920N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10920N/A- Bump to 2.8.2
10851N/A* Thu Oct 27 2005 - laca@sun.com
10853N/A- add patch uninstalled.pc.diff so the pygtk can be included in the same
10139N/A Solaris pkg as gnome-python
10139N/A- move from site-packages to vendor-packages
10139N/A* Tue Sep 27 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.7.4.
10139N/A* Thu Aug 25 2005 rich.burridge@sun.com
10139N/A- Adjusted the defattr lines to have three parameters, not four.
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.7.3.
10139N/A* Mon Aug 04 2003 - glynn.foster@sun.com
10139N/A- Initial Sun release
10139N/A