pulseaudio.spec revision 20909
10139N/A#
10139N/A# spec file for package pulseaudio
10139N/A#
12189N/A# Copyright (c) 2011, 2012, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner yippi
10139N/A# bugdb: bugzilla.freedesktop.org
10139N/A#
10139N/A
10139N/A%define src_name pulseaudio
13105N/A%define src_url http://freedesktop.org/software/pulseaudio/releases
10139N/A
10139N/AName: pulseaudio
10139N/ASummary: Sample Rate Converter for audio
10139N/AVersion: 1.1
12571N/ALicense: LGPLv2.1, MIT, Sun Public Domain
12773N/ASource: %{src_url}/%{src_name}-%{version}.tar.gz
12773N/A# date:2011-09-27 owner:yippi type:bug bugid:41537
12773N/APatch1: pulseaudio-01-esdcompat.diff
10139N/A# This patch is very rough, but gets the code to compile.
10139N/A# date:2011-09-27 owner:yippi type:bug bugid:41538
10139N/APatch2: pulseaudio-02-solaris.diff
10139N/A# date:2011-10-05 owner:yippi type:feature bugid:41539
10139N/APatch3: pulseaudio-03-fixlink.diff
10139N/A# /usr/include/sys/stream.h also defines module_info.
10139N/A# date:2011-10-14 owner:yippi type:bug bugid:41823
10139N/APatch4: pulseaudio-04-gconf.diff
10139N/A# date:2011-10-14 owner:yippi type:bug
10139N/APatch5: pulseaudio-05-shm.diff
10139N/A# date:2011-10-31 owner:yippi type:branding
10139N/A# This patch configures PulseAudio for Solaris, by enabling the OSSv4 module
10139N/A# for example, instead of using the SunAudio (solaris) module.
10139N/APatch6: pulseaudio-06-configure.diff
10139N/A# date:2011-11-30 owner:yippi type:bug
10139N/APatch7: pulseaudio-07-sada.diff
10139N/A# date:2011-12-13 owner:yippi type:bug
10139N/APatch8: pulseaudio-08-oss4.diff
10139N/A# date:2011-10-06 owner:yippi type:feature
10139N/APatch9: pulseaudio-09-amd64.diff
10139N/A# date:2012-05-14 owner:yippi type:bug
10139N/APatch10: pulseaudio-10-endian.diff
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/A
10139N/A%prep
10139N/A%setup -q -n pulseaudio-%version
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A%patch8 -p1
10139N/A%patch9 -p1
10139N/A%patch10 -p1
10139N/A
10139N/Aperl -pi -e 's,/bin/sh,/bin/ksh,' src/daemon/esdcompat.in
10139N/A
10139N/A%build
10139N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/A# Build PulseAudio
10139N/A# Need to specify /usr/include/gc as an include directory since the atomic_ops
10139N/A# headers are delivered there on Solaris.
10139N/A#
10139N/Aexport ACLOCAL=aclocal-1.11
10139N/Aexport AUTOMAKE=automake-1.11
10139N/Aexport CPPFLAGS="-xc99"
10139N/Aexport LDFLAGS="$SOLARIS_PULSE_LDFLAGS"
10139N/A
10139N/Aautoreconf --force --install
10139N/A
12773N/A# We build PulseAudio without samplerate or bluez support since these are GPL
12773N/A# and it is not desirable to build PulseAudio with GPL code. Bluez is not
12773N/A# available anyway yet in Solaris, but disabling it just to ensure that it does
12773N/A# not build if bluez is added.
12773N/A#
10139N/A# We must turn off avahi for amd64 since avahi 64-bit is not available.
10139N/A./configure --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --bindir=%{_bindir} \
10139N/A --libdir=%{_libdir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --disable-samplerate \
10139N/A --disable-bluez \
10139N/A $SOLARIS_PULSE_ARGS
10139N/A
10139N/Amake -j$CPUS
10273N/A
10273N/A%install
10273N/Amake install DESTDIR=$RPM_BUILD_ROOT
10273N/A
10139N/Afind $RPM_BUILD_ROOT%{_libdir}/ -name "*.a" -exec rm {} \; -print -o -name "*.la" -exec rm {} \; -print
10139N/A
10139N/A%if %build_l10n
10139N/A%else
10139N/A# REMOVE l10n FILES
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
10139N/A%endif
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%changelog
10139N/A* Tue May 15 2012 - Brian Cameron <brian.cameron@oracle.com>
10139N/A- Add patch pulseaudio-10-endian.diff.
10139N/A* Fri May 04 2012 - Brian Cameron <brian.cameron@oracle.com>
10139N/A- Now set optimization -xO2 on sparc to fix CR #7166622.
10139N/A* Thu Oct 20 2011 - Brian Cameron <brian.cameron@oracle.com>
10139N/A- Bump to 1.1.
13105N/A* Thu Oct 06 2011 - Brian Cameron <brian.cameron@oracle.com>
13105N/A- Split from SUNWpulseaudio.spec and now build amd64. Add the
13035N/A pulseaudio-05-amd64.diff patch.
13035N/A
12988N/A