20843N/A#
20843N/A# spec file for package pulseaudio
20843N/A#
20885N/A# Copyright (c) 2011, 2012, Oracle and/or its affiliates. All rights reserved.
20843N/A# This file and all modifications and additions to the pristine
20843N/A# package are under the same license as the package itself.
20843N/A#
20843N/A%define owner yippi
20843N/A# bugdb: bugzilla.freedesktop.org
20843N/A#
20843N/A
20843N/A%define src_name pulseaudio
20843N/A%define src_url http://freedesktop.org/software/pulseaudio/releases
20843N/A
20843N/AName: pulseaudio
20843N/ASummary: Sample Rate Converter for audio
20862N/AVersion: 1.1
20855N/ALicense: LGPLv2.1, MIT, Sun Public Domain
20843N/ASource: %{src_url}/%{src_name}-%{version}.tar.gz
20843N/A# date:2011-09-27 owner:yippi type:bug bugid:41537
20843N/APatch1: pulseaudio-01-esdcompat.diff
20843N/A# This patch is very rough, but gets the code to compile.
20843N/A# date:2011-09-27 owner:yippi type:bug bugid:41538
20843N/APatch2: pulseaudio-02-solaris.diff
20843N/A# date:2011-10-05 owner:yippi type:feature bugid:41539
20899N/APatch3: pulseaudio-03-fixlink.diff
20852N/A# /usr/include/sys/stream.h also defines module_info.
20852N/A# date:2011-10-14 owner:yippi type:bug bugid:41823
20899N/APatch4: pulseaudio-04-gconf.diff
20867N/A# date:2011-10-14 owner:yippi type:bug
20899N/APatch5: pulseaudio-05-shm.diff
20867N/A# date:2011-10-31 owner:yippi type:branding
20867N/A# This patch configures PulseAudio for Solaris, by enabling the OSSv4 module
20867N/A# for example, instead of using the SunAudio (solaris) module.
20899N/APatch6: pulseaudio-06-configure.diff
20876N/A# date:2011-11-30 owner:yippi type:bug
20899N/APatch7: pulseaudio-07-sada.diff
20918N/A# date:2011-12-13 owner:yippi type:bug bugid:50266
20899N/APatch8: pulseaudio-08-oss4.diff
20899N/A# date:2011-10-06 owner:yippi type:feature
20899N/APatch9: pulseaudio-09-amd64.diff
20918N/A# date:2012-05-14 owner:yippi type:bug bugid:50268
20906N/APatch10: pulseaudio-10-endian.diff
20843N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
20843N/A
20843N/A%prep
20843N/A%setup -q -n pulseaudio-%version
20843N/A%patch1 -p1
20843N/A%patch2 -p1
20899N/A%patch3 -p1
20843N/A%patch4 -p1
20843N/A%patch5 -p1
20852N/A%patch6 -p1
20866N/A%patch7 -p1
20867N/A%patch8 -p1
20876N/A%patch9 -p1
20906N/A%patch10 -p1
20899N/A
20899N/Aperl -pi -e 's,/bin/sh,/bin/ksh,' src/daemon/esdcompat.in
20843N/A
20843N/A%build
20843N/ACPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
20843N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
20843N/A CPUS=1
20843N/Afi
20843N/A
20899N/A# Build PulseAudio
20876N/A# Need to specify /usr/include/gc as an include directory since the atomic_ops
20876N/A# headers are delivered there on Solaris.
20843N/A#
20908N/Aexport ACLOCAL=aclocal-1.11
20908N/Aexport AUTOMAKE=automake-1.11
20899N/Aexport CPPFLAGS="-xc99"
20843N/Aexport LDFLAGS="$SOLARIS_PULSE_LDFLAGS"
20843N/A
20843N/Aautoreconf --force --install
20843N/A
20856N/A# We build PulseAudio without samplerate or bluez support since these are GPL
20856N/A# and it is not desirable to build PulseAudio with GPL code. Bluez is not
20856N/A# available anyway yet in Solaris, but disabling it just to ensure that it does
20856N/A# not build if bluez is added.
20856N/A#
20843N/A# We must turn off avahi for amd64 since avahi 64-bit is not available.
20843N/A./configure --prefix=%{_prefix} \
20843N/A --mandir=%{_mandir} \
20843N/A --bindir=%{_bindir} \
20843N/A --libdir=%{_libdir} \
20843N/A --libexecdir=%{_libexecdir} \
20843N/A --sysconfdir=%{_sysconfdir} \
20852N/A --disable-samplerate \
20856N/A --disable-bluez \
20852N/A $SOLARIS_PULSE_ARGS
20843N/A
20843N/Amake -j$CPUS
20843N/A
20843N/A%install
20843N/Amake install DESTDIR=$RPM_BUILD_ROOT
20843N/A
20843N/Afind $RPM_BUILD_ROOT%{_libdir}/ -name "*.a" -exec rm {} \; -print -o -name "*.la" -exec rm {} \; -print
20843N/A
20843N/A%if %build_l10n
20843N/A%else
20843N/A# REMOVE l10n FILES
20843N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/locale
20843N/A%endif
20843N/A
20843N/A%clean
20843N/Arm -rf $RPM_BUILD_ROOT
20843N/A
20843N/A%changelog
20909N/A* Tue May 15 2012 - Brian Cameron <brian.cameron@oracle.com>
20916N/A- Add patch pulseaudio-10-endian.diff. Fix CR #7168796.
20904N/A* Fri May 04 2012 - Brian Cameron <brian.cameron@oracle.com>
20904N/A- Now set optimization -xO2 on sparc to fix CR #7166622.
20862N/A* Thu Oct 20 2011 - Brian Cameron <brian.cameron@oracle.com>
20862N/A- Bump to 1.1.
20843N/A* Thu Oct 06 2011 - Brian Cameron <brian.cameron@oracle.com>
20843N/A- Split from SUNWpulseaudio.spec and now build amd64. Add the
20843N/A pulseaudio-05-amd64.diff patch.
20843N/A