ptlib.spec revision 20022
17090N/A#
17090N/A# spec file for package ptlib
17090N/A#
17090N/A# Copyright 2007 Sun Microsystems, Inc.
17090N/A# This file and all modifications and additions to the pristine
17090N/A# package are under the same license as the package itself.
17090N/A#
17090N/A%define owner hawklu
17090N/A
17090N/A%define OSR 4034:2.0
17090N/A
17090N/AName: ptlib
17090N/ALicense: MPL
17090N/AGroup: System/Libraries
17090N/AVersion: 2.6.7
17090N/ARelease: 1
17090N/ADistribution: Java Desktop System
17090N/AVendor: Gnome Community
17090N/ASummary: PTLib Class Library
17090N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ptlib/2.6/%{name}-%{version}.tar.gz
17090N/A
17162N/A# owner:davelam date:2006-04-14 type:branding
17090N/A# use cxxflags to fix build problem
17162N/A# updated by elaine
17162N/APatch1: ptlib-01-cxxflags.diff
17162N/A
17171N/A# owner:elaine date:2008-11-11 type:branding
17162N/A# help ekiga to find the ptlib.pc
17175N/APatch3: ptlib-03-no-public-pc.diff
17175N/A
17090N/A# owner:elaine date:2009-07-14 type:bug
17090N/A# sourceforge:2821205
17090N/APatch5: ptlib-05-allocator-and-new.diff
17090N/A
17090N/A# owner:elaine date:2009-07-16 type:bug
17090N/A# bugster:6739228
17090N/APatch8: ptlib-08-enable-mjpeg.diff
17090N/A
17090N/A# owner:brian date:2011-02-13 type:bug
17090N/APatch9: ptlib-10-operator-new-delete.diff
17090N/A
17090N/AURL: http://www.ekiga.org
17090N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17090N/ADocdir: %{_defaultdocdir}/%{name}
17090N/AAutoreqprov: on
17090N/A
17090N/A%description
17090N/APTLib is a moderately large class library that was created many years
17090N/Aago as a method to produce applications that run on both Microsoft
17090N/AWindows and the X Window System.
17090N/A
17090N/A%package devel
17090N/ASummary: Headers for developing programs that will use ptlib
17090N/AGroup: Development/Libraries
17090N/ARequires: %{name}
17090N/A
17090N/A%description devel
17090N/AThis package contains the headers that programmers will need to develop
17090N/Aapplications which will use ptlib.
17090N/A
17090N/A%prep
17090N/A%setup -q -n %{name}-%{version}
17090N/A%patch1 -p1
17090N/A%patch3 -p1
17162N/A%patch5 -p1
17175N/A%patch8 -p1
17090N/A%patch9 -p1
17090N/A
17090N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
17090N/A# ln -s make bin
17090N/A
17090N/A%build
17090N/A%ifos linux
17090N/Aif [ -x /usr/bin/getconf ]; then
17090N/A CPUS=`getconf _NPROCESSORS_ONLN`
17090N/Afi
17090N/A%else
17090N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17090N/A%endif
17090N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17175N/A CPUS=1
17090N/Afi
17090N/A
17090N/Acd plugins
17090N/Aaclocal
17090N/Aautoconf
17090N/Acd ..
17090N/Aaclocal
17175N/Aautoconf
17175N/A
17175N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
17175N/Aexport RPM_OPT_FLAGS=""
17175N/A
17090N/Aexport CFLAGS="%optflags"
17090N/Aexport CXXFLAGS="%cxx_optflags"
17175N/Aexport LDFLAGS="%_ldflags"
17090N/A./configure \
17090N/A --prefix=%{_prefix} \
17090N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
17090N/A --bindir=%{_bindir} \
17090N/A --sysconfdir=%{_sysconfdir} \
17090N/A --mandir=%{_mandir} \
17090N/A --enable-plugins \
17090N/A --enable-resolver \
17090N/A --enable-opal \
17090N/A --disable-openssl \
17090N/A --enable-sunaudio \
17090N/A --enable-url \
17090N/A --enable-http\
17090N/A --enable-httpforms\
17090N/A --enable-httpsvc\
17090N/A --enable-v4l2
17090N/A
17090N/Amake -j $CPUS
17090N/A
17090N/A%install
17090N/Amake install DESTDIR=$RPM_BUILD_ROOT
17090N/A
17090N/A# need the -f to remove write protected file
17090N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
17090N/A
17090N/A%clean
17090N/Arm -rf $RPM_BUILD_ROOT
17090N/A
17090N/A%post -p /sbin/ldconfig
17090N/A%postun -p /sbin/ldconfig
17090N/A
17090N/A%files
17090N/A%defattr (-, root, root)
17090N/A%{ekiga_libdir}/*.so.*
17090N/A
17090N/A%files devel
17090N/A%defattr(-, root, root)
17090N/A%{ekiga_libdir}/*.so
17090N/A
17090N/A%changelog
17090N/A* Fri Jun 04 2010 - brian.lu@sun.com
17090N/A- Bump to 2.6.7
17090N/A* Thu Jan 07 2009 - brian.lu@sun.com
17090N/A- Change the owner to hawklu
17090N/A* Fri Sep 25 2009 - brian.lu@sun.com
17175N/A- Add patch ptlib-09-build-fail.diff
17175N/A- Enable following options
17162N/A --enable-http
17162N/A --enable-httpforms
17090N/A --enable-httpsvc
17090N/A
* Wed Sep 23 2009 - dave.lin@sun.com
- Bump to 2.6.5
* Thu Jul 16 2009 - elaine.xiong@sun.com
- Add a new patch to workaround CR#6739228 then Ekiga sticks to
use MJPEG format instead of YUV format until this bug is
resolved.
* Tue Jul 14 2009 - elaine.xiong@sun.com
- Bump to 2.6.4. Update patches. Enable URL feature.
* Mon Jul 06 2009 - elaine.xiong@sun.com
- Disable openssl explicitly.
* Mon Mar 23 2009 - elaine.xiong@sun.com
- Add a new patch to fix bugzilla#576260.
* Thu Nov 20 2008 - elaine.xiong@sun.com
- Bump to 2.4.2.
* Fri Nov 14 2008 - elaine.xiong@sun.com
- Rename to ptlib.spec from pwlib.spec.
- Bump to 2.4.1. Add new patches and remove obsolete patches.
- update build options for new version.
* Wed Sep 03 2008 - elaine.xiong@sun.com
- Add note to not bump to 2.3.1 as ekiga depends on it.
* Sun Dec 23 2007 - patrick.ale@gmail.com
- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
* Mon Nov 19 2007 - elaine.xiong@sun.com
- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
* Tue Sep 18 2007 - damien.carbery@sun.com
- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
05-medialib. Renumber rest.
* Tue Jun 26 2007 - elaine.xiong@sun.com
- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
Change pwlib-05-medialib.diff status to upstreamable.
* Tue Jun 12 2007 - elaine.xiong@sun.com
- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
* Wed Apr 25 2007 - elaine.xiong@sun.com
- Update owner name for pwlib-05-medialib.diff.
* Thu Apr 19 2007 - elaine.xiong@sun.com
- Bump to 1.10.7.
* Thu Apr 5 2007 - laca@sun.com
- Create