ptlib.spec revision 18826
12258N/A#
12258N/A# spec file for package ptlib
12258N/A#
12412N/A# Copyright 2007 Sun Microsystems, Inc.
12258N/A# This file and all modifications and additions to the pristine
12258N/A# package are under the same license as the package itself.
12258N/A#
13305N/A%define owner hawklu
12258N/A
12258N/A%define OSR 4034:2.0
12258N/A
12258N/AName: ptlib
12258N/ALicense: MPL
14074N/AGroup: System/Libraries
12258N/AVersion: 2.6.7
12258N/ARelease: 1
12258N/ADistribution: Java Desktop System
12258N/AVendor: Gnome Community
12258N/ASummary: PTLib Class Library
12773N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ptlib/2.6/%{name}-%{version}.tar.gz
12773N/A
12773N/A# owner:davelam date:2006-04-14 type:branding
13371N/A# use cxxflags to fix build problem
12258N/A# updated by elaine
14365N/APatch1: ptlib-01-cxxflags.diff
14365N/A
12258N/A# owner:elaine date:2008-11-11 type:branding
12258N/A# help ekiga to find the ptlib.pc
12258N/APatch3: ptlib-03-no-public-pc.diff
12258N/A
12258N/A# owner:elaine date:2009-07-14 type:bug
12258N/A# sourceforge:2821205
12258N/APatch5: ptlib-05-allocator-and-new.diff
12258N/A
12258N/A# owner:elaine date:2009-07-16 type:bug
12258N/A# bugster:6739228
12258N/APatch8: ptlib-08-enable-mjpeg.diff
12258N/A
12258N/AURL: http://www.ekiga.org
12258N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
12258N/ADocdir: %{_defaultdocdir}/%{name}
12258N/AAutoreqprov: on
12258N/A
12258N/A%description
12258N/APTLib is a moderately large class library that was created many years
12258N/Aago as a method to produce applications that run on both Microsoft
12258N/AWindows and the X Window System.
12258N/A
12258N/A%package devel
12258N/ASummary: Headers for developing programs that will use ptlib
12258N/AGroup: Development/Libraries
12258N/ARequires: %{name}
12258N/A
12258N/A%description devel
12258N/AThis package contains the headers that programmers will need to develop
12258N/Aapplications which will use ptlib.
12258N/A
12258N/A%prep
12258N/A%setup -q -n %{name}-%{version}
12258N/A%patch1 -p1
12258N/A%patch3 -p1
12258N/A%patch5 -p1
12258N/A%patch8 -p1
12258N/A
12258N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
12258N/A# ln -s make bin
12258N/A
12258N/A%build
12258N/A%ifos linux
12258N/Aif [ -x /usr/bin/getconf ]; then
12258N/A CPUS=`getconf _NPROCESSORS_ONLN`
12258N/Afi
12258N/A%else
12258N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12258N/A%endif
12258N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
12258N/A CPUS=1
12258N/Afi
12258N/A
12258N/Acd plugins
12258N/Aaclocal
12258N/Aautoconf
12258N/Acd ..
12258N/Aaclocal
12258N/Aautoconf
12258N/A
12258N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
12258N/Aexport RPM_OPT_FLAGS=""
12258N/A
12258N/Aexport CFLAGS="%optflags"
12258N/Aexport CXXFLAGS="%cxx_optflags"
12258N/Aexport LDFLAGS="%_ldflags"
12258N/A./configure \
14365N/A --prefix=%{_prefix} \
12258N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
12258N/A --bindir=%{_bindir} \
12258N/A --sysconfdir=%{_sysconfdir} \
12258N/A --mandir=%{_mandir} \
12258N/A --enable-plugins \
12258N/A --enable-resolver \
12258N/A --enable-opal \
12424N/A --disable-openssl \
12424N/A --enable-sunaudio \
12424N/A --enable-url \
12424N/A --enable-http\
12424N/A --enable-httpforms\
12424N/A --enable-httpsvc\
12424N/A --enable-v4l2
12424N/A
12424N/Amake -j $CPUS
12424N/A
12424N/A%install
12258N/Amake install DESTDIR=$RPM_BUILD_ROOT
12258N/A
12773N/A# need the -f to remove write protected file
12773N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
12773N/A
12773N/A%clean
12773N/Arm -rf $RPM_BUILD_ROOT
12258N/A
12258N/A%post -p /sbin/ldconfig
12258N/A%postun -p /sbin/ldconfig
12258N/A
12258N/A%files
14365N/A%defattr (-, root, root)
14365N/A%{ekiga_libdir}/*.so.*
14365N/A
14365N/A%files devel
14365N/A%defattr(-, root, root)
14365N/A%{ekiga_libdir}/*.so
14365N/A
14365N/A%changelog
14365N/A* Fri Jun 04 2010 - brian.lu@sun.com
14365N/A- Bump to 2.6.7
14365N/A* Thu Jan 07 2009 - brian.lu@sun.com
14365N/A- Change the owner to hawklu
12424N/A* Fri Sep 25 2009 - brian.lu@sun.com
12258N/A- Add patch ptlib-09-build-fail.diff
12258N/A- Enable following options
12258N/A --enable-http
12258N/A --enable-httpforms
12258N/A --enable-httpsvc
12258N/A
12258N/A* Wed Sep 23 2009 - dave.lin@sun.com
12258N/A- Bump to 2.6.5
12258N/A* Thu Jul 16 2009 - elaine.xiong@sun.com
12258N/A- Add a new patch to workaround CR#6739228 then Ekiga sticks to
12258N/A use MJPEG format instead of YUV format until this bug is
12258N/A resolved.
12258N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
12258N/A- Bump to 2.6.4. Update patches. Enable URL feature.
12258N/A* Mon Jul 06 2009 - elaine.xiong@sun.com
12258N/A- Disable openssl explicitly.
12258N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
12258N/A- Add a new patch to fix bugzilla#576260.
12258N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
12258N/A- Bump to 2.4.2.
12258N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
12258N/A- Rename to ptlib.spec from pwlib.spec.
12258N/A- Bump to 2.4.1. Add new patches and remove obsolete patches.
12258N/A- update build options for new version.
12258N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
12258N/A- Add note to not bump to 2.3.1 as ekiga depends on it.
12258N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
12258N/A- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
12258N/A* Mon Nov 19 2007 - elaine.xiong@sun.com
12258N/A- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
12258N/A* Tue Sep 18 2007 - damien.carbery@sun.com
12258N/A- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
12258N/A 05-medialib. Renumber rest.
12258N/A* Tue Jun 26 2007 - elaine.xiong@sun.com
12258N/A- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
12258N/A Change pwlib-05-medialib.diff status to upstreamable.
12258N/A* Tue Jun 12 2007 - elaine.xiong@sun.com
12258N/A- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
12258N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
12258N/A- Update owner name for pwlib-05-medialib.diff.
12258N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
12258N/A- Bump to 1.10.7.
12258N/A* Thu Apr 5 2007 - laca@sun.com
12258N/A- Create
12258N/A