ptlib.spec revision 17396
16828N/A#
16828N/A# spec file for package ptlib
16828N/A#
16828N/A# Copyright 2007 Sun Microsystems, Inc.
16139N/A# This file and all modifications and additions to the pristine
16828N/A# package are under the same license as the package itself.
16828N/A#
16139N/A%define owner elaine
16139N/A#
16828N/AName: ptlib
16828N/ALicense: MPL
16828N/AGroup: System/Libraries
16828N/AVersion: 2.6.5
16828N/ARelease: 1
16828N/ADistribution: Java Desktop System
16828N/AVendor: Sun Microsystems, Inc.
16139N/ASummary: PTLib Class Library
16139N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ptlib/2.6/%{name}-%{version}.tar.gz
16139N/A
16139N/A# owner:davelam date:2006-04-14 type:branding
16828N/A# use cxxflags to fix build problem
16828N/A# updated by elaine
16828N/APatch1: ptlib-01-cxxflags.diff
16139N/A
16139N/A# owner:davelam date:2006-04-14 type:branding
16139N/A# change library naming rule to fit unix style
16139N/APatch2: ptlib-02-libname.diff
16139N/A
16139N/A# owner:elaine date:2008-11-11 type:branding
16139N/A# help ekiga to find the ptlib.pc
16139N/APatch3: ptlib-03-no-public-pc.diff
16139N/A
16139N/A# owner:elaine date:2009-07-14 type:bug
16139N/A# sourceforge:2821205
16139N/APatch5: ptlib-05-allocator-and-new.diff
16139N/A
16139N/A# owner:elaine date:2009-07-16 type:bug
16139N/A# bugster:6739228
16139N/APatch8: ptlib-08-enable-mjpeg.diff
16139N/A
16139N/AURL: http://www.ekiga.org
16139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
16139N/ADocdir: %{_defaultdocdir}/%{name}
16139N/AAutoreqprov: on
16139N/A
16139N/A%description
16139N/APTLib is a moderately large class library that was created many years
16139N/Aago as a method to produce applications that run on both Microsoft
16139N/AWindows and the X Window System.
16139N/A
16139N/A%package devel
16139N/ASummary: Headers for developing programs that will use ptlib
16139N/AGroup: Development/Libraries
16139N/ARequires: %{name}
16139N/A
16139N/A%description devel
16139N/AThis package contains the headers that programmers will need to develop
16139N/Aapplications which will use ptlib.
16139N/A
16139N/A%prep
16139N/A%setup -q -n %{name}-%{version}
16139N/A%patch1 -p1
16139N/A#%patch2 -p1
16139N/A%patch3 -p1
16139N/A%patch5 -p1
16139N/A%patch8 -p1
16139N/A
16139N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
16139N/A# ln -s make bin
16139N/A
16139N/A%build
16139N/A%ifos linux
16139N/Aif [ -x /usr/bin/getconf ]; then
16139N/A CPUS=`getconf _NPROCESSORS_ONLN`
16139N/Afi
16139N/A%else
16139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
16139N/A%endif
16139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
16139N/A CPUS=1
16139N/Afi
16139N/A
16139N/Acd plugins
16139N/Aaclocal
16139N/Aautoconf
16139N/Acd ..
16139N/Aaclocal
16139N/Aautoconf
16139N/A
16139N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
16139N/Aexport RPM_OPT_FLAGS=""
16139N/A
16139N/Aexport CFLAGS="%optflags"
16139N/Aexport CXXFLAGS="%cxx_optflags"
16139N/Aexport LDFLAGS="%_ldflags"
16139N/A./configure \
16139N/A --prefix=%{_prefix} \
16139N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
16139N/A --bindir=%{_bindir} \
16139N/A --sysconfdir=%{_sysconfdir} \
16139N/A --mandir=%{_mandir} \
16139N/A --enable-plugins \
16139N/A --enable-resolver \
16139N/A --enable-opal \
16139N/A --disable-openssl \
16139N/A --enable-sunaudio \
16139N/A --enable-url \
16139N/A --enable-v4l2
16139N/Amake -j $CPUS
16139N/A
16139N/A%install
16139N/Amake install DESTDIR=$RPM_BUILD_ROOT
16139N/A
16139N/A# need the -f to remove write protected file
16139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
16139N/A
16139N/A%clean
16139N/Arm -rf $RPM_BUILD_ROOT
16139N/A
16139N/A%post -p /sbin/ldconfig
16139N/A%postun -p /sbin/ldconfig
16139N/A
16139N/A%files
16139N/A%defattr (-, root, root)
16139N/A%{ekiga_libdir}/*.so.*
16139N/A
16139N/A%files devel
16139N/A%defattr(-, root, root)
16139N/A%{ekiga_libdir}/*.so
16139N/A
16139N/A%changelog
16139N/A* Wed Sep 23 2009 - dave.lin@sun.com
16139N/A- Bump to 2.6.5
16139N/A* Thu Jul 16 2009 - elaine.xiong@sun.com
16139N/A- Add a new patch to workaround CR#6739228 then Ekiga sticks to
16139N/A use MJPEG format instead of YUV format until this bug is
16139N/A resolved.
16139N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
16389N/A- Bump to 2.6.4. Update patches. Enable URL feature.
16389N/A* Mon Jul 06 2009 - elaine.xiong@sun.com
16389N/A- Disable openssl explicitly.
16389N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
16139N/A- Add a new patch to fix bugzilla#576260.
16139N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
16139N/A- Bump to 2.4.2.
16139N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
16139N/A- Rename to ptlib.spec from pwlib.spec.
16139N/A- Bump to 2.4.1. Add new patches and remove obsolete patches.
16139N/A- update build options for new version.
16139N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
16139N/A- Add note to not bump to 2.3.1 as ekiga depends on it.
16139N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
16139N/A- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
16139N/A* Mon Nov 19 2007 - elaine.xiong@sun.com
16139N/A- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
16139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
16139N/A- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
16139N/A 05-medialib. Renumber rest.
16139N/A* Tue Jun 26 2007 - elaine.xiong@sun.com
16139N/A- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
16389N/A Change pwlib-05-medialib.diff status to upstreamable.
16139N/A* Tue Jun 12 2007 - elaine.xiong@sun.com
16139N/A- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
16139N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
16139N/A- Update owner name for pwlib-05-medialib.diff.
16139N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
16139N/A- Bump to 1.10.7.
16139N/A* Thu Apr 5 2007 - laca@sun.com
16139N/A- Create
16139N/A