ptlib.spec revision 16772
17090N/A#
17090N/A# spec file for package ptlib
17090N/A#
18032N/A# Copyright 2007 Sun Microsystems, Inc.
17090N/A# This file and all modifications and additions to the pristine
17090N/A# package are under the same license as the package itself.
17090N/A#
17185N/A# Owner: elaine
17090N/A#
17090N/AName: ptlib
17090N/ALicense: MPL
17090N/AGroup: System/Libraries
17090N/AVersion: 2.6.4
17090N/ARelease: 1
17960N/ADistribution: Java Desktop System
17090N/AVendor: Sun Microsystems, Inc.
17090N/ASummary: PTLib Class Library
17090N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ptlib/2.6/%{name}-%{version}.tar.gz
17090N/A
17090N/A# owner:davelam date:2006-04-14 type:branding
17090N/A# use cxxflags to fix build problem
17960N/A# updated by elaine
18265N/APatch1: ptlib-01-cxxflags.diff
17991N/A
18265N/A# owner:davelam date:2006-04-14 type:branding
18032N/A# change library naming rule to fit unix style
18265N/APatch2: ptlib-02-libname.diff
18032N/A
18265N/A# owner:elaine date:2008-11-11 type:branding
17090N/A# help ekiga to find the ptlib.pc
17090N/APatch3: ptlib-03-no-public-pc.diff
17090N/A
17090N/A# owner:elaine date:2009-07-14 type:bug
17090N/A# sourceforge:2821189
17090N/APatch4: ptlib-04-yuv-convertor.diff
17090N/A
17090N/A# owner:elaine date:2009-07-14 type:bug
17090N/A# sourceforge:2821205
17090N/APatch5: ptlib-05-allocator-and-new.diff
17090N/A
17090N/A# owner:elaine date:2009-07-14 type:bug
17090N/A# sourceforge:2821218
17090N/APatch6: ptlib-06-rm-ldsopts-sunaudio.diff
17090N/A
17090N/A# owner:elaine date:2009-07-13 type:bug
17090N/A# sourceforge:2821247
17090N/APatch7: ptlib-07-v4l2-without-libv4l2.diff
17090N/A
17090N/A
17090N/AURL: http://www.ekiga.org
17090N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17090N/ADocdir: %{_defaultdocdir}/%{name}
17090N/AAutoreqprov: on
17090N/A
17090N/A%description
17090N/APTLib is a moderately large class library that was created many years
17090N/Aago as a method to produce applications that run on both Microsoft
17090N/AWindows and the X Window System.
17090N/A
17090N/A%package devel
17090N/ASummary: Headers for developing programs that will use ptlib
17090N/AGroup: Development/Libraries
17960N/ARequires: %{name}
17991N/A
18032N/A%description devel
18032N/AThis package contains the headers that programmers will need to develop
17090N/Aapplications which will use ptlib.
17090N/A
17090N/A%prep
17090N/A%setup -q -n %{name}-%{version}
17090N/A%patch1 -p1
17090N/A#%patch2 -p1
17090N/A%patch3 -p1
17090N/A%patch4 -p1
17090N/A%patch5 -p1
17090N/A%patch6 -p1
17090N/A%patch7 -p1
17090N/A
17090N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
17090N/A# ln -s make bin
17175N/A
17090N/A%build
18265N/A%ifos linux
18265N/Aif [ -x /usr/bin/getconf ]; then
18265N/A CPUS=`getconf _NPROCESSORS_ONLN`
18265N/Afi
18265N/A%else
18265N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18265N/A%endif
18265N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18265N/A CPUS=1
18265N/Afi
18265N/A
18265N/Acd plugins
17090N/Aaclocal
17090N/Aautoconf
17090N/Acd ..
17090N/Aaclocal
17090N/Aautoconf
17090N/A
17175N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
17175N/Aexport RPM_OPT_FLAGS=""
17175N/A
17175N/Aexport CFLAGS="%optflags"
17175N/Aexport CXXFLAGS="%cxx_optflags"
17090N/Aexport LDFLAGS="%_ldflags"
17090N/A./configure \
18201N/A --prefix=%{_prefix} \
17090N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
17090N/A --bindir=%{_bindir} \
18201N/A --sysconfdir=%{_sysconfdir} \
17090N/A --mandir=%{_mandir} \
17090N/A --enable-plugins \
17090N/A --enable-resolver \
18265N/A --enable-opal \
18265N/A --disable-openssl \
18265N/A --enable-sunaudio \
17090N/A --enable-url \
17090N/A --enable-v4l2
17090N/Amake -j $CPUS
17090N/A
17090N/A%install
17090N/Amake install DESTDIR=$RPM_BUILD_ROOT
17090N/A
17090N/A# need the -f to remove write protected file
17090N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
17090N/A
17090N/A%clean
17090N/Arm -rf $RPM_BUILD_ROOT
17090N/A
17090N/A%post -p /sbin/ldconfig
17090N/A%postun -p /sbin/ldconfig
17090N/A
17090N/A%files
17090N/A%defattr (-, root, root)
17090N/A%{ekiga_libdir}/*.so.*
17090N/A
17090N/A%files devel
17090N/A%defattr(-, root, root)
17090N/A%{ekiga_libdir}/*.so
17090N/A
17090N/A%changelog
17090N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
17090N/A- Bump to 2.6.4. Update patches. Enable URL feature.
17090N/A* Mon Jul 06 2009 - elaine.xiong@sun.com
17090N/A- Disable openssl explicitly.
17090N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
17090N/A- Add a new patch to fix bugzilla#576260.
17090N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
17090N/A- Bump to 2.4.2.
17090N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
17090N/A- Rename to ptlib.spec from pwlib.spec.
17090N/A- Bump to 2.4.1. Add new patches and remove obsolete patches.
17090N/A- update build options for new version.
17090N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
17090N/A- Add note to not bump to 2.3.1 as ekiga depends on it.
18265N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
18265N/A- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
18265N/A* Mon Nov 19 2007 - elaine.xiong@sun.com
18201N/A- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
18201N/A* Tue Sep 18 2007 - damien.carbery@sun.com
18032N/A- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
18032N/A 05-medialib. Renumber rest.
17991N/A* Tue Jun 26 2007 - elaine.xiong@sun.com
17991N/A- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
17991N/A Change pwlib-05-medialib.diff status to upstreamable.
17916N/A* Tue Jun 12 2007 - elaine.xiong@sun.com
17916N/A- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
17232N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
17232N/A- Update owner name for pwlib-05-medialib.diff.
17175N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
17175N/A- Bump to 1.10.7.
17162N/A* Thu Apr 5 2007 - laca@sun.com
17960N/A- Create
17090N/A