ptlib.spec revision 16219
10139N/A#
10139N/A# spec file for package ptlib
10139N/A#
12153N/A# Copyright 2007 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: elaine
10139N/A#
12285N/AName: ptlib
10139N/ALicense: MPL
10139N/AGroup: System/Libraries
10139N/AVersion: 2.4.2
16372N/ARelease: 1
13494N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: PTLib Class Library
10139N/ASource: http://www.ekiga.org/admin/downloads/latest/sources/ekiga_3.0.1/%{name}-%{version}.tar.gz
16167N/A
10139N/A# owner:davelam date:2006-04-14 type:branding
12285N/A# use cxxflags to fix build problem
12773N/A# updated by elaine
12773N/APatch1: ptlib-01-cxxflags.diff
12773N/A
13368N/A# owner:davelam date:2006-04-14 type:branding
16208N/A# change library naming rule to fit unix style
10139N/APatch2: ptlib-02-libname.diff
10737N/A
11419N/A# owner:elaine date:2008-11-11 type:branding
10139N/A# help ekiga to find the ptlib.pc
13494N/APatch3: ptlib-03-no-public-pc.diff
11419N/A
11895N/A# owner:elaine date:2007-06-12 type:bug
13494N/A# bugzilla:445066
10737N/APatch4: ptlib-04-rm-flush.diff
13494N/A
11420N/A# owner:elaine date:2009-03-23 type:bug
11044N/A# bugzilla:576260
13494N/APatch5: ptlib-05-check-null.diff
11420N/A
13368N/AURL: http://www.ekiga.org
16081N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15306N/ADocdir: %{_defaultdocdir}/%{name}
16081N/AAutoreqprov: on
13494N/A
16081N/A%description
14053N/APTLib is a moderately large class library that was created many years
16081N/Aago as a method to produce applications that run on both Microsoft
14281N/AWindows and the X Window System.
14127N/A
16081N/A%package devel
14281N/ASummary: Headers for developing programs that will use ptlib
15825N/AGroup: Development/Libraries
16081N/ARequires: %{name}
15756N/A
16139N/A%description devel
16139N/AThis package contains the headers that programmers will need to develop
16139N/Aapplications which will use ptlib.
16139N/A
16139N/A%prep
16339N/A%setup -q -n %{name}-%{version}
16339N/A%patch1 -p1
10737N/A#%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A
10139N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
10139N/A# ln -s make bin
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
12285N/Acd plugins
12285N/Aaclocal
12285N/Aautoconf
12285N/Acd ..
15811N/Aaclocal
10139N/Aautoconf
13449N/A
13494N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
13449N/Aexport RPM_OPT_FLAGS=""
13494N/A
13855N/Aexport CFLAGS="%optflags"
13489N/Aexport CXXFLAGS="%cxx_optflags"
13830N/Aexport LDFLAGS="%_ldflags"
13581N/A./configure \
13489N/A --prefix=%{_prefix} \
13489N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
14127N/A --bindir=%{_bindir} \
16081N/A --sysconfdir=%{_sysconfdir} \
16081N/A --mandir=%{_mandir} \
16081N/A --enable-plugins \
13830N/A --enable-resolver \
13859N/A --enable-opal \
14281N/A --enable-sunaudio \
16081N/A --enable-v4l2
14281N/Amake -j $CPUS
16081N/A
16081N/A%install
16081N/Amake install DESTDIR=$RPM_BUILD_ROOT
16139N/A
16339N/A# need the -f to remove write protected file
10139N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post -p /sbin/ldconfig
10139N/A%postun -p /sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{ekiga_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{ekiga_libdir}/*.so
10139N/A
10139N/A%changelog
10139N/A* Mon Mar 23 2209 - elaine.xiong@sun.com
10139N/A- Add a new patch to fix bugzilla#576260.
10139N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
10139N/A- Bump to 2.4.2.
10139N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
10139N/A- Rename to ptlib.spec from pwlib.spec.
12773N/A- Bump to 2.4.1. Add new patches and remove obsolete patches.
12773N/A- update build options for new version.
12773N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
12773N/A- Add note to not bump to 2.3.1 as ekiga depends on it.
12773N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
10139N/A- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
10139N/A* Mon Nov 19 2007 - elaine.xiong@sun.com
10139N/A- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
10139N/A* Tue Sep 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
10139N/A 05-medialib. Renumber rest.
10139N/A* Tue Jun 26 2007 - elaine.xiong@sun.com
10139N/A- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
10139N/A Change pwlib-05-medialib.diff status to upstreamable.
10139N/A* Tue Jun 12 2007 - elaine.xiong@sun.com
13830N/A- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
10139N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
10139N/A- Update owner name for pwlib-05-medialib.diff.
10139N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
10139N/A- Bump to 1.10.7.
10139N/A* Thu Apr 5 2007 - laca@sun.com
10139N/A- Create
15811N/A