15354N/A#
15354N/A# spec file for package ptlib
15354N/A#
15354N/A# Copyright 2007 Sun Microsystems, Inc.
15354N/A# This file and all modifications and additions to the pristine
15354N/A# package are under the same license as the package itself.
15354N/A#
18030N/A%define owner hawklu
18644N/A
18644N/A%define OSR 4034:2.0
18644N/A
15354N/AName: ptlib
15354N/ALicense: MPL
15354N/AGroup: System/Libraries
18826N/AVersion: 2.6.7
15354N/ARelease: 1
15354N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
15354N/ASummary: PTLib Class Library
16772N/ASource: http://ftp.gnome.org/pub/GNOME/sources/ptlib/2.6/%{name}-%{version}.tar.gz
15354N/A
15354N/A# owner:davelam date:2006-04-14 type:branding
15354N/A# use cxxflags to fix build problem
15354N/A# updated by elaine
15354N/APatch1: ptlib-01-cxxflags.diff
15354N/A
15354N/A# owner:elaine date:2008-11-11 type:branding
15354N/A# help ekiga to find the ptlib.pc
15354N/APatch3: ptlib-03-no-public-pc.diff
15354N/A
16772N/A# owner:elaine date:2009-07-14 type:bug
16772N/A# sourceforge:2821205
16772N/APatch5: ptlib-05-allocator-and-new.diff
15354N/A
16789N/A# owner:elaine date:2009-07-16 type:bug
16789N/A# bugster:6739228
16789N/APatch8: ptlib-08-enable-mjpeg.diff
16219N/A
20022N/A# owner:brian date:2011-02-13 type:bug
20022N/APatch9: ptlib-10-operator-new-delete.diff
20022N/A
20354N/A# temporary build fix, please find the root cause and fix properly
20354N/APatch11: ptlib-11-tmp-bld.diff
20354N/A
15354N/AURL: http://www.ekiga.org
15354N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15354N/ADocdir: %{_defaultdocdir}/%{name}
15354N/AAutoreqprov: on
15354N/A
15354N/A%description
15354N/APTLib is a moderately large class library that was created many years
15354N/Aago as a method to produce applications that run on both Microsoft
15354N/AWindows and the X Window System.
15354N/A
15354N/A%package devel
15354N/ASummary: Headers for developing programs that will use ptlib
15354N/AGroup: Development/Libraries
15354N/ARequires: %{name}
15354N/A
15354N/A%description devel
15354N/AThis package contains the headers that programmers will need to develop
15354N/Aapplications which will use ptlib.
15354N/A
15354N/A%prep
15354N/A%setup -q -n %{name}-%{version}
15354N/A%patch1 -p1
15354N/A%patch3 -p1
16219N/A%patch5 -p1
16789N/A%patch8 -p1
20022N/A%patch9 -p1
20354N/A%patch11 -p1
15354N/A
15354N/A# symlink the make dir to bin so that ptlib-config is found by ekiga
15354N/A# ln -s make bin
15354N/A
15354N/A%build
15354N/A%ifos linux
15354N/Aif [ -x /usr/bin/getconf ]; then
15354N/A CPUS=`getconf _NPROCESSORS_ONLN`
15354N/Afi
15354N/A%else
15354N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15354N/A%endif
15354N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15354N/A CPUS=1
15354N/Afi
15354N/A
15354N/Acd plugins
15354N/Aaclocal
15354N/Aautoconf
15354N/Acd ..
15354N/Aaclocal
15354N/Aautoconf
15354N/A
15354N/A# unix.mak adds this to a STDCCFLAGS, which is also used for C++ builds
15354N/Aexport RPM_OPT_FLAGS=""
15354N/A
15354N/Aexport CFLAGS="%optflags"
15354N/Aexport CXXFLAGS="%cxx_optflags"
15354N/Aexport LDFLAGS="%_ldflags"
15354N/A./configure \
15354N/A --prefix=%{_prefix} \
15354N/A --libdir=%{?ekiga_libdir}%{?!ekiga_libdir:%{_libdir}} \
15354N/A --bindir=%{_bindir} \
15354N/A --sysconfdir=%{_sysconfdir} \
15354N/A --mandir=%{_mandir} \
15354N/A --enable-plugins \
15354N/A --enable-resolver \
15354N/A --enable-opal \
16748N/A --disable-openssl \
15354N/A --enable-sunaudio \
16772N/A --enable-url \
17406N/A --enable-http\
17406N/A --enable-httpforms\
17406N/A --enable-httpsvc\
15354N/A --enable-v4l2
17406N/A
15354N/Amake -j $CPUS
15354N/A
15354N/A%install
15354N/Amake install DESTDIR=$RPM_BUILD_ROOT
15354N/A
15354N/A# need the -f to remove write protected file
15354N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
15354N/A
15354N/A%clean
15354N/Arm -rf $RPM_BUILD_ROOT
15354N/A
15354N/A%post -p /sbin/ldconfig
15354N/A%postun -p /sbin/ldconfig
15354N/A
15354N/A%files
15354N/A%defattr (-, root, root)
15354N/A%{ekiga_libdir}/*.so.*
15354N/A
15354N/A%files devel
15354N/A%defattr(-, root, root)
15354N/A%{ekiga_libdir}/*.so
15354N/A
15354N/A%changelog
18826N/A* Fri Jun 04 2010 - brian.lu@sun.com
18826N/A- Bump to 2.6.7
18030N/A* Thu Jan 07 2009 - brian.lu@sun.com
18030N/A- Change the owner to hawklu
17406N/A* Fri Sep 25 2009 - brian.lu@sun.com
17406N/A- Add patch ptlib-09-build-fail.diff
17406N/A- Enable following options
17406N/A --enable-http
17406N/A --enable-httpforms
17406N/A --enable-httpsvc
17406N/A
17396N/A* Wed Sep 23 2009 - dave.lin@sun.com
17396N/A- Bump to 2.6.5
16789N/A* Thu Jul 16 2009 - elaine.xiong@sun.com
16789N/A- Add a new patch to workaround CR#6739228 then Ekiga sticks to
16789N/A use MJPEG format instead of YUV format until this bug is
16789N/A resolved.
16772N/A* Tue Jul 14 2009 - elaine.xiong@sun.com
16772N/A- Bump to 2.6.4. Update patches. Enable URL feature.
16748N/A* Mon Jul 06 2009 - elaine.xiong@sun.com
16748N/A- Disable openssl explicitly.
16748N/A* Mon Mar 23 2009 - elaine.xiong@sun.com
16219N/A- Add a new patch to fix bugzilla#576260.
15386N/A* Thu Nov 20 2008 - elaine.xiong@sun.com
15386N/A- Bump to 2.4.2.
15354N/A* Fri Nov 14 2008 - elaine.xiong@sun.com
15354N/A- Rename to ptlib.spec from pwlib.spec.
15354N/A- Bump to 2.4.1. Add new patches and remove obsolete patches.
15354N/A- update build options for new version.
15354N/A* Wed Sep 03 2008 - elaine.xiong@sun.com
15354N/A- Add note to not bump to 2.3.1 as ekiga depends on it.
15354N/A* Sun Dec 23 2007 - patrick.ale@gmail.com
15354N/A- Download tar.gz instead of tar.bz2 . bz2 tarball is N/A
15354N/A* Mon Nov 19 2007 - elaine.xiong@sun.com
15354N/A- Add pwlib-06-idct-mlib.diff to fix bugzilla#498082.
15354N/A* Tue Sep 18 2007 - damien.carbery@sun.com
15354N/A- Bump to 1.10.10. Remove upstream patches, 07-sunaudio-vol-range and
15354N/A 05-medialib. Renumber rest.
15354N/A* Tue Jun 26 2007 - elaine.xiong@sun.com
15354N/A- Add pwlib-07-sunaudio-vol-range.diff to fix bugster6572725.
15354N/A Change pwlib-05-medialib.diff status to upstreamable.
15354N/A* Tue Jun 12 2007 - elaine.xiong@sun.com
15354N/A- Add pwlib-06-rm-flush.diff to fix bugzilla445066.
15354N/A* Wed Apr 25 2007 - elaine.xiong@sun.com
15354N/A- Update owner name for pwlib-05-medialib.diff.
15354N/A* Thu Apr 19 2007 - elaine.xiong@sun.com
15354N/A- Bump to 1.10.7.
15354N/A* Thu Apr 5 2007 - laca@sun.com
15354N/A- Create