10139N/A#
10139N/A# spec file for package pilot-link
10139N/A#
15905N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17255N/A%define owner wangke
10139N/A# bugdb: http://bugs.pilot-link.org/
10139N/A#
17182N/A
17182N/A%define OSR 3221:0.12
17182N/A
10139N/AName: pilot-link
15294N/ALicense: GPL v2 LGPL v2
10139N/AGroup: Applications/Communications
19064N/AVersion: 0.12.5
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
18616N/AVendor: Other
10139N/ASummary: PalmOS link utilities
19064N/ASource: http://downloads.pilot-link.org/%{name}-%{version}.tar.bz2
20307N/A#date:2007-11-23 owner:wangke type:bug bugid:6632092
11977N/APatch1: pilot-link-01-man.diff
20307N/A#date:2008-08-07 owner:wangke type:branding
13809N/APatch2: pilot-link-02-manpages.diff
18958N/A#date:2010-08-02 owner:kewang type:bug
18958N/APatch3: pilot-link-03-libpng.diff
10139N/AURL: http://www.pilot-link.org/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-root
10139N/AAutoreqprov: on
10139N/A
10139N/A%description
10139N/Apilot-link is a suite of tools used to connect your Palm or PalmOS[tm]
10139N/Acompatible handheld with Unix, Linux, and any other POSIX-compatible
10139N/Amachine.
10139N/A
10139N/A%package devel
10139N/ASummary: pilot-link development files.
10139N/AGroup: Development/Libraries
10139N/A
10139N/A%description devel
10139N/Apilot-link is a suite of tools used to connect your Palm or PalmOS[tm]
10139N/Acompatible handheld with Unix, Linux, and any other POSIX-compatible
10139N/Amachine.
10139N/AThis package contains the files required for developing or building
10139N/Aprograms that use pilot-link.
10139N/A
10139N/A%prep
10139N/A%setup -q -n %{name}-%{version}
11977N/A%patch1 -p0
17335N/A%patch2 -p1
18958N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
16876N/A#libtoolize --force
16703N/Aaclocal $ACLOCAL_FLAGS -I m4
16703N/Aautoheader
16703N/Aautomake -a -c -f
16703N/Aautoconf
10139N/ACFLAGS="$RPM_OPT_FLAGS" \
16703N/A./configure --prefix=%{_prefix} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --libdir=%{_libdir} \
10139N/A --includedir=%{_includedir}/libpisock \
10139N/A --enable-libusb \
11977N/A --enable-conduits
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr(-, root, root)
10139N/A%{_datadir}/pilot-link
10139N/A%{_bindir}/*
10139N/A%{_libdir}/*.so.*
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_includedir}/libpisock/*
10139N/A%{_libdir}/pkgconfig
10139N/A%{_datadir}/aclocal
10139N/A
10139N/A%changelog
19064N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19064N/A- Bump to 0.12.5.
17335N/A* Fri Sep 18 2009 - ke.wang@sun.com
17335N/A- Rework patch 02
16703N/A* Mon Jun 22 2009 - halton.huo@sun.com
16703N/A- Use ./configure instead of ./autogen.sh
13809N/A* Thu Aug 07 2008 - jijun.yu@sun.com
13809N/A- Add a manpage patch.
11977N/A* Fri Nov 23 2007 - jijun.yu@sun.com
11977N/A- Add a patch.
11916N/A* Tue Nov 13 2007 - jijun.yu@sun.com
11916N/A- Bump to 0.12.3
10139N/A* Wed Feb 14 2007 - jijun.yu@sun.com
10139N/A- Bump to 0.12.2
10139N/A* Wed Dec 13 2006 - halton.huo@sun.com
10139N/A- Bump to 0.12.1
10139N/A* Wed Mar 8 2006 - <laszlo.peter@sun.com>
10139N/A- Initial version