pidgin.spec revision 13510
10139N/A#
10139N/A# spec file for package pidgin
10139N/A#
12184N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: rickju
10139N/A# old_bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=235&atid=300235&aid=
10139N/A# bugdb: http://developer.pidgin.im/ticket/
10139N/A#
10139N/A%include l10n.inc
10139N/AName: pidgin
10139N/AVersion: 2.4.3
12288N/ARelease: 1
10139N/ALicense: GPL
10139N/AGroup: Applications/Internet
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
12022N/ASummary: Multiprotocol Instant Messaging Client
10139N/ASource: http://easynews.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
10139N/ASource1: gaim-po-sun-%{po_sun_version}.tar.bz2
10139N/A%if %build_l10n
11894N/ASource2: l10n-configure.sh
10139N/A%endif
12184N/A# date:2006-11-16 owner:rickju type:branding bugster:6439103
12184N/APatch1: pidgin-01-gnome-keyring.diff
10139N/A# date:2006-12-20 owner:rickju type:feature bugid:1643233
10139N/APatch2: pidgin-02-uninstalled-pc.diff
10139N/A# date:2007-01-20 owner:rickju type:bug bugster:6508240 state:upstream
10139N/APatch3: pidgin-03-dbus-abort.diff
10139N/A# date:2007-03-07 owner:rickju type:bug bugster:6524856 state:upstream
10139N/APatch4: pidgin-04-jabber-msg.diff
10139N/A# date:2007-04-03 owner:rickju type:bug bugster:6524819 state:upstream
10139N/APatch5: pidgin-05-option-menu.diff
10139N/A# date:2007-08-27 owner:rickju type:bug bugster:6595691 state:upstream
10139N/APatch6: pidgin-06-parse-account.diff
10139N/A# date:2008-06-02 owner:rickju type:branding
10139N/APatch7: pidgin-07-runpath.diff
10139N/AURL: http://www.pidgin.im
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/pidgin
10139N/AAutoreqprov: on
10139N/APrereq: sed
10139N/A
10139N/ABuildRequires: gtk2-devel
10139N/ABuildRequires: glib2-devel
10139N/A
10139N/A%description
10139N/AGaim allows you to chat over the Internet using a variety of
10139N/Amessaging protocols, including AIM, ICQ, IRC, Yahoo!,
10139N/AMSN Messenger and Jabber.
10139N/AThese protocols are implemented using a modular, easy to use
10139N/Adesign.
10139N/A
10139N/A%package devel
10139N/ASummary: Multiprotocol Instant Messaging Client
10139N/AGroup: System/GUI/GNOME
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
12184N/A
10139N/A%description devel
10139N/AGaim allows you to chat over the Internet using a variety of
10504N/Amessaging protocols, including AIM, ICQ, IRC, Yahoo!,
10139N/AMSN Messenger and Jabber.
10139N/AThese protocols are implemented using a modular, easy to use
10139N/Adesign.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10139N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
10139N/Afor po in po/*.po; do
10139N/A dos2unix -ascii $po $po
11439N/Adone
10139N/A
10139N/A%patch1 -p1
11149N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A
10139N/A%build
10139N/A%{!?perl_vendorarch: %define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)}
12043N/A
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
12184N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
12184N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aglib-gettextize -f
10139N/Alibtoolize --force
10139N/Aintltoolize --force --copy --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE2 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
12184N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -DG_IMPLEMENT_INLINES -DG_HAVE_ISO_VARARGS" \
10139N/ALD_LIBRARY_PATH="%{_libdir}:$LD_LIBRARY_PATH"
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --sysconfdir=%{_sysconfdir} \
12288N/A --disable-binreloc \
12288N/A --enable-gnutls=no \
12184N/A --with-nss-includes=/usr/include/mps \
12184N/A --with-nss-libs=/usr/lib/mps \
12043N/A --with-nspr-includes=/usr/include/mps \
12043N/A --with-nspr-libs=/usr/lib/mps \
12022N/A --enable-gnome-keyring \
12022N/A --enable-gevolution \
11989N/A --enable-cap \
11989N/A --disable-gtkspell \
11960N/A --disable-meanwhile \
11960N/A --disable-nm \
11416N/A --disable-consoleui \
11416N/A --with-perl-lib=vendor
11253N/A
11253N/Amake -j $CPUS
11149N/A
11149N/A%install
11123N/Amake DESTDIR=$RPM_BUILD_ROOT install \
11123N/A SITEPREFIX=/dummy VENDORPREFIX=/dummy PERLPREFIX=/dummy
10979N/Arm -Rf $RPM_BUILD_ROOT/dummy
10979N/Arm -rf $RPM_BUILD_ROOT%{_bindir}/purple-client-example
10917N/Arm $RPM_BUILD_ROOT%{_libdir}/pidgin/*.la
10917N/Arm $RPM_BUILD_ROOT%{_libdir}/purple-2/*.la
10817N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10817N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/pixmaps/purple/buddy_icons/qq
10642N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/purple/ca-certs
10642N/Arm -rf $RPM_BUILD_ROOT%{_datadir}/purple
10611N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/purple-2/libqq.so
10611N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/purple-2/libsimple.so
10504N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/purple-2/libzephyr.so
10504N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/purple-2/libmyspace.so
10474N/Arm -rf $RPM_BUILD_ROOT%{_libdir}/purple-2/dbus-example.so
10474N/A
10285N/A
10285N/A%files
10139N/A%defattr(-, root, root)
10139N/A%doc doc/the_penguin.txt doc/CREDITS NEWS COPYING AUTHORS
10139N/A%doc doc/FAQ README ChangeLog HACKING
10139N/A%attr(755, root, root) %{_libdir}/pidgin/*.so
10139N/A%{_bindir}/*
10139N/A%{_libdir}/lib*.so.*
10139N/A%{_datadir}/locale/*/*/*
10139N/A%{_datadir}/pixmaps/*
10139N/A%{_datadir}/sounds/pidgin/*
10139N/A%{_datadir}/icons/*
10139N/A%{_datadir}/applications/*
10139N/A%{_datadir}/dbus-1
10139N/A%attr(755, root, root) %{perl_vendorarch}/Pidgin.pm
10139N/A%attr(755, root, root) %{perl_vendorarch}/Purple.pm
10139N/A%attr(755, root, root) %{perl_vendorarch}/auto/Pidgin
10139N/A%attr(755, root, root) %{perl_vendorarch}/auto/Purple
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_includedir}/pidgin/*
10139N/A%{_datadir}/aclocal
10139N/A
10139N/A%clean
10139N/Arm -r $RPM_BUILD_ROOT
10139N/A
10139N/A%changelog
10139N/A* Mon Jul 07 2008 - damien.carbery@sun.com
10139N/A- Bump to 2.4.3.
10139N/A
10139N/A* Mon Jun 23 2008 - damien.carbery@sun.com
10139N/A- Disable consoleui support - we don't have ncurses on the build machines. If a
10139N/A system does have ncurses then additional files will be delivered and appear
10139N/A to break the build. Adding --disable-consoleui to configure prevents this.
10139N/A
10139N/A* Thu Jun 02 2008 - rick.ju@sun.com
10139N/A- Add a runpath fix for nss library
10139N/A
10139N/A* Thu May 29 2008 - rick.ju@sun.com
10139N/A- fix the cap.so and gevolution.so missing issue
10139N/A
* Thu May 22 2008 - rick.ju@sun.com
bump to 2.4.2
* Fri Mar 07 2008 - rick.ju@sun.com
Enable dbus, Avahi and Gadu-gadu.
* Thu Mar 06 2008 - rick.ju@sun.com
bump to pidgin 2.4.0
* Fri Jan 04 2008 - rick.ju@sun.com
bump to pidgin 2.3.1
* Tue Dec 06 2007 - rick.ju@sun.com
bump to pidgin 2.3.0
* Tue Nov 06 2007 - rick.ju@sun.com
bump to pidgin 2.2.2
* Fri Nov 02 2007 - rick.ju@sun.com
remove libbonjour.so
* Thu Aug 30 2007 - damien.carbery@sun.com
- Add intltoolize call to update intltool scripts.
* Mon Aug 27 2007 - rick.ju@sun.com
- Add pidgin-06-parse-account.diff to fix bug bugster:6595691
gaim crash on startup when parsing the account.
* Wed Aug 22 2007 - damien.carbery@sun.com
- Bump to 2.1.1.
* Thu Aug 02 2007 - rick.ju@sun.com
- bump to 2.1.0
* Tue Jul 10 2007 - rick.ju@sun.com
- remove the line removing libxmpp.so
* Thu Jun 07 2007 - damien.carbery@sun.com
- Add patch, 10-remove-evo-header, to remove reference to obsolete evolution
header file.
* Tue May 30 2007 - rick.ju@sun.com
- bump to pidgin 2.0.1
* Tue May 03 2007 - rick.ju@sun.com
- Reopen configure arguments for nss/nspr include/lib
- Added patch 14-enable-nss.diff
* Tue Apr 28 2007 - rick.ju@sun.com
- Added configure arguments for nss/nspr include/lib
* Tue Apr 03 2007 - rick.ju@sun.com
- Added 13-option-menu.diff for bug#6524819
* Wed Feb 21 2007 - takao.fujiwara@sun.com
- Added l10n tarball. Fixes CR 6463000.
* Thu Feb 8 2007 - damien.carbery@sun.com
- Renumber 'Patch??:' lines to be sequential after Patch3 removal.
* Thu Jan 25 2007 - alvaro.lopez@sun.com
- gaim-03-long-preferences.diff removed. It's no longer needed.
* Thu Jan 25 2007 - rick.ju@sun.com
- Bump to beta6. Add patches 11-return-void and 12-static-prpls. Rename patch
11-dbus-abort to 10-dbus-abort.
* Sun Jan 21 2007 - rick.ju@sun.com
- Add patch 11-dbus-abort to fix #6508240.
* Thu Jan 18 2007 - damien.carbery@sun.com
- Remove the code from %install that deletes $RPM_BUILD_ROOT as it trashes the
'make install' of gaim-otr when part of SUNWgnome-im-client build.
* Wed Jan 17 2007 - damien.carbery@sun.com
- Remove unneded patch, 02-perl-common-argc, renumber remainder.
* Thu Nov 30 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta5.
* Thu Nov 30 2006 - rick.ju@sun.com
- Add configure argument enable-gnome-keying to fix #6439103.
* Thu Nov 13 2006 - rick.ju@sun.com
- Add patches 08-gnome-keyring and 09-gtk-file-chooser; add
--enable-gnome-keyring to configure and
* Mon Nov 13 2006 - patrick.wade@sun.com
- Add patch, 07-protocol-mnemonics, to add protocol mnemonics, CR#6477194
* Mon Nov 06 2006 - rick.ju@sun.com
- Remove upstream patch 05-msn-crash. Rename rest.
* Fri Nov 03 2006 - damien.carbery@sun.com
- Specify sysconfdir in configure call as gaim.schemas is installed there.
* Thu Nov 02 2006 - damien.carbery@sun.com
- Add patch, 07-gtk-func-def, to fix inconsistency between a function
declaration and definition. Submitted upstream via sourceforge.net bug db.
* Thu Nov 02 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta4. Remove upstream patch, 05-nopyextension, and obsolete
patch, 06-psychic, (referenced code no longer in module). Rename remainder.
* Mon Oct 16 2006 - damien.carbery@sun.com
- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
module source will be seen as a build error and action can be taken.
* Mon Aug 28 2005 - rick.ju@sun.com
- Bump to 2.0.0beta3.1
* Mon Aug 28 2006 - patrick.wade@sun.com
- Add patch gaim-12-proxy_mnemonics.diff to add new mnemonics, CR#6442067
* Wed May 10 2006 - brian.cameron@sun.com
- Add patch gaim-11-nopyextensions.diff to remove .py extensions from
executables and move gaim-notifications-example to
/usr/share/doc/gaim/examples since it is a system-independant demo
program.
* Wed Feb 15 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta2. Remove obsolete patch, 11-forte.
* Wed Jan 18 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta1, remove obsolete patches (08-sound_errors and
11-g11n-enable-im). Add patches 08-libgaimperl and 11-forte.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 1.5.0.
* Thu Jun 10 2005 - glynn.foster@sun.com
- Bump to 1.3.0
* Thu Mar 24 2005 - alvaro.lopez@sun.com
- Rev to 1.3.0. Patches #9, 12, 17, 18 and 19 removed.
* Thu Mar 24 2005 - vijaykumar.patwari@wipro.com
- Added gaim-19-yahoo-privacy-fix.diff patch, fixes yahoo
privacy issue.
* Tue Jan 25 2005 - damien.carbery@sun.com
- Update docs with Linux specific tarball from maeve.anslow@sun.com.
* Tue Jan 18 2005 - glynn.foster@sun.com
- New backported patch to fix msn messenger. Fixes #6217610.
* Wed Jan 12 2005 - takao.fujiwara@sun.com
- Added gaim-15-g11n-enable-im.diff to enable Ja input method. Fix 4990149.
- Added gaim-16-g11n-filename.diff to get/put localized filenames. Fixes 6216501
* Tue Jan 11 2005 - alvaro.lopez@sun.com
- Added patch #15. Fixes #6204972
* Thu Dec 16 2004 - kazuhiko.maekawa@sun.com
- Update l10n help tarball to use linux version
* Wed Dec 8 2004 - damien.carbery@sun.com
- Update docs tarball from maeve.anslow@sun.com.
* Fri Nov 12 2004 - kazuhiko.maekawa@sun.com
- Added workaround fix for 6193354
* Fri Oct 29 2004 - vijaykumar.patwari@wipro.com
- Fixes msn security issues.
* Thu Oct 21 2004 - alvaro.lopez@sun.com
- Added patch #11. Fixes #5101982
* Mon Sep 06 2004 - matt.keenan@sun.com
- Add javahelp-convert for new docs
* Fri Sep 03 2004 - damien.carbery@sun.com
- Add docs tarball from patrick.costello@sun.com.
- Add patch to incorporate docs tarball.
* Mon Aug 30 2004 - glynn.foster@sun.com
- Bump to 0.82.1
* Tue Aug 24 2004 - laszlo.kovacs@sun.com
- mandir/man3 added to base package
* Tue Aug 24 2004 - glynn.foster@sun.com
- Bump to 0.81 and create a devel package.
* Fri Aug 20 2004 - damien.carbery@sun.com
- Comment out removal of man3 files - these don't exist on Solaris.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gaim-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed Jun 09 2004 - kaushal.kumar@wipro.com
- Modified patch gaim-02-remove-unwanted-protocols.diff to remove the
unnecessary protocols from the build.
* Fri Jun 04 2004 - arvind.samptur@wipro.com
- Add patch gaim-10-iconv-open.diff. Fixes the irc protocol on
Solaris
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gaim-l10n-po-1.1.tar.bz2
* Sun May 02 2004 - laca@sun.com
- add patch #9 (void-return) for a void function returning a value
* Tue Apr 27 2004 - vijaykumar.patwari@wipro.com
- Bumped new tarball 0.76 version and updated spec file
accordingly.
* Mon Apr 05 2004 - niall.power@sun.com
- ifos'ify glib-gettexttize, to stop nameless .mo files being
generated on cinnabar/linux.
* Sun Apr 04 2004 - laca@sun.com
- add glib-gettextize to make the build work with Solaris msgfmt
* Wed Mar 31 2004 - brian.cameron@sun.com
- replace tar jxf with the more solaris friendly
bzcat piped through tar
* Mon Mar 29 2004 - damien.donlon@sun.com
- Adding gaim-l10n-po-1.0.tar.bz2 l10n content
* Mon Mar 08 2004 - Vijaykumar.patwari@wipro.com
- Fixes all vulnerabilities reproted in the bug report.
* Thu Mar 04 2004 - takao.fujiwara@sun.com
- Removed gaim-01-menu-entry.diff
- Added gaim-01-g11n-menu-entry.diff to fix 4957377
- Added gaim-08-g11n-potfiles.diff
* Wed Mar 03 2004 - <laca@sun.com>
- fix Solaris build by forcing the use of the glib gettext test macro
* Fri Feb 20 2004 - <matt.keenan@sun.com>
- Distro to Cinnabar, fixed patch gaim-06-po-mkinstalldirs.diff
* Thu Feb 19 2004 - <damien.carbery@sun.com>
- Update to 0.75.
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the menu
patch.
* Mon Oct 20 2003 - <stephen.browne@sun.com>
- update to 0.70 and removed potfiles patch
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.a, *.la
* Tue Aug 05 2003 michael.twomey@sun.com
- Added POTFILES.in patch again (updated)
* Fri Aug 01 2003 Stephen.Browne@sun.com
- removed unwanted protocols
* Fri Aug 01 2003 Stephen.Browne@sun.com
- why was there no changelog for this before? well
new tarball, bumped release, reset release, added lbgaim-remote.so.*