pidgin.spec revision 10710
18861N/A#
18861N/A# spec file for package pidgin
18861N/A#
18861N/A# Copyright (c) 2005 Sun Microsystems, Inc.
18861N/A# This file and all modifications and additions to the pristine
18861N/A# package are under the same license as the package itself.
18861N/A#
18861N/A# Owner: rickju
18861N/A# bugdb: http://sourceforge.net/tracker/index.php?func=detail&group_id=235&atid=300235&aid=
18861N/A#
18861N/A%include l10n.inc
18861N/AName: pidgin
18861N/AVersion: 2.0.1
18861N/ARelease: 1
18861N/ALicense: GPL
18861N/AGroup: Applications/Internet
18861N/ADistribution: Java Desktop System
18861N/AVendor: Sun Microsystems, Inc.
18861N/ASummary: Multiprotocol Instant Messaging Client
18861N/ASource: http://heanet.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
18861N/ASource1: gaim-po-sun-%{po_sun_version}.tar.bz2
18861N/A# date:2006-08-28 owner:pwade type:bug bugster:6442067
18970N/APatch1: pidgin-01-proxy_mnemotics.diff
20818N/A# date:2006-11-02 owner:dcarbery type:bug bugid:1589599
18861N/APatch2: pidgin-02-gtk-func-def.diff
18861N/A# date:2006-11-13 owner:pwade type:bug bugster:6477194
18861N/APatch3: pidgin-03-protocol-mnemonics.diff
18861N/A# date:2006-11-16 owner:rickju type:branding bugster:6439103
18861N/APatch4: pidgin-04-gnome-keyring.diff
18861N/A# date:2006-12-20 owner:rickju type:feature bugid:1643233
18861N/APatch5: pidgin-05-uninstalled-pc.diff
19142N/A# date:2007-01-20 owner:rickju type:bug bugid:6508240
19997N/APatch6: pidgin-06-dbus-abort.diff
18861N/A# date:2007-03-07 owner:rickju type:bug bugster:6524856 state:upstream
18861N/APatch7: pidgin-07-jabber-msg.diff
18861N/A# date:2007-04-03 owner:rickju type:bug bugser:6524819 state:upstream
18861N/APatch8: pidgin-08-option-menu.diff
18861N/A# date:2007-05-03 owner:rickju type:branding bugser:6437319
18861N/APatch9: pidgin-09-enable-nss.diff
18861N/AURL: http://www.pidgin.im
18861N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
18861N/ADocdir: %{_defaultdocdir}/pidgin
18861N/AAutoreqprov: on
18861N/A
18861N/ABuildRequires: gtk2-devel
18861N/ABuildRequires: glib2-devel
18861N/A
19142N/A%description
18861N/AGaim allows you to chat over the Internet using a variety of
18861N/Amessaging protocols, including AIM, ICQ, IRC, Yahoo!,
18861N/AMSN Messenger and Jabber.
19126N/AThese protocols are implemented using a modular, easy to use
18861N/Adesign.
19126N/A
18861N/A%package devel
19142N/ASummary: Multiprotocol Instant Messaging Client
18861N/AGroup: System/GUI/GNOME
18861N/AAutoreqprov: on
18861N/ARequires: %name = %version
18861N/A
18861N/A%description devel
18861N/AGaim allows you to chat over the Internet using a variety of
18861N/Amessaging protocols, including AIM, ICQ, IRC, Yahoo!,
18861N/AMSN Messenger and Jabber.
18861N/AThese protocols are implemented using a modular, easy to use
18861N/Adesign.
18861N/A
18861N/A%prep
18861N/A%setup -q
18861N/A%if %build_l10n
18861N/Abzcat %SOURCE1 | tar xf -
18861N/Acd po-sun; make; cd ..
18861N/A%endif
18861N/A%patch1 -p1
18861N/A%patch2 -p1
19898N/A%patch3 -p1
19898N/A%patch4 -p1
19911N/A%patch5 -p1
19911N/A%patch6 -p1
18880N/A%patch7 -p1
18861N/A%patch8 -p1
18861N/A%patch9 -p1
18861N/A
18861N/A%build
18861N/A%ifos linux
18861N/Aif [ -x /usr/bin/getconf ]; then
18861N/A CPUS=`getconf _NPROCESSORS_ONLN`
18861N/Afi
18861N/A%else
18861N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
18861N/A%endif
18861N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
18861N/A CPUS=1
18861N/Afi
18861N/A
18861N/Aglib-gettextize -f
18861N/Alibtoolize --force
18861N/Aaclocal $ACLOCAL_FLAGS -I .
18861N/Aautoheader
18861N/Aautomake -a -c -f
19142N/Aautoconf
19142N/A
19142N/ACFLAGS="$RPM_OPT_FLAGS -DG_IMPLEMENT_INLINES -DG_HAVE_ISO_VARARGS" \
18861N/ALD_LIBRARY_PATH="%{_libdir}:$LD_LIBRARY_PATH"
18861N/A./configure \
18861N/A --prefix=%{_prefix} \
18861N/A --mandir=%{_mandir} \
18861N/A --sysconfdir=%{_sysconfdir} \
18861N/A --disable-binreloc \
18861N/A --disable-dbus \
18861N/A --enable-gnutls=no \
18861N/A --with-nss-includes=/usr/include/mps \
18861N/A --with-nss-libs=/usr/lib/mps \
18861N/A --with-nspr-includes=/usr/include/mps \
18861N/A --with-nspr-libs=/usr/lib/mps \
18861N/A --enable-gnome-keyring
18861N/A
18861N/Amake -j $CPUS
18861N/A
18861N/A%install
18861N/Amake DESTDIR=$RPM_BUILD_ROOT install \
18861N/A SITEPREFIX=/dummy VENDORPREFIX=/dummy PERLPREFIX=/dummy
18861N/Arm -Rf $RPM_BUILD_ROOT%{_libdir}/perl5
18861N/Arm -Rf $RPM_BUILD_ROOT/dummy
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/pidgin/*.la
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/purple-2/*.la
18861N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
18861N/Arm -rf %PM_BUILD_ROOT%{_libdir}/purple-2/libgg.so
18861N/Arm -rf %PM_BUILD_ROOT%{_libdir}/purple-2/libxmpp.so
18861N/Arm -rf %PM_BUILD_ROOT%{_libdir}/purple-2/libqq.so
18861N/Arm -rf %PM_BUILD_ROOT%{_libdir}/purple-2/libsimple.so
18861N/Arm -rf %PM_BUILD_ROOT%{_libdir}/purple-2/libzephyr.so
18861N/A
18861N/A%files
18861N/A%defattr(-, root, root)
18861N/A%doc doc/the_penguin.txt doc/CREDITS NEWS COPYING AUTHORS
18861N/A%doc doc/FAQ README ChangeLog HACKING
18861N/A%attr(755, root, root) %{_libdir}/pidgin/*.so
18861N/A%{_bindir}/*
18861N/A%{_mandir}/man1/*
18861N/A%{_libdir}/lib*.so.*
18861N/A%{_datadir}/locale/*/*/*
18861N/A%{_datadir}/pixmaps/*
18861N/A%{_datadir}/sounds/pidgin/*
18861N/A%{_datadir}/icons/*
18861N/A%{_datadir}/applications/*
18861N/A%{_datadir}/dbus-1
18861N/A
18861N/A%files devel
18861N/A%defattr(-, root, root)
18861N/A%{_libdir}/pkgconfig/*
18861N/A%{_includedir}/pidgin/*
18880N/A%{_datadir}/aclocal
18880N/A
19898N/A%clean
19911N/Arm -r $RPM_BUILD_ROOT
19898N/A
19911N/A%changelog
20818N/A* Tue May 30 2007 - rick.ju@sun.com
20818N/A- bump to pidgin 2.0.1
20818N/A
20818N/A* Tue May 03 2007 - rick.ju@sun.com
20818N/A- Reopen configure arguments for nss/nspr include/lib
20818N/A- Added patch 14-enable-nss.diff
20818N/A
20818N/A* Tue Apr 28 2007 - rick.ju@sun.com
20818N/A- Added configure arguments for nss/nspr include/lib
18861N/A
18861N/A* Tue Apr 03 2007 - rick.ju@sun.com
18861N/A- Added 13-option-menu.diff for bug#6524819
18861N/A
18861N/A* Wed Feb 21 2007 - takao.fujiwara@sun.com
18861N/A- Added l10n tarball. Fixes CR 6463000.
18861N/A
18861N/A* Thu Feb 8 2007 - damien.carbery@sun.com
18861N/A- Renumber 'Patch??:' lines to be sequential after Patch3 removal.
18861N/A
18861N/A* Thu Jan 25 2007 - alvaro.lopez@sun.com
18861N/A- gaim-03-long-preferences.diff removed. It's no longer needed.
20818N/A
20818N/A* Thu Jan 25 2007 - rick.ju@sun.com
18970N/A- Bump to beta6. Add patches 11-return-void and 12-static-prpls. Rename patch
18970N/A 11-dbus-abort to 10-dbus-abort.
18954N/A
18954N/A* Sun Jan 21 2007 - rick.ju@sun.com
18954N/A- Add patch 11-dbus-abort to fix #6508240.
18880N/A
18880N/A* Thu Jan 18 2007 - damien.carbery@sun.com
18880N/A- Remove the code from %install that deletes $RPM_BUILD_ROOT as it trashes the
18861N/A 'make install' of gaim-otr when part of SUNWgnome-im-client build.
18861N/A
18861N/A* Wed Jan 17 2007 - damien.carbery@sun.com
18861N/A- Remove unneded patch, 02-perl-common-argc, renumber remainder.
18861N/A
18861N/A* Thu Nov 30 2006 - damien.carbery@sun.com
18861N/A- Bump to 2.0.0beta5.
18861N/A
18861N/A* Thu Nov 30 2006 - rick.ju@sun.com
18861N/A- Add configure argument enable-gnome-keying to fix #6439103.
18861N/A
18861N/A* Thu Nov 13 2006 - rick.ju@sun.com
18861N/A- Add patches 08-gnome-keyring and 09-gtk-file-chooser; add
18861N/A --enable-gnome-keyring to configure and
18861N/A
18861N/A* Mon Nov 13 2006 - patrick.wade@sun.com
18861N/A- Add patch, 07-protocol-mnemonics, to add protocol mnemonics, CR#6477194
18861N/A
18861N/A* Mon Nov 06 2006 - rick.ju@sun.com
18861N/A- Remove upstream patch 05-msn-crash. Rename rest.
18861N/A
18861N/A* Fri Nov 03 2006 - damien.carbery@sun.com
18861N/A- Specify sysconfdir in configure call as gaim.schemas is installed there.
18861N/A
18861N/A* Thu Nov 02 2006 - damien.carbery@sun.com
18861N/A- Add patch, 07-gtk-func-def, to fix inconsistency between a function
18861N/A declaration and definition. Submitted upstream via sourceforge.net bug db.
18861N/A
18861N/A* Thu Nov 02 2006 - damien.carbery@sun.com
18861N/A- Bump to 2.0.0beta4. Remove upstream patch, 05-nopyextension, and obsolete
18861N/A patch, 06-psychic, (referenced code no longer in module). Rename remainder.
18861N/A
18861N/A* Mon Oct 16 2006 - damien.carbery@sun.com
18861N/A- Remove the '-f' from the 'rm *.la *.a' lines so that any changes to the
18861N/A module source will be seen as a build error and action can be taken.
18861N/A
18861N/A* Mon Aug 28 2005 - rick.ju@sun.com
18861N/A- Bump to 2.0.0beta3.1
18861N/A
18861N/A* Mon Aug 28 2006 - patrick.wade@sun.com
18861N/A- Add patch gaim-12-proxy_mnemonics.diff to add new mnemonics, CR#6442067
18861N/A
18861N/A* Wed May 10 2006 - brian.cameron@sun.com
18861N/A- Add patch gaim-11-nopyextensions.diff to remove .py extensions from
18861N/A executables and move gaim-notifications-example to
18861N/A /usr/share/doc/gaim/examples since it is a system-independant demo
19286N/A program.
19603N/A
* Wed Feb 15 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta2. Remove obsolete patch, 11-forte.
* Wed Jan 18 2006 - damien.carbery@sun.com
- Bump to 2.0.0beta1, remove obsolete patches (08-sound_errors and
11-g11n-enable-im). Add patches 08-libgaimperl and 11-forte.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Mon Aug 15 2005 - damien.carbery@sun.com
- Bump to 1.5.0.
* Thu Jun 10 2005 - glynn.foster@sun.com
- Bump to 1.3.0
* Thu Mar 24 2005 - alvaro.lopez@sun.com
- Rev to 1.3.0. Patches #9, 12, 17, 18 and 19 removed.
* Thu Mar 24 2005 - vijaykumar.patwari@wipro.com
- Added gaim-19-yahoo-privacy-fix.diff patch, fixes yahoo
privacy issue.
* Tue Jan 25 2005 - damien.carbery@sun.com
- Update docs with Linux specific tarball from maeve.anslow@sun.com.
* Tue Jan 18 2005 - glynn.foster@sun.com
- New backported patch to fix msn messenger. Fixes #6217610.
* Wed Jan 12 2005 - takao.fujiwara@sun.com
- Added gaim-15-g11n-enable-im.diff to enable Ja input method. Fix 4990149.
- Added gaim-16-g11n-filename.diff to get/put localized filenames. Fixes 6216501
* Tue Jan 11 2005 - alvaro.lopez@sun.com
- Added patch #15. Fixes #6204972
* Thu Dec 16 2004 - kazuhiko.maekawa@sun.com
- Update l10n help tarball to use linux version
* Wed Dec 8 2004 - damien.carbery@sun.com
- Update docs tarball from maeve.anslow@sun.com.
* Fri Nov 12 2004 - kazuhiko.maekawa@sun.com
- Added workaround fix for 6193354
* Fri Oct 29 2004 - vijaykumar.patwari@wipro.com
- Fixes msn security issues.
* Thu Oct 21 2004 - alvaro.lopez@sun.com
- Added patch #11. Fixes #5101982
* Mon Sep 06 2004 - matt.keenan@sun.com
- Add javahelp-convert for new docs
* Fri Sep 03 2004 - damien.carbery@sun.com
- Add docs tarball from patrick.costello@sun.com.
- Add patch to incorporate docs tarball.
* Mon Aug 30 2004 - glynn.foster@sun.com
- Bump to 0.82.1
* Tue Aug 24 2004 - laszlo.kovacs@sun.com
- mandir/man3 added to base package
* Tue Aug 24 2004 - glynn.foster@sun.com
- Bump to 0.81 and create a devel package.
* Fri Aug 20 2004 - damien.carbery@sun.com
- Comment out removal of man3 files - these don't exist on Solaris.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to gaim-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed Jun 09 2004 - kaushal.kumar@wipro.com
- Modified patch gaim-02-remove-unwanted-protocols.diff to remove the
unnecessary protocols from the build.
* Fri Jun 04 2004 - arvind.samptur@wipro.com
- Add patch gaim-10-iconv-open.diff. Fixes the irc protocol on
Solaris
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to gaim-l10n-po-1.1.tar.bz2
* Sun May 02 2004 - laca@sun.com
- add patch #9 (void-return) for a void function returning a value
* Tue Apr 27 2004 - vijaykumar.patwari@wipro.com
- Bumped new tarball 0.76 version and updated spec file
accordingly.
* Mon Apr 05 2004 - niall.power@sun.com
- ifos'ify glib-gettexttize, to stop nameless .mo files being
generated on cinnabar/linux.
* Sun Apr 04 2004 - laca@sun.com
- add glib-gettextize to make the build work with Solaris msgfmt
* Wed Mar 31 2004 - brian.cameron@sun.com
- replace tar jxf with the more solaris friendly
bzcat piped through tar
* Mon Mar 29 2004 - damien.donlon@sun.com
- Adding gaim-l10n-po-1.0.tar.bz2 l10n content
* Mon Mar 08 2004 - Vijaykumar.patwari@wipro.com
- Fixes all vulnerabilities reproted in the bug report.
* Thu Mar 04 2004 - takao.fujiwara@sun.com
- Removed gaim-01-menu-entry.diff
- Added gaim-01-g11n-menu-entry.diff to fix 4957377
- Added gaim-08-g11n-potfiles.diff
* Wed Mar 03 2004 - <laca@sun.com>
- fix Solaris build by forcing the use of the glib gettext test macro
* Fri Feb 20 2004 - <matt.keenan@sun.com>
- Distro to Cinnabar, fixed patch gaim-06-po-mkinstalldirs.diff
* Thu Feb 19 2004 - <damien.carbery@sun.com>
- Update to 0.75.
* Fri Oct 31 2003 - <glynn.foster@sun.com>
- Remove the Sun Supported keyword from the menu
patch.
* Mon Oct 20 2003 - <stephen.browne@sun.com>
- update to 0.70 and removed potfiles patch
* Thu Aug 14 2003 - <laca@sun.com>
- remove *.a, *.la
* Tue Aug 05 2003 michael.twomey@sun.com
- Added POTFILES.in patch again (updated)
* Fri Aug 01 2003 Stephen.Browne@sun.com
- removed unwanted protocols
* Fri Aug 01 2003 Stephen.Browne@sun.com
- why was there no changelog for this before? well
new tarball, bumped release, reset release, added lbgaim-remote.so.*