pidgin-otr.spec revision 10710
10139N/A#
10139N/A# spec file for package pidgin-otr
10139N/A#
10139N/A# Copyright (c) 2005 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: rickju
10139N/A# bugdb :
10139N/A#
10139N/AName: pidgin-otr
10139N/AVersion: 3.0.1
10139N/A%define libotr_version 3.0.0
12812N/ARelease: 1
10139N/ALicense: GPL
10139N/AGroup: Applications/Internet
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
11922N/ASummary: Off-the-Record (OTR) Messaging plugin for GAIM
10139N/ASource0: http://www.cypherpunks.ca/otr/%{name}-%{version}.tar.gz
12773N/ASource1: http://www.cypherpunks.ca/otr/libotr-%{libotr_version}.tar.gz
12773N/A# owner:rickju date:2007-03-07 type:bug bugster:6524858 state:upstream
12773N/APatch1: pidgin-otr-01-gtk-ui.diff
10139N/A# owner:rickju date:2007-04-03 type:bug bugster:6532728 state:upstream
10139N/APatch2: pidgin-otr-02-gtk-dialog.diff
11927N/A# owner:rickju date:2007-05-27 type:branding
11927N/APatch3: pidgin-otr-03-makefile.diff
13034N/AURL: http://www.cypherpunks.ca/otr/
13034N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/pidgin
10139N/AAutoreqprov: on
10139N/A
10139N/ABuildRequires: pidgin-devel
10139N/A
10139N/A%description
10139N/AOff-the-Record (OTR) Messaging allows you to have private
10139N/Aconversations over instant messaging.
10139N/AThis is a plugin for pdgin which implements Off-the-Record
10139N/AMessaging over any IM network pidgin supports.
10139N/A
10139N/A%package devel
10139N/ASummary: Off-the-Record (OTR) Messaging Plugin For GAIM
10139N/AGroup: System/GUI/GNOME
10139N/AAutoreqprov: on
10139N/ARequires: %name = %version
10139N/A
10139N/A%description devel
10139N/AOff-the-Record (OTR) Messaging allows you to have private
10139N/Aconversations over instant messaging.
10139N/AThis is a plugin for pidgin which implements Off-the-Record
10139N/AMessaging over any IM network pidgin supports.
10139N/A
10139N/A%prep
10139N/A%setup -q -b 1 -n %{name}*
10139N/A#patch for libotr
10139N/Acd ../libotr*
10139N/A#patch for pidgin-otr
10139N/Acd ../pidgin-otr*
10139N/A%patch1 -p1
10139N/A%patch2 -p1
10139N/A%patch3 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
13034N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/A#build libotr
10139N/Acd ../libotr*
10139N/Aglib-gettextize -f
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I .
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
12773N/A
12773N/ACFLAGS="$RPM_OPT_FLAGS -DG_IMPLEMENT_INLINES -DG_HAVE_ISO_VARARGS" \
12773N/ALD_LIBRARY_PATH="%{_libdir}:$LD_LIBRARY_PATH"
12773N/A./configure \
12773N/A --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake -j $CPUS
10139N/A
10139N/A# get root dir
10139N/Acd ..
10139N/Aexport MYDIR=`pwd`
10139N/A
10139N/A#build pidgin-otr
10139N/Acd libotr*
10139N/Aif [ -d my_build_tmp ]; then rm -rf my_build_tmp; fi;
10139N/Amkdir my_build_tmp; mkdir my_build_tmp/libotr;
10139N/Acp src/*.h my_build_tmp/libotr
10139N/Acp toolkit/*.h my_build_tmp/libotr
10139N/A
10139N/Acd ../pidgin-otr*
10139N/Aglib-gettextize -f
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I . -I ${MYDIR}/libotr-%{libotr_version}
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A
10139N/ACFLAGS="$RPM_OPT_FLAGS -DG_IMPLEMENT_INLINES -DG_HAVE_ISO_VARARGS -I${MYDIR}/libotr-%{libotr_version}/my_build_tmp/libotr"
10139N/ALD_LIBRARY_PATH="%{_libdir}:$LD_LIBRARY_PATH -L${MYDIR}/libotr-%{libotr_version}/src/.libs"
10139N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --with-libotr-inc-prefix=${MYDIR}/libotr-%{libotr_version}/my_build_tmp \
10139N/A --with-libotr-prefix=${MYDIR}/libotr-%{libotr_version}/src/.libs
10139N/Amake -j $CPUS
13034N/A
13034N/A%install
12812N/A# install libotr
12812N/Acd ../libotr*
11926N/Amake DESTDIR=$RPM_BUILD_ROOT install \
11926N/A SITEPREFIX=/dummy VENDORPREFIX=/dummy PERLPREFIX=/dummy
11927N/A# install pidgin-otr
11927N/Acd ../pidgin-otr*
11927N/Amake DESTDIR=$RPM_BUILD_ROOT install \
11927N/A SITEPREFIX=/dummy VENDORPREFIX=/dummy PERLPREFIX=/dummy
11922N/A
11922N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
11416N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
11416N/Arm $RPM_BUILD_ROOT%{_libdir}/pidgin/*.la
11252N/A
11252N/A%files
10918N/A%defattr(-, root, root)
10918N/A# libotr
10763N/A%attr(755, root, root) %{_libdir}/*.so
10763N/A%{_bindir}/*
10732N/A%{_mandir}/man1/*
10732N/A%{_libdir}/lib*.so.*
10642N/A%{_libdir}/lib*.a
10642N/A# pidgin-otr
10479N/A%attr(755, root, root) %{_libdir}/pidgin/*.so
10479N/A%{_libdir}/pidgin/*.la
10280N/A%{_libdir}/lib*.la
10280N/A
10194N/A%files devel
10194N/A%defattr(-, root, root)
10181N/A# libotr
10181N/A%{_includedir}/libotr/*
10139N/A%{_datadir}/aclocal
10139N/A# pidgin-otr
10139N/A
10139N/A%clean
10139N/Arm -r $RPM_BUILD_ROOT
10139N/A
10139N/A%changelog
10139N/A* Tue May 30 2007 - rick.ju@sun.com
10139N/A- bump to pidgin-otr 3.0.1
10139N/A
10139N/A* Tue Apr 03 2007 - rick.ju@sun.com
10139N/A- Add a gaim-otr-03-gtk-dialog.diff for bug#632728
10139N/A
10139N/A* Thu Jan 18 2007 - damien.carbery@sun.com
10139N/A- Remove the code from %install that deletes $RPM_BUILD_ROOT as it trashes the
10139N/A 'make install' of gaim when part of SUNWgnome-im-client build.
10139N/A
10139N/A* Thu Dec 21 2006 - damien.carbery@sun.com
10139N/A- Remove *.a and *.la files in %install.
10139N/A
10139N/A* Mon Dec 18 2006 - rick.ju@sun.com
10139N/A- Add this new spec for libotr and gaim-otr
10139N/A