nimbus.spec revision 14445
17167N/A#
17167N/A# spec file for package nimbus
17167N/A#
17167N/A# Copyright (c) 2006 Sun Microsystems, Inc.
17167N/A# This file and all modifications and additions to the pristine
17167N/A# package are under the same license as the package itself.
17167N/A#
17167N/A# Owner: erwannc
17167N/A#
17167N/AName: nimbus
17167N/ASummary: Engine for GTK2 Nimbus Theme
17167N/A# NOTE: If the version is bumped the new tarball must be uploaded to the
17167N/A# Sun Download Center. Contact GNOME RE for assistance.
17167N/AVersion: 0.1.0
17167N/A%define tarball_version %{version}
17167N/ARelease: 1
17167N/ALicense: LGPL
17167N/ADistribution: Java Desktop System
17167N/AVendor: Sun Microsystems, Inc.
17167N/AGroup: System/GUI/GNOME
17167N/ASource: http://dlc.sun.com/osol/jds/downloads/extras/nimbus/%{name}-%{tarball_version}.tar.bz2
17167N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
17167N/AURL: http://www.sun.com/software/javadesktopsystem/
17167N/A#owner:erwannc date:2006-09-20 type:branding
17167N/APatch1: nimbus-01-icon-name-mapping-hack.diff
17167N/A
17167N/A%define gtk2_version 2.4.0
17167N/A%define intltool_version 0.30
17167N/ABuildRequires: gtk2 >= %{gtk2_version}
17167N/ABuildRequires: intltool >= %{intltool_version}
17167N/A
17167N/A%description
17167N/AThis package contains the Nimbus theme engine for GTK2
17167N/A
17167N/A%prep
17167N/A%setup -q -n %name-%tarball_version
17167N/A%patch1 -p1
17167N/A
17167N/A%build
17167N/A%ifos linux
17167N/Aif [ -x /usr/bin/getconf ]; then
17167N/A CPUS=`getconf _NPROCESSORS_ONLN`
17167N/Afi
17167N/A%else
17167N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17167N/A%endif
17167N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17167N/A CPUS=1
17167N/Afi
17167N/A
17167N/Alibtoolize --force
17167N/Aaclocal $ACLOCAL_FLAGS -I .
17167N/Aautomake -a -c -f
17167N/Aautoconf
17167N/Aexport CFLAGS="%optflags"
17167N/Aexport LDFLAGS="%_ldflags"
17167N/A./autogen.sh --prefix=%{_prefix} \
17167N/A --libdir=%{_libdir} \
17167N/A --sysconfdir=%{_sysconfdir}
17167N/Amake -j $CPUS
17167N/Acd -
17167N/A
17167N/A%install
17167N/Amake DESTDIR=$RPM_BUILD_ROOT install
17167N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.a
17167N/Arm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/engines/*.la
17167N/A
17167N/A%clean
17167N/Arm -rf $RPM_BUILD_ROOT
17167N/A
17167N/A%files
17167N/A%defattr(-, root, root)
17167N/A%{_libdir}/gtk-2.0/*/engines/*.so
17167N/A%{_datadir}/themes/*
17167N/A%{_datadir}/icons/*
17167N/A%{_datadir}/locale/*
17167N/A%{_datadir}/pixmaps/*
17167N/A
17167N/A%changelog
17167N/A* Thu Aug 14 2008 - erwann@sun.com
17167N/A- bumped to 0.0.17
17167N/A* Fri May 18 2007 - laca@sun.com
17167N/A- set CFLAGS/LDFLAGS and configure options such that we can use this spec
17167N/A file for the 64-bit build too
17167N/A* Fri Jul 21 2006 - damien.carbery@sun.com
- Add patch to comment out the redefine of an enum.
* Mon May 12 2006 Erwann Chenede - <erwann.chenede@sun.com>
- initial implementation of the spec file