metacity.spec revision 13460
10139N/A#
10139N/A# spec file for package metacity
10139N/A#
12119N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner: erwannc
10139N/A#
10139N/A%include l10n.inc
10139N/AName: metacity
10139N/ALicense: GPL
10139N/AGroup: System/GUI/GNOME
12370N/AVersion: 2.23.34
10139N/ARelease: 4
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: GNOME Window Manager
11912N/ASource: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.23/metacity-%{version}.tar.bz2
10142N/ASource1: %{name}-po-sun-%{po_sun_version}.tar.bz2
11444N/A%if %build_l10n
10139N/ASource2: l10n-configure.sh
10139N/A%endif
11444N/A#owner:erwannc date:2000-00-00 type:branding
10139N/APatch1: metacity-01-default-theme.diff
10139N/A#owner:gheet date:2003-07-17 type:branding
10139N/APatch2: metacity-02-ctrl-esc-mod4-r.diff
10139N/A#owner:gman date:2003-11-20 type:branding
10139N/APatch3: metacity-03-ctrl-alt-del.diff
10139N/A#owner:erwannc date:2004-04-30 type:branding
10139N/APatch4: metacity-04-sunpowerswitch-key.diff
10139N/A#owner:erwannc date:2004-07-23 type:feature
10139N/APatch5: metacity-05-raise-on-frame-click.diff
10139N/A#owner:erwannc date:2004-10-06 type:bug bugster:5101706
10139N/APatch6: metacity-06-logout-shortcut.diff
10139N/A#owner:erwannc date:2006-05-12 type:branding
11314N/APatch7: metacity-07-branding-hack.diff
10139N/A#owner:erwannc date:2006-11-02 type:feature bugster:6393724
10139N/APatch8: metacity-08-trusted-extensions.diff
11314N/A#owner:erwannc date:2004-10-08 type:feature bugster:5103120
10139N/APatch9: metacity-09-enable-Sun-keys-Open-Front.diff
12129N/A#owner:bewitche date:2008-05-23 type:bug bugster:6676458 bugzilla:161239
11008N/APatch10: metacity-10-wireframe.diff
12129N/A#owner:erwannc date:2008-006-02 type:feature bugster:0000000
11008N/APatch11: metacity-11-remove-xopen-source-posix.diff
10420N/A
10139N/AURL: http://www.gnome.org
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define intltool_version 0.30
10139N/A%define GConf_version 2.6.1
10139N/A%define pkgconfig_version 0.15.0
10139N/A%define libglade_version 2.3.6
10139N/A
10139N/ARequires: GConf >= %{GConf_version}
10139N/ARequires: libglade >= %{libglade_version}
10139N/ABuildRequires: intltool >= %{intltool_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/ABuildRequires: GConf >= %{GConf_version}
10139N/ABuildRequires: libglade >= %{libglade_version}
10139N/A
10139N/A%description
10139N/AMetacity is the window manager for the GNOME Desktop.
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%if %build_l10n
10142N/Abzcat %SOURCE1 | tar xf -
10139N/Acd po-sun; make; cd ..
10139N/A%endif
11450N/A%patch1 -p1
10139N/A%patch2 -p1
11450N/A%patch3 -p1
10139N/A%patch4 -p1
10139N/A%patch5 -p1
10139N/A%patch6 -p1
10139N/A%patch7 -p1
10139N/A%patch8 -p1
10139N/A%patch9 -p1
12396N/A%patch10 -p1
12396N/A%patch11 -p1
12396N/A
12396N/A%build
12396N/A%ifos linux
12129N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize --force --copy
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE2 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS
10139N/Aautoheader
10139N/Aautomake -a -c -f
10139N/Aautoconf
10139N/A# Note, you need to install SFElibcm (from spec-files-extra) and
10139N/A# add --enable-compositor to the configure call to use metacity
10139N/A# with compositing mode. Note SFElibcm requires Xorg 7.1
10139N/A# Xcomposite library.
10139N/A#
12409N/ACFLAGS="$RPM_OPT_FLAGS -Icore -Iui " \
10139N/A./configure --prefix=%{_prefix} \
10139N/A --mandir=%{_mandir} \
10139N/A --libexecdir=%{_libexecdir} \
10139N/A --sysconfdir=%{_sysconfdir}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Aexport GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/Aunset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
10139N/A#Copy zh_HK from zh_TW
10139N/A#Fixes bug 4930405
10139N/Ainstall -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
10139N/Ainstall --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*.la
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/ASCHEMAS="metacity.schemas"
10139N/Afor S in $SCHEMAS; do
10139N/A gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
10139N/Adone
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_bindir}/*
10139N/A%{_datadir}/locale/*/LC_MESSAGES/*.mo
10139N/A%{_sysconfdir}/gconf/schemas/metacity.schemas
10139N/A%{_libexecdir}/*
10139N/A%{_libdir}/*.so*
10139N/A%{_libdir}/pkgconfig/*.pc
10139N/A%{_includedir}/metacity-1/metacity-private
10139N/A%{_datadir}/gnome/wm-properties/metacity.desktop
10139N/A%{_datadir}/metacity
10139N/A%{_datadir}/themes/*/metacity-1/*
10633N/A%{_datadir}/control-center/keybindings/*
10139N/A%{_mandir}/man1/*
10139N/A
10139N/A%changelog
12409N/A* Sat Jun 21 2008 - patrick.ale@gmail.com
12409N/A- Change source download location to 2.23 directory
12409N/A* Mon Jun 02 2008 - erwann.chenede@sun.com
12396N/A- Bump to 2.23.21. Remove upstream patches, 10-lame-client-crash, 14-wireframe,
12396N/A 11-iconic.diff. Add 11-remove-xopen-source-posix.
12409N/A* Fri May 23 2008 - chris.wang@sun.com
12370N/A- add patch metacity-14-wireframe.diff to fixed bug 6676458 with regular size
12409N/A window maximize it and then minimize it and a wire frame will appear.
12335N/A* Tue May 20 2008 - stephen.browne@sun.com
12409N/A- remove conditional build of tjds patch
12328N/A* Wed May 07 2008 - simon.zheng@sun.com
12409N/A- Rework 04-sunpowerswitch-key.diff to use gpm interface.
12119N/A* Wed Apr 30 2008 - chris.wang@sun.com
12071N/A- Add patch metacity-13-fail-windowattr.diff fix the bugster bug 6661472
12071N/A Metacity dumps core with an assertion failed
11912N/A* Mon Mar 10 2008 - damien.carbery@sun.com
11912N/A- Bump to 2.22.0.
11314N/A* Thu Mar 06 2008 - padraig.obriain@sun.com
11314N/A- Add metacity-11-iconic.diff
11264N/A* Thu Feb 28 2008 - damien.carbery@sun.com
11264N/A- Bump to 2.21.21.
11029N/A* Tue Feb 19 2008 - damien.carbery@sun.com
11029N/A- Add '-Icore -Iui' to CFLAGS so that TJDS changes can build.
10951N/A* Fri Feb 15 2008 - damien.carbery@sun.com
10951N/A- Remove patch 11-src-includes. The TJDS patch needs to be reworked. Disable
10854N/A TJDS patch for the moment so that module builds okay.
10854N/A* Wed Feb 13 2008 - damien.carbery@sun.com
10854N/A- Bump to 2.21.13.
10812N/A* Tue Feb 05 2008 - damien.carbery@sun.com
10812N/A- Add patch 11-src-includes to get module to build after source tree reorg.
10812N/A* Mon Feb 04 2008 - damien.carbery@sun.com
10782N/A- Bump to 2.21.8.
10783N/A* Thu Jan 03 2008 - damien.carbery@sun.com
10783N/A- Bump to 2.21.5. Comment out patch8 and patch9 to get it to build.
10633N/A* Tue Dec 18 2007 - damien.carbery@sun.com
10633N/A- Bump to 2.21.3.
10633N/A* Mon Nov 12 2007 - damien.carbery@sun.com
10633N/A- Bump to 2.21.1.
10426N/A* Fri Sep 28 2007 - laca@sun.com
10426N/A- disable tjds patch when tjds support is not requested
10285N/A* Wed Sep 19 2007 - damien.carbery@sun.com
10285N/A- Bump to 2.20.0.
10179N/A* Tue Aug 07 2007 - damien.carbery@sun.com
10179N/A- Bump to 2.19.55.
10139N/A* Tue Jul 24 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.34.
10139N/A* Fri Jun 22 2007 - damien.carbery@sun.com
10139N/A- Unbump to 2.19.8 because .13 and .21 tarballs have linker error. Readd patch
10139N/A XX-empty-struct (fixes 397296).
10139N/A* Mon Jun 18 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.21. Remove upstream patches, 09-empty-struct and
10139N/A 11-func-declaration-mismatch.
10139N/A* Mon Jun 11 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.19.13. Add patch, 12-func-declaration-mismatch, to fix bugzilla
10139N/A 446535.
10139N/A* Mon May 14 2007 - erwann.chenede@sun.com
10139N/A- Bump to 2.19.5
10139N/A- removed a patch
10139N/A- added dir in %files
10139N/A* Thu Apr 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.1.
10139N/A* Tue Mar 13 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.18.0.
10139N/A* Mon Mar 05 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.8.
10139N/A* Thu Jan 25 2007 - takao.fujiwara@sun.com
10139N/A- Added l10n tarball for metacity-xx-trusted-extensions.diff.
10139N/A* Wed Jan 17 2007 - damien.carbery@sun.com
10139N/A- Bump to 2.17.5.
10139N/A* Fri Dec 22 2006 - takao.fujiwara@sun.com
10139N/A- Updated metacity-10-trusted-extensions.diff. Fixes 6468212.
10139N/A* Mon Dec 11 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.3.
10139N/A* Thu Nov 23 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.17.2. Remove upstream patch, 13-terminal-strict-focus. Comment out
10139N/A patch 9 as it needs rework.
10139N/A* Sat 28 Oct 2006 - glynn.foster@sun.com
10139N/A- Commit patch to preserve strict focus mode with terminals
10139N/A and keep a few kernel hackers on our side. Bugzilla #361054.
10139N/A* Tue Oct 03 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.3.
10139N/A* Wed Sep 27 2006 - brian.cameron@sun.com
10139N/A- Add patch metacity-12-composite.diff so that if pkg-config
10139N/A finds cm.pc on the system, that it will build with
10139N/A composite support.
10139N/A* Tue Sep 26 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.2.
10139N/A* Mon Sep 04 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.16.0.
10139N/A* Tue Aug 08 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.21.
10139N/A* Mon Jul 24 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.15.13.
10139N/A* Fri Jun 23 2006 - brian.cameron@sun.com
10139N/A- Bump to 2.14.5.
10139N/A* Tue Apr 18 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.3.
10139N/A* Tue Apr 11 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.2.
10139N/A* Tue Mar 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.14.1.
10139N/A* Tue Feb 28 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.144.
10139N/A* Tue Feb 14 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.89.
10139N/A* Tue Jan 31 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.55.
10139N/A* Sat Jan 21 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.34
10139N/A* Tue Jan 17 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.21
10139N/A* Sun Jan 15 2006 - damien.carbery@sun.com
10139N/A- Bump to 2.13.13
10139N/A* Mon Jan 09 2006 - damien.carbery@sun.com
10139N/A- Add patch, pretty-function, to use a Gnome define instead of a pragma not
10139N/A available in forte. Bugzilla 326281.
10139N/A- Call intltoolize to process intltool-update/merge.
10139N/A* Wed Jan 04 2006 - damien.carbery@sun.com
10139N/A- Remove obsolete patch, 08-constrain-window.
10139N/A* Tue Dec 20 2005 - dermot.mccluskey@sun.com
10139N/A- Bump to 2.13.5
10139N/A* Tue Nov 29 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.2.
10139N/A* Tue Oct 11 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.12.1
10139N/A* Sat Sep 17 2005 - glynn.foster@sun.com
10139N/A- Bump to 2.12.0
10139N/A* Mon Sep 05 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.3.
10139N/A* Tue Aug 16 2005 - damien.carbery@sun.com
10139N/A- Bump to 2.11.2.
10139N/A* Wed Aug 03 2005 - laca@sun.com
10139N/A- remove upstream patch splash-layer.diff
10139N/A* Fri Jul 01 2005 - matt.keenan@sun.com
10139N/A- Add patch -09-pkgconfig.diff to add needed libs
10139N/A* Thu May 19 2005 - brian.cameron@sun.com
10139N/A- Fix patch so it uses -p1 instead of -p0 since Solaris is less
10139N/A forgiving than Linux. Remove patch 4 since it breaks the build.
10139N/A* Tue May 17 2005 - arvind.samptur@wipro.com
10139N/A- Adding patch to fix splash screens not to be
10139N/A on top of all windows all the time Fixes #6268588
10139N/A* Wed Feb 16 2005 - leena.gunda@wipro.com
10139N/A- Added metacity-11-constrain-window.diff to constrain windows within
10139N/A the strut area when shown for the first time. Fixes bug #6182510.
10139N/A* Fri Feb 11 2005 - srirama.sharma@wipro.com
10139N/A- Added metacity-10-window-title.diff to enable user to edit
10139N/A window title using font capplet. Fixes bug #6227065.
10139N/A* Thu Jan 20 2005 - leena.gunda@wipro.com
10139N/A- Added metacity-09-wireframe-double-click.diff to restore window on
10139N/A double-clicking the title-bar to unmaximize. Fixes bug 6204338.
10139N/A* Tue Jan 11 2005 - vinay.mandyakoppal@wipro.com
10139N/A- Modified metacity-02-ctrl-esc-mod4-r.diff to map 'show desktop' to <mod4>+d
10139N/A Fixes bug #5028221.
10139N/A* Mon Jan 03 2005 - arvind.samptur@wipro.comm
10139N/A- Add patch to disable wireframe feature when
10139N/A accessiblity is on.
10139N/A* Wed Nov 24 2004 - leena.gunda@wipro.com
10139N/A- Updated metacity-04-sunpowerswitch-key.diff to fix stopper bug #5104104.
10139N/A* Thu Oct 28 2004 - matt.keenan@sun.com
10139N/A- Add metacity-message.1, metacity-window-demo.1 man pages
10139N/A* Mon Oct 11 2004 - leena.gunda@wipro.com
10139N/A- Updated metacity-04-sunpowerswitch-key.diff to check if Xserver is local
10139N/A for GDM also. Fixes bug #5107206.
10139N/A* Wed Oct 06 2004 - vinay.mandyakoppal@wipro.com
10139N/A- Added metacity-07-logout-shortcut.diff Patch to implement an
10139N/A "apps/metacity/global_keybindings/logout" gconf key and
10139N/A its functionality. Fixes bug #5101706.
10139N/A* Fri Oct 01 2004 - arvind.samptur@wipro.com
10139N/A- Add the window_raise_on_frame_only key under sun-extenstions
10139N/A* Sat Sep 11 2004 - laca@sun.com
10139N/A- Move Solaris specific LDFLAGS to the Solaris spec file
10139N/A* Fri Sep 10 2004 - damien.carbery@sun.com
10139N/A- Set LDFLAGS so Xrandr and Xrender can be found.
10139N/A* Mon Aug 16 2004 - bill.haneman@sun.com
10139N/A- Added patch metacity-05-bigstruts.diff for bugzilla #144126.
10139N/A* Thu Jul 08 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to metacity-l10n-po-1.2.tar.bz2
10139N/A* Wed Jul 07 2004 - niall.power@sun.com
10139N/A- ported to rpm4
10139N/A* Wed Jul 07 2004 - dermot.mccluskey@sun.com
10139N/A- added "-j $CPUS" to make to speed up builds
10139N/A* Wed May 12 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to metacity-l10n-po-1.1.tar.bz2
10139N/A* Wed May 12 2004 - leena.gunda@wipro.com
10139N/A- Do aclocal, autoheader, autoconf and automake before doing a configure.
10139N/A* Fri Apr 30 2004 - leena.gunda@wipro.com
10139N/A- Added patch metacity-04-sunpowerswitch-key.diff to bind SunPowerSwitch
10139N/A key to gnome-sys-suspend for Solaris.
10139N/A* Wed Apr 07 2004 - arvind.samptur@wipro.com
10139N/A- Updated to 2.8.0
10139N/A* Mon Mar 29 2004 - damien.donlon@sun.com
10139N/A- Updated l10n content to metacity-l10n-po-1.0.tar.bz2
10139N/A* Tue Feb 24 2004 - <glynn.foster@sun.com> 2.7.0-1
10139N/A- Update to 2.7.0
10139N/A* Thu Feb 12 2004 - <niall.power@sun.com>
10139N/A- add "-p0" strip argument to patch commands
10139N/A* Tue Dec 16 2003 - <glynn.foster@sun.com> 2.6.3-1
10139N/A- Update to 2.6.3
10139N/A* Thu Oct 16 2003 - <markmc@sun.com> 2.6.2-1
10139N/A- Update to 2.6.2
10139N/A* Thu Oct 09 2003 - <markmc@sun.com> 2.6.1-1
10139N/A- Update to 2.6.1
- Remove panel keybindings patches - they're in 2.6.x
* Fri Aug 01 2003 - <markmc@sun.com> 2.4.55-1
- Update to 2.4.55
* Thu Jul 31 2003 - <markmc@sun.com> 2.4.34-11
- Add patch to fix workspace names not retained after
logging out.
* Thu Jul 17 2003 - <ghee.teo@sun.com>
- Combined the esc-ctrl patch with Mod4 (window) R key
patch.
* Thu Jul 10 2003 - <michael.twomey@sun.com>
- Added .po tarball
* Thu Jul 03 2003 - <markmc@sun.com>
- redo default window border theme patch
* Wed Jul 02 2003 - <markmc@sun.com>
- add metacity-04-ctrl-escape.diff
* Wed Jul 02 2003 - <markmc@sun.com>
- new version of metacity-01-panel-keybindings.diff
* Fri May 30 2003 - <markmc@sun.com>
- Backport panel keybindings patches.
* Tue May 13 2003 - <Stephen.Browne@sun.com>
- initial release