metacity.spec revision 10783
#
# spec file for package metacity
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: erwannc
#
%include l10n.inc
Name: metacity
License: GPL
Group: System/GUI/GNOME
Version: 2.19.13
Release: 4
Distribution: Java Desktop System
Vendor: Sun Microsystems, Inc.
Summary: GNOME Window Manager
Source: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.19/metacity-%{version}.tar.bz2
Source1: %{name}-po-sun-%{po_sun_version}.tar.bz2
#owner:erwannc date:2000-00-00 type:branding
Patch1: metacity-01-default-theme.diff
#owner:gheet date:2003-07-17 type:branding
Patch2: metacity-02-ctrl-esc-mod4-r.diff
#owner:gman date:2003-11-20 type:branding
Patch3: metacity-03-ctrl-alt-del.diff
#owner:erwannc date:2004-04-30 type:branding
Patch4: metacity-04-sunpowerswitch-key.diff
#owner:erwannc date:2004-07-23 type:feature
Patch5: metacity-05-raise-on-frame-click.diff
#owner:erwannc date:2004-10-06 type:bug bugster:5101706
Patch6: metacity-06-logout-shortcut.diff
#owner:erwannc date:2006-05-12 type:branding
Patch7: metacity-07-branding-hack.diff
#owner:erwannc date:2006-11-02 type:feature bugster:6393724
Patch8: metacity-08-trusted-extensions.diff
#owner:dcarbery date:2006-07-26 type:feature bugzilla:397296
Patch9: metacity-09-empty-struct.diff
#owner:erwannc date:2006-09-27 type:feature
Patch10: metacity-10-composite.diff
#owner:erwannc date:2004-10-08 type:feature bugster:5103120
Patch11: metacity-11-enable-Sun-keys-Open-Front.diff
#owner:dcarbery date:2007-06-11 type:bug bugzilla:446535
Patch12: metacity-12-func-declaration-mismatch.diff
URL: http://www.gnome.org
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Docdir: %{_defaultdocdir}/doc
Autoreqprov: on
Prereq: /sbin/ldconfig
%define intltool_version 0.30
%define GConf_version 2.6.1
%define pkgconfig_version 0.15.0
%define libglade_version 2.3.6
Requires: GConf >= %{GConf_version}
Requires: libglade >= %{libglade_version}
BuildRequires: intltool >= %{intltool_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}
BuildRequires: GConf >= %{GConf_version}
BuildRequires: libglade >= %{libglade_version}
%description
Metacity is the window manager for the GNOME Desktop.
%prep
%setup -q
%if %build_l10n
bzcat %SOURCE1 | tar xf -
cd po-sun; make; cd ..
%endif
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
libtoolize --force
intltoolize --force --copy
aclocal $ACLOCAL_FLAGS
autoheader
automake -a -c -f
autoconf
# Note, you need to install SFElibcm (from spec-files-extra) and
# add --enable-compositor to the configure call to use metacity
# with compositing mode. Note SFElibcm requires Xorg 7.1
# Xcomposite library.
#
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
--mandir=%{_mandir} \
--libexecdir=%{_libexecdir} \
--sysconfdir=%{_sysconfdir}
make -j $CPUS
%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="metacity.schemas"
for S in $SCHEMAS; do
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done
%postun
/sbin/ldconfig
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_sysconfdir}/gconf/schemas/metacity.schemas
%{_libexecdir}/*
%{_libdir}/*.so*
%{_libdir}/pkgconfig/*.pc
%{_includedir}/metacity-1/metacity-private
%{_datadir}/gnome/wm-properties/metacity.desktop
%{_datadir}/metacity
%{_datadir}/themes/*/metacity-1/*
%{_datadir}/control-center/keybindings/*
%{_mandir}/man1/*
%changelog
* Mon Jun 11 2007 - damien.carbery@sun.com
- Bump to 2.19.13. Add patch, 12-func-declaration-mismatch, to fix bugzilla
446535.
* Mon May 14 2007 - erwann.chenede@sun.com
- Bump to 2.19.5
- removed a patch
- added dir in %files
* Thu Apr 05 2007 - damien.carbery@sun.com
- Bump to 2.18.1.
* Tue Mar 13 2007 - damien.carbery@sun.com
- Bump to 2.18.0.
* Mon Mar 05 2007 - damien.carbery@sun.com
- Bump to 2.17.8.
* Thu Jan 25 2007 - takao.fujiwara@sun.com
- Added l10n tarball for metacity-xx-trusted-extensions.diff.
* Wed Jan 17 2007 - damien.carbery@sun.com
- Bump to 2.17.5.
* Fri Dec 22 2006 - takao.fujiwara@sun.com
- Updated metacity-10-trusted-extensions.diff. Fixes 6468212.
* Mon Dec 11 2006 - damien.carbery@sun.com
- Bump to 2.17.3.
* Thu Nov 23 2006 - damien.carbery@sun.com
- Bump to 2.17.2. Remove upstream patch, 13-terminal-strict-focus. Comment out
patch 9 as it needs rework.
* Sat 28 Oct 2006 - glynn.foster@sun.com
- Commit patch to preserve strict focus mode with terminals
and keep a few kernel hackers on our side. Bugzilla #361054.
* Tue Oct 03 2006 - damien.carbery@sun.com
- Bump to 2.16.3.
* Wed Sep 27 2006 - brian.cameron@sun.com
- Add patch metacity-12-composite.diff so that if pkg-config
finds cm.pc on the system, that it will build with
composite support.
* Tue Sep 26 2006 - damien.carbery@sun.com
- Bump to 2.16.2.
* Mon Sep 04 2006 - damien.carbery@sun.com
- Bump to 2.16.0.
* Tue Aug 08 2006 - damien.carbery@sun.com
- Bump to 2.15.21.
* Mon Jul 24 2006 - damien.carbery@sun.com
- Bump to 2.15.13.
* Fri Jun 23 2006 - brian.cameron@sun.com
- Bump to 2.14.5.
* Tue Apr 18 2006 - damien.carbery@sun.com
- Bump to 2.14.3.
* Tue Apr 11 2006 - damien.carbery@sun.com
- Bump to 2.14.2.
* Tue Mar 14 2006 - damien.carbery@sun.com
- Bump to 2.14.1.
* Tue Feb 28 2006 - damien.carbery@sun.com
- Bump to 2.13.144.
* Tue Feb 14 2006 - damien.carbery@sun.com
- Bump to 2.13.89.
* Tue Jan 31 2006 - damien.carbery@sun.com
- Bump to 2.13.55.
* Sat Jan 21 2006 - damien.carbery@sun.com
- Bump to 2.13.34
* Tue Jan 17 2006 - damien.carbery@sun.com
- Bump to 2.13.21
* Sun Jan 15 2006 - damien.carbery@sun.com
- Bump to 2.13.13
* Mon Jan 09 2006 - damien.carbery@sun.com
- Add patch, pretty-function, to use a Gnome define instead of a pragma not
available in forte. Bugzilla 326281.
- Call intltoolize to process intltool-update/merge.
* Wed Jan 04 2006 - damien.carbery@sun.com
- Remove obsolete patch, 08-constrain-window.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 2.13.5
* Tue Nov 29 2005 - damien.carbery@sun.com
- Bump to 2.12.2.
* Tue Oct 11 2005 - damien.carbery@sun.com
- Bump to 2.12.1
* Sat Sep 17 2005 - glynn.foster@sun.com
- Bump to 2.12.0
* Mon Sep 05 2005 - damien.carbery@sun.com
- Bump to 2.11.3.
* Tue Aug 16 2005 - damien.carbery@sun.com
- Bump to 2.11.2.
* Wed Aug 03 2005 - laca@sun.com
- remove upstream patch splash-layer.diff
* Fri Jul 01 2005 - matt.keenan@sun.com
- Add patch -09-pkgconfig.diff to add needed libs
* Thu May 19 2005 - brian.cameron@sun.com
- Fix patch so it uses -p1 instead of -p0 since Solaris is less
forgiving than Linux. Remove patch 4 since it breaks the build.
* Tue May 17 2005 - arvind.samptur@wipro.com
- Adding patch to fix splash screens not to be
on top of all windows all the time Fixes #6268588
* Wed Feb 16 2005 - leena.gunda@wipro.com
- Added metacity-11-constrain-window.diff to constrain windows within
the strut area when shown for the first time. Fixes bug #6182510.
* Fri Feb 11 2005 - srirama.sharma@wipro.com
- Added metacity-10-window-title.diff to enable user to edit
window title using font capplet. Fixes bug #6227065.
* Thu Jan 20 2005 - leena.gunda@wipro.com
- Added metacity-09-wireframe-double-click.diff to restore window on
double-clicking the title-bar to unmaximize. Fixes bug 6204338.
* Tue Jan 11 2005 - vinay.mandyakoppal@wipro.com
- Modified metacity-02-ctrl-esc-mod4-r.diff to map 'show desktop' to <mod4>+d
Fixes bug #5028221.
* Mon Jan 03 2005 - arvind.samptur@wipro.comm
- Add patch to disable wireframe feature when
accessiblity is on.
* Wed Nov 24 2004 - leena.gunda@wipro.com
- Updated metacity-04-sunpowerswitch-key.diff to fix stopper bug #5104104.
* Thu Oct 28 2004 - matt.keenan@sun.com
- Add metacity-message.1, metacity-window-demo.1 man pages
* Mon Oct 11 2004 - leena.gunda@wipro.com
- Updated metacity-04-sunpowerswitch-key.diff to check if Xserver is local
for GDM also. Fixes bug #5107206.
* Wed Oct 06 2004 - vinay.mandyakoppal@wipro.com
- Added metacity-07-logout-shortcut.diff Patch to implement an
"apps/metacity/global_keybindings/logout" gconf key and
its functionality. Fixes bug #5101706.
* Fri Oct 01 2004 - arvind.samptur@wipro.com
- Add the window_raise_on_frame_only key under sun-extenstions
* Sat Sep 11 2004 - laca@sun.com
- Move Solaris specific LDFLAGS to the Solaris spec file
* Fri Sep 10 2004 - damien.carbery@sun.com
- Set LDFLAGS so Xrandr and Xrender can be found.
* Mon Aug 16 2004 - bill.haneman@sun.com
- Added patch metacity-05-bigstruts.diff for bugzilla #144126.
* Thu Jul 08 2004 - damien.donlon@sun.com
- Updated l10n content to metacity-l10n-po-1.2.tar.bz2
* Wed Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Wed May 12 2004 - damien.donlon@sun.com
- Updated l10n content to metacity-l10n-po-1.1.tar.bz2
* Wed May 12 2004 - leena.gunda@wipro.com
- Do aclocal, autoheader, autoconf and automake before doing a configure.
* Fri Apr 30 2004 - leena.gunda@wipro.com
- Added patch metacity-04-sunpowerswitch-key.diff to bind SunPowerSwitch
key to gnome-sys-suspend for Solaris.
* Wed Apr 07 2004 - arvind.samptur@wipro.com
- Updated to 2.8.0
* Mon Mar 29 2004 - damien.donlon@sun.com
- Updated l10n content to metacity-l10n-po-1.0.tar.bz2
* Tue Feb 24 2004 - <glynn.foster@sun.com> 2.7.0-1
- Update to 2.7.0
* Thu Feb 12 2004 - <niall.power@sun.com>
- add "-p0" strip argument to patch commands
* Tue Dec 16 2003 - <glynn.foster@sun.com> 2.6.3-1
- Update to 2.6.3
* Thu Oct 16 2003 - <markmc@sun.com> 2.6.2-1
- Update to 2.6.2
* Thu Oct 09 2003 - <markmc@sun.com> 2.6.1-1
- Update to 2.6.1
- Remove panel keybindings patches - they're in 2.6.x
* Fri Aug 01 2003 - <markmc@sun.com> 2.4.55-1
- Update to 2.4.55
* Thu Jul 31 2003 - <markmc@sun.com> 2.4.34-11
- Add patch to fix workspace names not retained after
logging out.
* Thu Jul 17 2003 - <ghee.teo@sun.com>
- Combined the esc-ctrl patch with Mod4 (window) R key
patch.
* Thu Jul 10 2003 - <michael.twomey@sun.com>
- Added .po tarball
* Thu Jul 03 2003 - <markmc@sun.com>
- redo default window border theme patch
* Wed Jul 02 2003 - <markmc@sun.com>
- add metacity-04-ctrl-escape.diff
* Wed Jul 02 2003 - <markmc@sun.com>
- new version of metacity-01-panel-keybindings.diff
* Fri May 30 2003 - <markmc@sun.com>
- Backport panel keybindings patches.
* Tue May 13 2003 - <Stephen.Browne@sun.com>
- initial release