libunique.spec revision 18603
10139N/A#
10139N/A# spec file for package unique
10139N/A#
12119N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner halton
10139N/A#
10139N/A
10139N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
10139N/A
10139N/AName: libunique
14538N/ALicense: LGPL v2.1
14538N/AGroup: System/Libraries
10139N/AVersion: 1.1.6
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
14538N/AVendor: Sun Microsystems, Inc.
12559N/ASummary: A library for writing single instance applications
12773N/ASource: http://download.gnome.org/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
12773N/AURL: http://live.gnome.org/LibUnique
12773N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov:on
14166N/APrereq: /sbin/ldconfig
14166N/A
14166N/APatch1: libunique-01-fixxref-modules.diff
14166N/A
14166N/A%define gtk2_version 2.4.0
14166N/A%define pkgconfig_version 0.15.0
14166N/A%define gtk_doc_version 1.1
14166N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
10139N/A%description
10139N/ALibUnique is a library for writing single instance applications, that is
10139N/Aapplications that are run once and every further call to the same binary
10139N/Aeither exits immediately or sends a command to the running instance.
10139N/A
10139N/ALibUnique can be compiled against various backends, to allow the usage of
10139N/Adifferent IPC mechanisms depending on the platform.
13542N/A
14166N/A%package devel
15261N/ASummary: unique development headers
14166N/AGroup: Development/Libraries
15261N/A
15261N/A%description devel
10420N/Aunique development headers
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch1 -p1
10139N/A
10139N/A#FIXME: remove uncompatible m4 files
10139N/Arm -f build/autotools/lt~obsolete.m4
10139N/Arm -f build/autotools/ltoptions.m4
10139N/Arm -f build/autotools/libtool.m4
10139N/Arm -f build/autotools/ltsugar.m4
10139N/Arm -f build/autotools/ltversion.m4
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10142N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I build/autotools
10139N/Aautoheader
10139N/Aautomake -a -c -f
14166N/Aautoconf
10139N/A
14166N/A./configure --prefix=%{_prefix} \
14166N/A --bindir=%{_bindir} \
14166N/A --libdir=%{_libdir} \
14166N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --enable-introspection=no \
10139N/A %{gtk_doc_option} \
10139N/A%if %debug_build
12962N/A --enable-debug=yes \
12129N/A%else
10139N/A --enable-debug=no \
15261N/A%endif
13019N/A
10139N/A# FIXME: hack: stop the build from looping
10139N/A#touch po/stamp-it
10139N/A
10139N/Amake -j $CPU
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A#Clean up unpackaged files
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
12773N/A%files
12773N/A%defattr(-,root,root)
12773N/A%{_libdir}/*.so.*
12773N/A
12773N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_includedir}/*
10139N/A%{_libdir}/*.so
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_datadir}/gtk-doc/html/unique/*
10139N/A
10139N/A%changelog
10139N/A* Tue Jan 12 2010 - christian.kelly@sun.com
10139N/A- Add libunique-01-fixxref-modules to fix build issue.
13304N/A* Fri Nov 13 2009 - halton.huo@sun.com
10139N/A- Bump to 1.1.6
10139N/A* Tue Aug 25 2009 - halton.huo@sun.com
10139N/A- Bump to 1.1.2
12962N/A- Disable gobject-introspection because 64bit build fail
10139N/A* Sat Mar 28 2009 - halton.huo@sun.com
10139N/A- Bump to 1.0.8
10139N/A- Remove upstreamed patch gcc-warn-flags.diff
10139N/A* Sat Jan 24 2009 - halton.huo@sun.com
10139N/A- Initial package
10139N/A