libunique.spec revision 17698
10139N/A#
10139N/A# spec file for package unique
10139N/A#
10139N/A# Copyright 2009 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
15395N/A# package are under the same license as the package itself.
10139N/A#
10139N/A%define owner halton
10139N/A#
17185N/A
10139N/A%define OSR gnome.org:0
15395N/A
10139N/AName: libunique
17176N/ALicense: LGPL v2.1
17176N/AGroup: System/Libraries
10139N/AVersion: 1.1.6
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: A library for writing single instance applications
10139N/ASource: http://download.gnome.org/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
10139N/AURL: http://live.gnome.org/LibUnique
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15758N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov:on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A%define gtk2_version 2.4.0
10139N/A%define pkgconfig_version 0.15.0
10139N/A%define gtk_doc_version 1.1
10139N/A
10139N/ARequires: gtk2 >= %{gtk2_version}
10139N/ABuildRequires: gtk2-devel >= %{gtk2_version}
10139N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
10139N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
10139N/A
10139N/A%description
10139N/ALibUnique is a library for writing single instance applications, that is
10139N/Aapplications that are run once and every further call to the same binary
10139N/Aeither exits immediately or sends a command to the running instance.
10139N/A
10139N/ALibUnique can be compiled against various backends, to allow the usage of
10139N/Adifferent IPC mechanisms depending on the platform.
10139N/A
15395N/A%package devel
10139N/ASummary: unique development headers
10139N/AGroup: Development/Libraries
10139N/A
10139N/A%description devel
10139N/Aunique development headers
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A
10139N/A#FIXME: remove uncompatible m4 files
10139N/Arm -f build/autotools/lt~obsolete.m4
10139N/Arm -f build/autotools/ltoptions.m4
10139N/Arm -f build/autotools/libtool.m4
10139N/Arm -f build/autotools/ltsugar.m4
10139N/Arm -f build/autotools/ltversion.m4
10139N/A
15395N/A%build
15395N/A%ifos linux
15361N/Aif [ -x /usr/bin/getconf ]; then
15361N/A CPUS=`getconf _NPROCESSORS_ONLN`
11844N/Afi
11844N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
CPUS=1
fi
libtoolize --force
aclocal $ACLOCAL_FLAGS -I build/autotools
autoheader
automake -a -c -f
autoconf
./configure --prefix=%{_prefix} \
--bindir=%{_bindir} \
--libdir=%{_libdir} \
--includedir=%{_includedir} \
--sysconfdir=%{_sysconfdir} \
--mandir=%{_mandir} \
--enable-introspection=no \
%{gtk_doc_option} \
%if %debug_build
--enable-debug=yes \
%else
--enable-debug=no \
%endif
# FIXME: hack: stop the build from looping
#touch po/stamp-it
make -j $CPU
%install
make install DESTDIR=$RPM_BUILD_ROOT
#Clean up unpackaged files
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*
%{_datadir}/gtk-doc/html/unique/*
%changelog
* Fri Nov 13 2009 - halton.huo@sun.com
- Bump to 1.1.6
* Tue Aug 25 2009 - halton.huo@sun.com
- Bump to 1.1.2
- Disable gobject-introspection because 64bit build fail
* Sat Mar 28 2009 - halton.huo@sun.com
- Bump to 1.0.8
- Remove upstreamed patch gcc-warn-flags.diff
* Sat Jan 24 2009 - halton.huo@sun.com
- Initial package