15723N/A#
15723N/A# spec file for package unique
15723N/A#
18540N/A# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
15723N/A# This file and all modifications and additions to the pristine
15723N/A# package are under the same license as the package itself.
15723N/A#
20307N/A%define owner lin
15723N/A#
15723N/A
18603N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
17182N/A
16267N/AName: libunique
15723N/ALicense: LGPL v2.1
15723N/AGroup: System/Libraries
17698N/AVersion: 1.1.6
15723N/ARelease: 1
15723N/ADistribution: Java Desktop System
18616N/AVendor: Gnome Community
15723N/ASummary: A library for writing single instance applications
17096N/ASource: http://download.gnome.org/sources/%{name}/1.1/%{name}-%{version}.tar.bz2
15723N/AURL: http://live.gnome.org/LibUnique
15723N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15723N/ADocdir: %{_defaultdocdir}/doc
15723N/AAutoreqprov:on
15723N/APrereq: /sbin/ldconfig
15723N/A
18054N/APatch1: libunique-01-fixxref-modules.diff
18054N/A
15723N/A%define gtk2_version 2.4.0
15723N/A%define pkgconfig_version 0.15.0
15723N/A%define gtk_doc_version 1.1
15723N/A
15723N/ARequires: gtk2 >= %{gtk2_version}
15723N/ABuildRequires: gtk2-devel >= %{gtk2_version}
15723N/ABuildRequires: gtk-doc >= %{gtk_doc_version}
15723N/ABuildRequires: pkgconfig >= %{pkgconfig_version}
15723N/A
15723N/A%description
15723N/ALibUnique is a library for writing single instance applications, that is
15723N/Aapplications that are run once and every further call to the same binary
15723N/Aeither exits immediately or sends a command to the running instance.
15723N/A
15723N/ALibUnique can be compiled against various backends, to allow the usage of
15723N/Adifferent IPC mechanisms depending on the platform.
15723N/A
15723N/A%package devel
15723N/ASummary: unique development headers
15723N/AGroup: Development/Libraries
15723N/A
15723N/A%description devel
15723N/Aunique development headers
15723N/A
15723N/A%prep
15723N/A%setup -q
18054N/A%patch1 -p1
15723N/A
17096N/A#FIXME: remove uncompatible m4 files
17096N/Arm -f build/autotools/lt~obsolete.m4
17096N/Arm -f build/autotools/ltoptions.m4
17096N/Arm -f build/autotools/libtool.m4
17096N/Arm -f build/autotools/ltsugar.m4
17096N/Arm -f build/autotools/ltversion.m4
17096N/A
15723N/A%build
15723N/A%ifos linux
15723N/Aif [ -x /usr/bin/getconf ]; then
15723N/A CPUS=`getconf _NPROCESSORS_ONLN`
15723N/Afi
15723N/A%else
15723N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15723N/A%endif
15723N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15723N/A CPUS=1
15723N/Afi
15723N/A
15723N/Alibtoolize --force
17096N/Aaclocal $ACLOCAL_FLAGS -I build/autotools
15723N/Aautoheader
15723N/Aautomake -a -c -f
15723N/Aautoconf
15723N/A
15723N/A./configure --prefix=%{_prefix} \
15723N/A --bindir=%{_bindir} \
15723N/A --libdir=%{_libdir} \
15723N/A --includedir=%{_includedir} \
15723N/A --sysconfdir=%{_sysconfdir} \
15723N/A --mandir=%{_mandir} \
17096N/A --enable-introspection=no \
15723N/A %{gtk_doc_option} \
15723N/A%if %debug_build
15723N/A --enable-debug=yes \
15723N/A%else
15723N/A --enable-debug=no \
15723N/A%endif
15723N/A
15723N/A# FIXME: hack: stop the build from looping
17096N/A#touch po/stamp-it
15723N/A
17096N/Amake -j $CPU
15723N/A
15723N/A%install
15723N/Amake install DESTDIR=$RPM_BUILD_ROOT
15723N/A#Clean up unpackaged files
15723N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
15723N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
15723N/A
15723N/A%clean
15723N/Arm -rf $RPM_BUILD_ROOT
15723N/A
15723N/A%files
15723N/A%defattr(-,root,root)
15723N/A%{_libdir}/*.so.*
15723N/A
15723N/A%files devel
15723N/A%defattr(-,root,root)
15723N/A%{_includedir}/*
15723N/A%{_libdir}/*.so
15723N/A%{_libdir}/pkgconfig/*
15723N/A%{_datadir}/gtk-doc/html/unique/*
15723N/A
15723N/A%changelog
18054N/A* Tue Jan 12 2010 - christian.kelly@sun.com
18054N/A- Add libunique-01-fixxref-modules to fix build issue.
17698N/A* Fri Nov 13 2009 - halton.huo@sun.com
17698N/A- Bump to 1.1.6
17096N/A* Tue Aug 25 2009 - halton.huo@sun.com
17096N/A- Bump to 1.1.2
17096N/A- Disable gobject-introspection because 64bit build fail
16267N/A* Sat Mar 28 2009 - halton.huo@sun.com
16267N/A- Bump to 1.0.8
16267N/A- Remove upstreamed patch gcc-warn-flags.diff
15723N/A* Sat Jan 24 2009 - halton.huo@sun.com
15723N/A- Initial package