10139N/A#
10139N/A# spec file for package libtheora
10139N/A#
12973N/A# Copyright (c) 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
18739N/A%define owner yippi
11874N/A# bugdb: https://trac.xiph.org/
10139N/A#
17182N/A
17182N/A%define OSR 4198:1.0
17182N/A
10139N/AName: libtheora
18988N/ALicense: Xiph.org BSD-style, binaries use some LGPL v2.1
17033N/AGroup: Libraries/Multimedia
17547N/AVersion: 1.1.1
17547N/A%define tarball_version 1.1.1
13707N/ARelease: 2
10139N/ADistribution: Java Desktop System
18616N/AVendor: Xiph
10139N/ASummary: The Theora Video Compression Codec.
10139N/ASource: http://downloads.xiph.org/releases/theora/%{name}-%{tarball_version}.tar.gz
10139N/AURL: http://www.theora.org/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{tarball_version}-build
10139N/ADocdir: %{_docdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/ABuildRequires: libogg-devel >= 1.1
10139N/ABuildRequires: libvorbis-devel >= 1.0.1
10139N/ABuildRequires: SDL-devel
10139N/ARequires: libvorbis >= 1.0.1
10139N/A
10139N/A%description
10139N/ATheora is Xiph.Org's first publicly released video codec, intended
10139N/Afor use within the Ogg's project's Ogg multimedia streaming system.
10139N/ATheora is derived directly from On2's VP3 codec; Currently the two are
10139N/Anearly identical, varying only in encapsulating decoder tables in the
10139N/Abitstream headers, but Theora will make use of this extra freedom
10139N/Ain the future to improve over what is possible with VP3.
10139N/A
10139N/A%package devel
10139N/ASummary: Development tools for Theora applications.
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}-%{release}
10139N/ARequires: libogg-devel >= 1.1
10139N/A
10139N/A%description devel
10139N/AThe libtheora-devel package contains the header files and documentation
10139N/Aneeded to develop applications with Ogg Theora.
10139N/A
10139N/A%prep
10139N/A%setup -q -n %{name}-%{tarball_version}
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aaclocal $ACLOCAL_FLAGS -I ./m4
10139N/Aautoconf
10139N/Aautomake -a -c -f
17556N/Aexport CFLAGS="%optflags"
17556N/Aexport LDFLAGS="%_ldflags"
17556N/A#CFLAGS="$RPM_OPT_FLAGS" \
10139N/A./configure --enable-shared \
10139N/A --prefix=%{_prefix} \
17556N/A --libdir=%{_libdir} \
17556N/A --bindir=%{_bindir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
17116N/A --disable-asm \
17116N/A --disable-examples
17116N/A
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake DESTDIR=$RPM_BUILD_ROOT install
10139N/A
10139N/A#clean up unpackaged files
17556N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
17556N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post -p /sbin/ldconfig
10139N/A%postun -p /sbin/ldconfig
10139N/A
10139N/A%changelog
17556N/A* Mon Oct 19 2009 - ke.wang@sun.com
17556N/A- Add 64-bit support.
17547N/A* Sat Oct 17 2009 - brian.cameron@sun.com
17547N/A- Bump to 1.1.1.
17294N/A* Sun Sep 13 2009 - dave.lin@sun.com
17294N/A- Correct the version number, which is required as digit + dot only.
15318N/A* Fri Nov 07 2008 - jerry.tan@sun.com
15318N/A- bump to 1.0, remove upstream patches
14062N/A* Fri Aug 29 2008 - jerry.tan@sun.com
14062N/A- add patch libtheora-02-signed-short.diff to bump to 1.0beta3
12973N/A* Tue Apr 29 2008 - brian.cameron@sun.com
12973N/A- Bump to 1.0beta3. Remove upstream patch libtheora-01-fixlink.diff.
12973N/A Add new patch libtheora-01-fixtestlink.diff.
11864N/A* Mon Nov 05 2007 - brian.cameron@sun.com
11864N/A- Bump to 1.0beta2.
10139N/A* Fri Feb 09 2006 - brian.cameron@sun.com
10139N/A- Go back to 1.0alpha7, but add --disable-asm configure flag so that
10139N/A we don't try to compile GCC-style assembler code with Sun Studio
10139N/A compiler. Remove upstream patch 01-noversionscript.
10139N/A* Wed Dec 06 2006 - damien.carbery@sun.com
10139N/A- Revert to 1.0alpha5 because of compilation errors. Add patch too.
10139N/A* Sun Dec 03 2006 - damien.carbery@sun.com
10139N/A- Remove upstream patch, 01-noversionscript.
10139N/A* Thu Nov 30 2006 - damien.carbery@sun.com
10139N/A- Bump to 1.0alpha7.
10139N/A* Thu Nov 10 2005 - damien.carbery@sun.com
10139N/A- Change %setup to reference %{tarball_version} in order to build.
10139N/A* Tue Sep 20 2005 - brian.cameron@sun.com
10139N/A- Bump to 1.0alpha5
10139N/A* Fri Sep 09 2005 - laca@sun.com
10139N/A- Move ACLOCAL_FLAGS setting to the Solaris spec file
10139N/A- libtoolize so it builds with newer libtool
10139N/A* Fri Sep 02 2005 - damien.carbery@sun.com
10139N/A- Set ACLOCAL_FLAGS to build on Solaris.
10139N/A* Tue Aug 02 2005 - balamurali.viswanathan@wipro.com
10139N/A- Change copyright to license
10139N/A* Tue Jul 26 2005 - balamurali.viswanathan@wipro.com
10139N/A- Add patch libtheora-1.0alpha4-01-docs-make.diff
10139N/A* Wed Jul 20 2005 - balamurali.viswanathan@wipro.com
10139N/A- Initial spec file checkin