libsdl.spec revision 12261
10139N/A#
10139N/A# spec file for package libsdl
10139N/A#
18213N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
17185N/A# Owner: davelam
10139N/A#
10139N/A# bugdg: http://bugzilla.libsdl.org
10139N/A#
15322N/AName: libsdl
10139N/ALicense: LGPL
18504N/AGroup: System/Libraries
10139N/AVersion: 1.2.13
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10139N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: libsdl - Simple DirectMedia Layer
10139N/ASource: http://www.libsdl.org/release/SDL-%{version}.tar.gz
10139N/A# owner:dcarbery date:2008-01-17 type:bug bugzilla:542
10139N/APatch1: sdl-01-fixPATH.diff
10139N/AURL: http://www.libsdl.org/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/%{name}
10139N/AAutoreqprov: on
10139N/A
10139N/A%description
10139N/ASimple DirectMedia Layer is a cross-platform multimedia library designed to
10139N/Aprovide low level access to audio, keyboard, mouse, joystick, 3D hardware via
10139N/AOpenGL, and 2D video framebuffer. It is used by MPEG playback software,
10139N/Aemulators, and many popular games.
10139N/A
10139N/A%package devel
10139N/ASummary: Headers for developing programs that will use libsdl
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name}
10139N/A
10139N/A%description devel
10139N/AThis package contains the headers that programmers will need to develop
10139N/Aapplications which will use libsdl.
10139N/A
10139N/A%prep
10139N/A%setup -q -n SDL-%{version}
10139N/A%patch1 -p1
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Aexport CFLAGS="%optflags"
16796N/Aexport LDFLAGS="%_ldflags"
10392N/A./configure \
10139N/A --prefix=%{_prefix} \
10139N/A --libdir=%{_libdir} \
11881N/A --bindir=%{_bindir} \
11314N/A --sysconfdir=%{_sysconfdir} \
10139N/A --with-esd-prefix=%{_prefix} \
10139N/A --mandir=%{_mandir}
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
15503N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A
10139N/A# delete libtool .la files and static libs
11314N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10139N/Arm $RPM_BUILD_ROOT%{_libdir}/*la
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A%post -p /sbin/ldconfig
10139N/A%postun -p /sbin/ldconfig
10139N/A
10139N/A%files
10139N/A%defattr (-, root, root)
10139N/A%{_libdir}/*.so.*
10139N/A
10139N/A%files devel
10139N/A%defattr(-, root, root)
10139N/A%{_libdir}/*.so
10139N/A
10139N/A%changelog
10139N/A* Thu Jan 17 2008 - patrick.ale@gmail.com
10139N/A- Add patch to restore path after sdl-config check
10139N/A* Thu Jan 17 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.2.13.
10139N/A* Fri Oct 12 2007 - dave.lin@sun.com
10139N/A- Bump to 1.2.12 to fix bug CR6598379
10139N/A* Wed Apr 4 2007 - laca@sun.com
10139N/A- Create
10139N/A