10430N/A#
10430N/A# spec file for package libsdl
10430N/A#
12220N/A# Copyright 2008 Sun Microsystems, Inc.
10430N/A# This file and all modifications and additions to the pristine
10430N/A# package are under the same license as the package itself.
10430N/A#
17185N/A%define owner davelam
10430N/A#
13576N/A# bugdb: bugzilla.libsdl.org
12261N/A#
17182N/A
17182N/A%define OSR 6884:1.2.12
17182N/A
10430N/AName: libsdl
19064N/ALicense: LGPL v2.1
10430N/AGroup: System/Libraries
19064N/AVersion: 1.2.14
10430N/ARelease: 1
10430N/ADistribution: Java Desktop System
18616N/AVendor: Other
10430N/ASummary: libsdl - Simple DirectMedia Layer
10430N/ASource: http://www.libsdl.org/release/SDL-%{version}.tar.gz
10430N/AURL: http://www.libsdl.org/
10430N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10430N/ADocdir: %{_defaultdocdir}/%{name}
10430N/AAutoreqprov: on
10430N/A
10430N/A%description
10430N/ASimple DirectMedia Layer is a cross-platform multimedia library designed to
10430N/Aprovide low level access to audio, keyboard, mouse, joystick, 3D hardware via
10430N/AOpenGL, and 2D video framebuffer. It is used by MPEG playback software,
10430N/Aemulators, and many popular games.
10430N/A
10430N/A%package devel
10430N/ASummary: Headers for developing programs that will use libsdl
10430N/AGroup: Development/Libraries
10430N/ARequires: %{name}
10430N/A
10430N/A%description devel
10430N/AThis package contains the headers that programmers will need to develop
10430N/Aapplications which will use libsdl.
10430N/A
10430N/A%prep
10430N/A%setup -q -n SDL-%{version}
10430N/A
10430N/A%build
10430N/A%ifos linux
10430N/Aif [ -x /usr/bin/getconf ]; then
10430N/A CPUS=`getconf _NPROCESSORS_ONLN`
10430N/Afi
10430N/A%else
10430N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10430N/A%endif
10430N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10430N/A CPUS=1
10430N/Afi
10430N/A
19073N/Aexport CFLAGS="%optflags"
10430N/A./configure \
10430N/A --prefix=%{_prefix} \
10430N/A --libdir=%{_libdir} \
10430N/A --bindir=%{_bindir} \
10430N/A --sysconfdir=%{_sysconfdir} \
10430N/A --with-esd-prefix=%{_prefix} \
10430N/A --mandir=%{_mandir}
10430N/Amake -j $CPUS
10430N/A
10430N/A%install
10430N/Amake install DESTDIR=$RPM_BUILD_ROOT
10430N/A
10430N/A# delete libtool .la files and static libs
10430N/Arm $RPM_BUILD_ROOT%{_libdir}/*.a
10430N/Arm $RPM_BUILD_ROOT%{_libdir}/*la
10430N/A
10430N/A%clean
10430N/Arm -rf $RPM_BUILD_ROOT
10430N/A
10430N/A%post -p /sbin/ldconfig
10430N/A%postun -p /sbin/ldconfig
10430N/A
10430N/A%files
10430N/A%defattr (-, root, root)
10430N/A%{_libdir}/*.so.*
10430N/A
10430N/A%files devel
10430N/A%defattr(-, root, root)
10430N/A%{_libdir}/*.so
10430N/A
10430N/A%changelog
19064N/A* Wed Oct 27 2010 - brian.cameron@oracle.com
19064N/A- Bump to 1.2.14.
12610N/A* Fri Mar 14 2008 - damien.carbery@sun.com
12610N/A- Add -I/usr/X11/include to CFLAGS after update of SUNWwinc.
12224N/A* Thu Jan 17 2008 - patrick.ale@gmail.com
12224N/A- Add patch to restore path after sdl-config check
12220N/A* Thu Jan 17 2008 - damien.carbery@sun.com
12220N/A- Bump to 1.2.13.
11390N/A* Fri Oct 12 2007 - dave.lin@sun.com
11390N/A- Bump to 1.2.12 to fix bug CR6598379
10430N/A* Wed Apr 4 2007 - laca@sun.com
10430N/A- Create