libgsf.spec revision 18603
13980N/A#
13980N/A# spec file for package libgsf
13980N/A#
13980N/A# Copyright 2008 Sun Microsystems, Inc.
13980N/A# This file and all modifications and additions to the pristine
13980N/A# package are under the same license as the package itself.
13980N/A#
17185N/A%define owner jerrytan
18644N/A#
13980N/A
13940N/A%define OSR LFI#105446 (gnome Exec. summary):n/a
13940N/A
13940N/AName: libgsf
13940N/ALicense: LGPL 2.1
19067N/AGroup: System/Libraries
13940N/AVersion: 1.14.18
13940N/ARelease: 1
18688N/ADistribution: Java Desktop System
18688N/AVendor: Sun Microsystems, Inc.
13940N/ASummary: The GNOME Structured File Library
18850N/ASource: http://ftp.gnome.org/pub/gnome/sources/libgsf/1.14/%{name}-%{version}.tar.bz2
18644N/A%if %build_l10n
17051N/ASource1: l10n-configure.sh
18850N/A%endif
13980N/A# date:2004-04-12 owner:jerrytan type:feature
14072N/APatch0: libgsf-01-uninstalled-pc.diff
13940N/AURL: http://ftp.gnome.org/pub/gnome/sources/libgsf/
19067N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
19067N/ADocdir: %{_defaultdocdir}/doc
19870N/AAutoreqprov: on
19870N/APrereq: /sbin/ldconfig
13940N/A
13940N/A#####################################
18850N/A## Package Defines Section ##
15802N/A#####################################
13940N/A
19142N/A%define glib2_version 2.6.0
14419N/A%define zlib_version 1.2.1
18850N/A%define libxml2_version 2.6.7
18993N/A%define bzip2_version 1.0.2
15802N/A%define libbonobo_version 2.6.0
15802N/A%define gnome_vfs_version 2.6.0
13940N/A
13940N/A#####################################
13940N/A## Package Requirements Section ##
13940N/A#####################################
13940N/A
19142N/ARequires: glib2 >= %{glib2_version}
13940N/ARequires: libxml2 >= %{libxml2_version}
13940N/ARequires: zlib >= %{zlib_version}
13940N/ARequires: bzip2 >= %{bzip2_version}
18850N/ARequires: libbonobo >= %{libbonobo_version}
13940N/ARequires: gnome-vfs >= %{gnome_vfs_version}
17374N/ABuildRequires: glib2-devel >= %{glib2_version}
19870N/ABuildRequires: libxml2-devel >= %{libxml2_version}
13980N/ABuildRequires: zlib-devel >= %{zlib_version}
13940N/ABuildRequires: bzip2 >= %{bzip2_version}
13940N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
13940N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
13940N/A
13940N/A#####################################
13940N/A## Package Description Section ##
14072N/A#####################################
14072N/A
14072N/A%description
14072N/Alibgsf project aims to provide an efficient extensible i/o abstraction for
19086N/Adealing with different structured file formats.
14072N/A
14072N/A#####################################
14072N/A## Package Development Section ##
14072N/A#####################################
13940N/A
14072N/A%package devel
14072N/ASummary: libgsf development headers
13940N/AGroup: Development/Libraries
13940N/ARequires: %{name} = %{version}
13980N/ARequires: glib2-devel >= %{glib2_version}
13980N/ARequires: libxml2-devel >= %{libxml2_version}
13980N/ARequires: zlib-devel >= %{zlib_version}
18850N/ARequires: bzip2 >= %{bzip2_version}
13980N/ARequires: libbonobo-devel >= %{libbonobo_version}
13980N/ARequires: gnome-vfs-devel >= %{gnome_vfs_version}
13980N/A
13940N/A%description devel
13940N/Alibgsf development headers
13940N/A
13940N/A#####################################
13940N/A## Package Preparation Section ##
13940N/A#####################################
13940N/A
13940N/A%prep
13940N/A%setup -q
13940N/A%patch0 -p1
13940N/A
13940N/A#####################################
13940N/A## Package Build Section ##
13940N/A#####################################
13940N/A
13940N/A
13940N/A%build
19086N/A%ifos linux
19086N/Aif [ -x /usr/bin/getconf ]; then
19067N/A CPUS=`getconf _NPROCESSORS_ONLN`
19067N/Afi
18850N/A%else
18850N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
17374N/A%endif
17374N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
17374N/A CPUS=1
17374N/Afi
17104N/A
17104N/Alibtoolize --force
17104N/Aintltoolize --copy --force --automake
17104N/A
17075N/A%if %build_l10n
17075N/Abash -x %SOURCE1 --enable-copyright
17051N/A%endif
17051N/A
16904N/Aaclocal $ACLOCAL_FLAGS -I ./m4
16904N/Aautoheader
16466N/Aautomake -a -c -f
16466N/Aautoconf
15802N/A
15802N/A./configure --prefix=%{_prefix} \
14419N/A --bindir=%{_bindir} \
14419N/A --libdir=%{_libdir} \
14091N/A --includedir=%{_includedir} \
14091N/A --sysconfdir=%{_sysconfdir} \
14072N/A --mandir=%{_mandir} \
14072N/A --with-gnome \
13980N/A --with-bz2 \
13980N/A --with-gnome-vfs \
13940N/A --with-gio
13940N/A
13940N/Amake -j $CPUS
13940N/A
13940N/A%install
13940N/Amake install DESTDIR=$RPM_BUILD_ROOT
13940N/A#Clean up unpackaged files
13940N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
13940N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
19187N/Afind $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
19504N/A
# Move to vendor-packages
if [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
fi
%clean
rm -rf $RPM_BUILD_ROOT
#########################################
## Package Post[Un] Install Section ##
#########################################
%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
%postun
/sbin/ldconfig
%preun
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
#####################################
## Package Files Section ##
#####################################
%files
%defattr(-,root,root)
%{_bindir}/*
%{_sysconfdir}/gconf/schemas
%{_libdir}/*.so.*
%{_datadir}/locale
%{_mandir}/man1
%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*
%{_datadir}/gtk-doc/html/libgsf/*
%changelog
* Mon Apr 12 2010 - christian.kelly@oracle.com
- Bump to 2.14.18.
* Sun Feb 14 2010 - christian.kelly@sun.com
- Bump to 1.14.17.
* Wed Oct 14 2009 - dave.lin@sun.com
- Bump to 1.14.16
* Fri Feb 6 2009 - jerry.tan@sun.com
- move python binding from site-packges to vendor-packages
* Sun Sep 21 2008 - christian.kelly@sun.com
- Remove %gtk_doc_option as it's breaking the build on x86.
* Wed Sep 17 2008 - rick.ju@sun.com
- Use gio and support 64bit build
* Mon Sep 01 2008 - halton.huo@sun.com
- Bump to 1.14.9.
* Thu Mar 06 2008 - damien.carbery@sun.com
- Bump to 1.14.8.
* Wed Feb 20 2008 - halton.huo@sun.com
- Add comment for uninstalled-pc.diff.
- Unremove gtk-doc when gtk_doc is false
* Fri Sep 14 2007 - nonsea@users.sourceforge.net
- Add libtoolize and intltoolize to fix build fail.
* Mon Sep 10 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.7.
* Mon Aug 13 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.5.
* Thu May 03 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.3.
- use %gtk_doc_option in configure so that it can be
disabled using --without-gtk-doc
* Fri Jun 09 2006 - damien.carbery@sun.com
- Bump to 1.14.1.
* Fri Mar 10 2006 - damien.carbery@sun.com
- Bump to 1.14.0.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 1.13.3
* Tue Sep 27 2005 - damien.carbery@sun.com
- Bump to 1.12.3
* Wed Jun 15 2005 - matt.keenan@sun.com
- Bump to 1.12.1
* Tue May 24 2005 - brian.cameron@sun.com
- Turn on --enable-gtk-doc on Solaris since it works now.
* Tue May 24 2005 - laszlo.kovacs@sun.com
- libgsf-02-gtkdoc.diff removed
* Thu May 19 2005 - laszlo.kovacs@sun.com
- ported to 2.10
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected
on Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- added patch 01 (gtkdoc) back - it's needed to build on linux
* Mon Sep 13 2004 - damien.carbery@sun.com
- Disable gtk-doc on Solaris to get module to build.
* Wed Sep 01 2004 - laszlo.kovacs@sun.com
- fixed gtk-doc path problem
* Tue Aug 24 2004 - brian.cameron@sun.com
- Enabling gtk-docs and setting with-html-dir to place them in
the standard gtk-doc location.
* Thu Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Mon Apr 12 2004 - <brian.cameron@sun.com
- Added patch 1 to add uninstalled.pc file for Solaris build.
* Tue Feb 24 2004 - <michael.twomey@sun.com>
- Fixed distro typo
* Tue Feb 24 2004 - <matt.keenan@sun.com>
- Update Distro
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to 1.8.2.
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Thu Jul 17 2003 - michael.twomey@sun.com
- Initial package