libgsf.spec revision 15788
10139N/A#
10139N/A# spec file for package libgsf
10139N/A#
10139N/A# Copyright 2008 Sun Microsystems, Inc.
10139N/A# This file and all modifications and additions to the pristine
10139N/A# package are under the same license as the package itself.
10139N/A#
10139N/A# Owner:jerrytan
10139N/A#
10139N/A%define pythonver 2.4
10139N/A
10139N/AName: libgsf
10973N/ALicense: LGPL 2.1
10139N/AGroup: System/Libraries
10139N/AVersion: 1.14.9
10139N/ARelease: 1
10139N/ADistribution: Java Desktop System
10818N/AVendor: Sun Microsystems, Inc.
10139N/ASummary: The GNOME Structured File Library
10139N/ASource: http://ftp.gnome.org/pub/gnome/sources/libgsf/1.14/%{name}-%{version}.tar.bz2
10139N/A%if %build_l10n
10139N/ASource1: l10n-configure.sh
10139N/A%endif
10139N/A# date:2004-04-12 owner:yippi type:feature
10139N/APatch0: libgsf-01-uninstalled-pc.diff
10139N/A# date:2008-09-17 owner:rickju type:branding
10139N/APatch1: libgsf-02-gio.diff
10139N/AURL: http://ftp.gnome.org/pub/gnome/sources/libgsf/
10139N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
10139N/ADocdir: %{_defaultdocdir}/doc
10139N/AAutoreqprov: on
10139N/APrereq: /sbin/ldconfig
10139N/A
10139N/A#####################################
10139N/A## Package Defines Section ##
10139N/A#####################################
10139N/A
10139N/A%define glib2_version 2.6.0
10139N/A%define zlib_version 1.2.1
10139N/A%define libxml2_version 2.6.7
10139N/A%define bzip2_version 1.0.2
10139N/A%define libbonobo_version 2.6.0
10139N/A%define gnome_vfs_version 2.6.0
10139N/A
10139N/A#####################################
10139N/A## Package Requirements Section ##
10139N/A#####################################
10139N/A
10139N/ARequires: glib2 >= %{glib2_version}
10139N/ARequires: libxml2 >= %{libxml2_version}
10139N/ARequires: zlib >= %{zlib_version}
10139N/ARequires: bzip2 >= %{bzip2_version}
10139N/ARequires: libbonobo >= %{libbonobo_version}
10139N/ARequires: gnome-vfs >= %{gnome_vfs_version}
10139N/ABuildRequires: glib2-devel >= %{glib2_version}
10139N/ABuildRequires: libxml2-devel >= %{libxml2_version}
10139N/ABuildRequires: zlib-devel >= %{zlib_version}
10139N/ABuildRequires: bzip2 >= %{bzip2_version}
10139N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
10139N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/A
10139N/A#####################################
10139N/A## Package Description Section ##
10139N/A#####################################
10139N/A
10139N/A%description
10139N/Alibgsf project aims to provide an efficient extensible i/o abstraction for
10139N/Adealing with different structured file formats.
10139N/A
10139N/A#####################################
10139N/A## Package Development Section ##
10139N/A#####################################
10139N/A
11139N/A%package devel
10139N/ASummary: libgsf development headers
10139N/AGroup: Development/Libraries
10139N/ARequires: %{name} = %{version}
10139N/ARequires: glib2-devel >= %{glib2_version}
10139N/ARequires: libxml2-devel >= %{libxml2_version}
10139N/ARequires: zlib-devel >= %{zlib_version}
10139N/ARequires: bzip2 >= %{bzip2_version}
10139N/ARequires: libbonobo-devel >= %{libbonobo_version}
10139N/ARequires: gnome-vfs-devel >= %{gnome_vfs_version}
10139N/A
10139N/A%description devel
10139N/Alibgsf development headers
10139N/A
10139N/A#####################################
10139N/A## Package Preparation Section ##
10139N/A#####################################
10139N/A
10139N/A%prep
10139N/A%setup -q
10139N/A%patch0 -p1
10139N/A%patch1 -p1
10139N/A
10139N/A#####################################
10139N/A## Package Build Section ##
10139N/A#####################################
10139N/A
10139N/A
10139N/A%build
10139N/A%ifos linux
10139N/Aif [ -x /usr/bin/getconf ]; then
10139N/A CPUS=`getconf _NPROCESSORS_ONLN`
10139N/Afi
10139N/A%else
10139N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
10139N/A%endif
10139N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
10139N/A CPUS=1
10139N/Afi
10139N/A
10139N/Alibtoolize --force
10139N/Aintltoolize --copy --force --automake
10139N/A
10139N/A%if %build_l10n
10139N/Abash -x %SOURCE1 --enable-copyright
10139N/A%endif
10139N/A
10139N/Aaclocal $ACLOCAL_FLAGS -I ./m4
11139N/Aautoheader
11139N/Aautomake -a -c -f
10973N/Aautoconf
10973N/A
10818N/A./configure --prefix=%{_prefix} \
10818N/A --bindir=%{_bindir} \
10266N/A --libdir=%{_libdir} \
10266N/A --includedir=%{_includedir} \
10139N/A --sysconfdir=%{_sysconfdir} \
10139N/A --mandir=%{_mandir} \
10139N/A --with-gnome \
10139N/A --with-bz2 \
10139N/A --with-gnome-vfs \
10139N/A --with-gio
10139N/A
10139N/Amake -j $CPUS
10139N/A
10139N/A%install
10139N/Amake install DESTDIR=$RPM_BUILD_ROOT
10139N/A#Clean up unpackaged files
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
10139N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
10139N/A
10139N/A# Move to vendor-packages
10139N/Aif [ -x $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages ]; then
10139N/Amv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages \
10139N/A $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
10139N/Afi
10139N/A
10139N/A
10139N/A%clean
10139N/Arm -rf $RPM_BUILD_ROOT
10139N/A
10139N/A#########################################
10139N/A## Package Post[Un] Install Section ##
10139N/A#########################################
10139N/A
10139N/A%post
10139N/A/sbin/ldconfig
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/Agconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
10139N/A
10139N/A
10139N/A%postun
10139N/A/sbin/ldconfig
10139N/A
10139N/A%preun
10139N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
10139N/Agconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
10139N/A
10139N/A#####################################
10139N/A## Package Files Section ##
10139N/A#####################################
10139N/A
10139N/A%files
10139N/A%defattr(-,root,root)
10139N/A%{_bindir}/*
10139N/A%{_sysconfdir}/gconf/schemas
10139N/A%{_libdir}/*.so.*
10139N/A%{_datadir}/locale
10139N/A%{_mandir}/man1
10139N/A
10139N/A%files devel
10139N/A%defattr(-,root,root)
10139N/A%{_includedir}/*
10139N/A%{_libdir}/*.so
10139N/A%{_libdir}/pkgconfig/*
10139N/A%{_datadir}/gtk-doc/html/libgsf/*
10139N/A
10139N/A%changelog
10139N/A* Fri Feb 6 2009 - jerry.tan@sun.com
10139N/A- move python binding from site-packges to vendor-packages
10139N/A* Sun Sep 21 2008 - christian.kelly@sun.com
10139N/A- Remove %gtk_doc_option as it's breaking the build on x86.
10139N/A* Wed Sep 17 2008 - rick.ju@sun.com
10139N/A- Use gio and support 64bit build
10139N/A* Mon Sep 01 2008 - halton.huo@sun.com
10139N/A- Bump to 1.14.9.
10139N/A* Thu Mar 06 2008 - damien.carbery@sun.com
10139N/A- Bump to 1.14.8.
10139N/A* Wed Feb 20 2008 - halton.huo@sun.com
10139N/A- Add comment for uninstalled-pc.diff.
10139N/A- Unremove gtk-doc when gtk_doc is false
10139N/A* Fri Sep 14 2007 - nonsea@users.sourceforge.net
10139N/A- Add libtoolize and intltoolize to fix build fail.
10139N/A* Mon Sep 10 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 1.14.7.
10139N/A* Mon Aug 13 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 1.14.5.
10139N/A* Thu May 03 2007 - nonsea@users.sourceforge.net
10139N/A- Bump to 1.14.3.
10139N/A- use %gtk_doc_option in configure so that it can be
disabled using --without-gtk-doc
* Fri Jun 09 2006 - damien.carbery@sun.com
- Bump to 1.14.1.
* Fri Mar 10 2006 - damien.carbery@sun.com
- Bump to 1.14.0.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 1.13.3
* Tue Sep 27 2005 - damien.carbery@sun.com
- Bump to 1.12.3
* Wed Jun 15 2005 - matt.keenan@sun.com
- Bump to 1.12.1
* Tue May 24 2005 - brian.cameron@sun.com
- Turn on --enable-gtk-doc on Solaris since it works now.
* Tue May 24 2005 - laszlo.kovacs@sun.com
- libgsf-02-gtkdoc.diff removed
* Thu May 19 2005 - laszlo.kovacs@sun.com
- ported to 2.10
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected
on Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- added patch 01 (gtkdoc) back - it's needed to build on linux
* Mon Sep 13 2004 - damien.carbery@sun.com
- Disable gtk-doc on Solaris to get module to build.
* Wed Sep 01 2004 - laszlo.kovacs@sun.com
- fixed gtk-doc path problem
* Tue Aug 24 2004 - brian.cmaeron@sun.com
- Enabling gtk-docs and setting with-html-dir to place them in
the standard gtk-doc location.
* Thu Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Mon Apr 12 2004 - <brian.cameron@sun.com
- Added patch 1 to add uninstalled.pc file for Solaris build.
* Tue Feb 24 2004 - <michael.twomey@sun.com>
- Fixed distro typo
* Tue Feb 24 2004 - <matt.keenan@sun.com>
- Update Distro
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to 1.8.2.
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Thu Jul 17 2003 - michael.twomey@sun.com
- Initial package