libgsf.spec revision 14446
15341N/A#
15341N/A# spec file for package libgsf
15341N/A#
15341N/A# Copyright 2008 Sun Microsystems, Inc.
15341N/A# This file and all modifications and additions to the pristine
15341N/A# package are under the same license as the package itself.
15341N/A#
15341N/A# Owner:jerrytan
15341N/A#
15341N/A
15341N/AName: libgsf
15341N/ALicense: LGPL
15341N/AGroup: System/Libraries
15341N/AVersion: 1.14.9
15341N/ARelease: 1
15341N/ADistribution: Java Desktop System
15341N/AVendor: Sun Microsystems, Inc.
15341N/ASummary: The GNOME Structured File Library
15341N/ASource: http://ftp.gnome.org/pub/gnome/sources/libgsf/1.14/%{name}-%{version}.tar.bz2
15341N/A%if %build_l10n
15341N/ASource1: l10n-configure.sh
15428N/A%endif
15428N/A# date:2004-04-12 owner:yippi type:feature
15428N/APatch0: libgsf-01-uninstalled-pc.diff
15428N/A# date:2008-09-17 owner:rickju type:branding
15341N/APatch1: libgsf-02-gio.diff
15341N/AURL: http://ftp.gnome.org/pub/gnome/sources/libgsf/
15341N/ABuildRoot: %{_tmppath}/%{name}-%{version}-build
15341N/ADocdir: %{_defaultdocdir}/doc
15406N/AAutoreqprov: on
15406N/APrereq: /sbin/ldconfig
15341N/A
15341N/A#####################################
15341N/A## Package Defines Section ##
15341N/A#####################################
15341N/A
15341N/A%define glib2_version 2.6.0
15341N/A%define zlib_version 1.2.1
15341N/A%define libxml2_version 2.6.7
15341N/A%define bzip2_version 1.0.2
15341N/A%define libbonobo_version 2.6.0
15341N/A%define gnome_vfs_version 2.6.0
15341N/A
15341N/A#####################################
15341N/A## Package Requirements Section ##
15341N/A#####################################
15341N/A
15341N/ARequires: glib2 >= %{glib2_version}
15341N/ARequires: libxml2 >= %{libxml2_version}
15341N/ARequires: zlib >= %{zlib_version}
15341N/ARequires: bzip2 >= %{bzip2_version}
15341N/ARequires: libbonobo >= %{libbonobo_version}
15341N/ARequires: gnome-vfs >= %{gnome_vfs_version}
15341N/ABuildRequires: glib2-devel >= %{glib2_version}
15341N/ABuildRequires: libxml2-devel >= %{libxml2_version}
15341N/ABuildRequires: zlib-devel >= %{zlib_version}
15341N/ABuildRequires: bzip2 >= %{bzip2_version}
15341N/ABuildRequires: libbonobo-devel >= %{libbonobo_version}
15341N/ABuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
15341N/A
15341N/A#####################################
15428N/A## Package Description Section ##
15428N/A#####################################
15341N/A
15341N/A%description
15341N/Alibgsf project aims to provide an efficient extensible i/o abstraction for
15341N/Adealing with different structured file formats.
15341N/A
15341N/A#####################################
15341N/A## Package Development Section ##
15341N/A#####################################
15341N/A
15341N/A%package devel
15341N/ASummary: libgsf development headers
15341N/AGroup: Development/Libraries
15341N/ARequires: %{name} = %{version}
15406N/ARequires: glib2-devel >= %{glib2_version}
15406N/ARequires: libxml2-devel >= %{libxml2_version}
15341N/ARequires: zlib-devel >= %{zlib_version}
15428N/ARequires: bzip2 >= %{bzip2_version}
15341N/ARequires: libbonobo-devel >= %{libbonobo_version}
15341N/ARequires: gnome-vfs-devel >= %{gnome_vfs_version}
15341N/A
15341N/A%description devel
15341N/Alibgsf development headers
15341N/A
15341N/A#####################################
15341N/A## Package Preparation Section ##
15341N/A#####################################
15341N/A
15341N/A%prep
15341N/A%setup -q
15341N/A%patch0 -p1
15341N/A%patch1 -p1
15341N/A
15341N/A#####################################
15341N/A## Package Build Section ##
15341N/A#####################################
15341N/A
15341N/A
15341N/A%build
15341N/A%ifos linux
15341N/Aif [ -x /usr/bin/getconf ]; then
15341N/A CPUS=`getconf _NPROCESSORS_ONLN`
15341N/Afi
15341N/A%else
15341N/A CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
15341N/A%endif
15341N/Aif test "x$CPUS" = "x" -o $CPUS = 0; then
15406N/A CPUS=1
15406N/Afi
15406N/A
15406N/Alibtoolize --force
15406N/Aintltoolize --copy --force --automake
15406N/A
15406N/A%if %build_l10n
15406N/Abash -x %SOURCE1 --enable-copyright
15406N/A%endif
15406N/A
15406N/Aaclocal $ACLOCAL_FLAGS -I ./m4
15406N/Aautoheader
15341N/Aautomake -a -c -f
15341N/Aautoconf
15341N/A
15341N/A./configure --prefix=%{_prefix} \
15341N/A --bindir=%{_bindir} \
15341N/A --libdir=%{_libdir} \
15341N/A --includedir=%{_includedir} \
15341N/A --sysconfdir=%{_sysconfdir} \
15341N/A --mandir=%{_mandir} \
15341N/A --with-gnome \
15341N/A --with-bz2 \
15341N/A --with-gnome-vfs \
15341N/A --with-gio
15341N/A
15341N/Amake -j $CPUS
15341N/A
15341N/A%install
15341N/Amake install DESTDIR=$RPM_BUILD_ROOT
15341N/A#Clean up unpackaged files
15341N/Afind $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
15341N/Afind $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
15341N/A
15341N/A%clean
15341N/Arm -rf $RPM_BUILD_ROOT
15341N/A
15341N/A#########################################
15341N/A## Package Post[Un] Install Section ##
15341N/A#########################################
15341N/A
15341N/A%post
15428N/A/sbin/ldconfig
15428N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
15428N/Agconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
15406N/A
15406N/A
15344N/A%postun
15344N/A/sbin/ldconfig
15341N/A
15341N/A%preun
15341N/Aexport GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
15341N/Agconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gsf-office-thumbnailer.schemas >/dev/null
15341N/A
15341N/A#####################################
15341N/A## Package Files Section ##
15341N/A#####################################
15341N/A
15341N/A%files
15341N/A%defattr(-,root,root)
15341N/A%{_bindir}/*
15341N/A%{_sysconfdir}/gconf/schemas
15341N/A%{_libdir}/*.so.*
15341N/A%{_datadir}/locale
15341N/A%{_mandir}/man1
15341N/A
15341N/A%files devel
15341N/A%defattr(-,root,root)
15341N/A%{_includedir}/*
15341N/A%{_libdir}/*.so
15341N/A%{_libdir}/pkgconfig/*
15341N/A%{_datadir}/gtk-doc/html/libgsf/*
15341N/A
15341N/A%changelog
15341N/A* Sun Sep 21 2008 - christian.kelly@sun.com
- Remove %gtk_doc_option as it's breaking the build on x86.
* Wed Sep 17 2008 - rick.ju@sun.com
- Use gio and support 64bit build
* Mon Sep 01 2008 - halton.huo@sun.com
- Bump to 1.14.9.
* Thu Mar 06 2008 - damien.carbery@sun.com
- Bump to 1.14.8.
* Wed Feb 20 2008 - halton.huo@sun.com
- Add comment for uninstalled-pc.diff.
- Unremove gtk-doc when gtk_doc is false
* Fri Sep 14 2007 - nonsea@users.sourceforge.net
- Add libtoolize and intltoolize to fix build fail.
* Mon Sep 10 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.7.
* Mon Aug 13 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.5.
* Thu May 03 2007 - nonsea@users.sourceforge.net
- Bump to 1.14.3.
- use %gtk_doc_option in configure so that it can be
disabled using --without-gtk-doc
* Fri Jun 09 2006 - damien.carbery@sun.com
- Bump to 1.14.1.
* Fri Mar 10 2006 - damien.carbery@sun.com
- Bump to 1.14.0.
* Tue Dec 20 2005 - dermot.mccluskey@sun.com
- Bump to 1.13.3
* Tue Sep 27 2005 - damien.carbery@sun.com
- Bump to 1.12.3
* Wed Jun 15 2005 - matt.keenan@sun.com
- Bump to 1.12.1
* Tue May 24 2005 - brian.cameron@sun.com
- Turn on --enable-gtk-doc on Solaris since it works now.
* Tue May 24 2005 - laszlo.kovacs@sun.com
- libgsf-02-gtkdoc.diff removed
* Thu May 19 2005 - laszlo.kovacs@sun.com
- ported to 2.10
* Fri Nov 12 2004 - laca@sun.com
- added --libdir and --bindir to configure opts so they can be redirected
on Solaris
* Mon Sep 20 2004 - dermot.mccluskey@sun.com
- added patch 01 (gtkdoc) back - it's needed to build on linux
* Mon Sep 13 2004 - damien.carbery@sun.com
- Disable gtk-doc on Solaris to get module to build.
* Wed Sep 01 2004 - laszlo.kovacs@sun.com
- fixed gtk-doc path problem
* Tue Aug 24 2004 - brian.cmaeron@sun.com
- Enabling gtk-docs and setting with-html-dir to place them in
the standard gtk-doc location.
* Thu Jul 07 2004 - niall.power@sun.com
- ported to rpm4
* Wed Jul 07 2004 - dermot.mccluskey@sun.com
- added "-j $CPUS" to make to speed up builds
* Mon Apr 12 2004 - <brian.cameron@sun.com
- Added patch 1 to add uninstalled.pc file for Solaris build.
* Tue Feb 24 2004 - <michael.twomey@sun.com>
- Fixed distro typo
* Tue Feb 24 2004 - <matt.keenan@sun.com>
- Update Distro
* Tue Oct 21 2003 - <michael.twomey@sun.com>
- Updated to 1.8.2.
* Thu Aug 14 2003 - <laca@sun.com>
- move lib*.so to -devel, remove *.a, *.la
* Thu Jul 17 2003 - michael.twomey@sun.com
- Initial package